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About This Guide
Cisco Unified Contact Center Express (Unified CCX), a member of the Cisco Unified Communications family
of products, manages customer voice contact centers for departments, branches, or small to medium-size
companies planning to deploy an entry-level or mid-market contact center solution.

TheCisco Unified CCX Administration Guide provides instructions for using the Administration web interface
to provision the subsystems of the Unified CCX package and to configure Unified CCX applications.

This guide shows you how to implement the following two systems that integrate with the Unified CCX:

• Cisco Unified Contact Center Express (Unified CCX)

• Cisco Unified IP IVR

This guide also includes a reference section that describes all the menus and menu options of the Unified
CCX Administration web interface.

This guide will help you to:

• Perform initial configuration tasks

• Administer applications such as the Unified CCX Engine and other components of the Cisco Unified
Communications family of products

• Familiarize yourself with the menus andmenu options of the Unified CCXAdministration web interface

Audience
The Cisco Unified CCX Administration Guide is written for business analysts and application designers who
have the domain-specific knowledge required to create multimedia and telephony customer response
applications. Experience or training with Java is not required but is useful for making best use of the capabilities
of the Cisco Unified Communications family of products.
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Documentation and Support
To download documentation, submit a service request, and find additional information, seeWhat's New in
Cisco Product Documentation at: http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html.

You can also subscribe to theWhat's New in Cisco Product Documentation RSS feed to deliver updates
directly to an RSS reader on your desktop. The RSS feeds are a free service. Cisco currently supports RSS
Version 2.0.

Documentation Feedback
To provide your feedback for this document, send an email to:

contactcenterproducts_docfeedback@cisco.com
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C H A P T E R  1
Unified CCX Introduction

Unified CCX provides a multimedia (voice, data, and web) IP-enabled customer-care application environment
that enhances the efficiency of contact centers by simplifying business integration, easing agent administration,
increasing agent flexibility, and enhancing network hosting.

The following sections provide an overview of the configuration and management components of the Unified
CCX product family:

• Unified CCX Components, page 1

• Unified CCX Product Family, page 3

• Unified CCX Cluster Architecture, page 5

• Unified CCX Engine, page 6

• Set Up Unified CCX, page 7

• Manage Unified CCX, page 12

Unified CCX Components
This section describes the following components of the Unified CCX system:

• Unified Gateway—Connects the Cisco Unified Communications family of products to the Public
Switched Telephone Network (PSTN) and to other private telephone systems such as PBX.

• Unified CM Server—The Cisco Unified Communications Manager (Unified CM) provides the features
required to implement IP phones, manage gateways, provide failover and redundancy service for the
telephony system, and direct Voice over IP (VoIP) traffic to the Unified CCX system.

CiscoUnified CommunicationsManager was previously known asUnified CallManager.
This guide uses Cisco Unified Communications Manager at the first occurrence and
Unified CM for later occurrences.

Note
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• Unified CCX Server—Contains the Unified CCX Engine that runs applications, including Cisco script
applications, Busy applications, Ring No Answer applications, and Voice Extensible Markup Language
(VXML) 2.0 applications.

You can position your Unified CCX application server anywhere on the IP network and administer your
applications from a web browser on any computer on the IP network. Because Unified CCX uses an
open architecture that supports industry standards, you can integrate your applications with a wide variety
of technologies and products, such as Enterprise databases. The Unified CCX Server has the following
components:

◦Unified CCXConfigurationDatastore (CDS)—Manages configuration, component, and application
information within the Unified CCX cluster and communicates with Unified CM. See the Cisco
Unified Contact Center Express Serviceability Administration Guide.

◦Historical Reports Database Server—Dedicated server that stores Unified CCX database for the
following datastores: Configuration Datastore (CDS), Historical Datastore (HDS), and Repository
Datastore (RDS).

If you are using Microsoft Internet Explorer Version 6.0 or later or Mozilla Firefox
Version 2.0 or 3.0 browser, verify that the popup blocker is disabled.

Note

◦Cisco SocialMiner—Acts as the endpoint that hosts the widgets that end users and agents use
during chat and email sessions. SocialMiner accepts chat request, communicates with Unified CCX
to allocate an agent for the chat and then establishes the chat session between agent and end user.

SocialMiner fetches email messages from the email server, communicates with Unified CCX to
allocate an agent, and provides the email management user interface components via the Finesse
desktop.

• Unified CCX Editor—Allows application developers to use a simple Graphical User Interface (GUI) to
create, modify, and debug Unified CCX scripts for automating customer interactions. Each script consists
of a series of steps, implemented as Java Beans.

• Unified CCXAdministration and Unified CCX Serviceability web interfaces—Provides access through
a web browser for administrators to configure and manage Unified CCX datastores, servers, and
applications.

• Cisco IP Agent and Supervisor Desktops—Desktop programs that allow Unified CCX agents and
supervisors to log in to the system, change agent states, and monitor status.

• Media Resource Control Protocol (MRCP) Automatic Speech Recognition (ASR) server—(optional)
Dedicated server that performs real-time speech recognition.

• MRCP Text-to-Speech (TTS) server—(optional) Dedicated server that converts text into speech and
plays it back to the caller.

Support for high availability and remote servers is available only in multiple-server
deployments.

Note
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• Cisco Unified Intelligence Center—A web-based reporting solution for historical reports that provides
detailed Call Contact Call Detail Records (CCDRs), application performance, and traffic analysis
information.

Unified CCX Product Family
TheUnified CCXproduct family provides contact-processing functions for your CiscoUnified Communications
solution.

The software package that you choose determines which steps, components, and subsystems you receive.
Each Unified CCX product includes Unified CCX Engine and Unified CCX Editor.

Unified IP IVR
The Unified IP IVR is a multimedia (voice, data, web) IP-enabled interactive voice response solution that
offers an open and feature-rich foundation for the creation and delivery of Unified IP IVR applications through
Internet technology.

Unified IP IVR automates call handling by autonomously interacting with contacts. Using Unified IP IVR,
you can create applications that answer calls, provide menu choices for callers, obtain caller data such as
passwords or account identification, and transfer calls to caller-selected extensions. You can also create Unified
IP IVR applications that respond to HTTP requests, perform outbound calling, send e-mail, and process VXML
2.0 commands.

The Unified IP IVR package provides the following features:

• Java Database Connectivity (JDBC) support—Unified IP IVR applications can access Oracle, Sybase,
and IBM DB2 databases.

• Real-time reporting client—Unified IP IVR applications can generate a variety of reports that provide
detailed information about the real-time status of your system.

• Cisco Unified Intelligence Center—A web-based reporting solution for historical reports that provides
detailed Call Contact Call Detail Records (CCDRs), application performance, and traffic analysis
information.

• Automatic Speech Recognition (ASR)—Unified IP IVR applications can take advantage of ASR to
provide callers with the option to use speech to navigate through menu options.

• Text-to-Speech (TTS)—Unified IP IVR applications can use TTS to read back documents and prescripted
prompts to callers.

Unified Contact Center Express
Cisco Unified Contact Center Express (Unified CCX) is an IP-based Automated Call Distribution (ACD)
system that queues and distributes incoming calls to Unified CCX agents, who can be groups of Unified CM
users for Unified CM integration.

You can use Unified CCX applications to route calls to specific agents. You can also integrate Unified CCX
with Unified IP IVR to gather caller data and classify incoming calls.
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Unified CCX includes a web-based real-time and historical reporting system that you can use to monitor
system, Contact Service Queue (CSQ), and resource performance.

The Unified CCX system consists of the following major components:

• Resource Manager—Application program that monitors Unified CCX agent phones and allows you to
organize agents into resource groups or skills-based partitions according to the types of calls each group
can handle.

• CSQ—Application program that places incoming calls in a queue and distributes them to the appropriate
set of agents as the agents become available.

The following licensing options are available for the Unified CCX system:

• Unified CCX Standard (designed for entry-level users)—Includes the steps necessary for creating basic
Unified CCX applications, including IP Phone Agent (IPPA) and skills-based routing.

• Unified CCX Enhanced (designed for enterprise-level users)—Includes all functions of Unified CCX
Standard, plus support for priority queuing. Includes a license to enable custom Java extensions.

• Unified CCXPremium—Adds full Unified IP IVR support (except for Unified ICM integration) including
database integration, Voice eXtensible Markup Language (VoiceXML), HTMLweb integration, custom
Java extensions, and e-Notification services. The outbound feature is now bundled with the Premium
package. You will receive one outbound seat free with each premium seat. The maximum number of
outbound seats supported will be based on the hardware type.

• Unified CCX Outbound—You need to have a Unified CCX Outbound license in addition to a Unified
CCX Premium license to enable the IVR and agent outbound feature. You can increase the number of
ports and agents for an existing Outbound license. For all the IVR and agent based outbound campaigns
that are running currently in your Unified CCX, the Display License submenu option displays these IVR
ports and agent seats:

• The licensed IVR ports for outbound.

• The licensed agent seats for outbound.

• The sum of the dedicated IVR ports configured for IVR-based outbound campaigns.

• The agent seats that currently in use for agent-based outbound campaigns.

Note • The dedicated outbound IVR ports for a campaign is the number of IVR ports that
you want to reserve for a campaign from the total number of CTI ports available
in the outbound call control group.

The Unified CCX Enhanced package and the Unified CCX Premium package are provisioned in the same
way.

Note
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Unified CCX Cluster Architecture

Support for high availability and remote servers is available only in multiple-server deployments.Note

The Unified CCX cluster consists of one or more servers (nodes) that are running Unified CCX components
in your Unified CCX deployment.

If you deploy Unified CCX components on a single server, the Unified CCX cluster (often referred to as
cluster in this manual) consists of that server. If you deploy Unified CCX on multiple servers, the cluster
includes the Unified CCX server and standby server on which you installed Unified CCX. The Unified CCX
cluster can support up to two Unified CCX Servers, one designated as the active Unified CCX Server and the
other designated as the standby Unified CCX Server for high availability purposes.

When you install or upgrade Unified CCX on a server, you designate the cluster to which the server will
belong by designating the cluster profile for that cluster.

Cluster architecture accommodates high availability and failover because if a component fails, a secondary
server will take over the functionality lost by that failed component.

All Unified CCX servers within the cluster are configured identically and installed with the same features.
One server is designated the active server.

Unified CCX Active Server

Support for high availability and remote servers is available only in multiple-server deployments.Note

The Unified CCX active server makes global decisions for the cluster and keeps track of calls in the CSQs,
agent states (if Unified CCX is installed) and generating historical detail records.

Only one server in the cluster can be the active server at any given time.Note

If the active server fails, the Unified CCX provides automatic failover to the standby server. If the active
server fails (for example, in the event a hardware failure occurs or the Unified CCXEngine process terminates),
some calls being handled by the server are lost. The lost calls are restricted to those being handled by the
system (those in the IVR stage or in queue). Calls answered by agents continue to remain live even though
related data on the agent desktop is lost. When the standby server takes over as the new active server, call
processing continues.

A Unified CCX cluster consists of the one or more servers (nodes) that run Unified CCX components in your
Unified CCX deployment.

Cluster management consists of two main elements:

Cluster Manager

Receives updates about cluster status and subsystem states.
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Cluster View Daemon (CVD)

Java code that interacts with Platform Service Manager and implements internode communication on
behalf of the cluster. It detects availability of the other nodes, components and services, provides
consistent cluster view, and dynamically elects a master service.

The following figure shows the components of the CVD interaction with nodes.

Figure 1: Components of the CVD Interaction with Nodes

The CVD has two interfaces:

• One that monitors inside the node, using:

• Node Manager to monitor and control local processes

• Cluster Manager publisher or subscriber to communicate with local applications, such as Engine
and Application Administration

• One that monitors outside the node and communicates with other nodes in the cluster

Unified CCX Engine
The Unified CCX Engine enables you to run multiple applications to handle Unified CM Telephony calls or
HTTP requests.

The Unified CCX Engine uses the Unified CM Telephony subsystem to request and receive services from
the Computer Telephony Interface (CTI) manager that controls Unified CM clusters. The Unified CCXEngine
is implemented as a service that supports multiple applications.

You can use a web browser to administer the Unified CCX Engine and your Unified CCX applications from
any computer on the network. Unified CCX provides you the following two web interfaces:

• Unified CCX Administration web interface— Used to configure system parameters, subsystems, view
real-time reports that include total system activity and application statistics, and so on

• Unified CCX Serviceability web interface— Used to view alarm and trace definitions for Unified CCX
services, start and stop the Unified CCX Engine, monitor Unified CCX Engine activity, and so on

If you are using Microsoft Internet Explorer Version 6.0 or later or Mozilla Firefox
Version 2.0 or 3.0 browser, verify that the popup blocker is disabled.

Note
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Depending on the Unified CCX products that you are using, the Unified CCX server may employ as many
as 14 subsystems for communicating with other services:

Applications

Manages the applications in the Unified CCX Engine and other features such as session management.

Cisco Media

Configures CiscoMedia Termination (CMT) dialog control groups, which can be used to handle simple
Dual Tone Multifrequency (DTMF)-based dialog interactions with customers.

Core Reporting

Provides information for Unified IP IVR real-time reports.

Database

Handles the connections between the Unified CCX server and the enterprise database.

eMail

Adds components to the Unified CCX Engine that allows the engine to send email messages.

HTTP

Adds components to the Unified CCX Engine that allow the engine to respond to HTTP requests.

ICM Subsystem

Manages the connection between the Unified CCX server and ICM.

Unified CM Telephony

Manages the connection between Unified CM CTI Manager and the Unified CCX Engine.

MRCP ASR

Allows a script to respond to voice input in addition to DTMF using the MRCP protocol.

MRCP TTS

Composes voice prompts that are generated real-time from text, such as speaking the words in the text
of an email message using the MRCP protocol.

Resource Manager-Contact Manager (RmCm)

Allows Unified CCX to monitor agent phones, control agent states, route and queue calls, and manage
the historical reporting feature.

NonVoice Subsystem

Allows Unified CCX to configure and manage Chat and Email.

Voice Browser

Manages Voice Browser functionality.

Set Up Unified CCX
After you install the Unified CCX system and perform the initial setup as described in Cisco Unified Contact
Center Express Installation Guide, you can start provisioning and configuring the system:
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• Provisioning is the process of allocating resources and devising strategies for using the resources to
support the needs of your business.

• Configuring is the process of making applications available to the Unified CCX system.

Provision Telephony and Media Subsystems
The Unified CCX telephony and media subsystems manage telephony and media resources and communicate
with supporting telephony and media systems.

Depending on the Unified CCX applications you plan to use, you need to provision some or all of the following
subsystems:

• Unified CM Telephony—The Unified CM Telephony subsystem controls the Unified CM Telephony
resources for the Unified CCX system.

While Unified CM supports Unicode characters in first and last names, those characters become corrupted
in Unified CCX Administration web pages for Real-Time Reporting.

Caution

• Cisco Media—The Cisco Media subsystem controls the CMT media resources for the Unified CCX
system.

•MRCP ASR—The MRCP ASR subsystem controls the ASR media resources for the Unified CCX
system.

•MRCP TTS—The MRCP TTS subsystem controls the TTS media resources for the Unified CCX
system.

Configure Unified CCX Subsystems
You need to provision your Unified CCX subsystems to enable the Unified CCX Engine to run multiple
applications to handle Unified Communications calls or HTTP requests.

You need to configure a particular subsystem only if you are using Unified CCX applications that require
it and which are installed and activated using the appropriate license.

Note

To continue the Unified CCX system configuration process, connect to the Unified CCX Administration web
interface and perform the task in the links listed in the Related Topics section.

Provision Unified CCX Subsystem
If you have purchased any of the three versions of Unified CCX, you must provision the Unified CCX
subsystem.

Provision the following settings on the Unified CCX subsystem:

• RmCm Provider
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The Resource Manager (RM) of the Unified CCX system uses a Unified CM user (called a Unified CM
Telephony provider) for monitoring agent phones, controlling agent states, and routing and queueing
calls.

• Resources
Agents that answer calls are also called resources. After you create a resource group, you must assign
agents (resources) to that group. You can assign skills to agents if you have a Unified CCX Standard
license.

• Resource Groups
Collections of agents that your CSQ uses to handle incoming calls. To use resource group-based CSQs,
you must specify a resource group.

• Skills
(Unified CCX Standard license) Customer-definable labels that are assigned to agents. You can route
incoming calls to agents who have the necessary skills or set of skills to handle the call.

• CSQs
After you assign an agent to a resource group or assign skills to an agent, you need to configure the
agent for the CSQ to which the agent will be assigned.

• Agent-Based Routing Settings
You can configure Automatic Work and Wrapup Time settings for the agent-based routing feature from
the Agent-Based Routing Settings page.

• Teams
If you want to create or associate teams with various agents, CSQs, and supervisors, you need to configure
team settings.

Provision Additional Unified CCX Subsystems
The additional Unified CCX subsystems provide HTTP, Database, and email features.

Provision the following subsystems:

• HTTP—The HTTP subsystem enables Unified CCX applications to respond to requests from a variety
of web clients.

• Database—The Database subsystem enables Unified CCX applications to communicate with enterprise
database servers.

• eMail—The eMail subsystem enables Unified CCX applications to create and send email.

View License Information
The initial license configuration is part of the Setup Wizard procedure (during installation). The uploaded
licenses define the feature set for a Unified CCX system. See Cisco Unified Contact Center Express Install
and Upgrade Guide for more information on obtaining and installing licenses for Cisco Unified CCX.

You can add additional licenses using the Add Licenses submenu option.
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Note • If two licenses with the same feature name are uploaded, the Unified CCX Administration Display
Licenses web page will display the earlier date as the expiry date. Although the expiry date refers
to the earlier date, it does not mean that the license expires on the date displayed in the “Display
Licenses” page if you upload a permanent license.

• If a permanent license is uploaded over an already existing temporary license, a license expiry
message is displayed for the temporary license for the feature. This license expirymessage is displayed
both in License Information and Appadmin home page. The Appadmin home page displays a popup
message.

For Unified CCX, if you have a premium license with an outbound license, the Unified CCX Administration
Display Licenses web page displays:

• The number of licensed IVR ports and dedicated IVR ports for IVR outbound.

• The number of licensed agent seats and In Use agent seats for progressive and predictive agent outbound.

The number of In Use IVR ports and In Use agent seats are displayed only for the master
node.

Note

Deleting or reducing the number of IVR ports for outbound in the license is not a supported scenario in
Unified CCX. Doing this might lead to inaccurate data in Dedicated Licensed Ports, which in turn might
lead to more abandoned calls.

Caution

To view license details, perform the following procedure:

Procedure

Choose System > License Information > Display License(s) from the Unified CCX Administration menu
bar.
The License Information web page opens, displaying the details of the configured licenses, including the
expiry date in the case of time-bound licenses.

Upload Licenses
Software for all of the Unified CCX feature components are loaded on the system during installation. However,
no feature is available for use unless a license for that feature is added and activated.

You can upload and display licenses using the License Information page. To upload a license, complete the
following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > License Information > Add License(s).
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The License Information web page opens.

Step 2 Specify a License file or click Browse to locate a file.
You can either specify a single file with a .lic extension or a .zip file containing multiple .lic files.

While you are upgrading from a previous release, if there are multiple licenses, zip all the .lic files
into a single .zip file and then upload the zip file. If specifying a .zip file, ensure that all .lic files that
need to be added are in the root of the .zip file and are not in subfolders in the .zip file.

Note

Step 3 Click Upload.
On successful upload of the license, you will see the following confirmation message in the status bar at the
top of this web page : License has been uploaded successfully

If you upload an Add-on license to increase the existing licensed Outbound IVR ports, the following message
will be displayed :

As the number of licensed Outbound IVR Ports have increased, please
increase the number of ports in the Outbound Call Control Group to utilize
all the licensed ports.

Configure Unified CCX Applications
After you provision the Unified CCX subsystems and view your license information, you need to configure
Unified CCX applications to interact with contacts and perform a wide variety of functions.

To continue the Unified CCX system configuration process, connect to the Unified CCX Administration web
interface and manage the following tasks:

• Available Applications, on page 11

• Manage Scripts Prompts, Grammars, and Documents, on page 12

•Wizards Menu, on page 287

Available Applications
There are several types of applications you can configure for Unified CCX:

• Script applications perform such functions as receiving calls, playing back prompts, receiving caller
input, transferring calls, and queueing calls.

• The Busy application simulates a busy signal.

• The Ring-No-Answer application simulates a ringtone.

After adding a Unified CCX application, you need to define a trigger so that this application can respond to
telephone calls and HTTP requests. Triggers are specified signals that invoke application scripts in response
to incoming contacts.
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Manage Scripts Prompts, Grammars, and Documents
The process of configuring Cisco script applications includes uploading Unified CCX scripts and prerecorded
prompts, installing grammars and customized languages, and adding triggers to applications.

Depending on your particular Unified CCX implementation, you may need to perform most or all of the
following tasks to configure a Cisco script application:

• Manage scripts—Cisco script applications are based on scripts that you must upload to the repository
and make available to the Unified CCX system.

• Manage prompts—Many applications make use of prerecorded prompts, stored as .wav files, which are
played back to callers to provide information and elicit caller response. You must upload these .wav
files to the repository and make them available to the Unified CCX system.

• Install grammars—A grammar is a specific set of all possible spoken phrases and Dual Tone
Multi-Frequency (DTMF) digits to be recognized by Unified CCX applications and acted upon during
run time. The Unified CCX system uses specific grammars when recognizing and responding to caller
responses to prompts. Youmust store these grammars in a directory to make them available to the Unified
CCX system.

• Install customized Unified CCX languages—Language packs, such as American English and Canadian
French, are installed with Unified CCX.

Configure Unified CCX Historical Reporting
When you install the Unified CCX system, the installation process creates a database named db_cra. This
database contains:

• Information for historical reports, including Unified CCX configuration information, stored procedures,
and some call statistics

• The ContactCallDetail table, which is the main table for call statistics

To conclude the Unified CCX system configuration process, connect to the Unified CCXAdministration web
interface and perform the following Historical Reporting Configuration tasks:

Procedure

Step 1 Define the maximum number of database connections for report client sessions.
Step 2 Assign historical reporting capability to users.
Step 3 Configure the Daily Purge Schedule and specify notification parameters.

Manage Unified CCX
To manage your Unified CCX, you must first provision and configure it. The day-to-day administration of
the Unified CCX system and datastores consist of many tasks, such as:
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• Starting and stopping the Unified CCX Engine and processes.

• Managing and monitoring the status of Unified CCX servers and components across the cluster.

Support for high availability and remote servers is available only in multiple-server
deployments.

Note
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C H A P T E R  2
Unified CCX Administration Web Interface

The Unified CCX provides a multimedia (voice, data, and web) IP-enabled customer-care application
environment, using VoIP technology that allows your Cisco Unified Communications network to share
resources with your data network.

You can then use a web browser located on any computer on the IP network to configure and administer
your applications with the Unified CCX Administration web interface.

Support for high availability and remote servers is available only in multiple-server deployments.Note

The Unified CCX Administration web interfaces (Cisco Unified CCX Administration and Cisco Unified
CCX Serviceability) allows you to:

• Configure and monitor overall system functions, applications, and subsystems

• Access a wide variety of system tools

• Perform many other administrative tasks

The following sections provide more information about the Unified CCX Administration web interface:

• Access Unified CCX Administration Web Interface, page 15

• Cisco Unified CCX Administration Menu Bar and Menus, page 16

• Cisco Unified CCX Administration Navigation, page 17

• Unified CCX Configuration Web Pages, page 19

Access Unified CCX Administration Web Interface
The web pages of the Unified CCX Administration web interface allow you to configure and manage the
Unified CCX system and its subsystems.

Use the following procedure to browse into the server and log in to Unified CCXAdministration web interface.
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Procedure

Step 1 Open the Unified CCX Administration Authentication page from a web browser on any computer on your
network and enter the following case-sensitive URL:
https://<servername>/appadmin

In this example, replace <servername> with the hostname or IP address of the required Unified CCX server.

A Security Alert dialog box is displayed.

Step 2 Click the appropriate button.
The Authentication page appears.

Note • Ensure that Cisco Tomcat and Cisco Unified Cluster View Daemon services are running before
you log in to the Unified CCX Administration using the URL in Step 1.

• Verify that the popup blocker is disabled if you are using Microsoft Internet Explorer Version
6.0 or later or Mozilla Firefox Version 2.0 or 3.0 browser.

• Enable the compatibility mode if you are using Microsoft Internet Explorer Version 11.0.
Add the IP address of the Unified CCX server to the "Compatibility View Settings," to
enable the compatibility mode in Microsoft Internet Explorer Version 11.0.

Tip

Step 3 On the main Cisco Unified CCX Administration web page, enter your Unified CCX username and password.
If you are accessing Unified CCX for the first time, enter the Application User credentials specified
during installation of the Unified CCX. See the Cisco Unified Contact Center Express Install and
Upgrade Guide for further instructions. The user ID is not case sensitive in Unified CCX 9.0(1).

Note

Step 4 Click Login.
A web page opens listing information about Cisco Unified CCX Administration and the Cisco Unified CCX
Administration menu bar appears at the top of the page.

Note • For security purposes, Cisco Unified CCX Administration logs you out after 30 minutes of
inactivity, and you must log back in.

• Unified CCX Administration detects web based cross-site request forgery attacks and rejects
malicious client requests. It displays the error message, "The attempted action is not allowed
because it violates security policies."

• Avoid using multiple sessions of the Unified CCX Administration at the same time.

Cisco Unified CCX Administration Menu Bar and Menus
The Cisco Unified CCX Administration menu bar appears at the top of every web page of the Unified CCX
Administration web interface. You begin every Unified CCX configuration and administration task by choosing
a menu and submenu option from the menu bar.

The Cisco Unified CCX Administration menu bar contains the following menu options:

• System—Contains options for configuring new servers in the cluster, Unified CM information, language
information, changing system parameters, custom file configuration, standalone CUIC configuration,
and adding or displaying licenses.
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• Applications—Contains options for managing applications, scripts, prompts, grammars, documents,
and AAR files.

• Subsystems—Contains options for configuring parameters for the subsystems that are licensed for your
Unified CCX server. Your Subsystems menu may include submenu options for one or more of the
following subsystems: Unified CM Telephony, Unified CCX, Database, HTTP, Chat and Email,
Cisco Media, MRCP Automatic Speech Recognition (ASR), and MRCP Text-To-Speech (TTS).

•Wizards—Contains options that provide access to the following wizards of your Unified CCX server:
Application and RmCm.

• Tools—Contains options that allow you to access system tools such as Plug-ins, Real-Time Reporting,
Real-Time Snapshot Config. You can also assign access levels to administrators and supervisors and
reset passwords.

• Help—Provides access to online help for Unified CCX.

Cisco Unified CCX Administration Navigation
After you log in, the main Cisco Unified CCX Administration web page appears.

The minimum supported screen resolution specifies 1024 x 768. Devices with lower screen resolutions
may not display the applications correctly.

Note

The choices in the drop-down list include the following Cisco Unified CCX Administration applications:

• Cisco Unified CCX Administration— Uses Cisco Unified CCX Administration to configure system
parameters, subsystems, wizards, and much more.

• Cisco Unified CCX Serviceability— Takes you to the main Cisco Unified CCX Serviceability web
page that is used to configure trace files, alarms, and to activate and deactivate services.

• Cisco Finesse Administration— Uses Cisco Finesse Administration to configure system settings in
Cisco Finesse.

• Cisco Unified Serviceability— Takes you to the main Cisco Unified Serviceability web page that is
used to save alarms and traces for troubleshooting, provide alarm message definitions, activate and
deactivate services and so on.

• Cisco Unified OS Administration— Takes you to the main Cisco Unified OS Administration web
page, so that you can configure and administer the Cisco Unified Communications platform.

• Disaster Recovery System— Takes you to the Cisco Disaster Recovery System, a program that provides
data backup and restore capabilities for all servers in a Cisco Unified CCX Administration cluster.

You can log in to Cisco Unified CCX Administration either as an administration user or an application user.
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An administration user is an end user that is configured on the Unified CM with Administrator capability
in Unified CCX.

An application user is an user that is configured during the installation of Unified CCX having administrator
capability by default.

Note

If you log in as an Administrator, you can access the following applications that display in the navigation
drop-down list in the top right corner of the Administration menu bar:

• Cisco Unified CCX Administration

• Cisco Unified CCX Serviceability

• Cisco Finesse Administrator

If you log in as an application user, you can seamlessly traverse between the Unified CCX web applications
as well as the Cisco Unified Serviceability without logging in again.

An application user can log in to these four Unified CCX web applications even when Unified CM is
down.

Note

To access these applications from Cisco Unified CCX Administration, you must first choose the desired
application from the navigation drop-down list in the upper right corner and click Go.

Cisco Finesse Administration Console opens in a new tab or in a new window based on the browser
settings.

To log in to Cisco Finesse Administration, you must be an user with administration privileges.

When the Cisco Tomcat service is down on any of the Unified CCX nodes, you will not be able to launch
Cisco Unified CCX Administration from any of the Unified CCX nodes; therefore, you will not be able
to launch the Cisco Finesse Administration from within it.

In that case, you can launch the Cisco Finesse Administration directly from the browser.

To launch the Finesse Administration Console, direct your browser to https://FQDN:8445/cfadmin, where
FQDN is the fully-qualified domain name of the server.

For more information about Cisco Finesse Administration Console, see Cisco Finesse Administration
Console, on page 316.

Note

You can access the following platform-based web applications using the platform user credentials as configured
during installation of Unified CCX:

• Cisco Unified Operating System Administration

• Disaster Recovery System
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Unified CCX Configuration Web Pages
When you choose any menu and submenu option from the Unified CCX Administration menu bar, a
configuration or administration web page opens. Use this web page to continue your configuration or
administration task.

In some cases, you will perform your configuration or administration task on this one web page.

In other cases, the web page that first opens when you choose a submenu item leads to a series of web pages.
For example, the Unified CM Telephony Call Control Group Configuration web page contains both a tool
bar in the top with a few icons that link to other web pages and a configuration area.

The following table describes the Refresh All button and the Copy, Delete, and Refresh icons that are found
on several Unified CCX web pages.

DescriptionIcon/Button

Click this icon to copy the information in that specific row.

When you clickCopy, the web page displays the copied configuration so you canmake
changes, if desired.

Note

Copy

Click this icon to delete the information in that specific row.Delete

Click this icon to refresh the information in that specific row.Refresh

Click this button to refresh the information listed on this page.Refresh
All

Details for Advanced Configuration
In Unified CCX Administration web interface, advanced configuration with Show More and Show Less
options exists. On the applicable pages, all configuration details can be displayed or minimised based on user
preferences and requirements.

A page by default displays fewer parameters. Parameters configured with default values and not requiring
modification or user input are now available in the advanced configuration section. You can access this
advanced configuration section by clicking the ShowMore button at the bottom of the page. When you click
this button, the extra parameters become visible and the button changes to Show Less. When you click Show
Less, the page reverts to its original list of parameters.

If you are using Unified CCX with Cisco Contact Center Gateway solution, see the Cisco IPCC Gateway
Deployment Guide for Cisco Unified ICME/CCE/CCX. The instructions for configuring Unified CCX
with that solution differs from what is described in this guide. The Unified Gateway provides for the
integration of the Unified ICME system with Unified CCX by way of Unified Gateway. See the Cisco
Unified Contact Center Enterprise installation and upgrade guides available at http://www.cisco.com/en/
US/products/sw/custcosw/ps1844/prod_installation_guides_list.html for detailed information. The Unified
Gateway is a Peripheral Gateway (PG), which you configure on the Unified ICME software.

Note
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Toolbar and Buttons
On the top left toolbar of many web pages, you will find an Add New icon and the same Add New will also
be displayed as a button at the bottom of the web page.

For example, the Unified CM Telephony Call Control Group Configuration web page containsAdd New and
Refresh All icons on the top left toolbar and the same are displayed as buttons at the bottom of the web page.
When you click theAddNew icon or button, another Unified CMTelephony Call Control Group Configuration
web page opens. Use this area to add a new Unified CM Telephony Call Control Group.

Many web pages contain icons or buttons that perform a variety of functions. For example, the Refresh All
button on the Unified CM Telephony Call Control Group Configuration web page refreshes all the Unified
CM Telephony call control group configurations in the Unified CCX server.

A few web pages (for example, Subsystems >Database > Parameters page) also contain aReset to Default
icon and button. This allows you to revert to the software set defaults for each parameter on this page.

Application and RmCm Wizards
In Unified CCX, two wizards are available in the main menu: the ApplicationWizard and the RmCmWizard.

To improve the usability and configuration process, these wizards take you through the configuration pages
in the required order and help ease the configuration process for these two features. You can access these
wizards from a new main menu option calledWizards.
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C H A P T E R  3
Unified CCX Provision Checklist

The Cisco Unified Communications Manager (CM) product supports both single-node and two-node (high
availability) deployments available for the Cisco Unified Contact Center Express (CCX).

The deployment model is transparent to the Unified CCX installer as the clustering for Unified CM is
performed through the Unified CCXAdministration using the Unified CCX setupwizard. The high availability
over WAN feature of Unified CCX is supported only for Unified CM deployments.

The following topics introduce the Unified CCX subsystem and explain how to modify the Unified CM
information from Unified CCX.

• Unified CCX, page 21

• Provision Unified CCX, page 22

• Change Licensing Packages, page 23

Unified CCX
The Unified CCX system uses the Unified CCX subsystem as part of an ACD system to provide resource
distribution and queueing to call centers.

Two types of routing are available:

• Contact Service Queue (CSQ)-based routing—CSQs are entities that route calls to your resources
(agents). Each CSQ controls incoming calls and determines where an incoming call is placed in the
queue and to which agent the call is sent.

Each CSQ selects resources from an associated resource pool that you define or from resource skills for
all Unified CCX license packages. When an agent becomes available to take a call, the system chooses
a queued call from one of the CSQs whose resource pool includes the agent, and routes that call to that
agent.

• Agent-based routing—Agent-based routing provides the ability to send a call to a specific agent, rather
than any agent available in a CSQ.

A Unified CCX agent can participate in both CSQ-based and agent-based routing. A Unified CCX agent can
be any one of the following:

• Cisco Finesse
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• IP Phone Agent

• Extension Mobility (EM) Agent

• Supervisor (if the supervisor is taking calls)

A supervisor who is not taking calls is not considered to be an agent.Note

Calls are queued in the Unified CCX server and sent to agents by the Unified CCX server.

The machine you install your Unified CCX system on determines how many agents and IVR ports Unified
CCX can accommodate. However, be aware of the following general configuration rules:

• Each agent cannot be associated with more than:

◦25 CSQs (This is a configuration design guideline; Unified CCX Administration does not enforce
the rule.)

◦50 skills (Unified CCX Administration enforces this rule.)

• Each CSQ cannot be associated with more than 50 skills. (Unified CCX Administration enforces this
rule.)

• A call should not queue for more than 25 CSQs. (This is a configuration design guideline; Unified CCX
Administration does not enforce the rule.)

Provision Unified CCX
To provision Unified CCX, complete the following tasks:

Unified CMTaskStep

Provision Unified CM for
Unified CCX, on page 25

Configure Unified CM users who will be agents in your Unified
CCX system.

Step 1

Provision Unified CM
Telephony Subsystem, on
page 57

Provision resources information for Unified CCX telephony and
media.

Step 2

RmCm Provider
Configuration, on page 85

Provision RmCm Provider to allow RmCm Subsystem to be in
service.

Step 3

Resource Groups, on page
87

Create resource groups.Step 4

Skills Configuration, on page
88

Create skills.Step 5

Agent Configuration, on
page 90

Assign agents to resource groups and assign skills to agents.Step 6
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Unified CMTaskStep

Contact Service Queue
Configuration, on page 94

Create Contact Service Queues.Step 7

Configure Agent-Based
Routing, on page 101

Provision agent-based routing—if using Unified CCX Enhanced or
Premium.

Step 9

Teams Configuration, on
page 103

Create teams and assign agents to teams.Step 10

Change Licensing Packages
The following three license upgrade options are available for Unified CCX system:

• Standard to Premium

• Standard to Enhanced

• Enhanced to Premium

While upgrading the licenses, you need to configure these system parameters:

• Standard to PremiumorEnhanced—Only Enhanced and Premiumpackage licenses support Recording.

• Standard or Enhanced to Premium—You need to configure the Number of Direct Preview Outbound
Seats while upgrading to a Premium license.

Downgrade of license is not supported in Unified CCX.Note

Procedure

Choose System > System Parameters from the Cisco Unified CCX Administration menu bar to open the
System Parameters Configuration web page where you can update these values.
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C H A P T E R  4
Provision Unified CM for Unified CCX

When you access Unified CCXAdministration for the first time in a cluster, the system automatically initiates
the cluster setup procedure once for each cluster to perform the following tasks:

• Identify Unified CCX license files

• Enter information about Unified CM Administrative XML Layer (AXL) and Unified CM Telephony
and RmCm providers

You can modify the Unified CM information from Unified CCX. See the Cisco Unified Contact Center
Express Install and Upgrade Guide for detailed information on how to perform the initial system setup using
the Unified CCX Administration web interface.

The following topics explain how to modify the Unified CM information from Unified CCX:

• Configure Unified Communications Manager Information, page 25

• Modify AXL Information, page 26

• Modify Unified Communications Manager Telephony Information, page 27

• Modify RmCm Provider Information, page 29

• Unified Communications Manager for Unified CCX Configuration, page 30

Configure Unified Communications Manager Information
During initial setup of Unified CCX using the Unified CCX Administration web interface, the administrator
who installed the Unified CCX should have already provided the Unified CommunicationsManager IP address
and hostname(s). The administrator must also provide the Administrative XML Layer (AXL) authentication
(user ID and password) information.

The Unified Communications Manager Configuration web page allows you to configure and update the AXL
authentication information, Unified CommunicationsManager Telephony subsystem information, and RmCm
Provider configuration information from within Unified CCX.

This page has three blocks of information: AXL service details, Unified CommunicationsManager Telephony
Provider details, and RmCm Provider details.
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Modify AXL Information
To change previously configured AXL information, complete the following steps.

If you want to change the credentials, change first in Unified CommunicationsManager and then in Unified
CCX. Otherwise, Unified CCXmight have issues communicating with Unified CommunicationsManager.

Note

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Cisco Unified CM Configuration.
The Cisco Unified Communications Manager Configuration web page opens.

Step 2 Go to theAXL Service Provider Configuration section to modify the AXL information using the following
fields:

DescriptionField

AXL Service Provider Configuration

Lists the AXL service providers selected by the Unified CCX user. Select the required
entry and move to the opposite list box using the right and left arrows. Arrange the
order of the selected entries using the up and down arrows.

If you deselect the AXL service provider from the Selected list box, a
Microsoft Internet Explorer or Mozilla Firefox window opens, informing
you about the (list of) deselected services. For security reasons (in case the
service is being used by another AXL service provider), manually disable
the AXL service only from the Unified Communications Manager.

Note

Selected AXL Service
Providers

Lists the Unified CommunicationsManager entries in the cluster. Select the required
entry and move to the opposite list box using the right and left arrows.

Make sure you configure multiple AXL providers running the AXL Service
for a redundant system.

Note

Available AXL
Service Providers

Cluster Wide Parameters

TheUnified CommunicationsManager User ID. This information is provided during
cluster setup in the Unified CCX installation process.

When you select an AXL Service Provider, the corresponding username is
automatically displayed in this field. This is a mandatory field.

User Name

Password for the Unified Communications Manager User ID. This information is
provided during cluster setup in the Unified CCX installation process. When you
select an AXL Service Provider, the corresponding user password is automatically
displayed in this field. This is a mandatory field.

Password

   Cisco Unified CCX Administration Guide, Release 11.0(1)
26

Provision Unified CM for Unified CCX
Modify AXL Information



Step 3 After logging in to the Unified CCX Administration web interface, follow these steps to update the AXL
password:
a) Log in to Unified Communications Manager Administration web interface and update the password for

the application user (AXL provider).
b) Navigate back to System > Cisco Unified CM Configuration web page of Unified CCX and enter the

new password in the Password field.
A dialog box prompts you to confirm the AXL username and password. Reenter the AXL user ID and
password and click Login.

The system validates the data and takes you back to the Unified Communications Manager configuration
page.

c) Enter the updated password once again to validate and click Update.
The AXL password is updated successfully and you should be able to log in to Unified CCXAdministration
web interface of Unified CCX with the new AXL password.

Step 4 ClickUpdate at the top of the Cisco Unified CommunicationsManager Configuration web page or theUpdate
button that displays at the bottom of the web page to save the changes. The Unified CommunicationsManager
Configuration web page refreshes to display the new settings.
The selected AXL services are now enabled. If the selected AXL services cannot be enabled, an error message
instructs you to reselect AXL service providers.

Modify Unified Communications Manager Telephony Information

TheUnified CommunicationsManager Telephony client is installed in the background after you configure
the Unified CommunicationsManager Telephony user. The Unified CommunicationsManager Telephony
client runs silently and verifies that the right version and the right client are installed.

Note

Configuring the Unified Communications Manager Telephony user does not automatically install the Unified
Communications Manager Telephony client. This is normally done during activation of Unified CCX Engine
in component activation (see Cisco Unified Contact Center Express Serviceability Administration Guide).
To install it manually, go to Subsystems > Unified CM Telephony and select the Cisco JTAPI Resync
submenu option from the Unified CCX Administration menu bar.

The latest list of CTI Managers within a cluster are listed in this section. If the Unified Communications
Manager is not functioning or if the Unified CCX cannot connect to the Unified Communications Manager
for any reason, information obtained from the most recent connection is saved as a part of the bootstrap
information.

To change previously configured Unified Communications Manager Telephony information, complete the
following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Unified CM Configuration.
The Cisco Unified Communications Manager Configuration web page opens.
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Step 2 Scroll down to the Unified CM Telephony Subsystem - Unified CM Telephony Provider Configuration
section and reconfigure the Unified Communications Manager Telephony information using the following
fields.

DescriptionField

Unified CM Telephony Subsystem—Unified CM Telephony Provider Configuration

Lists the CTIManagers selected by the Unified CCX
user. Select the required entry and move to the
opposite list box using the right and left arrows.
Arrange the order of the selected entries using the up
and down arrows.

If you deselect CTI Managers from the
Selected list box, a Microsoft Internet
Explorer or Mozilla Firefox window opens,
informing you about the (list of) deselected
CTI Managers.

Note

Selected CTI Managers

Lists the CTI Managers in the cluster. Move to the
opposite list box using the right and left arrows.

Available CTI Managers

Cluster Wide Parameters

The syntax of the User ID is: <userprefix>_<nodeid>

For example, if you set this field to cti_user, the User
ID for Node 1 will be cti_user_1. This is a mandatory
field.

User Prefix

Password you defined for the User ID in Unified
Communications Manager.

If a CTI Manager is already selected, the
corresponding password is displayed in this field.
This is a mandatory field.

Password

Reenter the password that you provided in the
Password field. This is a mandatory field.

Confirm Password

Step 3 Click Update at the top of the Cisco Unified Communications Manager Configuration web page or click the
Update button that displays at the bottom of the web page to save the changes.
The Unified Communications Manager Configuration web page refreshes to display the new settings.

The newly selected CTI Manager is now enabled. If the selected CTI Manager cannot be enabled, an error
message instructs you to reselect CTI Managers.

In a HA over WAN deployment of Unified CCX, the JTAPI user will be created only for the selected
node. To create JTAPI user for the HA node, you have to explicitly select the HA node, make necessary
updates, and click Update.

Note
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Modify RmCm Provider Information
The list of all CTI Managers available in a cluster are saved as a part of the bootstrap information. You can
change to any available CTI Managers listed in the Available CTI Managers list box in this page.

The RmCmProvider specified through the Unified CCXAdministration is automatically created in Unified
Communications Manager. You do not need to use the Unified Communications Manager web interface
to create the user.

Note

To change previously configured RmCmprovider information or to configure a newRmCmProvider, complete
the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Unified CM Configuration.
The Unified Communications Manager Configuration web page opens.

Step 2 Scroll down to RmCm Subsystem - RmCm Provider Configuration and reconfigure the selected CTI
Manager using the following fields:

DescriptionField

RmCm Subsystems—RmCm Provider Configuration

Lists the CTI Managers selected by the Unified CCX user. Select the required entry
and move to the opposite list box using the right and left arrows. Arrange the order
of the selected entries using the up and down arrows.

If you deselect CTIManagers from the Selected list box, aMicrosoft Internet
Explorer or Mozilla Firefox window opens, informing you about the (list
of) deselected CTI Managers.

Note

Selected CTI
Managers

Lists the CTI Managers in the cluster. Move to the opposite list box using the right
and left arrows.

Available CTI
Managers

User prefix for the Unified Communications Manager User IDs to be created in
Unified Communications Manager.

If a CTI Manager is already selected, the corresponding user name is displayed in
this field. If you change the CTI Managers, be sure to enter the corresponding user
prefix for the selected service. This is a mandatory field.

User ID

Password you defined for the User ID in Unified Communications Manager.

If a CTI Manager is already selected, the corresponding password is displayed in
this field. If you change the CTIManager, be sure to enter the corresponding password
for the selected service. This is a mandatory field.

Password

Reenter the password that you provided in the Password field. This is a mandatory
field.

Confirm Password
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Step 3 Click Update at the top of the Cisco Unified Communications Manager Configuration web page or click the
Update button that displays at the bottom of the web page to save the changes.
The Unified Communications Manager Configuration web page refreshes to display the new settings.

The newly selected RmCm Provider is now enabled. If the selected RmCm Provider cannot be enabled, an
error message instructs you to reselect RmCm Provider.

Unified Communications Manager for Unified CCX Configuration
To enable Unified CCX to communicate with Unified Communications Manager, you also need to assign
extensions for the users who will be agents in your Unified CCX system.

If you delete a Unified CCX user with Administrative rights fromUnified CommunicationsManager, you
can still log in to the Unified CCX Administration web interface as an application user.

Note

Q Signaling (QSIG) and Path Replacement (PR) features of Unified Communications Manager are not
supported by Unified CCX.

Note

Invoke Unified Communications Manager Administration
Begin the process of configuring Unified Communications Manager by connecting to the Unified
Communications Manager Administration web interface.

To connect to the Unified Communications Manager Administration web interface, complete the following
steps.

Procedure

Step 1 From a web browser on any computer on your network, enter the following URL:
https://servername/ccmadmin.
In this example, servername is the hostname or IP address of your Unified Communications Manager server.

A Security Alert dialog box is displayed.

Step 2 Click the appropriate button.
Step 3 At the main Cisco Unified Communications Manager Administration web page, enter the Unified

Communications Manager username and password, and then click Login.
The Unified Communications Manager Administration web page appears.

You are now ready to use the Unified Communications Manager Administration web interface to configure
users for Unified CCX.
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Unified Communications Manager Users as Unified CCX Agents

Do not configure Unified Communications Manager users having the same username/password as the
application administration credentials (configured during installation). Doing so may restrict the Unified
Communications Manager when shared across multiple Unified CCX servers.

Warning

Agent ID

When logging in to the desktop, agents use the Unified Communications Manager user ID and password.
Unified Communications Manager limits agent IDs to 128 alphanumeric characters, but Unified CCX limits
the agent IDs to 31 bytes.

Attention • Unified Communications Manager user ID should not exceed 31 bytes. If user ID exceeds 31 bytes,
Unified CCX does not synchronize users from Unified Communications Manager.

Agent Name

Agent name includes the first name and last name. The following is the limit for agent name:

• Engish-based script (German, Spanish, English, etc)—50 bytes / 50 characters

• Non-Engish script (Arabic, Chinese, Cyrillic, etc)—48 bytes / 16 characters

Unified CCX truncates the name to 50 / 48 bytes and stores if the agent name exceeds the above limit.Attention

RmCm uses the Unified Communications Manager database to determine which devices it can control and
provides an interface method for getting the Media Access Control (MAC) address of the calling party.

After you install RmCm, you have access to the Unified Communications Manager database. The database
stores parameters that initialize Unified CommunicationsManager Telephony, user profiles, application logic,
network-specific configuration information, and Directory Number Associations such as Primary Extension
and Unified CCX Extension.

The Primary Extension field represents the primary directory number for the end user. End users can have
multiple lines on their phones. From the drop-down list box, choose a primary extension when associating
devices for this end user.

Unified CCX Extension allows you to define Unified CommunicationsManager users as Unified CCX agents
in Unified Communications Manager.

To assign Unified CCX devices to end users and application users in the Unified Communications Manager,
these users must first exist in Unified Communications Manager. If these users do not exist, you must first
add the users. See the Cisco Unified Communications Manager Administration Guide to obtain detailed
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information about the Unified CCX web interface and configuration procedures. After adding the end user
and the application user, be sure to modify their Unified CCX settings.

Agents and Supervisors with IDs That Match Reserved Words Cannot Sign In

Do not use the following reserved words for agent ID or supervisor ID because these IDs conflict with system
account names that are used internally within the Unified CCX server:

Reserved wordsSystem\Components

adminUnified CCX Web Chat

adminCisco Finesse

finesse

fippa

xmpprootowner

presencelistener

Note • If a user tries to sign in with a reserved word for the agent ID or supervisor ID, the sign-in fails.

• Do not use the reserved words for IDs whether they are upper case, lower-case, or any combination
of both cases. For example, admin, ADMIN, or Admin.

Guidelines for Agent Phone Configuration
Follow these guidelines when configuring agent phones for Unified CCX agents:

• ChooseDevice > Phone in Unified CommunicationsManager Administration. The Find and List Phones
window is displayed.

Enter search criteria to locate a specific phone and click Find. A list of phones that match the search
criteria is displayed. Click the device name of the phone to which you want to add a directory number.
The Phone Configuration window is displayed.

In the Unified Communications Manager Administration Phone Configuration web page, select the
required Association Information (on the left) to get to the Directory Number Configuration web page.
On this page, make the following changes:

◦In the Multiple Call/Call Waiting Settings section, set the Maximum Number of Calls to 2 (default
is 4) for Cisco Unified IP Phones 7900 Series and 3 for Cisco Unified IP Phones 8961, 9951, and
9971.

If you are using Cisco Finesse for your agent desktop, you must set the Maximum
Number of Calls to 2 for all agent phones.

Note
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◦In the Multiple Call/Call Waiting Settings section, set the Busy Trigger value to 1 (default is 2).

◦In the Call Forward and Call Pickup Settings section, verify that you do not forward any Unified
Communications Manager device to the Unified CCX extension of an agent.

◦In the Call Forward and Call Pickup Settings section, verify that you do not configure the Unified
CCX extension of an agent to forward to a Unified CCX route point.

• Always disable (turn off) Secure Real-Time Transport Protocol (SRTP) when configuring a Cisco Unified
Communications product. You can disable SRTP for a specified device or for the entire Unified
Communications Manager:

◦For a specified device—Choose Device > Phone. In the Find and List Phone page, select the
required phone device. In the Phone Configuration page for the selected phone, scroll down to the
Protocol Specific Information section.To turn off SRTP on the phone device, select any one of the
Non Secure SCCP Profile auth by choices from the drop-down list in SCCP Phone Security
Profile or SCCP Device Security Profile field.

◦For the entire Unified Communications Manager cluster—Choose System > Enterprise
Parameters. In the Enterprise Parameters Configuration page, scroll down to the Securities
Parameters section, to verify that the corresponding value for the Cluster Security Mode field is
0. This parameter indicates the security mode of the cluster. A value of 0 indicates that phones will
register in nonsecure mode (no security).

• The Unified CCX extension for the agent must be listed within the top 4 extensions on the device profile.
Listing the extension from position 5 on will cause Unified CCX to fail to monitor the device, so the
agent will not be able to log in.

• Do not forward anyUnified CommunicationsManager device to the Unified CCX extension of an agent.

• Do not configure the Unified CCX extension of an agent to forward to a Unified CCX route point.

• Do not use characters other than the numerals 0 to 9 in the Unified CCX extension of an agent.

• Do not configure two lines on an agent phone with the same extension when both lines exist in different
partitions.

• Do not assign a Unified CCX extension to multiple devices.

• Do not configure the sameUnified CCX extension inmore than one device or device profile. (Configuring
a Unified CCX extension in one device or device profile is supported.)

• To use Cisco Unified IP Phones 9900 Series, 8900 Series, and 6900 Series as agent devices, the RmCm
application user in Unified Communications Manager needs to have “Allow device with connected
transfer/conference” option assigned to itself.

To determine a list of Unified CCX agent devices supported by Cisco Finesse Desktop, see the for active
releases available at http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX .

Modify Existing Unified Communications Manager Users
To use any version of Unified Communications Manager, you must first ensure that you define Unified
Communications Manager users as Unified CCX agents in Unified Communications Manager. After you
perform this task, these Unified CCX agents can be combined into Resource Groups, assigned Skills, and
placed in CSQs.
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In Unified CCX, this operation is called “associating a device.”Note

Be sure to assign Unified CCX devices to both end users and application users in the Unified
Communications Manager web interface.

Note

To assign devices to an end user, you must access the End User Configuration window for that user. The End
User Configuration window in Unified Communications Manager Administration allows the administrator
to add, search, display, and maintain information about Unified Communications Manager end users.

To assign devices to an application user, you must access the Application User Configuration window for
that user. The Application User Configuration window in Unified Communications Manager Administration
allows the administrator to add, search, display, and maintain information about Unified Communications
Manager application users.

If Enterprise Mobility (EM) is used together with both Cisco Unified Communications Manager release
8.0 or later and Cisco Unified Communications Manager, the Resource Manager application user must
be associated with the device profile and not with the device.

Note

To modify the Unified CCX Extension settings for existing Unified Communications Manager users who are
Unified CCX agents, complete the following steps:

If you change or update an end user ID in Unified Communications Manager, Unified CCX resets the end
user's resource name, skills, and team to default values.

Note

Procedure

Step 1 Connect to the Unified Communications Manager Administration web interface.
The Unified Communications Manager Administration web page appears.

Step 2 Choose User Management > End User.
The Find and List End Users page displays. Use the two drop-down list to search for an end user.

To find all end users that are registered in the database, click Find without entering any search text.
A list of discovered end users is displayed. Then, skip to Step 6.

Tip

Step 3 From the first Find end user where drop-down list, choose one of the listed criteria.
Step 4 From the second Find end user where drop-down list, choose one of the listed criteria.
Step 5 Specify the appropriate search text, if applicable, and click Find.

A list of discovered end users is displayed.

Step 6 From the list of records, click the end user name that matches your search criteria.
The End User Configuration page opens, displaying the configuration information for the end user that you
chose.
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Step 7 In the Controlled Devices list box below the Device Information section, select the device and click the Down
arrow below the Available Profiles list box. If the device that you want to associate with this end user is not
displayed in this pane, do the following to associate devices with an end user:
a) From the Device Information pane, click Device Association. The User Device Association page opens.
b) Finding a Device: Because youmay have several devices in your network, Cisco Unified Communications

Manager lets you locate specific devices on the basis of specific criteria. Click Find. All or matching
records are displayed. You can change the number of items that is displayed in each page by choosing a
different value from the Rows per Page drop-down.

c) Associating a Device: From the Device association for (this particular end user) pane, choose the devices
that you want to associate with this end user by checking the box to the left of the device names. You can
also use the buttons at the bottom of the window to select and deselect devices to associate with the end
user.

d) To complete the association, click Save Selected/Changes.
e) From Related Links drop-down list in the upper right corner of the web page, choose Back to User, and

click Go.
The End User Configuration page is displayed, and the associated devices that you chose are displayed in
the Controlled Devices pane.

Step 8 Select the required device and save your changes to associate that device with this end user.
After the device is associated, the Controlled Devices field displays the description information (for example,
the MAC address) that the end user controls.

Step 9 In the End User Configuration page, scroll down to the Directory Number Associations section.
Step 10 In the Primary Extension field drop-down list and the IPCC Extension field drop-down list, choose the

required agent extension for this device.
These fields represent the primary directory number for the end user. End users can have multiple lines on
their phones. If you have a single line, be sure to select the same extension for both fields.

Step 11 Click Update to apply the changes.
The specific End User Information page for this user appears, with the message that the update was successful.

Step 12 From the Unified Communications Manager Administration menu bar, choose User Management >
Application User. RmCmProviders are referred to as application users in Unified CommunicationsManager.

When you associate one device with the Unified CCX agent (end user), you must also be sure to
associate the same device with the Unified CCX RmCm Provider (application user).

Note

The Find and List Application Users window is displayed. Use the two drop-down list to search for the
application users in Unified Communications Manager.

To find all application users registered in the database, click Find without entering any search text. A
list of discovered end users is displayed. Then, skip to Step 16.

Tip

Step 13 From the first Find application user where drop-down list, choose one of the listed criteria.
Step 14 From the second Find application user where drop-down list, choose one of the listed criteria,
Step 15 Specify the appropriate search text, if applicable, and click Find.

A list of discovered application users is displayed.

Step 16 From the list of records, click the application user name that matches your search criteria.
The window displays the application user that you choose.

Step 17 Repeat Step 7 and Step 8 for the selected Application User.
These steps ensure that the Unified Communications Manager application users are also defined as Unified
CCX agents in Unified Communications Manager.
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Step 18 Click Update to apply the changes.
The specific Application Information page for this user appears, with themessage that the update was successful.

See the “User Management Configuration” section in the Cisco Unified Communications Manager
Administration Guide for detailed information on how to configure an end user and application user using
Unified Communications Manager.

Now that you have defined the agent in Unified Communications Manager, you can configure agents in
Unified CCX. Before you configure the agent, you will also need to configure resource groups and CSQs.

Assign Unified Communications Manager Users as Cisco TelePresence Virtual
Agents

The Cisco TelePresence application enables enterprises to create a live, face-to-face interaction with customers
over the network. This solution allows rapid deployment of a virtual contact center infrastructure. Agents
using Cisco TelePresence are referred to as virtual agents in this guide. Virtual agents connect to callers using
Unified CCX, which incorporates ACD, CTI, and Unified IP IVR with Cisco Unified Communications
Manager and providing the entire solution on one server.

For more information on the Cisco TelePresence solution, see http://www.cisco.com/en/US/products/
ps7060/index.html.

Note

The following guidelines apply for the Cisco TelePresence integration with Unified CCX:

• The only commonly supported codec for Unified CCX and Cisco TelePresence is G711.

• The following supervisor features are not supported:

◦Monitoring and Recording is not supported for Cisco TelePresence integration with Unified CCX.

Follow this procedure to assign Unified Communications Manager users as virtual agents:

Procedure

Step 1 Identify the required Cisco TelePresence system that will participate as a virtual agent in the Unified CCX
application.
a) Note the Unified Communications Manager extension of the Cisco TelePresence deployment.

The Cisco Unified IP Phone 7970G and Cisco TelePresence system must be assigned the same
extension in Unified Communications Manager, because they both share the same line.

Note

b) Note the MAC address or the Directory Number of the Cisco Unified IP Phone 7970G connected to the
identified Cisco TelePresence system.

From the Unified CCX perspective, this is another SIP
endpoint.

Tip
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Step 2 Associate the Cisco Unified IP Phone 7970G with the Unified Communications Manager user to configure
this user as a virtual agent.

Step 3 Associate the Cisco Unified IP Phone 7970G with the RmCm provider.
Do not associate the corresponding Cisco TelePresence systemwith the RmCmprovider.Note

Configure Tool for Auto-Registered Phones Support (TAPS)
The Tool for Auto-Registered Phone Support (TAPS) loads a preconfigured phone setting on a phone. The
TAPS works in conjunction with the Bulk Administration Tool (BAT). After the BAT is used to bulk add
phoneswith dummyMACaddresses to CiscoUnified CommunicationsManager Release 9.0(1) Administration,
you can plug the phones into the network.

The administrator or users can then dial a TAPS directory number that causes the phone to download its
configuration. At the same time, the phone gets updated in the Unified Communications Manager database
with the correct MAC address of the phone. Refer to Configuring the Bulk Administration Tool (BAT) if you
are not familiar with the BAT.

For the TAPS to function, you must make sure that Auto-registration is enabled in Cisco Unified
Communications Manager Administration (select System > Cisco Unified CM). Follow the instructions in
the procedure below to install and configure TAPS application with Unified CCX.

Procedure

Step 1 Log in to Cisco Unified Communications Manager Administration Release 9.0(1) and choose Application >
Plugins from the Cisco Unified Communications Manager Administration menu bar.

Step 2 In the Find and List Plugins web page, search for “Cisco TAPS” and click Find.
Step 3 Download the TAPS_AAR.aar file to your client PC, which is used for accessing Unified Communications

Manager Administration and Unified CCX Administration.
Step 4 Install Unified CCX. See the Cisco Unified Contact Center Express Install and Upgrade Guide, available at

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_installation_guides_list.html.
Step 5 After installing Unified CCX, follow these steps from the User Configuration page in Unified CCX

Administration:
a) In the Cisco Unified Communications Manager Users list, select the Cisco Unified Communications

Manager user whom youwant to designate as the Cisco Unified CCX administrator and who can configure
TAPS.

b) Click the left arrow (<) to move the selected user to the Cisco Unified CCX Administrator list.
c) Click Finish. The Cisco Unified CCX Setup Result Information window is displayed. This window

confirms the result of the initial setup. The Cisco Unified CCX engine will restart.
d) Close your web browser.

Step 6 Log in to Cisco Unified CCXAdministration as the Unified CCX application administrator, who can configure
TAPS. After installing and configuring Unified CCX and Unified Communications Manager, follow this
procedure to set up TAPS:
a) From the Unified CCX Administration menu bar, choose Applications > AARManagement. Click

Browse and upload the TAPS_AAR.aar file that you downloaded in Step 3 fromUnified Communications
Manager.
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On successful upload, you will see a confirmation message in the status bar at the top of the AAR
Management web page.

For TAPS configuration, you need to restart the Unified CCX engine and Unified CCX Cluster
View Daemon (CVD). You can restart the CVD using the CLI command,

utils service service name stop/start.

Note

b) After restarting the CVD, log in once again to Cisco Unified CCX Administration as the Unified CCX
application administrator. From the Unified CCXAdministration menu bar, choose Subsystems >Unified
CMTelephony >Call Control Group. ClickAddNew and provide the Call Control Group Configuration
values for TAPS using the following fields:

• Group ID

• Number of CTI Ports

• Media Termination Support

• Device Name Prefix

• Starting Directory Number

c) From the Unified CCX Administration menu bar, choose Subsystems > Cisco Unified CM Telephony
> Triggers. Click Add New and specify values for the following mandatory fields:

• Directory Number

• Language

• Application Name

• Device Name

• Description

• Call Control Group:
The call control group types can be Inbound or Outbound for Unified CCX running with Unified
Communications Manager.

d) Choose Subsystems > Cisco Unified CM Telephony > Data Resync from the Cisco Unified CCX
Administration menu bar to check and resynchronize the JTAPI data between Cisco Unified
Communications Manager and Cisco Unified CCX.

e) From the Unified CCXAdministration menu bar, chooseApplications >ApplicationManagement. The
Application Management web page opens, displaying the details of existing applications.

f) Click the Add New icon or button. The Add a New Application web page opens.
g) From the Application Type drop-down menu, choose Cisco Script Application and click Next. The Cisco

Script Application configuration web page opens.
h) In the Script field, select the script “/TAPS.aef” from the drop-down list and enter the IP address of the

Cisco Unified Communications Manager in the text box below the Script drop-down list.
i) Check the check box against Cisco_Unified_CM_IP_Address field.
j) Click the Yes radio button in the Enabled field.
k) Click Update.
l) Log in to Cisco Unified Communications Manager Serviceability Page and restart the TAPS Service.
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C H A P T E R  5
Cisco Applications Configuration

The Unified CCX system uses applications to interact with contacts and perform a wide variety of functions,
such as prompting callers for information, transferring calls, and providing information to callers.

To configure Unified CCX applications, you must complete the following tasks:

• Provision telephony and media resources (see Telephony and Media Provision, on page 55)

• Provision your Unified CCX subsystem, if required (see Provision of Unified CCX, on page 85)

• Provision additional subsystems, if required (see Provision of Additional Subsystems, on page 107)

The following sections describe how to configure applications and make them available to the Unified CCX
system.

• About Unified CCX Applications, page 39

• Application Triggers, page 45

• Script Management, page 50

About Unified CCX Applications
The Unified CCX system uses applications to interact with contacts and perform a wide variety of functions.

Unified CCX licenses you purchase and install determine the applications available on your system.Note

Unified CCX provides the following application types:

• Script

• Busy

• Ring-No-Answer
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Configure Script Applications
The Unified CCX script applications are applications based on scripts created in the Unified CCX Editor.
These applications come with every Unified CCX system and execute scripts created in the Unified CCX
Editor.

Use the Unified CCX Editor to create scripts that direct the Unified CCX system to automatically answer
calls and other types of contacts, prompt callers for information, accept caller input, queue calls, distribute
calls to available agents, place outbound calls, respond to HTTP requests, and send email messages.

The Unified CCX system includes a number of sample scripts. For a description of these sample scripts,
and for more information on creating scripts with the Unified CCX Editor, see the Cisco Unified Contact
Center Express Getting Started with Scripts. In addition, a script repository is available at http://
www.cisco.com/en/US/products/sw/custcosw/ps1846/products_implementation_design_guides_list.html.
This repository provides some examples of scripting techniques that can leverage Unified CCX abilities.

Note

Cisco script applications can make use of many components, such as scripts, prerecorded prompts, grammars,
languages, locales, and custom Java classes.

Upload these components to the repository before you configure a Cisco script application that uses them.Tip

Depending on your particular Unified CCX implementation, you may need to perform most or all of the
following tasks to configure a Cisco script application:

• Manage scripts—Cisco script applications are based on scripts that you must upload to the repository
and make available to the Unified CCX system.

• Manage prompts—Many applications make use of prerecorded prompts, stored as .wav files, which are
played back to callers to provide information and elicit caller response. You must upload these .wav
files to the repository and make them available to the Unified CCX system.

• Install grammars—The Unified CCX system uses specific grammars to recognize and respond to caller
response to prompts. Youmust store these grammars in a directory to make them available to the Unified
CCX system.

• Install customized Unified CCX languages—Language packs, such as American English, Canadian
French, and so on, are installed with Unified CCX. You install language packs in a directory accessible
by the Unified CCX system.

• Install Java files—In addition to the Java files automatically installed as part of the Unified CCX
installation process, you can install your own custom classes and Java Archive (JAR) files to customize
the performance of your Unified CCX system.

• Add a Cisco script application—Scripts created in the Unified CCX Editor are used as the basis for
Cisco script applications.

• Add an application trigger—Triggers are specified signals that invoke application scripts in response to
incoming contacts. After adding a new Cisco script application, you need to add a trigger so that this
application can respond to telephone calls and HTTP requests.
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Add New Cisco Script Application
To add a new Cisco script application, complete the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Application Management.
The Application Management web page opens, displaying the details of any existing applications.

Step 2 Click Add New icon that is displayed in the tool bar in the upper left corner of the window or the Add New
button that is displayed at the bottom of the window.
The Add a New Application web page opens.

Step 3 From the Application Type drop-down menu, choose Cisco Script Application and click Next.
The Cisco Script Application configuration Web page opens.

Step 4 Specify the following fields:
DescriptionField

A name for the application. This is a mandatory field.Name

Accept the automatically-generated ID, or enter a
unique ID. This is a mandatory field.

The Historical Reporting feature uses this
ID to identify this application.

Note

ID

The maximum amount of simultaneous sessions
(instances) that the application can handle. This is a
mandatory field.

Maximum Number Of Sessions
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DescriptionField

This field is available only for Cisco Script
Application type. This is a mandatory field.

Note

Perform one of the following actions:

• Choose a script from the drop-down list to run
the application. If the script contains parameters,
the parameters are displayed below the Script
drop-down menu. Each parameter has a check
box, which enables you to override the default
value for that parameter. If you want to override
the value, check the check box for that
parameter.

All scripts under the default directory are
listed in the drop-down list of the Script field
in the Cisco Script Application Configuration
web page.

Note

• Click Edit, enter the script name in the dialog
box, and clickOK. The User Prompt dialog box
closes, and the name you entered appears in the
Script field.

If you enter the script name as a file URL,
enter the value with double backslashes (\\).
For example, file://c:\\temp\\aa.aef

Note

Script

Use the Tab key to automatically populate this field.

For the Busy and Ring-No-Answer
application types, this field is only visible
when you click Show More.

Note

Description

Click the required radio button to accept (Yes =
default) or reject (No)

For the Busy and Ring-No-Answer
application types, this field is only visible
when you click Show More.

Note

Enabled
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DescriptionField

This field is available only for Cisco Script
Application type.

Note

The default script executes when an error occurs with
the configured script application that causes it to
abort.

Perform one of the following actions:

• Choose a script from the drop-down list to run
the application. If a Default Script is not defined,
the internal system default is executed.

• Click Edit, specify a script in the dialog box
that appears, and click OK.

Default Script

Step 5 Click Add.
The Cisco Script Application page refreshes, the Add New Trigger hyperlink appears in the left navigation
bar, and the following message is displayed in the status bar on top:

The operation has been executed successfully.

Click Back to Application List icon or button to view the list of existing applications.

Step 6 Add a trigger for the application.

Configure Busy Application
The Cisco Busy application comes with each Unified CCX system. This application returns a busy signal
when a call reaches a Computer Telephony Interface (CTI) route point and the extension is busy.

Before You Begin

To configure the Busy application, you will need to perform the following tasks:

• Add the Busy application.

• Add a Unified CM Telephony trigger to the Busy application. The Busy application is activated when
it is triggered by a Unified CMTelephony trigger. The Busy application does not support HTTP triggers.

To configure the Unified CCX server with the Busy application, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Application Management.
The Application Management web page opens, displaying the details of existing applications, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New
button that is displayed at the bottom of the window.
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The Add a New Application web page opens.

Step 3 From the Application Type drop-down menu, choose Busy, and then click Next.
The Busy Application Configuration web page appears.

Step 4 Specify the following fields:
DescriptionField

A name for the application. This is a mandatory field.Name

Accept the automatically-generated ID, or enter a unique ID. This is a mandatory
field.

The Historical Reporting feature uses this ID to identify this application.Note

ID

The maximum amount of simultaneous sessions (instances) that the application can
handle.

MaximumNumberOf
Sessions

The following fields are displayed only on click of Show More button.

Use the Tab key to automatically populate this field.Description

Click the required radio button to accept - Yes (the default).Enabled

Step 5 Click Add.
The Busy web page refreshes, the Add New Trigger hyperlink appears in the left navigation bar, and the
following message is displayed in the status bar on top:

The operation has been executed successfully

Step 6 Add a trigger for the application.

Configure Ring-No-Answer Application
The Cisco Ring-No-Answer application comes with each Unified CCX system. This application returns a
ring tone signal when a call reaches a CTI route point.

Before You Begin

To configure the Ring-No-Answer application, you will need to perform the following tasks:

• Add the Ring-No-Answer application.

• Add a Unified CM Telephony trigger to the Ring-No-Answer application. The Ring-No-Answer
application is activated when it is triggered by a Unified CM Telephony trigger.

To configure the Unified CCX server with the Ring-No-Answer application, complete the following steps:
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Application Management.
The Application Management web page opens, displaying the details of existing applications, if any.

Step 2 Click Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add New
button that is displayed at the bottom of the window.

Step 3 From the Application Type drop-down menu, choose Ring-No-Answer, and then click Next.
The Ring-No-Answer web page opens.

Step 4 Specify the following fields.
DescriptionField

A name for the application. This is a mandatory field.Name

Accept the automatically-generated ID, or enter a unique ID. This is a mandatory
field.

The Historical Reporting feature uses this ID to identify this application.Note

ID

The maximum amount of simultaneous sessions (instances) that the application can
handle. This is a mandatory field.

MaximumNumberOf
Sessions

The following fields are displayed only when you click the Show More button:

Use the Tab key to automatically populate this field.Description

Click the required radio button to accept - Yes (the default).Enabled

Step 5 Click Add.
The Ring-No-Answer web page refreshes, theAdd New Trigger hyperlink appears in the left navigation bar,
and the following message is displayed in the status bar on top:

The operation has been executed successfully

Step 6 Add a trigger for the application.

Application Triggers
After adding a new Cisco application, you need to add one or more triggers so that the application can respond
to Unified CM Telephony calls and HTTP requests.

Triggers are specified signals that invoke application scripts in response to incoming contacts. The Unified
CCX system uses Unified CM Telephony triggers to trigger responses to telephone calls and HTTP triggers
to respond to HTTP requests.

You can use either of the below two methods to add a trigger to an application:
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• Add the trigger from the Cisco Application web page or add the trigger from the Unified CMTelephony.

• HTTP Triggers web pages available from the Subsystem menu.

Unified CM Telephony Trigger
You must add Unified CM Telephony triggers to invoke Cisco applications in response to incoming contacts.

A Unified CM Telephony trigger responds to calls that arrive on a specific route point by selecting telephony
and media resources to serve the call and invoking an application script to handle the call.

Add Unified CM Telephony Triggers from Application Web Page
To add a Unified CMTelephony trigger directly from the Cisco Application Configuration web page, complete
the following steps.

Procedure

Step 1 From the configuration web page for the application you want to add a trigger for, click Add New Trigger.
The Add a New Trigger window opens.

Step 2 From the Trigger Type drop-down menu, choose Unified CM Telephony and click Next.
The Unified CM Telephony Trigger Configuration window opens.

Step 3 Follow the procedure described in Add Unified CM Telephony Trigger.

Add Unified CM Telephony Triggers from Unified CCX
To add a Unified CMTelephony trigger to an application from the Unified CMTelephony subsystem, complete
the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems >Unified CM Telephony > Triggers.
The Unified CM Telephony Trigger Configuration summary web page opens.

Step 2 Click the Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add
New button that is displayed at the bottom of the window.

Step 3 The Cisco Unified CM Telephony Trigger Configuration web page opens. Follow the procedure described
in Add Unified CM Telephony Trigger, on page 66 (Steps 3 and 4) for detailed instructions on adding and
configuring a Unified CM Telephony trigger.
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HTTP Trigger Provision
A Cisco application can be used to handle HTTP requests when the Unified CCX system is provisioned with
an HTTP trigger.

HTTP triggers are available if your system has a license installed for one of the following Cisco product
packages: Unified IP IVR or Unified CCX Premium.

Note

An HTTP trigger is the relative URL a user enters into the client browser to start the application. You can
upload either eXtensible Style Language Transformation (XSLT) templates or Java Server Pages (JSP)
templates to serve as your HTTP trigger.

The following path is an example of an HTTP-triggered request (using the HTTP trigger name “/hello”):

http://www.appserver.acme.com:9080/hello

In this example, the URL starts the application with the HTTP trigger “/hello” on a web server running on
port 9080 with the host name www.appserver.acme.com.

You can add the HTTP trigger from the Cisco Script Application web page or add the trigger from the HTTP
subsystem.

Add HTTP Trigger from Application Web Page
To add an HTTP trigger directly from a Cisco Application Configuration web page, complete the following
steps.

Procedure

Step 1 From the configuration web page for the application you want to add a trigger for, click Add New Trigger
hyperlink.
The Add a New Trigger window opens.

Step 2 From the Trigger Type drop-down menu, select HTTP and click Next.
The HTTP Trigger Configuration window opens.

Step 3 Specify the following fields.
DescriptionField

The relative URL

For example:

/hello

URL
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DescriptionField

Perform one of the following actions:

• Choose a default language from the drop-down
list.

• Click Edit, specify a default language in the
dialog box that appears, and click OK.

Language

The maximum amount of simultaneous sessions that
can be served by the HTTP subsystem for this trigger.

Maximum Number Of Sessions

Maximum amount of time (in milliseconds) that the
system will wait to invoke the application before
rejecting a contact.

Idle Timeout (in ms)

Click the required radio button to accept - Yes (the
default).

If you disable the trigger, the user receives
an error message when browsing to the
defined trigger URL.

Note

Enabled

Step 4 Click Add.
The Cisco Application Configuration web page appears, and the URL of the HTTP trigger appears on the
navigation bar.

Step 5 Test the trigger by entering the URL you just configured in the address bar of your browser.
For example,

/hello

The browser should display “hello”.

Add HTTP Trigger from HTTP Subsystem
To configure a HTTP trigger from the HTTP subsystem, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > HTTP.
The HTTP Trigger Configuration web page opens.

Step 2 Click the Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add
New button that is displayed at the bottom of the window.
The HTTP Trigger Configuration window opens.
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Step 3 Specify the following mandatory fields.
DescriptionField

The relative URL.

For example:

/hello

URL

Perform one of the following actions:

• Choose a default language from the drop-down
list.

• Click Edit, specify a default language in the
dialog box that appears, and click OK.

Language

Choose the name of the application from the
drop-down list.

Application Name

The maximum amount of simultaneous sessions that
can be served by the HTTP subsystem for this trigger.

Maximum Number Of Sessions

Maximum amount of time (in milliseconds) that the
system will wait to invoke the application before
rejecting a contact.

Idle Timeout (in ms)

Click the required radio button to accept - Yes (the
default)

If you disable the trigger, the user receives
an error message when browsing to the
defined trigger URL.

Note

Enabled

Step 4 Click Add.
The Cisco Application Configuration web page appears, and the URL of the HTTP trigger appears on the
navigation bar.

Step 5 To test the trigger, enter the URL you just configured in the address bar of your browser.
For example,

/hello

The browser should display “hello”.
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Script Management
Scripts are created with the Unified CCX Editor, and can perform a wide variety of functions. For example,
scripts can prompt callers for extension numbers to transfer calls, place callers in a queue and route calls to
available agents, and place outbound calls.

The Script Management option of the Applications menu of the Unified CCX Administration web interface
contains options for managing and refreshing Unified CCX scripts that are stored in the repository.

Your Unified CCX system includes sample scripts stored as .aef files.Note

If a large number of VRU scripts are configured for your system, the Upload a New Script and Refresh
Scripts operations can take a long time to complete. These tasks can also result in high CPU utilization.

Caution

Upload New Scripts
To make a script available for use as a Unified CCX application, you must first upload the script to the
repository. In Unified CCX Release 4.5 and later, uploaded scripts are stored in the Repository Datastore
(RDS) database, along with prompts, grammars, and documents files. Prior to Release 4.5, the RDS database
only contained the prompts, grammars, and documents files. The scripts can also be grouped into folders and
subfolders.When user scripts are uploaded into repository, they get synchronized to local disk and are accessed
from there.

To upload a script to the repository, complete the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management.
The Script Management page opens.

The Script Management page allows you to only work with user scripts; it does not have
language-based directories.

Note

The following table describes the available columns on the Script Management web page.

DescriptionField

The level of the directory that is currently selected in the folder drop-down list.Folder Path

The name of the script.

Click the icon in front of the script name to download the script
file.

Note

Name

The size of the script file prefixed with KB. The file size is converted from bytes to
KB.

This column is usually blank on the root page as the items on this page are
usually folders.

Note

Size
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DescriptionField

The date and time when the document was last uploaded or changed along with time
zone.

Date Modified

The user ID of the person who performed these modifications.Modified by

To delete the corresponding folder.

When you delete a folder, you permanently remove it from the repository
and make it unavailable to the Unified CCX system.

Caution

Delete

To rename the required subfolder within the default folder.Rename

To refresh the corresponding script.Refresh

Step 2 Click Upload New Scripts icon that is displayed in the tool bar in the upper, left corner of the window or the
Upload New Scripts button that is displayed at the bottom of the window.
The Upload Script dialog box opens.

Step 3 To locate the script, click Browse button next to the File Name field, navigate to the directory in which the
scripts are located, select a script, and click Open.
The script path for the profile appears in the File Name field.

Step 4 Click Upload to upload the script to the repository.
A window opens, informing you that the script was successfully uploaded.

You are now ready to manage any existing scripts shown in the Script Management page (if necessary) or
add prompts that may be useful to your applications.

Download Script File
To view or download a script file, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management.
The Script Management page opens to display the contents of the default folder.

Step 2 Click theDownload Script icon that appears before the Name of the script file you want to view or download.
The File Download dialog box opens.

Step 3 Perform one of the following tasks:
a) To view the script file, click Open.

The script file opens in the Unified CCX Editor.

b) To download the script file, click Save, and then follow the prompts to choose a directory and file name
for the script file.

Cisco Unified CCX Administration Guide, Release 11.0(1)    
51

Cisco Applications Configuration
Download Script File



The file is saved to the specified directory.

Refresh Scripts

If a large number of VRU scripts are configured for your system, the Upload a New Script and Refresh
Scripts operations can take a long time to complete. These tasks can also result in high CPU utilization.

Caution

When you make changes to a script, you must refresh the script to direct all the applications and subsystems
that use this script to reload the new version. There are two script refresh options:

• Refresh Scripts Individually, on page 52

• Refresh Bulk Scripts, on page 52

Refresh Scripts Individually
To refresh an individual script on the Unified CCX server from the repository (RDS), complete the following
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management.
The Script Management page opens to display the contents of the default folder.

Step 2 In the row that contains the script, click Refresh icon.
The script information refreshes and the Script Management page reappears.

Refresh Bulk Scripts

Support for high availability and remote servers is available only in multiple-server deployments.Note

Bulk scripts refers to multiple .aef script files within one .zip file.

This option is available only when you upload .zip files. You will see the option to refresh scripts after
the selected file is uploaded successfully.

Note

To refresh all scripts (within a zip file) with one command, complete the following steps.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management.
The Script Management page opens to display the contents of the default folder.

Step 2 Click the Upload New Scripts icon or button.
The Upload Script dialog box opens.

Step 3 To locate the script, click the Browse button next to the File Name field, navigate to the directory in which
the scripts are located, select a file, and click Open. The script path for the profile appears in the File Name
field.

You can only upload .zip files containing .aef files. The total size of the.zip file cannot exceed 20
MB.

Tip

Step 4 Click Upload to upload the script to the repository.
A window opens, informing you that the script upload succeeded.

Step 5 Click Refresh icon in the Script Management page.
The Script Management web page opens, giving you the option of refreshing the script and the applications
that reference it, or just refreshing the script.

Step 6 Specify one of the following options:

• If you want all applications and subsystems that reference the script (in the repository) to use the new
version, click Yes.

• If you only want to refresh the scripts, click No.

• If you want to cancel the operation, click Cancel.

The script information refreshes and the Script Management page reappears to display the newly loaded .zip
file.

Rename Script or Folder
To rename a script or folder, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management.
The Script Management page opens to display the contents of the default folder.

Step 2 Click Rename icon for the folder or script that you want to rename. A dialog box opens displaying the name
of the selected folder or script.

Step 3 Enter a new name for this folder or script in the text box.
Step 4 Click Rename button.

The dialog box refreshes to state that the folder was successfully renamed.

Step 5 Click Return to Script Management button.
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The dialog box closes and the default folder's updated Script Management page displays the new script name.

Delete Script or Folder
When you delete a script or a folder, you remove it permanently from the repository.

To delete a script or folder, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management.
The Script Management page opens to display the contents of the default folder.

Step 2 To delete a folder, click Delete icon for the folder or script that you want to delete.
A dialog box opens to confirm your action on the selected script or folder.

Step 3 Click OK.
The dialog box closes and the default folder's updated ScriptManagement page refreshes to display the updated
list of folders and scripts.

Sample Scripts
Your Unified CCX system includes sample scripts stored as .aef files. These scripts have been built using
Unified CCX Editor steps, including prerecorded prompts. You can use these scripts to create applications
without performing any script development, or you can use these scripts as models for your own customized
scripts.

The included scripts are bundled with the Unified CCX system only as samples; they are not supported
by Cisco. For more information on these sample scripts, see the Cisco Unified Contact Center Express
Getting Started with Scripts.

Note
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C H A P T E R  6
Telephony and Media Provision

Resource provisioning information for the Unified CCX telephony and media subsystems are provided in
this chapter.

• Unified CCX Telephony and Media, page 55

• Provision Unified CM Telephony Subsystem, page 57

• Additional Unified CM Telephony Information, page 70

• Cisco Media Subsystem, page 71

• ASR and TTS in Unified CCX, page 73

Unified CCX Telephony and Media
The Unified CCX system uses a telephony resource called Computer Telephony Interface (CTI) ports to accept
incoming calls and to place outbound calls. The Unified CCX system uses the following media resources to
provide interactive services for calls:

• Unified CM Telephony—The Unified CCX Engine uses the Unified CM Telephony subsystem to send
and receive calls from the Unified CM by interfacing with the CTI Manager through the Unified CM
Telephony client.

• Cisco Media Termination (CMT)—The CMT channels provide media terminations in the Unified CCX
for Unified CM Telephony Call Contacts. These channels enable the Unified CCX to play media to the
connected party. DTMF digits are received out of band by the Unified CM Telephony subsystem.

• MRCP Automated Speech Recognition (MRCP ASR)—The ASR media resource allows callers to use
speech to navigate menus and to provide other information to Unified CCX applications.

• MRCP Text-To-Speech (MRCP TTS)—The TTS media resource enables Unified CCX applications to
play back documents to callers as speech.
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Media resources are licensed and sold as Unified IP IVR ports. Although you can
provision more channels than you are licensed for, licensing is enforced at run-time. If
more channels are provisioned than licensed, the system will not accept the extra calls,
because doing so would violate your licensing agreements.

Note

The Unified CCX system uses groups to share telephony and media resources among different applications:

• Call control groups allow you to control how the system uses CTI ports. For example, you can reserve
more ports for higher-priority applications or provide access to fewer ports for applications with less
traffic.

• Media resource groups allow you to share media resources among different applications. For example,
you can share ASRmedia resource groups with applications that collect caller information and applications
that transfer calls to specific extensions.

The Unified CCX system also uses triggers, which are specified signals that invoke application scripts in
response to incoming contacts.

Media Termination Groups
Media termination groups are associated with CTI port groups.

For Unified CM deployment, you can create and use additional CTI port groups as required.Note

If a CTI port group is selected to support media termination and if the number of channels are identical to
both groups, the CTI port group is automatically created in the background. This auto creation feature eliminates
the manual CTI port group creation process.

If you choose to override media termination, the call control channel chooses the media termination
automatically. If you want to select a new dialog group, you can have more than one media termination option.
The options are used in the order that is displayed in the drop-down list.

Channels Required to Process Calls
Unified CCX needs two types of channels to process calls:

• A call control channel, which is provisioned through the Unified CM Telephony subsystem and
corresponds to CTI port resources in Unified CM.

• Amedia channel, which is provisioned through either the CMT subsystem or the MRCP subsystem and
corresponds to the kernel resources for handling the media voice path with the caller.

MRCP channels also correspond to additional resources on the MRCP server for
performing speech recognition.

Note
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Unified CCX needs access to a channel of each type to successfully process a call. However, the capabilities
of the two channel types are not identical.

For example, consider a Unified CCX system provisioned with a single Unified CM Telephony call control
channel (that is, a CTI port) and a single CMT channel. The system can handle one call at a time; when that
call terminates, the system must reinitialize the channel resources before it can accept another call.

However, the time each channel takes to reinitialize is not equal—CMT channels take more time to reinitialize
than CTI ports. For example:

• The Unified CM Telephony call control channel may take approximately 1 millisecond to reinitialize.

• The CMT channel may take approximately 200 milliseconds to reinitialize.

This example implies that the system will not be able to accept a new incoming call for 200 milliseconds after
the first call terminates; although the Unified CM Telephony channel is available after one millisecond, the
CMT channel is not and Unified CCX needs both channels to process a call.

Such a delay can become an issue when a Unified CCX system is experiencing a high load condition or needs
to handle a burst of incoming calls. Consequently, CMT channels require a higher channel count provisioning.

To provision Unified CCX systems to handle burst calls equally among all required resources, you must
configure approximately 10 percentage more CMT channels than CTI ports, and approximately 10
percentage more MRCP channels than ASR licenses.

Tip

Provision Telephony and Media Resources
To provision telephony and media resources, complete the following tasks:

Procedure

Step 1 Provision the Unified CM Telephony subsystem.
Unified CM Telephony subsystem controls telephony resources for Unified CCX system.

Step 2 Provision the Cisco Media subsystem.
Cisco Media subsystem controls CMT media resources for Unified CCX system.

Step 3 Provision the MRCP ASR subsystem.
MRCP ASR subsystem controls ASR media resources for Unified CCX system.

Step 4 Provision the MRCP TTS subsystem.
MRCP TTS subsystem controls TTS media resources for Unified CCX system.

Provision Unified CM Telephony Subsystem
The Unified CM Telephony subsystem is the subsystem of the Unified CCX Engine that sends and receives
call-relatedmessages from the Unified CMCTIManager through the Unified CMTelephony client. To enable
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your Unified CCX server to handle Cisco Unified Communications requests, you must provision the Unified
CM Telephony subsystem. The Unified CM Telephony subsystem is available in all the Unified CCX license
packages.

In previous versions of Unified CCX, it was necessary to configure Unified CM Telephony information
using Unified CM. In Unified CCX Release 4.0 and later, Unified CM Telephony configuration tasks are
performed directly through Unified CCX Administration web pages.

Note

To provision the Unified CM Telephony subsystem, complete the following tasks:

Procedure

Step 1 Configure a Unified CM Telephony Provider, if not already configured. Specify the server on which Unified
CM CTI Manager is running, and provide a Unified CM user ID and password.

Step 2 Provision Unified CM Telephony call control groups.
Unified CM Telephony call control groups pool together a series of CTI ports, which the system then uses to
serve calls as they arrive at the Unified CCX server.

Step 3 Provision a Unified CM Telephony trigger.
Unified CM Telephony triggers invoke application scripts in response to incoming contacts.

Step 4 Resynchronize Unified CM Telephony versions.

Resynchronize Cisco JTAPI Client
During the resynchronizing process, an additional check ensures that the Unified CM Telephony Client (also
known as the Cisco JTAPI Client) are the same between the clients installed on the Unified CCX node and
the Cisco Unified CM. If the Unified CCX detects a mismatch, the system downloads and installs the required
version of Cisco JTAPI Client.

To resynchronize and view the status of Cisco JTAPI client, complete the following steps.

Procedure

Step 1 Choose Subsystems > Cisco Unified CM Telephony > Cisco JTAPI Resync from the Unified CCX
Administration menu bar.

Step 2 The Cisco JTAPI Resync web page opens, displaying the status of Cisco JTAPI Client resynchronization.
At this point, if there is an incompatible version, it automatically downloads the new client.
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Resynchronize Unified CM Telephony Data
This resynchronizing process ensures that the Unified CM Telephony user, the call control groups, and the
triggers match the data of Unified CM being used.

To resynchronize the Unified CM Telephony data, complete the following steps.

Procedure

From the Unified CCX Administration menu bar, choose Subsystems > Cisco Unified CM Telephony >
Data Synchronization .
The Cisco Unified CM Telephony Data Synchronization web page opens after resynchronization, displaying
the Data Resync status of Unified CM Telephony Port Groups and Unified CM Telephony Triggers.

Configure Unified CM Telephony Provider
The Unified CM Telephony Provider web page is a read-only page that displays the latest configured
information.

Some setupsmay prevent the Unified CMdirectory administrator from creating newUnified CMTelephony
providers in a multiserver configuration. If this setup applies to you, be sure to delete preexisting Unified
CM Telephony providers before creating new Unified CM Telephony providers. For example, if the
Unified CMTelephony provider prefix is cmtelephony and you have a two-server configuration (node_id1
and node_id2), you must delete both cmtelephony_<node_id1> and cmtelephony_<node_id2>. If you do
not verify and delete preexisting Unified CM Telephony providers, the Unified CM Telephony subsystem
issues an error and will not allow you to create Unified CM Telephony providers from the Unified CM
Telephony Provider Configuration web page.

Caution

Procedure

Step 1 Choose Subsystems > Cisco Unified CM Telephony > Provider from the Unified CCX Administration
menu bar.
The Cisco Unified CM Telephony Provider web page opens.

The following table describes the read-only fields displayed in the Unified CM Telephony Provider
Configuration web page.

DescriptionField Heading

IP address of the Server, running Unified CM CTI
Manager in the cluster. This is normally the first CTI
Manager or Cisco Unified CM Telephony Provider
selected by the Unified CCX user for Unified CM
Telephony subsystem using System >Cisco Unified
CM Configuration web page.

Primary Unified CM Telephony Provider
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DescriptionField Heading

IP address of the second Server, running Unified CM
CTI Manager in the cluster. This is normally the
second CTIManager or Cisco Unified CMTelephony
Provider selected by the Unified CCX user for Unified
CM Telephony subsystem using System > Cisco
Unified CM Configuration web page.

If you have selected only one Unified CM
Telephony provider, this field will be blank.

Note

Secondary Unified CM Telephony Provider

User prefix for the Unified CM user IDs created in
Unified CM.

User Prefix

Step 2 To modify the Unified CM Telephony subsystem, clickModify Cisco Unified CM Telephony Provider
Information icon that displays in the tool bar in the upper left corner of the window. The Cisco Unified CM
Configuration web page opens.

Add New Call Control Group
The Unified CCX system uses Unified CM Telephony call control groups to pool together a series of CTI
ports, which the system uses to serve calls as they arrive or depart from the Unified CCX server. You can
create multiple Unified CM Telephony call control groups to share and limit the resources to be used by
specific applications.

To configure a new Unified CM Telephony call control group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Unified CM Telephony > Call
Control Group.
The Cisco Unified CM Telephony Call Control Group Configuration web page opens, which displays the
existing Unified CM Telephony Call Control Group information, if any.

Step 2 Click Add New icon that is displayed in the tool bar in the upper left corner of the window or the Add New
button that is displayed at the bottom of the window to create a newCTI port. The Cisco Unified CMTelephony
Call Control Group Configuration web page opens.

You can create only one call control group of the Outbound type, in which the number of CTI ports
must be always equal to or greater than the licensed Outbound IVR ports.

Note

Step 3 Use this web page to specify the following information:
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DescriptionFieldPage Area

Corresponds to the trunk group number reported to Cisco Unified
Intelligent Contact Management Enterprise (Unified ICME) when
the Unified CCX server is part of the Unified ICME solution. The
value for this field is automatically generated.

If a Stop icon displays beside the Group ID (on the Cisco
Unified CM Call Control Group Configuration list page), it
indicates that the data is invalid or out of sync with Unified
CM data; if a Head icon displays, the group is valid.

Note

Group IDGroup
Information

Description of the Group ID. Press the Tab key to automatically
populate the Description field.

Description

Number of CTI Ports assigned to the call control group. This is a
mandatory field.

If you have a Premium license with an Outbound license, you can
create only one Outbound call control group with a minimum licensed
number of IVR ports or more. The number of CTI ports for an
outbound type of call control group can be modified but not below
the licensed ports for Outbound IVR. This rule does not apply to
inbound type call control groups. You can continue to create more
inbound type call control groups.

If this field is set to <n>, the system creates <n> ports for
each Unified CCXEngine node (node in which Unified CCX
Engine component is enabled).

Note

Number of CTI
Ports

Group
Information
(continued)

Enables the auto-creation of media termination groups. This is a
mandatory field.

Yes = Provides automatic media termination if the CTI port group is
successful.

No = Media termination port group is not created (default).

Media
Termination
Support

Select the group type for the call control group using this radio button.
The choices are Inbound and Outbound. This is a mandatory field
and Inbound radio button is enabled by default. You cannot change
the group type from Outbound to Inbound and vice versa. The
Outbound type call control group will be displayed only if you have
uploaded the Outbound license on top of the premium license in your
Unified CCX.

The existing call control groups will have this value as
inbound after an upgrade from Unified CCX versions prior
to 9.0(1).

Note

Group Type
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DescriptionFieldPage Area

The Device Name Prefix (DNP) used in the name that will be given
all of the CTI Ports in this group. This is a mandatory field.

The CTI ports for this port group is restricted to a maximum of 5
characters and has the following format:

<deviceprefix>_<directoryno>

For example, if the Device Name Prefix is CTP and the starting
Directory Number is 7000, the CTI Port that is created in Unified CM
can have the device name CTP_7000.

Device Name
Prefix

Directory
Number
Information

Select Server for Telephony Port Group Configuration (displayed only in a HA overWAN deployment).

This field is displayed only in a HA over WAN deployment and it
displays the different Unified CCX nodes that are available in a HA
over WAN deployment in a drop-down list.

In a HA overWAN setup, you need to configure directory information
along with Unified CM-specific information for the ports in each
node. Once you select a node, all configuration details displayed
below this field will be specific to the selected node only. So, if you
update any node-specific parameters (below the Select Server field),
it will be applicable only to the ports specific to the selected node.
But, if you update any configuration data above the Select Server
field, it will be applicable for the ports in both the nodes except for
the Number of CTI Ports field.

You need to ensure that the values in Number of CTI ports
field for both the nodes are the same. If you modify this field,
the number of ports is modified for the selected node only as
the device pool selection for both nodes could be different
in a HA over WAN deployment. If you click Add before
updating this value for either of the node, the port group for
that node will be marked with a red cross in the main Cisco
Unified CM Telephony Call Control Group Configuration
web page to signify the fact that the number of ports between
the two nodes is different and the other node should also be
updated. In such a scenario, click the hyperlink for the node
that is tagged in red; and from the Cisco Unified CM
Telephony Call Control Group Configuration page for the
selected node, update the value in theNumber of CTI Ports
field and clickUpdate to ensure the number of CTI ports for
both the nodes are the same.

Note

After you configure the data for the selected node and click Add or
Update, the updated configuration information will be saved. For
detailed information on behavior in HA over WAN scenario, refer to
the http://www.cisco.com/en/US/products/sw/custcosw/ps1846/
products_implementation_design_guides_list.html. In case of LAN
deployment, this field is not displayed, as the same configuration data
will be applicable for both the nodes in the cluster.

Select Server
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DescriptionFieldPage Area

A unique phone number. The Starting Directory Number contains
numerals, and can have an asterisk (*) or a hash (#), or both as a prefix
or a suffix. To support E.164 compliance, Unified CCX allows you
to add the plus sign (+) before the directory number. The specified
number of ports will be created starting from the value specified in
this field. The Directory Number that you enter can appear in more
than one partition. This is a mandatory field.

When a pattern is used as a Directory Number, the phone
display and the caller ID display on the dialed phone will
contain characters other than digits. To avoid this, provide
a value for Display (Internal Caller ID), Line Text Label,
and External Phone Number Mask.

Note

StartingDirectory
Number

Directory
Number
Information

Set of common characteristics for devices, such as region, date/time
group, softkey template, and MLPP information to which you want
to assign this phone.

The support for having multiple device pools associated with
call control group(s) has been withdrawn in Unified CCX.
If you havemultiple device pools associated with call control
group(s) in an older version of Unified CCX, it is
recommended to manually assign a single device pool to
each call control group. For more information, see
Synchronize Unified CM Telephony Data, on page 257.

Note

In a HA overWAN setup, you need to configure directory information
along with Unified CM-specific information for the ports in each
node. Once you select a node, all configuration details displayed
below this field will be specific to the selected node only. So, if you
update any node-specific parameters (below the Select Server field),
it will be applicable only to the ports specific to the selected node.
But, if you update any configuration data above the Select Server
field, it will be applicable for the ports in both the nodes except for
the Number of CTI Ports field.

You need to ensure that the values in Number of CTI ports
field for both the nodes are the same. If you modify this field,
the number of ports is modified for the selected node only as
the device pool selection for both nodes could be different
in a HA over WAN deployment. If you click Add before
updating this value for either of the node, the port group for
that node will be marked with a red cross in the main Cisco
Unified CM Telephony Call Control Group Configuration
web page to signify the fact that the number of ports between
the two nodes is different and the other node should also be
updated. In such a scenario, click the hyperlink for the node
that is tagged in red; and from the Cisco Unified CM
Telephony Call Control Group Configuration page for the
selected node, update the value in theNumber of CTI Ports
field and clickUpdate to ensure the number of CTI ports for
both the nodes are the same.

Note

Device Pool
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DescriptionFieldPage Area

DN Calling
Search Space

A collection of partitions that are searched to determine how a dialed
number should be routed. The calling search space for the device and
the calling search space for the directory number get used together.
The directory number calling search space takes precedence over the
device calling search space.

For more information, see the System Configuration Guide for Cisco
Unified Communications Manager.

The Cisco Unified Communications phone location setting specifies
the total bandwidth that is available for calls to and from this location.
A location setting of HUB_NONE means that the location feature
does not keep track of the bandwidth that this Cisco Unified
Communications phone consumes.

Location

Advanced Directory Number Information (only available if you click Show More)

This information is automatically populated based on the configuration
in the Unified CM setup and displays the ASCII name filed used in
one of the following situations:

• If the device is not capable of handling the Unicode strings

• If the locals on endpoint devices do not match

• If the Unicode string is not specified

Alerting Name
ASCII

Directory
Number
(continued)

A collection of partitions that are searched to determine how a
redirected call is routed.

Redirect Calling Search Space options:

DNCalling Search Space is deprecated. UseCalling Party
or Redirect Party instead.

Note

• DN Calling Search Space—This option enables the CTI Port
to use its directory number CSS when performing a redirect /
consult transfer.

• Calling Party—This option enables the CTI Port to use the
calling party's CSSwhen performing a redirect / consult transfer.

• Redirect Party—This option enables the CTI Port to use the
CTI Route Point's CSS when performing a redirect / consult
transfer.

Redirect Calling
Search Space

A prioritized grouping of media resource groups. An application
chooses the required media resource, such as aMusic On Hold server,
from the available media resources according to the priority order
that is defined in a Media Resource Group List.

If you choose <none>, Unified CM uses the Media Resource Group
that is defined in the device pool.

Media Resource
Group List
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DescriptionFieldPage Area

A list of profiles defined in the Voice Mail Profile Configuration.

The first option is <None>, which is the current default Voice Mail
Profile that is configured in the Voice Mail Profile Configuration.

Voice Mail
Profile

Directory
Number Setting

See the Cisco Unified Communications Manager Administration
Guide for detailed information on how to configure presence groups.

Presence Group

A Unified CM radio button to determine if DTMF reception is
required. Yes is selected by default. If you select No, a warning
message is displayed.

Require DTMF
Reception

Automated Alternate Routing (AAR) group for this device. The AAR
group provides the prefix digits that are used to route calls that are
otherwise blocked due to insufficient bandwidth. An AAR group
setting of <None> specifies that no rerouting of blocked calls will be
attempted.

AAR Group

Audio source heard by the caller when the Unified CCX Script places
the caller on Hold by using the Hold Step (when you press the hold
key).

User Hold Audio
Source

Audio source heard by the caller when Unified CCX performs a
Consult Transfer (when Unified CCX calls an agent). Use this entry
for the .wav file (for example, .wav file playing a ringback tone) to
be played to the caller during this Consult Transfer.

Network Hold
Audio Source

The number that can be dialed to answer calls to this directory number
in the specified partition.

Call Pickup
Group

Call Forward and
Pickup Settings

Use a maximum of 30 alphanumeric characters. Typically, use the
user name or the directory number (if you use the directory number,
the person receiving the call may not see the proper identity of the
caller).

Leave this field blank to have the system display the extension.

Display

Phone number (or mask) that is used to send Caller ID information
when a call is placed from this line.

You can enter a maximum of 24 number, the international escape
character +, *, # and "X" characters. The X characters represent the
directory number and must appear at the end of the pattern. For
example, if you specify a mask of 972813XXXX, an external call
from extension 1234 displays a caller ID number of 9728131234.

External Phone
Number Mask

Step 4 Click Add or Save.
The Unified CM Telephony Call Control Group Configuration summary web page opens. The corresponding
CTI ports are created in the Unified CM Telephony call control group. The new call control group appears in
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the list of call control groups displayed in the Cisco Unified CMTelephony Call Control Group Configuration
web page.

Add Unified CM Telephony Trigger
You must configure Unified CM Telephony triggers to invoke application scripts in response to incoming
contacts. A Unified CM Telephony trigger responds to calls that arrive on a specific route point by selecting
telephony and media resources to serve the call and invoking an application script to handle the call. The
Unified CM Telephony triggers are available with all Unified CCX license packages.

Unified CM Telephony trigger settings include:

• Session information, such as the application to associate with the trigger, MaximumNumber of sessions
allowed, and the Idle Timeout value.

• CTI information, such as a CTI port device and CTI route points for each call Unified CCX
simultaneously places or accepts.

• Directory Number information, such as the Voice Mail Profile and Calling Search Space.

• Call Forward and Pickup instructions.

To add and configure a Unified CM Telephony trigger, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco Unified CM Telephony >
Triggers.
The Unified CM Telephony Trigger Configuration web page opens displaying the following fields.

DescriptionField

Available CTI route point, which is the directory number associated with the trigger.Route Point

Application name to associate with the trigger.Application

Maximum number of simultaneous calls that the trigger can handle.Sessions

True if the trigger is enabled; False if the trigger is disabled.Enabled

If you try to delete a trigger associated with an outbound call control group, then the campaigns
associated with the trigger become invalid and the application also gets deleted. In such cases, when
you click theDelete icon or button, a dialog box opens to confirm your action. ClickOK if you want
to delete the trigger and disassociate the campaigns associated with it. If you delete a trigger and
navigate to the Campaign Configuration web page, you will also see an alert regarding the missing
trigger association for that campaign.

Note
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Step 2 Click the Add New icon that is displayed in the tool bar in the upper left corner of the window or the Add
New button that is displayed at the bottom of the window.
The Unified CM Telephony Trigger Configuration web page opens.

Step 3 Use this web page to specify the following mandatory fields:
DescriptionField

Directory Information

A unique phone number. To support E.164 compliance, Unified CCX allows you
to add a plus sign (+) before the agent extension or a route point directory number
followed by 15 characters which consist of numerals and the following special
characters: uppercase letter X, hash (#), square brackets ([ ]), hyphen (-), and asterisk
(*).

• Supports only route point directory numbers and Finesse agent and supervisor
extensions.

Note • +1234 and 1234 are two different directory numbers.

• The square brackets ([ ]) enclose a range of values.

• For more information, see the “Wildcards and Special Characters in
Route Patterns and Hunt Pilots” section in the System Configuration
Guide for Cisco Unified Communications Manager, located at http:/
/www.cisco.com/en/us/products/sw/voicesw/ps556/prod_
maintenance_guides_list.html.

Examples:

• Valid directory numbers—+1223* or *#12#*

• Invalid directory numbers—91X+ or +-12345

Directory Number

Trigger Information

Choose the default language to associate with the incoming call when the application
is started from this drop-down menu.

To add a Language option, click Edit button. The User Prompt dialog box
opens. Enter a locale string value and click OK. The User Prompt dialog
box closes, and the name of the language opens in the Language field in
the Unified CM Telephony Configuration web page.

Note

Language

From the drop-down menu, choose the application to associate with the trigger.Application Name

A unique identifier for this device, consisting of alphanumeric characters, dots,
dashes, or underscores.

Device Name

A descriptive name for the CTI route point.Description
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DescriptionField

Choose the call control group to associate with the trigger from this drop-down
menu. For Outbound IVR Dialer, you must select the call control group from
Outbound type call control group list. The route point should be created on Unified
CM. Once you assign the Outbound group for a trigger, you cannot change it to an
Inbound group and vice versa.

Call Control Group

Advanced Configuration (available only if you click Show More).

Advanced Trigger Information

Radio buttons to choose the required option:

• Yes—enable the trigger (default)

• No—disable the trigger.

Enabled

Themaximum number of simultaneous calls that this trigger can handle. The number
is actually governed by the Unified CM (10,000 for each separate line). However
in Unified CCX, this number is restricted to the maximum number of sessions. Any
call after this number is exceeded gets the busy tone.

Maximum Number of
Sessions

The number of milliseconds (ms) the system should wait before rejecting the Unified
CM Telephony request for this trigger.

Idle Timeout (in ms)

Radio buttons to choose the required options:

Yes—Override media termination.

No—Enable media termination (default).

If you select Yes, two panes open:

• Selected Dialog Groups displays the default or selected group.

• Available Dialog Groups lists the configured dialog.

Override Media
Termination

CTI Route Point Information

This information is automatically populated based on the configuration in the Unified
CM setup and displays the ASCII name filed used in one of the following situations:

• If the device is not capable of handling the Unicode strings

• If the locals on endpoint devices do not match

• If the Unicode string is not specified

Alerting Name ASCII

The device pool to which you want to assign this route point. A device pool defines
sets of common characteristics for devices, such as region, date/time group, softkey
template, and MLPP information.

Device Pool
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DescriptionField

The total bandwidth that is available for calls to/from this location. A location setting
of HUB_NONE indicates that the locations feature does not keep track of the
bandwidth used by this route point.

Location

Directory Number Settings

The partition to which the Directory Number belongs. The Directory Number field
value must be unique within the partition that you choose.

If you do not want to restrict access to the Directory Number, select <None> as the
partition setting.

Partition

A list of profiles defined in the Voice Mail Profile Configuration.

The first option is <None>, which is the current default Voice Mail Profile that is
configured in the Voice Mail Profile Configuration.

Voice Mail Profile

A collection of partitions that are searched for numbers that are called from this
directory number. The specified value applies to all devices that use this directory
number.

For example, assume you have two calling search spaces: Building and PSTN.
Building only allows users to call within the building, while PSTN allows users to
call both in and outside the building. You could assign the phone to the Building
calling search space and the line on your phone to the PSTN calling search space.
For more information, see the System Configuration Guide for Cisco Unified
Communications Manager.

Calling Search Space

By default, Cisco Unified CommunicationsManager uses the original calling party's
calling search space (CSS) to process the redirected call from a Unified CCXTrigger
to a Unified CCXCTI Port. This default behavior requires the partition of the Unified
CCXCTI ports to be amember of the original calling party's CSS even if the partition
of the CTI Route Point/Unified CCX Trigger is accessible to the calling device's
CSS and the CSS of the CTI Route Point/Unified CCXTrigger contains the partition
of the Unified CCX CTI Ports.

You can modify this behavior using the drop-down list to instruct Cisco Unified
CommunicationsManager which CSS to use when redirecting the call from the CTI
Route Point to the CTI Port.

Calling Search Space for Redirect options:

• Default Calling Search Space—CSS of the calling device

• Calling Address Search Space—CSS of the calling device

• Route Point Address Search Space—CSS of the CTI Route Point (Trigger)

Calling Search Space
for Redirect

A list of groups to integrate the device with the iPass server. The device/line
information is provided for integrating applications.

Presence Group

Call Forward and Pickup Settings

Cisco Unified CCX Administration Guide, Release 11.0(1)    
69

Telephony and Media Provision
Add Unified CM Telephony Trigger



DescriptionField

Check one of the following options:

VoiceMail—Check this box to use settings in the Voice Mail Profile Configuration
window.

When this box is checked, Unified CM ignores the settings in the
Destination box and Calling Search Space.

Note

Destination—To use any disable phone number, including an outside destination.

Calling Search Space—To apply the above setting all devices that are using this
directory number.

Forward Busy

Use a maximum of 30 alphanumeric characters. Typically, use the user name or the
directory number (if using the directory number, the person receiving the call may
not see the proper identity of the caller). Leave this field blank to have the system
display an extension.

Display

Phone number (or mask) that is used to send Caller ID information when a call is
placed from this line.

You can enter a maximum of 24 number, the international escape character +, *, #
and "X" characters. The X characters represent the directory number andmust appear
at the end of the pattern. For example, if you specify a mask of 972813XXXX, an
external call from extension 1234 displays a caller ID number of 9728131234.

External Phone
Number Mask

Step 4 Click Add or Save to save the changes. The specified route point is created on the Unified CM.
TheUnified CMTelephony Trigger Configurationweb page opens and displays the newUnified CMTelephony
trigger.

Additional Unified CM Telephony Information
This section includes the following topics:

• Unified CM Telephony Triggers for Unified CCX Queuing, on page 70

• Unified CM Telephony Information Resynchronization, on page 71

Unified CM Telephony Triggers for Unified CCX Queuing
When limiting the number of calls per application in Unified CCX applications, you need to take care to
coordinate the Unified CM Telephony trigger Maximum Number of Sessions limit with the Media Group
session limit.

For example, if you are using Unified CCX for queuing calls and set the Unified CM Telephony trigger
Maximum Number of Sessions limit on Unified CCX to 4 and set the Call Forward and Pickup Settings to
send the fifth call to voice mail. To make this happen, you must configure the Media Group Session Limit to
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the identical setting (4). This will cause Unified CM to forward the next incoming call to voice mail (once
the CTI New Call Accept timer setting expires).

The disadvantage of this approach is that you need to define more media groups for each application and you
cannot share the same set of media groups across multiple applications.

Unified CM Telephony Information Resynchronization
If the Unified CM Telephony information (Unified CM Telephony users, CTI ports, triggers) in the Unified
CM is missing or not in sync with Unified CCX data, choose Subsystems > Cisco Unified CM Telephony
> Data Resync from the Unified CCX Administration menu bar. Unified CCX checks whether:

• The Unified CM Telephony users exist in Unified CM.

• All the ports belonging to the Port Group exist in Unified CM.

• The port group's data is in sync with Ports data in Unified CM.

• The ports' association to users are correct.

• The route point exists in Unified CM.

• The triggers data is in sync with the Route Point data in the Unified CM.

• The route points have been associated with all the Unified CM Telephony users in Unified CM.

Unified CCX synchronizes the data by:

• Creating any missing users

• Creating any missing ports

• Modifying out-of-sync ports

• Associating CTI Ports to Unified CM Telephony users. (For example, associating CTI Ports created for
Node 1 to the Unified CM Telephony User for Node 1, and so forth)

• Creating any missing route points

• Modifying out-of-sync route points

• Associating route points to all the Unified CM Telephony users.

Cisco Media Subsystem
The CiscoMedia subsystem is a subsystem of the Unified CCX Engine. The CiscoMedia subsystemmanages
the CMT media resource. CMT channels are required for Unified CCX to be able to play or record media.

The Cisco Media subsystem uses dialog groups to organize and share resources among applications. A dialog
group is a pool of dialog channels in which each channel is used to perform dialog interactions with a caller,
during which the caller responds to automated prompts by pressing buttons on a touch-tone phone.
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The built-in grammars and grammar options that are supported by Unified CCX when using an MRCP
dialog channel is determined by the MRCP speech software you purchase. See the software vendor for
information about what built-in grammars and features are supported.

Note

To enable your Unified CCX applications to handle simple DTMF-based dialog interactions with customers,
you must provision the Cisco Media subsystem to configure CMT dialog groups.

All media termination strings begin with auto and contain the same ID as the call control group—not the
CMT dialog group. If the default media termination is configured and the ID differs, follow the procedure
provided in the Add CMT Dialog Control Group.

Caution

Add CMT Dialog Control Group
To add a CMT dialog control group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco Media.
The CiscoMedia Termination Dialog Group Configuration web page opens. Any preconfigured entry is listed
on this page with the following information:

DescriptionField

The unique Group ID associated with the media.GroupID

CMT group description.

The ID in this field need not necessarily
match the CMT group ID.

Note

Description

Number of channels associated with the group.Channels

Step 2 ClickAddNew icon at the top orAddNew button at the bottom of the window. The CiscoMedia Termination
Dialog Group Configuration web page opens.

By default, a Unified CMTelephony Call Control Group with Group ID 0 is created.Note

Step 3 Use this web page to specify the following fields.
DescriptionField

A Group ID value unique within all media group
identifiers, including ASR group identifiers. This is
a mandatory field.

Group ID

Description for the Cisco Media Termination Dialog
group.

Description
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DescriptionField

Number of licensed IVR ports. Display only.Number of Licensed IVR ports

Maximum number of channels associated with this
group. This is a mandatory field.

You can specify any value for Maximum
Number Of Channels, but restrictions are
placed on the system when a call is made.
This restriction is imposed by the number of
licensed IVR ports on your system. This is
a mandatory field.

Note

Maximum Number Of Channels

Step 4 Click Add icon that displays in the tool bar in the upper left corner of the window or the Add button that
displays at the bottom of the window.
The CMT Dialog Group Configuration web page opens, displaying the new CMT dialog group.

You are now ready to provision MRCP ASR and MRCP TTS subsystems.

ASR and TTS in Unified CCX
Unified CCX supports ASR and TTS through two subsystems:

MRCP ASR

This subsystem allows users to navigate through a menu of options by speaking instead of pressing
keys on a touch-tone telephone.

MRCP TTS

This subsystem converts plain text (UNICODE) into spoken words to provide a user with information,
or prompt a user to respond to an action.

Only G.711 codec is supported for ASR/TTS integrations.Note

Prepare to Provision ASR/TTS
It is the responsibility of the customer to perform the following tasks:

• Order ASR/TTS speech servers from Cisco-supported vendors.
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For more information on supported speech servers for Unified CCX, see the for Active
Releases available at http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_
CCX.

Note

•Work with the ASR/TTS vendor to size the solutions.

• Provision, install, and configure the ASR/TTS vendor software on a different server (in the same LAN)
and not where the Unified CCX runs. You can configure the speech software for Unified CCX in the
same way as Unified CCX 7.0 (see http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_
CCX for detailed information).

• Before uploading a ASR/TTS script to Unified CCX Administration, validate the script against the
capabilities and specifications supported by the ASR/TTS vendor.

Provision of MRCP ASR Subsystem
TheMRCPASR subsystem allows users to navigate through a menu of options by speaking instead of pressing
keys on a touch-tone telephone. When a user calls local directory assistance, for example, ASR can prompt
the user to say the city and state in which to locate the information, then connect the user to an appropriate
operator.

To provision the MRCP ASR subsystem, define the following information:

•MRCP ASR Providers—Information about the vendor of your speech server, including the number of
licenses and the grammar type.

•MRCPASRServers—Information about the ASR server’s name, port location, and available languages.

•MRCPASRGroups— Information about theMRCPASR dialog control groups and associated locales,
which enable Unified CCX applications to use speech recognition.

Provision MRCP ASR Providers
Use theMRCPASR Provider Configuration web page to specify information about the vendor of your speech
server.

Procedure

Step 1 From theUnified CCXAdministrationmenu bar, choose Subsystem >MRCPASR >MRCPASRProviders.
The MRCP ASR Provider Configuration web page opens, displaying the list of currently configured MRCP
providers, licenses, and the corresponding status.

Step 2 ClickAddNew icon that displays in the tool bar in the upper left corner of the window or theAddNew button
that is displayed at the bottom of the window.
The MRCP ASR Provider Configuration web page opens.

Step 3 Specify the following mandatory fields:
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DescriptionField

Enter the name of theMRCPASR provider supported
by Unified CCX.

Provider Name

The number of ASR port licenses purchased from the
ASR vendor.

Number of Provider Licenses

Vendor-specific grammar setting. Valid options:

• Nuance Open Speech Recognizer servers
version 9.0 and above (OSR 3.1.x)

• Nuance 8.5 and below version ASR servers
(Nuance)

• IBM WVS ASR servers (2003 SISR)

Grammar Variant

Step 4 Click Add icon in the tool bar in the upper left corner of the window or the Add button that displays at the
bottom of this window to apply changes.

After you updateMRCPASR/TTS Providers, Servers, and Groups, the corresponding provider needs
to be refreshed for changes to take effect. The Unified CCX Engine does not need to be restarted.
However, during a Refresh, Unified CM Telephony triggers using affected groups will fall back to
the dialog group that is configured and the MRCP Provider being refreshed will go
NOT_CONFIGURED until the reload is complete.

Note

Your changes appear in the MRCP ASR Providers List page. You are now ready to provision MRCP ASR
Servers.

If you delete an ASR/TTS provider and all of its associated servers and then create a new ASR/TTS
provider, its status might become IN_SERVICE immediately, even before you create any servers for
it. In this situation, click Refresh for that ASR/TTS provider, or click Refresh All. These actions
change the status of the ASR/TTS provider to NOT_CONFIGURED.

Note

Provision MRCP ASR Servers
Use the MRCP ASR Server Configuration web page to specify information about the speech server's name,
port location, and available language.

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Server.Note

Procedure

Step 1 From the Unified CCXAdministration menu bar, choose Subsystem >MRCPASR >MRCPASR Servers.
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The MRCP ASR Server Configuration web page opens, displaying a list of previously configured servers, if
applicable with the following information:

DescriptionColumn

Host name or IP address in which the ASR server
software is installed.

ASR server deployment over WAN is not
supported in Unified CCX. The ASR server
should be in the same LAN where Unified
CCX is. You need to specify the ASR server
host name or IP address that is local with the
Unified CCX node while installing the ASR
server software in this field.

Note

Computer Name

The MRCP ASR Provider to which this server is
associated.

Provider

TCP port numbers used to connect to a MRCP server

• OSR 3.1x—4900

• 2003 SISR—554

• Nuance—554

Port

Status or state of the subsystem.Status

Step 2 Click Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add New
button that is displayed at the bottom of the window to provision a new MRCP ASR Server.
The MRCP ASR Server Configuration web page opens.

Step 3 Use this web page to specify the following fields.
DescriptionField

Host name or IP address of the server where the
MRCP ASR server software is installed.

Server Name

Select the name of theMRCPASRProvider to which
this server is associated from this drop-down list.

Provider Name
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TCP port numbers that are used to connect to an
MRCP server. Though the default value is shown as
4900, you need to provide any one of the following
values in this field based on the TCP provider or
grammar variant you have selected while configuring
an MRCP ASR provider:

• OSR 3.1x—4900

• 2003 SISR—554

• Nuance—554

Port Number

Languages supported by the ASR Provider. Select a
language (or multiple languages) from the drop-down
list and click Add Language; the selected language
appears in the Enabled Language list.

Use the check box to disable/enable a
language.

Note

Locales

Step 4 Click Add to apply changes.
Your changes appear in the MRCP ASR Server list web page. You are now ready to provision MRCP ASR
Groups.

Provision MRCP ASR Dialog Groups
Use the MRCP Groups Configuration web page to specify information about MRCP ASR dialog control
groups, which enable Unified CCX applications to use speech recognition.

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Group. Also, you
should configureMRCPASR Servers for the specificMRCP Provider before configuring theMRCPASR
Groups. This allows users to configure languages for the groups based on the languages supported by the
configured servers.

Note

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystem >MRCP ASR >MRCP ASR Dialog
Groups.
The MRCP ASR Dialog Group Configuration web page opens to display a list of preconfigured entries, if
applicable with the following information:

DescriptionField

Identifier for the group.Group ID
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DescriptionField

Description of this dialog group.Description

Name of the MRCP ASR provider.Provider

Maximum number of sessions.Channels

This web page also displays the Number of Licensed IVR Channels.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New
button that displays at the bottom of the window to provision a MRCP ASR Group.
The MRCP ASR Dialog Group Configuration web page opens.

Step 3 Use this web page to specify the following fields:
DescriptionField

Associated group ID.Group ID

Description of this dialog group.

Include languages that will be used by this
Group to the description. Doing so will
provide insight into the languages this Group
uses when you set up the dialog group in the
Unified CM Telephony trigger configuration.
This also ensures that the locales used by the
application configured in the Unified CM
Telephony trigger match the locales supported
by the MRCP ASR dialog group being
selected.

Tip

Description

Display only.Number Of Provider Licenses

Display only.Number Of Licensed IVR Ports
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DescriptionField

Maximum number of sessions associated with this
dialog group.

You can assign any value for Maximum
Number Of Channels, but restrictions are
placed on the system when a call is made.
This restriction is imposed by the number of
licensed IVR ports on your system.

Note

Under heavy load, calls that utilize a
channel from an MRCP ASR Dialog
Control Group, might have a reduced call
completion rate as the MRCP channels
used by calls can take some additional time
to clean up all the sessions set up with
MRCP resources. To address this situation,
you can overprovision the value of this
field by a factor of 1.2 or by an additional
20 percent. For example, if your
application requires 100 MRCP ASR
channels, modify the value in this field to
be 120 MRCP ASR channels.

Caution

Maximum Number Of sessions

Select a MRCP Provider name from the drop-down
list that contains a list of all previously defined
provider names.

Provider Name

Select the languages that you wish to configure for
this group from the list displayed.

The displayed languages represent the locales
configured for all MRCP ASR servers for the
specified provider. If there are noMRCPASR servers
configured, no languages are displayed. In this case,
youmust update the group configuration onceMRCP
ASR servers have been configured for the specified
provider.

Enabled Languages

Step 4 Click Add to apply changes.
Your changes appear in the MRCP ASR Groups list web page.

MRCP TTS Subsystem
The MRCP TTS subsystem converts plain text (UNICODE) into spoken words to provide a user with
information, or prompt a user to respond to an action.
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For example, a company might use TTS to read back a customer's name, address, and telephone number for
verification before the company ships a requested product to the customer's location. Or a customer might
dial into a pre-designated phone number, access a voice portal, and listen to the latest weather report or stock
quotes. TTS can also convert email text to speech and play it back to the customer over telephone.

To provision the MRCP TTS subsystem, define the following information:

•MRCP TTS Providers—Information about the vendor of your TTS system.

If you delete an ASR/TTS provider and all of its associated servers and then create a
new ASR/TTS provider, its status might become IN_SERVICE immediately, even
before you create any servers for it. In this situation, click Refresh for that ASR/TTS
provider, or click Refresh All. These actions change the status of the ASR/TTS provider
to NOT_CONFIGURED.

Note

•MRCPTTS Servers—Information about the TTS server's name, port location, and available languages.

•MRCP TTS Default Genders—Information about the default gender setting for the Locales specified
during TTS Server provisioning.

You will need at least one MRCP TTS Provider for each vendor requiring TTS server installation.Note

Provision MRCP TTS Providers
Use the MRCP TTS Providers Configuration web page to specify information about the vendor of your TTS
server.

After you update MRCP ASR/TTS Providers, Servers, and Groups, the corresponding provider needs to
be refreshed for changes to take effect. The Unified CCX Engine does not need to be restarted. However,
during a Refresh, Unified CM Telephony triggers using affected groups will fall back to the dialog group
that is configured and the MRCP Provider being refreshed will go NOT_CONFIGURED until the reload
is complete.

Note

Procedure

Step 1 From the Unified CCXAdministrationmenu bar, choose Subsystems >MRCPTTS >MRCPTTSProvider.
The MRCP TTS Provider Configuration web page opens. If providers are already configured, this page lists
the provider name and corresponding status.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New
button that displays at the bottom of the window.
Use this web page to specify the MRCP TTS Provider supported by Unified CCX.

The MRCP TTS Provider Configuration web page reopens. The Provider Name drop-down list displays the
existing MRCP TTS Providers. Choose the MRCP TTS Provider supported by Unified CCX from this list.
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Support for High Availability and remote servers is available only in multiple-server deployments.Note

Step 3 Click Add to apply changes.
Your changes appear in the MRCP TTS Provider Configuration web page. You are now ready to provision
MRCP TTS Servers.

Configure Default TTS Provider for Unified CCX System

Optionally, you can configure a default TTS provider. The Unified CCX Prompt Manager uses the default
TTS provider for rendering TTS prompts if a TTS provider is not configured in the TTS Prompt. This usually
happens in the case of VXML applications. For additional information on supported VXML tags for Unified
CCX, see Cisco Unified Contact Center Express Getting Started with Scripts.

To configure a default TTS provider, follow these steps.

Procedure

Step 1 Choose System > System Parameters.
Step 2 In the Default TTS Provider drop down list below Media Parameters section, select the provider you wish to

be the system default. You must select only a preconfigured TTS provider as the Default TTS Provider.
If you are deploying an VXML applications and the only TTS functionality you need is to play
pre-recorded .wav files, select the Cisco LiteSSMLProcessor option as the Default TTS Provider.
This option allows you to execute SSML that has .wav file references in them.

Note

Step 3 Click Update.

Provision MRCP TTS Servers
Use the MRCP TTS Servers Configuration web page to configure the TTS server's name, port location, and
available languages.

You need at least one MRCP TTS Server associated with each configured provider.

You must have a MRCP TTS Provider defined before you can provision a MRCP TTS Server.Note

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems >MRCP TTS >MRCP TTS Server.
The MRCP TTS Server Configuration web page opens, displaying a list of previously configured servers, if
applicable, with the following information:

DescriptionColumn
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Host name or IP address of the server in which the
TTS server software is installed.

TTS server deployment over WAN is not
supported in Unified CCX. In other words,
the TTS server should be in the same LAN
where Unified CCX is. Thus, you need to
specify the TTS server host name or IP
address that is local with the Unified CCX
node while installing the TTS server
software in this field.

Note

Computer Name

TCP port numbers used to connect to aMRCP server:

• IBM WebSphere Voice Server

• Nuance Vocalizer 4.0

• Scansoft Realspeak 4.0

Port

The MRCP TTS Provider to which this server is
associated.

Provider

Status or state of the subsystem.Status

Step 2 Click Add MRCP TTS Server icon that displays in the tool bar in the upper, left corner of the window or
the Add New button that displays at the bottom of the window to provision a new MRCP ASR Server.
The MRCP TTS Server Configuration web page opens.

Step 3 Specify the following fields:
DescriptionField

Host name or IP address of the server theMRCPTTS
server software is installed.

Server Name

Select the name of theMRCP TTS Provider to which
this server is associated from this drop-down list.

Provider Name

TCP port number used to connect to a MRCP TTS
server. The port numbers are automatically displayed
based on the provider or grammar variant that you
have selected while configuring a MRCP TTS
provider. Following are the different TCP Provider
names along with their port numbers:

• IBM WebSphere Voice Server V5.1.3 - 554

• Nuance Vocalizer 4.0 - 554

• Scansoft Realspeak 4.0 - 4900

Port Number
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Languages supported by the TTS Provider. Select a
language (or multiple languages) from the drop-down
list and click Add Language; the selected language
appears in the Enabled Language list.

Use the check box to disable/enable a
language.

Note

Locales

Step 4 Click Add to apply changes.
Your changes appear in the MRCP TTS Server Configuration web page. You are now ready to provision
MRCP TTS Default Genders.

Whenever a new language is added for a MRCP Server—and if this is the first instance of this
language being added for the correspondingMRCP Provider—then the default gender for that locale
and for the specified provider is set to Neutral. You should check the MRCP Locales page to review
the default genders that are set automatically per locale per provider. Default genders are used when
a prompt for a specific locale is used without specifying any gender.

Note

Provision MRCP TTS Default Genders
Use the MRCP TTS Default Genders Configuration web page to configure the default gender settings per
Locale per Provider. TTS uses default genders when a prompt for a specific locale is used without specifying
the gender.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems >MRCP TTS >MRCP TTS Default
Genders.
The MRCP TTS Default Gender Configuration web page opens, displaying the default genders currently
configured for each locale for every MRCP TTS Provider that is currently configured.

Step 2 Optionally, change the default gender setting for each locale for each provider.
The Locale radio button has the Male, Female, or Neutral options. By default, the “Default Gender”
is set to “Neutral” unless configured explicitly.

Note

Step 3 Click Update to apply changes.
The system updates the default gender setting for each Locale per Provider.
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C H A P T E R  7
Provision of Unified CCX

To provision the Unified CCX subsystem, you must provision your telephony and media resources (see the
Provision Telephony and Media Resources, on page 57).

Do not edit users, teams and permissions in Unified Intelligence Center. The Unified CCX to Unified
Intelligence Center sync runs as part of daily purge and synchronizes these settings on Unified Intelligence
Center according to Unified CCX settings.

Attention

The following topics introduce the Unified CCX subsystem and explain how to provision it in the Unified
CCX system:

• RmCm Provider Configuration, page 85

• Resource Groups, page 87

• Skills Configuration, page 88

• Agent Configuration, page 90

• Contact Service Queue Configuration, page 94

• Configure Agent-Based Routing, page 101

• Teams Configuration, page 103

RmCm Provider Configuration
The Unified CCX Resource Manager (RM) uses a Unified CM Telephony user (called the RmCm Provider)
to monitor agent phones, control agent states, and route and queue calls. For information on adding Unified
CMusers, see section "Adding Users to a User Group" section in theCisco Unified CommunicationsManager
Administration Guide available here:

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_installation_and_configuration_guides_
list.html.
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The RmCm user specified through Unified CCX Administration is updated automatically in Unified CM.Note

RmCm Provider Modification

This section only applies to Unified CCX deployments with Unified CM.Note

While Unified CM supports Unicode characters in first and last names, those characters become corrupted
in Unified CCX Administration web pages for RmCm configuration and real-time reporting .

Caution

The RmCm Provider web page is a read-only page that displays the latest configured information. To access
this configuration area, choose Subsystems > RmCm > RmCm Provider from the Unified CCX
Administration menu bar. The RmCm Provider web page opens, displaying the following read-only fields.

DescriptionField

The host name or IP address of the server, running CTI Manager (Unified
CM that runs CTI Manager).

The RmCm subsystem registers with the CTIManager so that it can observe
an agent's device when the agent logs in. When the CTI Manager fails, the
RmCm subsystem registers with the second CTI Manager, if there is one
configured.

Primary RmCm Provider

The host name or IP address of the secondary RmCm Provider.Secondary RmCm Provider

The RmCm user ID.User ID

Tomodify the RmCm Provider, clickModify RmCmProvider Information icon in the tool bar in the upper,
left corner of the window. The Cisco Unified CM Configuration web page opens.

Associating Agent Extensions with the RmCm Provider

This section only applies to Unified CCX Deployments with Unified CM.Note

For every agent/resource created in Unified CM, make sure that the agent phone is also associated with the
RmCm Provider. You do this from the Unified CM User Page for the RmCm Provider. In other words, even
though you create the RmCm User in Unified CCX Administration, you still need to use the Unified CM
interface to associate the RmCm user with an agent phone. These phones are the same as those associated
with each agent.
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Resource Groups
Resource groups are collections of agents that your CSQ uses to handle incoming calls. To use resource
group-based CSQs, you must specify a resource group.

Create Resource Group
To create a resource group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Resource Groups.
The Resource Group web page opens with a list of configured resource groups (if any).

Step 2 Click Add New icon in the tool bar in the upper, left corner of the window or Add New button at the bottom
of the window.
The Resource Group Configuration area opens.

Step 3 In the Resource Group Name field, enter a resource group name.
Enter a name that identifies the resource group to which you want to assign agents (for example, “Languages”).

Step 4 Click Add.
The Resource Groups page opens displaying the resource group name in the Resource Group Name column.

Modify Resource Group Name
To modify a resource group name, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Resource Groups.
The Resource Group web page opens.

Step 2 In the Resource Group Name column, click the resource group that you want to modify.
The Resource Group Configuration area opens.

Step 3 Type the name of the resource group in the Resource Group Name text field.
Step 4 Click Update to apply the modifications.

The Resource Groups area opens, displaying the modified resource group name in the Resource Group Name
column.
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Delete Resource Group
When you delete a resource group, the resource group is removed automatically if it is not associated with
any agents and CSQs. If the resource group is associated with any agents or CSQs and if you click Delete,
you will be directed to another web page, where you can see a list of the associated CSQs and agents, and
you are prompted to confirm whether you want to delete the same.

To delete resource groups, you can use the following procedure or open a Resource Group and click the
Delete icon or button in the Resource Group Configuration web page.

Tip

To delete a resource group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Resource Groups.
The Resource Group web page opens.

Step 2 Click Delete icon next to the name of the Resource Group that you want to delete.
A dialog box opens, warning that the resource group is about to be permanently deleted.

Step 3 Click Continue.
The resource group is deleted.

Skills Configuration
Skills are customer-definable labels assigned to agents. All the Unified CCX license packages can route
incoming calls to agents who have the necessary skill or sets of skill to handle the call.

Create a Skill
To create a skill, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Skills.
The Skills web page opens to display the Skill Name (customer-definable label assigned to an agent), if
configured.

Step 2 Click Add New icon in the tool bar in the upper, left corner of the window or Add New button at the bottom
of the window.

When the system reaches the maximum number of skills that can be created, the Add New icon or
button no longer appears.

Note

The Skill Configuration web page opens.
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Step 3 In the Skill Name field, enter a description of a relevant skill (for example, French).
Step 4 Click Add.

The Skills web page opens, showing the skill in the Skill Name column and the total number of skills that
exist in the system. You can add a maximum of 150 skills.

Modify a Skill Name
To modify a skill name, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Skills.
The Skills web page opens.

Step 2 In the Skill Name column, click the skill that you want to modify.
The Skill Configuration web page opens.

Step 3 Modify the name of the skill in the Skill Name text field.
Step 4 Click Update to apply the modifications.

The Skills Configuration summary opens, displaying the modified skill name in the Skill Name column.

Delete a Skill
When you delete a skill, the skill is removed automatically if it is not associated with any agents and CSQs.
If the skill is associated with any agents or CSQs and if you click Delete, you are directed to another web
page, where you can see a list of the associated CSQs and agents, and you are prompted to confirm whether
you want to delete the same.

To delete a skill, you can use the following procedure or open a skill and click Delete icon or button in
the Skills Configuration web page.

Tip

To delete a skill, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Skills.
The Skills web page opens.

Step 2 Click the Delete icon next to the name of the skill that you want to delete.
A dialog box opens, warning that the skill is about to be permanently deleted.

Step 3 Click Continue.
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The skill is deleted.

Agent Configuration
Once the end users in Cisco Unified Communications1 are defined as agents, the list of agents and their
associated Unified CCX devices are displayed in the Subsystems > RmCm > Resources page. These agents
are also called resources. After you create a resource group, you can assign agents (resources) to that group.

If you have the Unified CCX Standard license package, you can add skills to agents once the skills have been
created. You can also select the competence level of agents in assigned skills. Competence level indicates
agent level of expertise in that skill.

You can assign resource groups and skills to agents either individually or in bulk. The bulk option enables
you to assign skills and resource groups to multiple agents at the same time.

Once you assign agents to resource groups and skills, you can create a CSQ.

After an agent is added, wait for 10 minutes for Unified CCX to automatically synchronize or force
synchronization before the agent can sign in to Cisco Finesse.

The maximum allowed length of an agent's IPCC Extension is 15.

Warning

Special Characters

• Unified CM supports the use of special characters—square brackets ([ ]), dollar ($), ampersand (&),
single quotes (' '), colon (:), angle brackets( < >), forward slash (/), question mark ( ?), backward slash
( \), parentheses ({ }), double quotes(" "), hash(#), percent (%), semicolon ( ;), comma ( ,), pipe ( |),
tilde( ~) and space in a user ID when you configure end users. However, Unified CCX restricts the use
of these characters when you configure end users as agents or supervisors.

• Unified CCX does not support the use of special characters—square brackets ([ ]), dollar ($), ampersand
(&), single quotes (' '), colon (:), angle brackets( < >), forward slash (/), question mark ( ?), backward
slash ( \), parentheses ({ }), double quotes(" "), hash(#), percent (%), semicolon ( ;), comma ( ,), pipe (
|), tilde( ~).

•With Cisco Finesse for Unified CCX, agent IDs (or usernames) are case-sensitive and can contain letters,
numbers, hyphens (-), underscores (_), and periods (.) They cannot begin or end with a period or contain
two periods in a row.

• Finesse agent passwords are restricted to 7-bit printable ASCII characters (any of the 94 characters with
the numeric values from 32 to 126). They do not support control characters (for example, Tab) or
international characters.

However, the character '@' is not supported as the agent ID (or username) and password.Note

1 Unified Communications users in a Unified CM deployment refers to a Unified CM user.

   Cisco Unified CCX Administration Guide, Release 11.0(1)
90

Provision of Unified CCX
Agent Configuration



Implications of Deleting Agents in Unified CM
If you modify an agent's record in Unified CM (for example, changing the Unified CCX extension or deleting
the agent), ensure to refresh the user page onUnified CCXAdministration interface so that the agent information
in the Unified CCX RmCm subsystem is updated. Choose Subsystems > RmCm > Resources option to
update the Unified CCX information in the Unified CCX Administration any time. If you change the Unified
CCX extension of an agent who is currently logged in, the agent will continue to use the old extension until
the agent logs off. The agent must log off and then log back in to the Cisco Finesse desktop to get the new
extension. When Unified CCX performs an agent sync and detects that the agent no longer exists in Unified
CM, the contact is marked as inactive in theResource table of the Unified CCXHistorical Reporting Database
(db_cra). The resource is not deleted as the resource information is referenced for the HR reports.

Deleting Inactive Agents removes the agent details and records from the Historical Reporting Database,
and HR reports will not display historical information of these agents.

If Unified CM connection errors have occurred, all agents will not be visible to Unified CCX. In this case,
Unified CCX interprets these agents as deleted agents. As a result, the Inactive Agents list will not be
accurate. When the errors are resolved, click Inactive Agents again to see an accurate list.

Caution

Assign Resource Groups and Skills to One Agent
To assign a resource group and skills to an individual agent, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Resources.
The Resources web page opens.

Only agents or supervisors who have assigned Unified CCX extensions are displayed in the list of
resources in the Resources area.

Note

Step 2 Click the name of the agent in the Resource Name column.
The Resource Configuration web page opens.

Step 3 Specify the following fields.
DescriptionField

Name of the agent (display only).Resource Name

Unique identifying number of the agent (display only). This is the alpha-numeric
user id assigned in the Unified CM End User Configuration page.

Resource ID

Unified CCX Extension assigned to the resource group (display only). This is the
IP Phone extension assigned to the user from the Unified CM End User
Configuration page as IPCC Extension.

Unified CCX
Extension

A resource group with which to associate the agent (optional).Resource Group
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DescriptionField

Accept the default (Enabled) to automatically put the agent into the Available or
Ready state after the agent finishes a call and disconnects.

When a logged on agent in Ready, Not Ready, or Work state answers a
call, the agent state is subject to the Automatic Available setting.

Note

Automatic Available

Select one or more skills from the Unassigned Skills list and click < to add the skills
to the Assigned Skills List.

Select one or more skills from the Assigned Skills List and click > to remove skills
from the Unassigned Skills list.

You can assign up to 50 skills to the agent.

Assigned/Unassigned
Skills

Select a skill from the Assigned Skills list and choose a number from the
Competence Level drop-down menu

Changes the competence level of an assigned skill (1 = Beginner, 10 = Expert).

You can change the competency level one skill at a time, only. You cannot
change skill competency level as a bulk procedure.

Note

Competence Level

A group of agents who assign the team to which the resource belongs.Team

Agent alias is the name used instead of the agent ID when an agent chats with a
customer. This option is available only when Finesse is used by the chat agent.

Agent Alias

Step 4 Click Update to apply the changes.
The Resources area of the RmCm Configuration summary web page opens, and the agent is now assigned to
the resource group and skills (if skills were assigned).

Assign Resource Groups and Skills to Multiple Agents
To assign resource groups and skills to agents in bulk, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, select Subsystems > RmCm > Assign Skills.
The Assign Skills summary web page opens.

Only agents or supervisors who have assigned Unified CCX extensions are displayed in the list of
resources in the Resources area.

Tip

Step 2 In the Resource Name column, check the check box beside each agent to whom you want to assign set of
same resource group and skills. In the Resource Name column, check the check box next to each agent you
want to assign set of same resource group and skills.

You can check the Select All check box to select all
agents.

Note
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The Skill summary web page shows the total number of skills created.

Step 3 Click Add Skill icon that displays in the tool bar in the upper, left corner of the window or the Add Skill
button that displays at the bottom of the window.
The Add Skill web page opens.

Step 4 Specify the following fields.
DescriptionField

To assign a resource group to all the selected agents, choose a resource group from
the Resource Group drop-down menu.

Resource Group

Select one or more skills from the Skills list and click < to add the skills to the Skills
to Add List.

The Skills to Add list contains all skills, not just the skills that agents
already have.

Note

Skills to Add

List of the available skills.Skills

Select a skill from the Assigned Skills list and choosing a number from the
Competence Level drop-down menu

Competence Level

Step 5 Click Update to apply the changes.
The Assign Skills area of the RmCm Configuration web page opens, and the agents are now assigned to the
resource group and their skills (if skills were assigned).

Remove Skills from Agents

If a resource is not assigned a skill that you attempt to remove, the resource is not updated. However, the
system will still generate a related message.

Note

To remove skills from agents, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Assign Skills.
The Assign Skill summary web page opens.

Step 2 In the Resource Name column, click the check box next to the agent you want to remove skills from.
You can click Select All check box to select all
agents.

Note

Step 3 Click Remove Skill icon that displays in the tool bar in the upper, left corner of the window or the Remove
Skill button that displays at the bottom of the window.
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The Remove Skill Configuration web page opens.

Step 4 Remove skills by choosing one or more skills from the Skills list and clicking > to move the skills to the Skills
to Remove list.

Step 5 Click Update to apply the changes.
The Assign Skills area of the RmCm Configuration web page opens, and the agents are no longer assigned
to the skills.

Contact Service Queue Configuration
The Contact Service Queue (CSQ) controls incoming calls by determining where an incoming call should be
placed in the queue and to which agent the call is sent.

After you assign an agent to a resource group and assign skills, you need to configure the CSQs.

You assign agents to a CSQ by associating a resource group or by associating all skills of a particular CSQ.
Agents in the selected resource group or who have all the selected skills are assigned to the CSQ.

Skills within the CSQ can be ordered. This means, when resources are selected, a comparison is done based
on the competency level (highest for “most skilled” and lowest for “least skilled”) of the first skill in the list.
If there is a “tie” the next skill within the order is used, and so on.
Skills within the CSQ can also be weighted. The weight value is an integer from 1 to 1000. Each competency
level is multiplied by the skill's associated weight, and a final comparison is done on the sum of all the weighted
skill competencies (highest value for “most skilled” and lowest for “least skilled”). The maximum number of
CSQs in the system depends on the type of server on which the engine is running.

For more information, see the Unified CCXData Sheets at http://www.cisco.com/en/US/products/sw/custcosw/
ps1846/prod_literature.html.

Each agent can belong to up to 25 CSQs. To ensure that agents are not assigned to more than 25 CSQs, click
Resources submenu option in the RmCm Configuration web page, and click Open Resources Summary
Report icon. The report opens, listing each agent and the number of CSQs to which the agent belongs. If the
agent belongs to more than 25 CSQs, modify the skills and resource groups to which the agent is assigned so
that the agent does not belong to more than 25 CSQs.

Create a Contact Service Queue
To create a new CSQ and assign agents, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Contact Service Queues.
The Contact Service Queues web page opens.

Use this web page to view the following fields:
DescriptionField

Name of the resource or skill group.Name
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DescriptionField

Algorithm used to order the queued calls (contacts).Contact Queuing Criteria

The resource selection criteria chosen for this CSQ.Resource Pool Selection Model

The skills or resource group used for this CSQ.Resource Pool

The type of the CSQ.CSQ Type

Deletes the selected CSQ.Delete

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New
button that displays at the bottom of the window.
The Contact Service Queue Configuration web page opens.

If this link does not appear on the page, it means that the system has reached the maximum number
of CSQs that can be created. The CSQ Summary page displays the total number of created CSQs.

Note

Step 3 Use the Contact Service Queue Configuration web page to specify the various fields. For more information
on the fields, see Contact Service Queue Configuration Web Page.

Step 4 Click Next.
The second Contact Service Queue Configuration area opens with the newly-assigned CSQ Name.

Step 5 Select an option from the Resource Selection Criteria drop-down menu.
The Resource Pool Selection Model settings determine the options available in this drop-down
menu.

Note

• Longest Available—Selects the agent who has been in the Available state for the longest amount of
time.

•Most Handled Contacts—Selects the agent who has handled the most calls.

• Shortest Average Handle Time—Selects the agent who generally spends the least amount of time
talking to customers.

•Most Skilled—Used for expert agent call distribution. Selects the agent with the highest total competency
level. The total competency level is determined by adding the agent's competency levels for each of
their assigned skills that are also assigned to the CSQ.

◦Example 1: If Agent1 is assigned Skill1(5), Skill2(6), and Skill3(7) and CSQ1 specifies
Skill1(min=1) and Skill3(min=1), the total competency level for Agent1 for CSQ1 is 12.

◦Example 2: If Agent1 is assigned Skill1(5) and Skill2(6) and Skill3(7) and CSQ1 specifies
Skill1(min=1), only, the total competency level for Agent1 for CSQ1 is 5.

• Least Skilled—Used for expert agent call distribution. Selects the agent with the lowest total competency
level. The total competency level is determined by adding the agent’s competency level in each assigned
skill.

•Most Skilled by Weight— Used for expert agent call distribution. Selects the agent with the highest
total competency level multiplied by the skill’s associated weight.
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• Least Skilled by Weight—Used for expert agent call distribution. Selects the agent with the lowest
total competency level multiplied by the skill’s associated weight.

•Most Skilled by Order—Used for expert agent call distribution. Selects the agent with the highest total
competency level in the ordered list.

• Least Skilled by Order—Used for expert agent call distribution. Selects the agent with the lowest total
competency level in the ordered list.

If two or more agents have equal competency level, the selection automatically defaults to Longest
Available selection criteria.

Note

Step 6 Specify the following settings, as necessary:
The Resource Pool SelectionModel setting determines the availability of these options.Note

a) Use the Select Skills list to highlight the skills you want; click the Add button next to the list.
b) Specify a Minimum Competence Level for the skills assigned to the CSQ. Depending on the Resource

pool criteria you chose, specify a Weight value between 1 and 1000.
c) If the Resource Selection Criteria is Most Skilled by Order or Least Skilled by Order, use the arrow icons

to order the skills by moving them up or down in the list.
Use the Delete icon next to a skill to delete that skill from the Skills Required
list.

Note

Step 7 If you selected one of the Least/Most Skilled options as shown in the list below for the Resource Selection
Criteria, you can view the agent order using Show Resources icon or button.

The order of the agents determines the priority, with the agent at the top of the list having the highest
priority.

Note

To change the order of the agents belonging to the CSQ, you should modify the skill set of the agents. The
Least/Most Skilled Resource Selection Criteria option comprises the following:

a) Most Skilled
b) Least Skilled
c) Most Skilled by Order
d) Least Skilled by Order
e) Most Skilled by Weight
f) Least Skilled by Weight

Step 8 If you selected Resource Groups as the Resource Pool Selection Model on the previous page, follow these
steps:
a) Select an option from the Resource Selection Criteria drop-down menu.

• Longest Available—Selects the agent who has been in the Available state for the longest amount
of time.

• Linear—Selects the next available agent with the highest priority, as determined by the agent order
in the Resources list.

• Circular—Selects the next available agent with the highest priority, based on the last agent selected
and the agent order in the Resources list.

•Most Handled Contacts—Selects the agent who has handled the most calls.

• Shortest Average Handle Time—Selects the agent who generally spends the least amount of time
talking to customers.
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b) Choose the resource group for this CSQ from the Resource Group drop-down menu.
c) Click Show Resources icon to show all agents who meet the specified criteria.
d) If you selected Linear or Circular as the Resource Selection Criteria, if necessary, rearrange the order of

agents in the Resources list by highlighting an agent and using the up and down arrows to move the agent
in the list.

e) Click Add to apply changes and update the system.
The newCSQ is now displayed, and all agents who belong to the resource group or all selected skill groups
are now a part of this CSQ.

Contact Service Queue Configuration Web Page
Contact Service Queue Configuration web page:

DescriptionField

Enter a meaningful name that is concise, yet easy to recognize (for example,
Language Experts). This is a mandatory field.

Contact ServiceQueue
Name

Display only. Voice—Agents in this CSQ can handle inbound and outbound voice
calls.

Contact ServiceQueue
Type

Display only. Displays the criteria used for queuing the contacts. For example, First
In, First Out (FIFO).

Contact Queuing
Criteria

Determines whether agents handling calls that are routed through this CSQ
automatically enter theWork state when a call ends. This field is mandatory. Options
are:

• Enabled—Agents belonging to a CSQ that has the Automatic Work option
enabled enter the Work state automatically when a call that is allocated from
this CSQ ends. If agents belonging to a CSQ that has the Automatic Work
option disabled handle transferred calls that were originally delivered by a
CSQ that has Automatic Work enabled, they also enter the Work state
automatically when a call ends.

• Disabled (default)—Agents enter Ready or Not Ready state when a call ends,
depending on the Automatic Available setting.

Automatic Work

Determines the length of the Work state for this CSQ when a call ends. Options are:

• Enabled button with Seconds field—The Seconds field specifies the length of
the Work state phase.

• Disabled—No limit on how long the agent can stay in the Work state.

Wrapup Time
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DescriptionField

Select one of the following options from the drop-down menu:

• Resource Skills—To create a skills-based CSQ.

• Resource Group—To create a resource group-based CSQ.

This is a mandatory field.

Resource Pool
Selection Model

The target maximum number of seconds a call is queued before it is connected to
an agent. This is a mandatory field.

Service Level

The target goal for percentage of contacts that meet the service level. This is a
mandatory field.

For example, a call center that has a service level of 20 and a service level percentage
of 80 percent has a goal of answering 80 percent of its calls within 20 seconds.

Service Level
Percentage

Modify a Contact Service Queue

Changes take effect when all agents affected by the changes have left the Ready state. Emails Contact
Service Queues cannot be modified. It is for display only.

Note

To modify an existing CSQ, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Contact Service Queues.
The Contact Service Queues web page opens.

Step 2 In the Name list, click the CSQ that you want to modify.
The Contact Service Queue Configuration page opens.

Step 3 Modify the Contact Service Queue Configuration information as necessary.
If you change an existing CSQ name, the old name still exists in the HR reports and the CSQ is not
removed even if all the data is purged.

Note

ClickNext icon that displays in the tool bar in the upper, left corner of the window or theNext button
that displays at the bottom of the window to view and update the remaining fields.

Note

Step 4 Click Update icon in the top of the window or the Update button that displays at the bottom of the window
to apply the modifications.
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Delete a Contact Service Queue

Existing Email Contact Service Queues can be deleted.Note

When you delete a CSQ, any skills or resource groups assigned to that CSQ are automatically removed from
the CSQ, and any application using that CSQ can no longer access it. Before deleting the CSQ, change the
applications to use a different CSQ. If the application is using a CSQ when the CSQ is deleted, new incoming
calls will get an error and existing queued calls will not be routed to agents.

To delete a CSQ, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Contact Service Queues.
The Contact Service Queues web page opens.

Step 2 Click the Delete icon next to the name of the CSQ that you want to delete.
You can also delete a CSQ from its Contact Service Queue Configuration page using the Delete icon
or button.

Note

Resource Pool Selection Criteria: Skills and Groups
The resource selection criteria available for CSQs with Resource Skills is different from that of CSQs with
Resource Groups.

Example—In a banking application with two skills (Banking and CreditCard) and one Resource Group
(General Queries), assume that the following agents, skills, and resource groups are defined:

Resource GroupAssigned SkillsAgent ID

GeneralQueriesBanking (Competence Level 10)

CreditCard (Competence Level 6)

Agent1

GeneralQueriesBanking (Competence Level 5)

CreditCard (Competence Level 10)

Agent2

GeneralQueriesNoneAgent3

In addition, suppose you had the following Contact Service Queue information defined:
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Table 1: Agent Skill and Resource Group Settings

Available
Agents

Skill/CompetenceResource Selection
Criteria

Resource Pool
Selection Model

CSQ Name

Agent1

Agent2

BankingMinimum
competency: 5

Most SkilledResource SkillsCSQ1

Agent1

Agent2

CreditCardMinimum
competency: 5

Most SkilledResource SkillsCSQ2

Agent1

Agent2

Agent3

GeneralQueriesLongest AvailableResource GroupCSQ3

In this scenario, if a caller calls with a question about CreditCard information and there are no CSQs currently
available with CreditCard skills (that is, Agent1 and Agent2), there is a possibility for Agent3—who has no
CreditCard skill—to get selected as the Longest Available Agent.

To avoid such a situation, you could design the script to always look into CSQ2 for available agents since it
has the highest competency of 10 for CreditCard, and agent selection here is based on most skilled.

If two or more agents have equal competency level, the selection automatically defaults to Longest
Available selection criteria.

Note

Resource Skill Selection Criteria within a Contact Service Queue
Resource selection within a CSQ is based on the resource competency levels of the skills associated to the
CSQ. You can choose between the most and least skilled.

The Unified CCX system defines a Level 10 competency to be the highest skill level, while a Level 1 denotes
the lowest skill level. When more than one skill is involved, each skill is given the same weight, meaning no
preference is given to any skill. A comparison is performed on the sum of all the competency levels for the
associated skills. (Skills assigned to resources but not associated to the CSQ are ignored.) In the case of a tie
when skill competencies are equal, the resource that has been ready for the longest amount of time will be
chosen.

The following table provides examples of how Unified CCX selects resources within a CSQ.
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Table 2: Resource Skill Selection Criteria

Selection OrderSequence Agents
Become Ready

Agent Competency
Levels

CSQ SkillsExample

A, B, CA, B CAgent A = 10

Agent B = 10

Agent C = 5

Technical
Support

Most skilled resource
selection model

A, B, CC, A, B

A, B, CA, C, B

B, A, CC, B, A

C, A, BA, B, CAgent A = 10

Agent B = 10

Agent C = 5

Technical
Support

Least skilled
resource selection
model C, A, BC, A, B

C, A, BA, C, B

C, B, AC, B, A

The ordering in the two examples above are not opposite because the selection criteria has changed
from most to least skilled—when competency levels are equal, both selection models choose the
resources that have been available for the longest time.

Note

A, B, CA, B, CAgent A = Sales (10)
Support (5)

Agent B = Sales (5),
Support (10)

Agent C = Sales (5)
Support (1)

SalesSupportMost skilled resource
selection model

A, B, CC, A, B

A, B, CA, C, B

B, A, CC, B, A

C, A, BA, B, CAgent A = Sales (10)
Support (5)

Agent B = Sales (5),
Support (10)

Agent C = Sales (5)
Support (1)

SalesSupportLeast skilled
resource selection
model C, A, BC, A, B

C, A, BA, C, B

C, B, AC, B, A

Configure Agent-Based Routing
Agent-based routing provides the ability to send a call to a specific agent, rather than any agent available in
a CSQ.

Use the Agent Based Routing Settings web page to configure system-wide parameters to be used in an
agent-based routing application.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Agent Based Routing
Settings. The Agent Based Routing Settings area opens.

The Agent Based Routing Settings are available only if you are using Unified CCX Enhanced or
Premium license packages.

Note

Step 2 Specify the following fields:
DescriptionField

Determines whether agents handling calls that are routed through this CSQ
automatically enter the Work state when a call ends.

• Enabled—Agents belonging to a CSQ that has the Automatic Work option
enabled enter the Work state automatically when a call that is allocated from
this CSQ ends. If agents belonging to a CSQ that has the Automatic Work
option disabled handle transferred calls that were originally delivered by a
CSQ that has Automatic Work enabled, they also enter the Work state
automatically when a call ends.

• Disabled (default)—Agents enter Ready or Not Ready state when a call ends,
depending on the Automatic Available setting.

Automatic Work

Determines if agents automatically enter Wrapup when a call ends.

• Enabled button with seconds field—Controls how long the agent can stay in
the Work state if Automatic work is enabled. The seconds field specifies the
Wrapup time length.

• Disabled (default)—No limit of how long the agent can stay in the Work
state if Automatic Work is enabled.

Wrapup Time

Step 3 Click Save icon that displays in the tool bar in the upper, left corner of the window or the Save button that
displays at the bottom of the window to apply changes.

Wrap-Up Data Usage
Contact centers use wrap-up data to track the frequency of activities or to identify the account to which a call
is charged, and other similar situations. Like reason codes, wrap-up data descriptions are set up by your system
administrator to reflect the needs of your contact center. By default this feature is disabled.
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Teams Configuration
A team is a group of agents who report to the same supervisor. A team can have one primary supervisor and
optional secondary supervisors. A supervisor can also monitor CSQs that are assigned to the team being
supervised.

Barge-in is when a supervisor joins an existing call between an agent and a customer.

Intercept is when the supervisor joins a call and drops the agent from the call.

A default team is automatically created by the system and cannot be deleted. If agents are not assigned to any
team, they belong to the default team. When an agent is assigned to a team, the team supervisor can barge-in
and intercept any call being handled by the agent.

Before creating a team, you must set up supervisors using the User Management page.Note

A team that accesses Live Data reports should be limited to 50 agents.Note

Assign Supervisor Privilege to a User
Perform the following procedure to assign supervisor privilege to a user.

Procedure

Step 1 From the Unified CCX Administration menu, choose Tools > User Management > User View.
The User Configuration page displays the list of all users.

Step 2 Click the user to whom you want to assign supervisor capability.
The User Configuration page displays information about that user. In the Capabilities section, the left pane
displays the list of assigned capabilities and the right pane displays the list of capabilities.

Step 3 Using the left arrow, assign Supervisor capability.
Step 4 Click Update to save your changes.

Create Team Supervisor
Perform the following procedure to create team supervisor:

Procedure

Step 1 From the Unified CCX Administration menu, choose Subsystems > RmCm > Teams.

Cisco Unified CCX Administration Guide, Release 11.0(1)    
103

Provision of Unified CCX
Teams Configuration



The Team page displays the list of all teams.

Step 2 Click the team for which you want to create a supervisor.
The Team Configuration page displays the configuration information about the team.

Step 3 From the Primary Supervisor drop-down list, select the primary supervisor for the team.
Step 4 (Optional) If you want to assign a secondary supervisor, select the supervisor from theAvailable Supervisors

pane and then click the left arrow.
Step 5 Click Save.

Create Teams
Use the Teams area of the RmCm Configuration web page to create or associate teams with various agents,
CSQs, and supervisors.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Teams.
Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New

button that displays at the bottom of the window.
The Team Configuration page appears.

Step 3 Click Add to apply changes.

Modify Agents on Teams
Use the Teams area to add agents or change agents on an existing Team.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Teams.
The Teams web page opens.

Step 2 Click a name in the Team Name column
The Team Configuration page appears.

Step 3 Select an agent name in the Resources Assigned to other Teams list and use the arrow icon to move it into
the Assigned Resources list if you want to add an agent to this team.
To remove an agent from this team, select an agent name in the Assigned Resources list and use the arrow
icon to move it into theResources Assigned to other Teams list. This agent now belongs to the default team.

Step 4 Click Update to apply changes.

   Cisco Unified CCX Administration Guide, Release 11.0(1)
104

Provision of Unified CCX
Create Teams



Delete a Team
Use the Teams area of the RmCm Configuration web page to delete an existing Team.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Teams.
The Teams web page opens.

Step 2 Click the Delete icon beside the Team Name icon you want to delete.
The system prompts you to confirm the delete.

Step 3 Click OK.
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C H A P T E R  8
Provision of Additional Subsystems

To provision additional subsystems, you must complete the following tasks:

• Log into the Unified CCX Administration.

• Provision your telephony and media resources.

• Provision your Unified CCX subsystem, if required.

The following sections introduce the additional Unified CCX subsystems and explain how to provision them.

• About Additional Subsystems, page 107

• Provision of HTTP Subsystem, page 108

• Provision of Database Subsystem, page 109

• Provision eMail Subsystem, page 112

About Additional Subsystems
Your Unified CCX system may include some or all of the following additional subsystems:

• The HTTP subsystem—The Unified CCX system uses the HTTP subsystem to enable Unified CCX
applications to respond to requests from a variety of web clients, including computers and IP phones.

• The Database subsystem—The Unified CCX system uses the Database subsystem to enable Unified
CCX applications to interact with customer-provided enterprise database servers to make database
information accessible to contacts.

• The eMail subsystem—The Unified CCX system uses the eMail subsystem to communicate with your
email server and enable your applications to create and send email.

If you plan to run applications that use any of the additional Unified CCX subsystems included in your Unified
CCX package, you should now provision those subsystems. The Unified CCX system uses these additional
subsystems to communicate with supporting systems such as web servers, database servers, and email servers.
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You need to provision a particular subsystem only if you are using Unified CCX applications that require
it.

Note

Provision of HTTP Subsystem

The HTTP subsystem is available if your system has a license installed for one of the following Cisco
product packages: Unified IP IVR or Unified CCX Premium.

Note

The Unified CCX system uses the HTTP subsystem to enable Unified CCX applications to respond to requests
from a variety of web clients, including computers and IP phones.

If you are not using HTTP applications, you do not need to provision the HTTP subsystem.Note

The Unified CCX system uses subdirectories in the Unified CCX installation directory to store text substitution,
eXtensible Style Language (xsl) templates, static and dynamic web pages, and Java Servlet Pages (JSPs).

Use the Document Management page to upload these documents.Note

To provision the HTTP subsystem, you need to provision HTTP triggers. HTTP applications use triggers to
activate the application in response to an incoming HTTP message.

You cannot change the TCP/IP port numbers used by the HTTP subsystems or triggers in Unified CCX.Note

Configure HTTP Triggers
You need to create an application using Applications > Application Management menu from the Unified
CCX Administration menu bar. After you create an application, you can configure HTTP triggers for the
application using the following procedure.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > HTTP.
The HTTP Trigger Configuration web page opens.

Step 2 Specify the following fields:
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DescriptionField

The relative URL.

For example:

/hello

URL

Select an application for which you want to add a HTTP trigger from this list box.Application Name

The maximum amount of simultaneous sessions (instances) that the application can
handle.

Sessions

Click the required radio button to accept - Yes (the default).

If you disable the trigger, the user receives an error message when browsing
to the defined trigger URL.

Note

Enabled

Step 3 Click Add New.
The HTTP Trigger Configuration web page closes, and the trigger information appears on the HTTP Trigger
Configuration summary web page.

You are now ready to provision any additional subsystems your Unified CCX applications require or to begin
configuring Unified CCX applications.

Provision of Database Subsystem

The Database subsystem is available if your system has a license installed for either the Unified IP IVR
or Unified CCX Premium product packages. If you are not using Unified CCX applications that require
access to databases, you do not need to provision the Database subsystem.

Note

The Unified CCX system uses the Database subsystem to enable Unified CCX applications to interact with
database servers to make database information accessible to contacts.

The Database subsystem does not support database views or execute store procedures.Caution

Database Subsystem Configuration
The Database subsystem enables the Unified CCX applications to obtain information from data sources, which
are databases configured to communicate with the Unified CCX system. You can connect the Unified CCX
system with enterprise databases such as Microsoft SQL Server, Sybase, Oracle, or IBM DB2.

You can upload JDBC driver files using Subsystems > Database > Drivers menu option.
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To determine a list of enterprise databases supported for the Database subsystem, see the for active releases
available at http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX.

Note

Add New Datasource
After uploading the JDBC driver, you need to use this to create the datasource in the Database subsystem.

To add a new data source, complete the following steps.

Procedure

Step 1 From the Unified CCXAdministration menu bar, choose Subsystems >Database >DataSource. ClickAdd
New icon that displays in the tool bar in the upper, left corner of the window or the Add New button that
displays at the bottom of the page.
The Datasource Configuration web page opens. For more information on the web page fields, seeDatasource
Configuration Web Page.

Step 2 Click Add to save the changes.
The Enterprise Database Subsystem Configuration web page opens. You are now ready to provision any
additional subsystems your Unified CCX applications require or to begin configuringUnified CCX applications.

Datasource Configuration Web Page
Datasource Configuration web page.

DescriptionField

Data source name for referring to the datasource. This is a mandatory field.Data Source Name

Username defined for connecting to the enterprise database. This is a mandatory
field.

User Name

Password defined for connecting to the enterprise database.Password

Re-enter the password that you provided in the Password field.Confirm Password
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DescriptionField

Maximum number of connections allowed to connect to the database.

This database is usually an external database to which the customer script can
connect. While the limit is set by that database and governed by your license, if
this number in this setting is exceeded, the corresponding workflow is aborted
and the caller receives an error message. However, you can avoid this error by
configuring the appropriate number of sessions in the corresponding script or
application. Also, the script writer can provide information about how many
connections are used per call (or instance of application). This is a mandatory
field.

Maximum Number of
Connections

Displays the list of available drivers for the enterprise database. One or more
datasources can use the same driver. Select a driver for this datasource from this
list box. This is a mandatory field.

Driver

JDBC URL that is used to obtain a connection to the enterprise database. This is
a mandatory field. The JDBC URL provided will be used by Unified CCX to
connect to the enterprise database using JDBC. The URL to be used is dependent
on the database you are connecting. The examples provided in the Datasource
Configuration web page can be used as a reference to define the URL. Refer to
the driver documentation for more information.

If the test connection fails for Oracle JDBC drive connection, try the
following connection url:
jdbc:oracle:thin:[user/password]@[host][:port]:SID

Note

JDBC URL

Poll Database Connectivity
To poll connectivity to the database on a periodic basis, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Database > Parameters.
The Parameters web page opens to display the parameter-related fields.

Step 2 Specify the following fields:
DescriptionField

Specifies the interval between two connection attempts when a data source is
initialized. The default is 15,000 milliseconds.

RetryConnectInterval

Specifies the number of attempts to establish connections to the database when a
data source is initialized. The default is 3 attempts.

NumAttempt

Sets themaximum time in seconds that a driver will wait while attempting to connect
to a database. The default is 0 (disabled).

LoginTimeout
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Step 3 Click Update to apply changes (or Reset to Default if you prefer to retain the default values).
The window refreshes and Unified CCX updates the parameters with your changes. You are now ready to
provision any additional subsystems your Unified CCX applications require or to begin configuring Unified
CCX applications.

Provision eMail Subsystem

The eMail subsystem is available if your system has a license installed for one of the following Cisco
product packages: Unified IP IVR or Unified CCX Premium.

Note

The Unified CCX system uses the eMail subsystem to communicate with your email server and enable your
applications to create and send email. You must provision the eMail subsystem if you intend to create scripts
that use messaging steps to create and send email.

If your email system is configured to receive acknowledgments, you should process the mailbox you
identify in your configuration to determine whether or not an email was successfully sent.

Tip

The email configuration process identifies the default email address and server to be used for sending email
(including e-pages and faxes) and for receiving acknowledgments.

If you are not using email applications, you do not need to provision the eMail subsystem.Note

Complete the following steps.

Procedure

Step 1 Choose Subsystems > eMail.
The eMail Configuration web page opens.

Step 2 Specify the following fields:
DescriptionField

A fully-qualified email server name. (Example:
server.domain.com)

Mail Server

An existing fully qualified e-mail address for the
administrative account.
Example:administrator@domain.com

Unified CCX supports alphanumeric IDs and
special characters (only hyphen "-" ,
underscore "_", and dot ".").

Note

email Address
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Step 3 Click Update.
The Unified CCX system saves your changes and the Unified CCX Administration web page opens.

Cisco does not currently support multiple email configurations. To remove the email information,
you must erase the fields and click Update.

Note

You are now ready to provision any additional subsystems your Unified CCX applications require, or to begin
configuring Unified CCX applications.
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C H A P T E R  9
Management of Prompts, Grammars, Documents,
and Custom Files

Unified CCX applications can make use of many auxiliary files that interact with callers, such as scripts,
pre-recorded prompts, grammars, and custom Java classes.

To manage these auxiliary files, you must complete the following tasks:

• Provision telephony and media resources.

• Provision Unified CCX subsystem, if required.

• Provision additional subsystems, if required.

• Configure Cisco script applications.

Depending on your particular Unified CCX implementation, your applications might make use of some or
all of the file types described in the following sections.

• Manage Prompt Files, page 115

• Manage Grammar Files, page 117

• Manage Document Files, page 118

• Language Management, page 119

• Upload of Prompt Files, page 122

• Management of Custom Files, page 124

• AAR File Management, page 125

Manage Prompt Files
Many applications make use of pre-recorded prompts stored as .wav files, which are played back to callers
to provide information and elicit caller response.

Several system-level prompt files are loaded during Unified CCX installation. However, any file you create
needs to be made available to the Unified CCX Engine before a Unified CCX application can use them. This

Cisco Unified CCX Administration Guide, Release 11.0(1)    
115



is done through the Unified CCX cluster's Repository datastore, where the prompt, grammar, and document
files are created, stored, and updated.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

The Unified CCX Server's local disk prompt files are synchronized with the central repository during Unified
CCX Engine startup and during run-time when the Repository datastore is modified.

To access the Prompt Management page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Application > Prompt Management.
Step 2 The Prompt Management web page opens to display the following fields and buttons.

DescriptionField or Button

Lists the location of the items listed in the Name column.Language

Path of the current item selected in the Name column with respect to the root folder.Folder

Name of the language.Name

The size of the prompt file prefixed with KB. The file size is converted from bytes
to KB.

This column is usually blank on the root page because the items on this
page are usually folders.

Note

Size

The date and time when the document was last uploaded or changed along with time
zone.

Date Modified

The user ID of the person who performed these modifications.Modified by

Click Delete icon to remove the folder and its contents from the repository.Delete

Click Rename icon to rename the folder in the repository.Rename

Click Refresh icon to refresh the folder in the repository.Refresh

Displays a dialog box that lets you create a new language folder.Create Language

Displays a dialog box that lets you locate and upload a zip file.
The zip file must contain language folders in the root directory. Be sure to
place the grammar files in folders and then zip the folders.

Note
Upload Zip Files

When you click a hyperlink (if configured) in the Name folder column, a secondary page appears. From this
page, you can create a new subfolder or upload a new prompt.

   Cisco Unified CCX Administration Guide, Release 11.0(1)
116

Management of Prompts, Grammars, Documents, and Custom Files
Manage Prompt Files



Manage Grammar Files
The Unified CCX system uses specific grammars when recognizing and responding to caller response to
prompts. A grammar is a specific set of all possible spoken phrases and Dual Tone Multi-Frequency (DTMF)
digits to be recognized by Unified CCX applications and acted upon during run time.

Several system-level grammar files are loaded during Unified CCX installation. However, any file you create
needs to be made available to the Unified CCX Engine before a Unified CCX application can use them. This
is done through the Unified CCX cluster's Repository datastore, where the grammar files are created, stored,
and updated.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

The Unified CCX Server's local disk grammar files are synchronized with the central repository during Unified
CCX Engine startup and during run-time when the Repository datastore is modified.

To access the Grammar Management page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Grammar Management.
Step 2 The Grammar Management web page opens to display the following fields and buttons.

DescriptionField or Button

Lists the location of the items listed in the Name
column.

Language

Path of the current item selected in the Name column
with respect to the root folder.

Folder

The codec chosen during installation for this Unified
CCX server. Display only.

Codec

Name of the language folder.Name

The size of the grammar file prefixed with KB. The
file size is converted from bytes to KB.

This column is usually blank on the root page as the
items on this page are usually folders.

Size

The date and time when the document was last
uploaded or changed along with time zone.

Date Modified

The user ID of the person who performed these
modifications.

Modified by
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DescriptionField or Button

Displays a dialog box that lets you delete an existing
language folder.

Delete

Displays a dialog box that lets you rename an existing
language folder.

Rename

Refreshes the specified folder in the repository.Refresh

Displays a dialog box that lets you create a new
language folder.

Create Language

Displays a dialog box that lets you locate and upload
a zip file.

The zip file must contain language folders
in the root directory. Be sure to place the
grammar files in folders and then zip the
folders.

Note

Upload Zip Files

When you click a hyperlink (if configured) in the Name folder column, a secondary page appears. From this
page, you can create a subfolder or upload a new Prompt, Grammar, or Document.

Manage Document Files
Documents might consist of .txt, .doc, .jsp, or .html files. Documents can also include custom classes and
Java Archive (JAR) files that allow you to customize the performance of your Unified CCX system.

Several system-level document files are loaded during Unified CCX installation. However, any file you create
needs to be made available to the Unified CCX Engine before a Unified CCX application can use them. This
is done through the Unified CCX cluster’s Repository datastore, where the document files are created, stored,
and updated.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

The Unified CCX Server's local disk document files are synchronized with the central repository during
Unified CCX Engine startup and during run-time when the Repository datastore is modified.

To access the Document Management page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Document Management.
Step 2 The Document Management web page opens to display the following fields and buttons.
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DescriptionField or Button

Lists the location of the items listed in the Name
column.

Language

Path of the current item selected in the Name column
with respect to the root folder.

Folder

Name of the language folder.Name

The size of the grammar file prefixed with KB. The
file size is converted from bytes to KB.

This column is usually blank on the root page as the
items on this page are usually folders.

Size

The date and time when the document was last
uploaded or changed along with time zone.

Date Modified

The user ID of the person who performed these
modifications.

Modified by

Displays a dialog box that lets you delete an existing
language folder.

Delete

Displays a dialog box that lets you rename an existing
language folder.

Rename

Refreshes the specified folder in the repository.Refresh

Displays a dialog box that lets you create a new
language folder.

Create Language

Displays a dialog box that lets you locate and upload
a zip file.

The zip file must contain language folders
in the root directory. Be sure to place the
grammar files in folders and then zip the
folders.

Note

Upload Zip Files

When you click a hyperlink (if configured) in the Name folder column, a secondary page appears. From this
page, you can create a subfolder or upload a new Prompt, Grammar, or Document.

Language Management
The topics in this section describe the procedure for managing languages.
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Create New Language
Follow this procedure to create a new Prompt, Grammar, or Document language folder in the Repository
datastore:

Procedure

Step 1 From the Unified CCXAdministrationmenu bar, chooseApplications > PromptManagement orGrammar
Management or Document Management.
The corresponding Management web page opens.

Step 2 Click Create New Folder or Create Language icon that displays in the tool bar in the upper, left corner of
the window or theCreate New Folder orCreate Language button that displays at the bottom of the window.
The Create New Folder or Create Language dialog box opens.

Step 3 Perform any one of the following actions:

• Select a value from the Language drop-down list.

• If you are unable to find a particular language or if the Language drop-down list is empty, click Edit
button to add a new Language. The Explorer User Prompt dialog box opens. Enter the name of the new
language in the Language Name field and click OK.

Step 4 Click Create.
A new language folder Name appears on the summary web page.

Rename Language
Follow this procedure to rename a Prompt/Grammar/Document language folder in the Repository datastore:

Procedure

Step 1 From the Unified CCXAdministrationmenu bar, chooseApplications > PromptManagement orGrammar
Management or Document Management.
The corresponding Management web page opens.

Step 2 Select the Rename icon against the folder you want to rename.
The Rename Folder dialog box opens.

Step 3 From the Select Language Folder To Rename field, choose the name of the folder to be renamed.
Step 4 In the Rename Folder To field, enter the new name.
Step 5 Click Rename.

The web page then refreshes itself to provide a summary and status. ClickReturn to DocumentManagement
to navigate to the respective Prompt or Grammar or Document Management page.
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Delete Language
Follow this procedure to delete a Prompt/Grammar/Document language folder in the Repository datastore:

Procedure

Step 1 From the Unified CCXAdministrationmenu bar, chooseApplications > PromptManagement orGrammar
Management or Document Management.
The corresponding Management web page opens.

Step 2 Select the Delete icon against the respective folder, that you want to delete.
A dialog box opens to confirm the Delete action for the specific folder.

Step 3 Click OK to delete.

Upload Zip Files to Language Folder
In addition to adding Prompt or Document files individually, you can upload multiple files from a Zip file.

The maximum upload file size is 20 MB, whether it is a single file or a Zip file.Note

Be sure to upload (or download) large zip files in Prompt, Grammar and Document Management pages
during off-peak hours.

Tip

Procedure

Step 1 From the Unified CCXAdministrationmenu bar, chooseApplications > PromptManagement orGrammar
Management or Document Management.
The corresponding Management web page opens.

Step 2 ClickUpload Zip Files icon that displays in the tool bar in the upper, left corner of the window or theUpload
Zip Files button that displays at the bottom of the window to upload a new prompt or zip file.
The Upload Document dialog box opens.

Step 3 Enter the path for the script file or click Browse to locate the script or the zip file containing the script files.
Select the required script file and click Open.

You can upload only files with extension .aef or
.zip.

Note

Step 4 Click the Upload button to upload the new script to the repository. A dialog box confirms the successful
upload of the files.

If you try to upload invalid script files, the upload will be unsuccessful and an error message will be
displayed on the upload dialog box. You can also create user-defined directories using “Create a New
folder” option and uploads scripts to those directories.

Note
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Step 5 By default, the files are unzipped after uploading. If you want to change this option, uncheck the Unzip after
uploading check box.

In the Documents Management summary web page, you have the option to zip or to unzip the file
before uploading. By default, this check box is checked to unzip the file before uploading. Ensure
to uncheck the check box if you want to upload it as a zipped file.

The maximum upload file size of the Zip file is 20 MB.

Caution

Step 6 The contents of the zip file is uploaded to the folder. On successful uploading of the zip file, the status icon
is updated accordingly. Click Return to Document Management button to go back to the respective
Management web page.

Upload of Prompt Files
Prompts are messages that the Unified CCX system plays back to callers. Unified CCX applications often
use prompts to elicit caller response so that the Unified CCX system can transfer calls, receive account
information, and perform other functions.

To use prompts in your Unified CCX applications, you must first create a folder to store them. You can then
record and upload new user prompts, delete prompts, and modify existing prompts.

You store pre-recorded prompts as .wav files. The Unified CCX system also allows users to record spoken
names, which you can upload to be used in the playback of prompts.

Unified CCX supports audio playback of RIFF header .wav files only though your MRCP vendor might
support multiple .wav file header formats.

Note

ScanSoft uses RIFF headers. When generating a wav file prompt specifically for Nuance, be sure to consider
the server playing the prompt:

• If the prompt is played by the Nuance Speech Server, the .wav file requires a SPHERE header.

• If the prompt is played by the Unified CCX server, the .wav file requires a RIFF header.

Nuance provides a tool to convert .wav files from RIFF headers to SPHERE headers.

Managing prompts can include one or more of the following activities:

• Creating a folder: You must create a folder to store the .wav files that the Unified CCX system uses as
prompts.

• Recording a prompt: You can record your own prompts to be used in applications.

• Upload one or more prompts: You can replace any of the stored prompts used by Cisco script applications
with a different .wav file by uploading the new.wav file. If necessary, you can also add spoken name
prompts. Some Unified CCX applications play back the pre-recorded names of the people that callers
are trying to reach, to allow the caller to confirm the transfer of the call.
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Record a Prompt
You can record your own prompts to be used in applications. The example provided in this section uses the
Windows Sound Record option. This option is one of many possibilities for recording G711 prompts. G711
is a freely distributed public domain codec and has several recording options. Some of these options are
included in Microsoft Windows systems and are available to any sound recording application.

The G729 codec is licensed and is not freely distributed. A white paper that describes the G729 prompt
recording options is available on request. Send an email to apps-support@cisco.com to obtain a copy of this
white paper. To record a prompt, complete the following steps.

The following procedure is an example of recording G.711 prompts withMicrosoftWindows Sound Recorder,
using a microphone plugged into your computer. If you are not using Microsoft Windows Sound Recorder,
see the documentation provided with your audio application.

Procedure

Step 1 From your Windows Start menu, choose Start > Programs > Accessories > Entertainment > Sound
Recorder.
The Sound Recorder dialog box opens.

Step 2 Click the Record button and speak your greeting into the microphone.
Step 3 Click the Stop button when you finish recording.
Step 4 To check your greeting, click the Rewind button or drag the slider back to the beginning of the recording.

Then click the Play button.
Step 5 When you are satisfied with your greeting, choose File > Save As.

The Save As window opens.

Step 6 Click Change to set the recording options.
You can also set recording properties by choosing Properties from the Sound Recorder File menu.

The Sound Selection dialog box opens.

Step 7 From the Format drop-down menu, choose one of the following options based on the prompts selected during
the installation of Unified CCX software:

• If you selected G711 prompts, CCITT u-Law.

• If you selected G729 prompts, see your G.729 white paper.
The instructions in this procedure assume that, during Unified CCX installation, you configured
Unified CCX to use the G.711 codec for prompts. If this assumption is incorrect, and you
specified the G.729 codec instead, you would choose a G.729 option from this menu. For more
information about recording prompts with G.729, see your G.729 documentation.

Note

Step 8 From the Attributes drop-down menu, choose 8.000 kHz, 8 Bit, Mono 7 kb/sec.
Step 9 Click Save As.

The Save As dialog box opens.

Step 10 Enter a name for this format, and then click OK.
The Save As Dialog Box closes.

Step 11 In the Sound Selection dialog box, click OK.
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The Sound Selection dialog box closes.

Step 12 In the Save As window, navigate to the directory of your choice, preferably a directory that you have set aside
for prompts.

Step 13 Select the file name, and click Save.
The Save As dialog box closes.

You are now ready to add this prompt to the Unified CCX system.

Add Spoken-Name Prompts
Some Unified CCX applications play back the pre-recorded names of people that callers are trying to reach,
to allow callers to confirm the transfer of a call.

To upload .wav files of the spoken names of users, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > User Management > Spoken Name
Upload.

Step 2 The Spoken Name Prompt Upload web page opens with the following fields:
DescriptionField

Unique identifier of the user for which the spoken name is to be uploaded. This
is a mandatory field.

User Id

The codec chosen during installation for this Unified CCX server. Display only.Codec

Location of the .wav file. This is a mandatory field.Spoken Name (.wav)

Step 3 In the User Id field, enter an ID number that will identify the user.
Step 4 In the Spoken Name (.wav) field, enter the path for a .wav file or click Browse to navigate to the directory

that contains the Spoken Name .wav file.
The Choose File dialog box opens. Select the required script file and click Open.

Step 5 Click Upload icon that displays in the tool bar in the upper, left corner of the window or click the Upload
button that displays at the bottom of the window to upload the file.

Step 6 Repeat this process as needed to upload all spoken name .wav files.

Management of Custom Files
Use the Custom File Configuration web page to configure the classpath location of custom classes.
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Specify Custom Classpath Entries
Use the Custom Classes Configuration web page to specify the available classpath entries.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Custom File Configuration.
The Custom Classes Configuration web page opens. You can:

• Select required entries from the Available Classpath Entries list and arrange them in the order you want.

• Use the arrow icons to move items between the Available Classpath Entries and Selected Classpath
Entries lists.

Step 2 Click Update when your selections are complete.
Click Upload Custom Jar Files icon that displays in the tool bar in the upper, left corner of the window or
the Upload Custom Jar Files button that displays at the bottom of the window to upload Jar files. The
Document Management web page opens.

AAR File Management

Ensure that the contents of the AAR file are correct and conform to the specifications detailed in this
section. If you upload AAR files that do not conform to these specifications, the Unified CCX Engine
may not function as designed. Consequently, you need to manually reconfigure some of the applications
uploaded through AAR.

Caution

AAR files are archives of prompt, grammar, document, scripts, applications, and custom classes that you use
as building blocks for applications and extensions.

AnAAR file can be simple—for instance, consisting of a single prompt—or complex—for example, containing
all the prompts for all languages application uses, the workflow, and the configuration information for an
application.

An AAR file is essentially a zip file that contains an optional META-INF directory. TheMETA-INF directory,
if it exists, stores configuration data, including security, versioning, extensions, and services.

You create AAR files using Java tools. After creating a file, you need to upload it to Unified CCX.

The following example shows a sample AAR Main Manifest and a sample AAR Application Manifest.

Sample AAR Main Manifest
Manifest-Version: 1.1Created-By: 1.4.2_05 (Sun Microsystems Inc.)
Built-By: aaruser
Sealed: false
Cisco Unified CCX-Version: 9.0(1)
Class-Path:
Application-List: customApp1.mf customApp2.mf
Subsystem-List: sub1.mf sub2.mf
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Palette-List: Custom1 Custom2
Custom1-Palette-Name: Category1
Custom2-Palette-Name: Category2
Custom1-Step-List: step1.mf
Custom2-Step-List: step2.mf step3.mf
Implementation-Title: AAR Test File
Implementation-Version: 4.5(1)
Implementation-Vendor: Cisco Systems, Inc.
Implementation-Vendor-Id: 12345
Implementation-URL: http://www.cisco.com

Sample AAR Application Manifest
Application-Version: 1.1Created-By: 1.4.2_05 (Sun Microsystems Inc.)
Built-By: aaruser
Sealed: false
Implementation-Title: AAR Application MF
Implementation-Version: 9.0(1)
Implementation-Vendor: Cisco Systems, Inc.
Implementation-Vendor-Id: 12345
Implementation-URL: http://www.cisco.com
Application-Name: Custom AA
Application-Type: Cisco Script Application
Application-Description: Cisco Unified CCX Cisco Custom Application
Application-Id: 100
Max-Sessions: 300
Enabled: true
Script: SSCRIPT[aa.aef]
Default-Script: SSCRIPT[aa.aef]
Initial-Script: SSCRIPT[aa.aef]
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The figure below shows a sample AAR file.

Figure 2: Sample AAR File

To deploy custom applications, steps, and subsystems through an AAR file, you must first create the AAR
file using a jar or zip tool and then upload the file through the Unified CCX Administration web page.

AAR File Creation
You create an AAR file using a jar or WinZip tool.

An AAR file format is similar to a Zip file format. It includes an optional META-INF directory, which is used
to store configuration data, including security, versioning, extension, and services.

Upload AAR Files
To upload an AAR file, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > AARManagement.
The AAR Management web page opens to display the following fields and buttons.
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DescriptionField or Button

You can either enter the name of the AAR file or click Browse button next to this
field to navigate to the directory in which the file is located. This is a mandatory
field.

Enter a Valid AAR File
to Upload

Enable this checkbox in case you want to overwrite the existing files.Overwrite existing files

Click this button to upload the AAR file.Upload

Click this button to clear the selected file.Clear

Enter the path for the AAR file or click Browse button to upload the file. The Choose File dialog box opens.
Select the required script file and click Open.

Step 2 Click Upload.
The contents of the AAR file are uploaded to the respective folders.

Unified CCX generates an error if the AAR file is not formatted correctly or is missing some custom
files.

Note

META-INF Directory
Unified CCX uses the following files and subdirectories in theMETA-INF directory to configure applications,
extensions and services:

•MANIFEST.MF. The file used to define extension and application related data.

• applications. This directory stores all application configuration files.

Directories for Prompts, Grammars, Documents, and Scripts
The AAR files features also provides directories to store prompts, grammars, documents, and scripts to be
uploaded to the Repository.

The AAR directory structure mirrors the function of the Unified CCX Prompt, Grammar, Documents, and
Scripts Management web pages. Each directory corresponds to each language for which to install prompts,
grammars, documents and scripts. Languages are defined using the Java Locale standard, and the special
default directory is used for prompts, grammars, and documents that are common to all languages.

Only Unified CCX supported prompt files and extensions are allowed within each directory. The maximum
length of each individual folder name and file name within a directory is 64 characters.

Prompts Directory
The Prompts directory stores prompts that must be uploaded to the prompt repository (to make it seem like
they were uploaded through Unified CCX Prompt Management).
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Grammars Directory
The Grammars directory stores grammars that must be uploaded to the grammar repository (to make it seem
like they were uploaded through Unified CCX Grammar Management).

Documents Directory
The Documents directory stores documents that must be uploaded to the document repository (to make it
seem like they were uploaded through Unified CCX Document Management).

Scripts Directory
The Scripts directory stores scripts that must be uploaded to the script repository (to make it seem like they
were uploaded through Unified CCX Script Management).

The Script directory must define a single directory named default under which all script files must be
listed.

Note

AAR Manifest
An AAR file manifest consists of a main section followed by a list of sections for individual AAR file entries,
each separated by a newline.

Information in a manifest file contains name-value pairs—which are also referred to as headers or attributes.
Groups of name-value pairs are known as a section; sections are separated by empty lines.

The following table describes the expected syntax of the manifest file.

Table 3: Manifest File Syntax

ValueName

*header +newlinesection:

+header +newlinenonempty-section:

CR LF | LF | CR (not followed by LF)newline:

name: valueheader:

alphanum *headercharname:

SPACE *otherchar newline *continuationvalue:

SPACE *otherchar newlinecontinuation:

{A-Z} | {a-z} | {0-9}alphanum:
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ValueName

alphanum | - | _headerchar:

any UTF-8 character except NUL, CR and LFotherchar:

To prevent corruption of files sent through email, do not use “From” to start a header.Note

The main section, which is terminated by an empty line:

• Contains security and configuration information about the AAR file itself, as well as the applications or
extensions that this AAR file is defining.

• Defines main attributes that apply to every individual manifest entry. No attribute in this section can
have its name equal to “Name”.

The individual sections define various attributes for directories or files contained in this AAR file. Not all
files in the AAR file need to be listed in the manifest as entries. The manifest file itself must not be listed.
Each section must start with an attribute with the name as “Name”, and the value must be a relative path to
the file or directory.

If there are multiple individual sections for the same file entry, the attributes in these sections are merged. If
a certain attribute has different values in different sections, the last one is recognized.

Attributes that are not understood are ignored. Such attributes may include implementation-specific information
used by applications.

The following table describes the specification for any file that can be archived in the AAR.

Table 4: Syntax for AAR Files

ValueName

main-section newline *individual-sectionmanifest-file

version-info newline *main-attributemain-section

Manifest-Version: version-numberversion-info

digit+{.digit+}*version-number

(any legitimate main attribute) newlinemain-attribute

Name: value newline *perentry-attributeindividual-section

(any legitimate perentry attribute) newlineperentry-attribute

CR LF | LF | CR (not followed by LF)newline

{0-9}digit
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Attribute Types
Attributes that appear in the main section are called main attributes. Attributes that appear in individual sections
are called per-entry attributes. Some attributes appear in both the main and individual sections, in which case
the per-entry attribute value overrides the main attribute value for the specified entry.

Main Attributes
Main attributes are the attributes that are present in the main section of the manifest:

General main attributes as shown in the following table.

Table 5: General Main Attributes

DescriptionAttribute

The manifest file version. The value is a legitimate version number.Manifest-Version

The version and the vendor of the java implementation on top of which this manifest file is
generated. This attribute is generated by the jar tool.

Created-By

The minimum Unified CCX version release compatible with the AAR file. Unified
CCX-version is the accumulation of the Unified CCX release, Unified CCX Service Release,
and Unified CCX Engineering Special defined in that order. For example, if the AAR file
is compatible with Cisco Unified CCX release 4.5(1)_Build705, SR1_Build001,
ES2_Build002, the Cisco Unified CCX-Version would be defined as
4.5(1)SR1ES2_Build002. Only the last build number is taken. So for instance, if the AAR
file is compatible with Cisco Unified CCX release 4.5(1)_build705, SR1_Build001, then
the Cisco Unified CCX-Version is 4.5(1)SR1_Build001. As a last example, if AAR file is
compatible with Cisco Unified CCX release 4.5(1)_Build705 and above, then Cisco Unified
CCX-Version would be 4.5(1)_Build705.

Cisco Unified
CCX-Version

The directories or JAR files that need to be installed and accessed by scripts directly. Entries
are separated by one or more spaces. The Unified CCX class loader uses the value of this
attribute to construct its internal search path where each entry is defined relative to the
/Documents/default/classpath directory in this AAR file.

Class-Path

The application configuration files from theMETA-INF/applications/ directory to be installed.
Entries are separated by one or more spaces.

Application-List

The subsystem configuration files from theMETA-INF/subsystems/ directory to be installed.
Entries are separated by one or more spaces.

Subsystem-List

The step palettes that need to be installed. Each palette listed in this attribute will have a set
of additional attributes that the Unified CCX editor uses to specify the palette name and the
palette steps to install. Entries are separated by one or more spaces.

Palette-List

The unique name of the palette to define in the Unified CCX editor where the specified steps
will be grouped and accessible.

Palette-Name
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DescriptionAttribute

The step configuration files from the META-INF/steps/ directory to be installed under the
palette. Entries are separated by one or more spaces.

Step-List

Attribute defined for extension identification: Extension-Name

This attribute specifies a name for the extension contained in the AAR file. The name should be a unique
identifier.

The following tables shows attributes defined for extension and directory versioning and sealing information.
These attributes define features of the extension which the AAR file is a part of. The values of these attributes
apply to all the directories in the AAR file, but can be overridden by per-entry attributes.

Table 6: Implementation Category in Main Attributes

DescriptionAttribute

The title of the extension implementation.Implementation-Title

The version of the extension implementation.Implementation-Version

The organization that maintains the extension implementation.Implementation-Vendor

The ID of the organization that maintains the extension implementation.Implementation-Vendor-Id

The URL from which the extension implementation is downloaded.Implementation-URL

Defines if this AAR file is sealed. Sealing a directory means that the files uploaded
to the corresponding repository will not be modifiable once installed unless the
AAR file is reinstalled. If set to true, then all directories in the AAR file default to
be sealed, unless individually defined otherwise. If set to false, then all directories
are modifiable.

Sealed

Per-entry Attributes
Per-entry attributes apply only to the individual AAR file entry with which the manifest entry is associated.
If the same attribute also appears in the main section, then the value of the per-entry attribute overwrites the
main attribute value.

• Example 1: If AAR file a.aar has the following manifest content, then all the files archived in a.aar are
sealed, except US English prompts. If the same attributes also appeared in an entry representing a parent
directory of another entry, then the value of the per-entry attribute overwrites the parent directory
per-entry attribute value.
Manifest-Version: 1.1 Created-By: 1.2 (Sun Microsystems Inc.)
Sealed: true
Name: Prompts/en_US/
Sealed: false
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• Example 2: If AAR file a.aar has the followingmanifest content, then all the US English prompts archived
in a.aar are sealed, except US English prompts located in the AA/ directory.
Manifest-Version: 1.1 Created-By: 1.2 (Sun Microsystems Inc.)
Name: Prompts/en_US/
Sealed: true
Name: Prompts/en_US/AA/
Sealed: false

The per-entry attributes fall into the following groups:

• Attributes defined for file contents: Content-Type
This attribute specifies the MIME type and subtype of data for a specific file entry in the AAR file. The
value should be a string in the form of type/subtype. For example, image/bmp is an image type with a
subtype of bmp (representing bitmap). This indicates that the file entry is an image with the data stored
as a bitmap. RFC 1521 and 1522 discuss and define the MIME types definition.

• Attributes defined for directory versioning and sealing information:
These are the same set of attributes defined in Table 6: Implementation Category in Main Attributes,
on page 132 for the main attributes.When used as per-entry attributes, these attributes overwrite the main
attributes for the individual file specified by the manifest entry.

META-INF Directory Attributes
The Unified CCX recognizes the x.MF file in the applications, subsystems, and steps subdirectories in the
META-INF directory and interprets each to configure applications, subsystems, and steps respectively. The
x is the base file name as listed on the Application-List main attribute of the manifest file. The X.MF file
contains one section defining the configuration of a particular application.

Application Subdirectory Attributes

The following table describes the syntax of the manifest file for the application subdirectory.

Table 7: Application Subdirectory Manifest File Syntax

ValueName

version-info newline *application-attributeapplication-file

Application-Version: version-numberversion-info

digit+{.digit+}*version-number

(any legitimate application attribute) newlineapplication-attribute

CR LF | LF | CR (not followed by LF)newline

{0-9}digit

The application attributes fall into the following groups:
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Table 8: Application Attributes

DescriptionAttribute

The application configurations file version. The value is a legitimate version number.
For example, Cisco Unified CCX Release 4.5 starts with version 1.1.

Application-Version

The unique name of the application (see Unified CCX Application Management).Application-Name

The type of the application (Cisco Script Application, Busy, Ring-No-Answer.Application-Type

The description for the application (see Unified CCX Application Management).Application-Description
(optional)

A unique identifier for the application (see Unified CCXApplicationManagement).Application-Id

Themaximum number of sessions for the application (see Unified CCXApplication
Management).

Max-Sessions

The application is enabled if the value is set to true (see Unified CCX Application
Management). If the value is set to false, the case is ignored.

Enabled

The main script of a Cisco Script Application (see Unified CCX Application
Management). The value must be relative to the Scripts directory. Unified CCX
does not support configuring script parameters.

Script

The default script of a Cisco Script Application, Unified ICME Translation or Post
Routing application (see Unified CCX Application Management). The value must
be relative to the Scripts directory. Unified CCX does not support configuring script
parameters.

Default-Script

The initial script of a Unified CCX Post Routing application (see Unified CCX
ApplicationManagement). The valuemust be relative to the Scripts directory. Unified
CCX does not support configuring script parameters.

Initial-Script

• Attributes defined for application versioning and sealing information: These attributes define features
of the application to which the AAR file belongs. These attributes are the same as those listed in Main
Attributes, on page 131.
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C H A P T E R  10
Unified CCX System Management

Unified CCX administration provides options to configure, control, and monitor Unified CCX component
activities and information across a cluster.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

See the Cisco Unified Contact Center Express Install and Upgrade Guide for instructions about tasks that
significantly change your Unified CCX deployment, such as:

• Changing from a single-server deployment to a multiple-server deployment.

• Removing a Unified CCX Software component from a server.

• Moving a Unified CCX Software component to another server.

• Changes to a Unified CCX cluster (adding, removing, or replacing a server).

The following sections describe the day-to-day management of Unified CCX components.

• Basic Terminology, page 135

• High Availability and Automatic Failover, page 136

• Unified CCX CDS Information Management, page 137

• Manage System Parameters, page 137

• Unified CCX IP Address/hostname Management, page 142

• Exit Unified CCX Administration, page 155

Basic Terminology
This section provides information about different Unified CCX terminology.

• Cluster. A Unified CCX cluster (often referred to as cluster in this manual) consists of one or more
servers (nodes) that are running Unified CCX components in your Unified CCX deployment. If you
deploy Unified CCX components on a single server, the Unified CCX cluster consists of that server. If
you deploy Unified CCX on multiple servers, the cluster includes the Unified CCX server and standby
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server on which you installed Unified CCX. The Unified CCX cluster supports up to two Unified CCX
servers, one designated as the active Unified CCX server and the other designated as the standby Unified
CCX server for high availability purposes.

Support for High Availability and remote servers is available only in multiple-server
deployments.

Note

• Cluster profile. The Unified CCX Administration web page (home page) displays information about
the cluster profile. A cluster profile includes data relating to the Unified CCX servers, components, and
licenses installed in a cluster.

• Node (server). A server that is part of the Unified CCX cluster.

• Active Server. The active server provides all system services and resources. You can deploy one active
server in eachUnified CCX subsystem. If the active server fails, the Unified CCX subsystem automatically
fails over to the standby server.

• Standby Server. You can deploy up to two servers in eachUnified CCX system for high availability—one
active server (master) and one standby (not active) server. With high availability, if an active server
becomes unavailable, the standby server automatically becomes the active server.

• Component.The software units in the Unified CCX system. The main software components of the
Unified CCX server are the Engine, datastores, monitoring, recording, and the Cluster View Daemon
(CVD). See the Cisco Unified Contact Center Express Install and Upgrade Guide for more information
on setup and installation procedures.

• Service. An executable unit. A service may have other services as its children. (For example, subsystems
and managers are children of the engine service).

• Feature. A logical representation of the functional unit.

•Master service. A specially-elected service. Only one service from the Engine service, or database
services set can be the master within the Unified CCX Engine component.

• Standby service. An active service that can take over the master functionality in case the master service
becomes unavailable within the Unified CCX Engine component. You cannot configure the standby
service. The Cluster View Daemon (CVD) dynamically elects the services on the active node to be the
master.

High Availability and Automatic Failover

Support for High Availability (HA) and remote servers is available only in multiple-server deployments.
Unified CCX does not support more than two nodes in a HA setup. Expansion servers where the Database,
Monitoring, or Recording components are running on separate servers are not supported.

Note

Unified CCX provides high availability and automatic failover capability through the use of two servers, the
active server and the standby server.

The active server provides all system services and resources; no services or resources are available from the
standby server. When you make administrative changes on the active server, both the servers are synchronized.
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If the active server fails, there is automatic failover to the standby server. For detailed information on HA
over WAN deployment, see .

After a Unified CCX failover or failback the agent state changes to Not Ready state.Note

Network Partitions
Network malfunction or misconfiguration can create network partitions and split the network into separate
islands. If a node enters this state, the node is referred to as being in the island mode. Nodes in the island
mode are hard to detect. While these nodes can communicate within a partitioned island, they cannot
communicate between partitioned islands. If the islands do not communicate, then each island will select its
own active server.

Generally, you can connect to the Unified CCX administration on any node, and see a consistent cluster view.
If a node is in the island mode, you will see different cluster views when you connect to nodes in each island.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

If your node enters the island mode, it should recover from the island mode as soon as the underlying network
issue is resolved. If the island mode persists, check the network connectivity/reachability between the two
CCX servers and take action accordingly.

Unified CCX CDS Information Management
The Unified CCX system stores configuration information in the Cisco Configuration Datastore Server (CDS).
The Unified CCX Administration configurations are stored in the CDS.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

TheUnified CCX server can receive directory information from one Cisco Unified Communications directory
and application configuration and script logic from a repository on another server.

Manage System Parameters
The parameters in the System Parameters Configuration page are grouped logically into sections with headings.
Each parameter has a corresponding suggested or default value on the right side of the page.Where applicable,
radio buttons are used to toggle between the parameter options.

In this web page, you can configure the port settings, default session timeout, and codec.
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Changing some system parameters like IP address, Network Time Protocol (NTP) and so on can result in
a different License MAC. You need to get rehosted license files (with new License MAC) in such cases
within 30-day grace period beyond which the system will stop working.

Note

Procedure

Step 1 Choose System > System Parameters from the Unified CCX Administration menu bar.
The System Parameters Configuration web page appears.

Step 2 Click theUpdate icon that displays in the tool bar in the upper, left corner of the window or theUpdate button
that displays at the bottom of the window.
The system notifies all nodes in the cluster about the changes.

If Cluster View Daemon is in Shutdown state during this operation, then the changes just made are
synchronized on that node when Cluster View Daemon is started again.

Note

System Parameters Configuration Web Page
The System Parameters Configuration web page displays the following fields.

Table 9: System Parameters Configuration

DescriptionField

Generic System Parameters

The system or primary time zone will be the same as local time zone of the primary
Unified CCX node configured during installation. Display only. Unified CCX
Administration uses this primary time zone to display time-related data.

If you have changed the primary time zone, you need to reboot both the nodes
in the Unified CCX cluster.

Note

System Time Zone

Network Deployment Parameters (displayed only in a HA over WAN deployment)

Displays the network deployment type as LAN or WAN only if we have more than
one node. Display only.

Network
Deployment Type

Internationalization Parameters

Use to specify a unique locale.

Default: (blank)

Customizable
Locales
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DescriptionField

Default currency, such as American dollars (USD), Euros, and so on. This is a
mandatory field.

The system uses the default currency for converting currency amounts in a playable
format when no currency designator is specified.

Default: American Dollar [USD]

Default Currency

Media Parameters

The codec chosen during installation for this Unified CCX server.

Unified CCX supports packetization intervals of 20 ms, 30 ms, or 60 ms only.

Default: 30 ms

Codec

Default TTS (Text-to-Speech) provider.

Default: By default, no TTS provider is configured. Select a provider from the
drop-down list to configure it as the default. The system uses the default TTS provider
to determine which provider to use if the TTS request does not explicitly specify the
provider to use.

Default TTS
Provider

When enabled, custom recorded prompt files can be uploaded to the appropriate
language directory under Prompt Management to override the system default prompt
files for that language. By default, this is disabled.

User Prompts
override System
Prompts

Application Parameters

The Administrator uses this option to allow certain privileges to supervisors (all
supervisors have the same privilege). The options are:

• No access to teams—The supervisor logs into the Supervisor page, but will not
be able to see any team information (No RmCm info).

• Access to all teams—The supervisor logs into the Supervisor page, and will be
able to see all the teams (RmCm information).

• Access to supervisor teams only—The supervisor logs into the Supervisor page,
and will be able to see the teams they supervise. When this option is selected,
only the Primary Supervisor can see the team specific information. The secondary
supervisor fill not be able to see the team specific information.

Default: No access to teams

A supervisor who does not have administrator privileges can add, modify, or
remove skills from an agent.

Note

Supervisor Access

The maximum number of steps an application can execute before the Unified
CCX Engine terminates the script or application. This is a mandatory field.

This limitation is intended to prevent a script from running indefinitely.

Default: 1000

Do not change the default
value.

Note

Max Number of
Executed Steps
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DescriptionField

This field allows you to control the creation of additional threads that the Unified CCX
server internally initializes based on licensed Unified IP IVR ports. This is a mandatory
field.

Default: 0

Additional Tasks

Maximum amount of time (in minutes) a user-defined mapping ID remains in the
session object memory after the session is moved to the idle state. During this duration,
the session continues to be accessible even if you have terminated that session. Use
this setting to configure the time required to perform your after-call work (for example,
writing variables to a database before clearing the session). This is a mandatory field.

The default is 30 minutes (recommended). If you reduce this number, you also reduce
the system memory usage comparatively.

You can add a user-defined mapping ID to a session using the Session Mapping step
in the script editor. Once assigned, you can use this mapping ID to get the session
object from another application instance. By doing so, other applications obtain access
to the session context. See the Cisco Unified Contact Center Express Getting Started
with Scripts for more information.

Default Session
Timeout

A character used Get/Set Enterprise Call Info steps in the Unified CCX Editor to act
as a delimiter for call data. This is a mandatory field.

Default: | (bar)

Enterprise Call Info
Parameter Separator

Radio button determining how agent state should be set after a Ring No Answer event.
This is a mandatory field. The options are:

• Ready. If an agent does not answer a Unified CCX call, the Agent State is set to
Ready.

• Not Ready (default). If an agent does not answer a Unified CCX call, the Agent
State is set to Not Ready.

Agent State after
Ring No Answer

This parameter applies to Live Data reports that are available to agents and supervisors
on Finesse desktops.

For certain fields in the live data reports, you can set the short term value to 5, 10 or
15 minutes.

Long term value is always set to 30 minutes.

Live Data - Short
Term Reporting
Duration

The maximum number of Direct Preview Outbound seats. The configuration of
Outbound seats is done during the initial configuration or setup phase, after the
installation.

This is a mandatory field. This field is displayed only if you have a Premium
license.

Note

The maximum number of direct preview outbound seats that can be configured is
limited by the Premium Seat Count. If there is an invalid entry during configuration,
an error message is displayed.

Number of Direct
Preview Outbound
seats
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DescriptionField

Radio button that determines whether to establish persistent connection to a remote
device. The options are:

• Enable (default)—Establishes persistent connection.

• Disable—Does not establish persistent connection.

Persistent
Connection

System Ports Parameters

The port number used by the Unified CCX CVD to serve RMI requests. This is a
mandatory field.

Default: 6999

RMI Port

TCP port number on which the CTI server component of the RmCm subsystem opens
the server socket and listens to the clients. All CTI server clients, such as Sync Server,
and IP Phone Agent Server, use this port number. This is a read-only field and cannot
be modified.

Default: 12028

RmCm TCP Port

Context Service Parameters

Radio button indicates if the ContextService is in production mode or lab mode.

• Enable—ContextService switches to lab mode.

• Disable (default)—ContextService will be in production mode.

ContextService in the Lab mode will create the data in the lab work group.
When ContextService switches to the production mode, the data created in
the lab work group will no longer be available in the production mode and
vice versa. Lab mode is a workgroup created for test and debug.

Note

Lab Mode

The number of milliseconds (ms) the system should wait before rejecting the
ContextService cloud connectivity.

Default: 1200 milliseconds, Range: 200 to 15000 milliseconds.

A typical Context Service request within the same geographical area takes
around 100ms to 300ms while it takes as long as 1.2 to 1.5 seconds across
the globe.

Note

Request Timeout

The maximum number of times the ContextService system is allowed to retry
connecting to cloud during network related issues.

Default: 1, Range: 0 to 5.

Max Retries

Context Service Parameter changes requires restart of Cisco Unified CCX Engine of all nodes in
the cluster. For more information on the ContextService parameters see, Context Service Connection
Timeouts and Retries, on page 395.

Note
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Unified CCX IP Address/hostname  Management
This section provides the steps you need to follow whenever there is a change in IP address/hostname for the
following Unified CCX deployments:

• Unified CCX Cluster with Single-node

• Unified CCX Cluster with High Availability (HA)

You may want to change the IP address/hostname for a variety of reasons, including moving the server from
one segment to another or resolving a duplicate IP address/hostname problem.

Hostname change is supported in Cisco Unified CCX. Hostname must be in lower case and the character
limit is 24 characters.

Note

Prepare System for IP Address/host name  Change
Perform the following tasks to ensure that your system is prepared for a successful IP address/host name
change.

If you do not receive the results that you expect when you perform these tasks, do not continue with this
procedure until after you resolve any problems that you find. DB replication across the entire cluster is
essential for this process. Also, if the DNS check fails then the IP Address/host name change will not
happen.

Note

Procedure

Step 1 List all servers in the cluster and note whether the nodes are defined by using IP addresses or host names.

• From Cisco Unified CCX Administration menu bar on the first node, navigate to System > Server.
A list of all servers in the cluster displays.

• See whether the servers are defined using IP addresses or host names and capture this list of servers for
later reference. Ensure that you have saved an inventory of both the host name and IP address of each
node in your cluster.

Step 2 Ensure that all servers in the cluster are up and available by checking for any active ServerDown alerts. You
can check by using either the Real Time Monitoring Tool (RTMT) or the Command Line Interface (CLI) on
the first node.

• To check by using RTMT, access Alert Central and check for ServerDown alerts.

• To check by using the CLI on the first node, enter the following command and inspect the application
event log:

file search activelog syslog/CiscoSyslog ServerDown
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Step 3 Check the DB replication status on all the Cisco CRS nodes and Cisco Unified Communications nodes in the
cluster to ensure that all servers are replicating database changes successfully using the following substeps:
a) For Unified CCX: In a High Availability deployment of Unified CCX, you can check the DB replication

status for the datastores across all servers in the cluster using Unified CCX Serviceability Administration.
Choose Tools > Datastore Control Center > Replication Servers from the Unified CCX Serviceability
menu bar to view the replication status. The value in State field for both the servers in this web page should
display ACTIVE/ CONNECTED.

b) For Cisco Unified Communications Platform: You can check the DB replication status on all the Cisco
Unified Communications nodes in the cluster by using either RTMT or a CLI command.

• To check by using RTMT, access the Database Summary and inspect the replication status.

• To check by using the CLI, enter the command that is shown in the following example:

admin: show perf query class "Number of Replicates Created and
State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of
Replication)
has instances and values:
ReplicateCount -> Number of Replicates Created = 344
ReplicateCount -> Replicate_State = 2

Be aware that the Replicate_State object shows a value of 2 in this case. The following list shows the
possible values for Replicate_State:

• 0—Replication Not Started. Either no subscribers exist, or the Database Layer Monitor service is
not running and has not been running since the subscriber was installed.

• 1—Replicates have been created, but their count is incorrect.

• 2—Replication is good.

• 3—Replication is bad in the cluster.

• 4—Replication setup did not succeed.

Step 4 Run a manual DRS backup and ensure that all nodes and active services are backed up successfully.
Step 5 Run the CLI command utils diagnose module validate_network through Platform CLI on all nodes in

the cluster to ensure network connectivity and DNS server configuration are intact.

IP Address Modification
This section describes how to change the IP address.
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Changing the IP address on any node in a Cisco CRS cluster can interrupt call processing and other system
functions. Also, changing the IP address can cause the system to generate certain alarms and alerts such
as ServerDown and automatic failover to a backup server may not operate. Because of this potential impact
to the system, you must perform IP address changes during a planned maintenance window.

Caution

As a prerequisite ensure that the DNS is reachable and the DNS record exists for the server.Note

Change IP Address for Server in Single-Node Deployment
Use this procedure to change the IP address of the server in a single-node deployment.

Procedure

Step 1 Change the DNS record of the server to point to the new IP address. Ensure that you correctly update both
the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 If you want to change the IP address of the server on the same subnet or a different subnet that requires a new
default gateway address, use either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

Using CLI commands:

Skip (a) if you want to change only the IP address of the
server.

Note

a) To change the default gateway, enter the following CLI command:
set network gateway <IP Address>
The following sample output displays:

admin:set network gateway 10.3.90.2

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.

Continue(y/n):
Continue (y/n)?y

Ensure that the server is moved to the new subnet and has access to the default gateway before
proceeding to the following sub-step.

Caution

b) To change the IP address of the server, enter the following CLI command:
set network ip eth0 <ip_address> <netmask> <default gateway>

where ip_address specifies the new server IP address and netmask specifies the new server network mask
and default gateway specifies the default gateway of the new server.

The following sample output displays:

admin: set network ip eth0 10.3.90.21 255.255.254.0 10.3.90.1
** W A R N I N G ***
If there are IP addresses (not hostnames)
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configured in UCCX Administration
under System -> Servers then you must change
the IP address there BEFORE changing it here
or call processing will fail. This will cause the
system to restart
=======================================================
Note: To recognize the new IP address all nodes within
the cluster will have to be manually rebooted.
=======================================================
Do you want to continue?
Enter "yes" to continue and restart or any other key
to abort

Enter y and press Enter. This will automatically reboot this server with the new IP address.

Using Cisco Unified Communications Operating System Administration interface:

Alternatively, you can change the IP address and default gateway of the server from Cisco Unified
Communications Operating System Administration interface as follows:

• Choose Settings > IP > Ethernet.

• Change the IP address, default gateway, and netmask, and click Save. The server restarts automatically
with the new IP address.

If you change the IP address, LicenseMAC of the server will also change. Rehost the new license. Old license
enters its grace period.

IP Address Modification in High-Availability (HA) Deployment

Change IP Address for Publisher Server in HA Deployment

Use this procedure to change the IP address of publisher server in a HA deployment.

Procedure

Step 1 Change the DNS record of the publisher server to point to the new IP address. Ensure that you correctly update
both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the utils network host <IP Address> and
show tech network hosts CLI commands on all the cluster nodes.

Step 3 From the Cisco Unified Operating SystemAdministration page of the subscriber server in the cluster, perform
the following tasks:
a) Navigate to Settings > IP > Publisher.
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b) Change the IP address of the publisher server.

Step 4 To update new IP of the publisher server in subscriber, enter the following CLI command on the subscriber
server:
utils uccx modify remote_IPAddress <Old_IP_of_Publisher>
<New_IP_of_Publisher>

The following output displays:

admin:utils uccx modify remote_IPAddress 10.3.90.21 10.3.90.28

Old Remote IP Address: 10.3.90.21
New Remote IP Address: 10.3.90.28

This command should be executed only in case you are changing IP Address of remote server.
Are you sure you want to run this command?
Continue (y/n)?

Enter y and press Enter.

Step 5 If you want to change the IP address of the server on the same subnet or a different subnet that requires a new
default gateway address, use either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

Using CLI commands:
Skip (a) if you want to change only the IP address of the
server.

Note

a) To change the default gateway, enter the following CLI command:
set network gateway <IP Address>
The following sample output displays:

admin:set network gateway 10.3.90.2

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.

Continue(y/n):
Continue (y/n)?y

Ensure that the server is moved to the new subnet and has access to the default gateway before
proceeding to the following sub-step.

Caution

b) To change the IP address of the server, enter the following CLI command:
set network ip eth0 <ip_address> <netmask> <default gateway>

where ip_address specifies the new server IP address, netmask specifies the new server network mask
and default gateway specifies the default gateway of the new server.

The following sample output displays:

admin:set network ip eth0 10.78.92.55 255.255.255.0 10.78.92.1

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.

Continue (y/n)?y
*** W A R N I N G ***

This command will cause the system to restart
=======================================================
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Note: Please verify that the new ip address is unique
across the cluster and, if DNS services are
utilized, any DNS configuration is completed
before proceeding.
To recognize the new ip address all nodes within
the cluster will have to be manually rebooted.

=======================================================
Continue (y/n)?y

Enter y and press Enter. This will automatically reboot this server with the new IP address.

Using Cisco Unified Communications Operating System Administration interface:

Alternatively, you can change the IP address and default gateway of the server from Cisco Unified
Communications Operating System Administration interface as follows:

• Choose Settings > IP > Ethernet.

• Change the IP address, default gateway, and netmask, and click Save. The server restarts automatically
with the new IP address.

Step 6 Reboot all the servers in the cluster including the publisher using the CLI command utils system restart.
If you do not reboot the subscriber after the IP address change, all the services on the publisher may
not start properly.

Note

If you change the IP address, LicenseMACwill also change. Rehost the new license for the new LicenseMAC.
Old license enters its grace period.

Change IP Address for Subscriber Server in HA Deployment

Use this procedure to change the IP address of a subscriber server in a HA deployment.

Procedure

Step 1 Change the DNS record of the subscriber server to point to the new IP address. Ensure that you correctly
update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the utils network host <IP Address> and
show tech network hosts CLI commands on all the cluster nodes.

Skip Step 3 if the server is defined by host name and you are changing only the IP address.Caution

Step 3 From Cisco Unified CCX Administration page, perform the following tasks:
a) Navigate to System > Server. From the List Servers web page, click the IP address of the subscriber

server.
The Server Configuration page for the subscriber server opens.

b) Enter the new IP address in the Host Name/IP Address field and click Save.
You can use the CLI command run sql select name,nodeid from ProcessNode to check
whether the new IP address has been replicated on all the servers.

Note

Step 4 To update new IP of the subscriber in publisher, enter the following CLI command on the publisher server:
utils uccx modify remote_IPAddress <Old_IP_of_Subscriber> <New_IP_of_Subscriber>
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The following output displays:

admin:utils uccx modify remote_IPAddress 10.3.90.21 10.3.90.28

Old Remote IP Address: 10.3.90.21
New Remote IP Address: 10.3.90.28

This command should be executed only in case you are changing IP
Address of remote server.
Are you sure you want to run this command?
Continue (y/n)?

Enter y and press Enter.

Step 5 If you want to change the IP address of the server on the same subnet or a different subnet that requires a new
default gateway address, use either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

Using CLI commands:
Skip (a) if you want to change only the IP address of the
server.

Note

a) To change the default gateway, enter the following CLI command:
set network gateway <IP Address>
The following sample output displays:

admin:set network gateway 10.3.90.2

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.

Continue(y/n):
Continue (y/n)?y

Ensure that the server is moved to the new subnet and has access to the default gateway before
proceeding to the following sub-step.

Caution

b) To change the IP address of the server, enter the following CLI command:
set network ip eth0 <ip_address> <netmask> <default gateway>

where ip_address specifies the new server IP address, netmask specifies the new server network mask
and default gateway specifies the default gateway of the new server.

The following sample output displays:

admin:set network ip eth0 10.78.92.55 255.255.255.0 10.78.92.1

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.

Continue (y/n)?y
*** W A R N I N G ***

This command will cause the system to restart
=======================================================
Note: Please verify that the new ip address is unique

across the cluster and, if DNS services are
utilized, any DNS configuration is completed
before proceeding.
To recognize the new ip address all nodes within
the cluster will have to be manually rebooted.
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=======================================================
Continue (y/n)?y

Enter y and press Enter. This will automatically reboot this server with the new IP address.

Using Cisco Unified Communications Operating System Administration interface:

Alternatively, you can change the IP address and default gateway of the server from Cisco Unified
Communications Operating System Administration interface as follows:

• Choose Settings > IP > Ethernet.

• Change the IP address, default gateway, and netmask, and click Save. The server restarts automatically
with the new IP address.

Step 6 Reboot all the servers in the cluster including the publisher using the CLI command utils system restart.
If you do not reboot the subscriber after the IP address change, all the services on the publisher may
not start properly.

Note

Host Name Modification
This section describes how to change the host name.

Changing the host name on any node in a Cisco CRS cluster can interrupt call processing and other system
functions. Also, changing the host name can cause the system to generate certain alarms and alerts such
as ServerDown and automatic failover to a backup server may not operate. Because of this potential impact
to the system, you must perform host name changes during a planned maintenance window.

Caution

As a prerequisite ensure that the DNS is reachable and the DNS record exists for the server.Note

Change Host Name for Server in a Single-Node Deployment
Use this procedure to change the host name of the server in a single-node deployment.

Hostname must be in lower case and the character limit is 24 characters.Note

Procedure

Step 1 Change the DNS record of the server to point to the new host name. Ensure that you correctly update both
the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 You can change the host name of the server either using the CLI (command line interface) command or using
Cisco Unified Communications Operating System Administration interface. To change the host name
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using CLI command, go to step 3 or to change the host name usingCisco UnifiedCommunicationsOperating
System Administration interface go to step 4.

Step 3 At the CLI prompt, perform the following tasks:
a) Enter the CLI command set network hostname and press Enter.

The following sample output displays:

admin:set network hostname

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.

Continue(y/n):
Continue (y/n)?y
ctrl-c: To quit the input.

*** W A R N I N G ***
Do not close this window without first canceling the command.

This command will automatically restart system services.
The command should not be issued during normal operating
hours.

=======================================================
Note: Please verify that the new hostname is a unique

name across the cluster and, if DNS services are
utilized, any DNS configuration is completed
before proceeding.

=======================================================

Security Warning : This operation will regenerate
all UCCX Certificates including any third party
signed Certificates that have been uploaded.

Continue (y/n)?y
Enter the hostname:

b) Enter y twice to continue and enter the hostname and press Enter.

Step 4 From Cisco Unified Communications Operating System Administration interface, perform the following
task:
a) Choose Settings > IP > Ethernet.
b) Change the host name.
c) Click Save. The server automatically reboots with the new host name.

Step 5 On changing the host name/IP address, License MAC of the server changes. Rehost the new license. Old
license enters its grace period.

Step 6 Verify the status of SocialMiner:
a) Choose Subsystems > Chat and Email > SocialMiner Configuration.
b) Click Save and verify that the SocialMiner Status displays green for all the components.
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Host Name Modification in High-Availability (HA) Deployment
Hostname must be in lower case and the character limit is 24 characters.

Change Host Name for Publisher Server in HA Deployment

Use this procedure to change the host name of publisher server in a HA deployment.

Procedure

Step 1 Change the DNS record of the publisher server to point to the new host name. Ensure that you correctly update
both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the utils network host <IP Address> and
show tech network hosts CLI commands on all the cluster nodes.

Step 3 To change the host name of the publisher on the subscriber node, use either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

Using CLI commands:

a) Run the following CLI command on the subscriber node:
set network cluster publisher hostname <hostname>

where hostname is the new publisher.

The following output displays:

admin:set network cluster publisher hostname hijk-lmn-n1

New Remote hostname: hijk-lmn-n1

Using Cisco Unified Communications Operating System Administration interface:

FromCisco Unified Communications Operating SystemAdministration interface of the subscriber server,
perform the following tasks:

a) Navigate to Setting > IP > Publisher.
b) The Server Configuration page for the publisher server opens. Change the host name of Publisher server

in the Host Name or IP Address field and then click Save.

Step 4 Run the following CLI command on the Subscriber node to update new host name of the Publisher server :
utils uccx modify remote_hostname <Old_hostname_of_Publisher> <New_hostname_of_Publisher>

The following output displays:

admin:utils uccx modify remote_hostname abcd-efg-n1 hijk-lmn-n1

Old Remote hostname: abcd-efg-n1
New Remote hostname: hijk-lmn-n1

This command should be executed only in case you are changing Hostname of remote server.
Are you sure you want to run this command?
Continue (y/n)?
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Enter y and press Enter.

Step 5 To change the host name of publisher server, use either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

Using CLI commands:
a) Run the following CLI command on the publisher node:

set network hostname

The following output displays:

admin:set network hostname

*** W A R N I N G ***
Do not close this window without first canceling the command.

This command will automatically restart system services.
The command should not be issued during normal operating
hours.

=======================================================
Note: Please verify that the new hostname is a unique

name across the cluster and, if DNS services are
utilized, any DNS configuration is completed
before proceeding.

=======================================================
Security Warning : This operation will regenerate

all UCCX Certificates including any third party
signed Certificates that have been uploaded.

Continue (y/n)?

Enter y and press Enter.

b) Enter the hostname when prompted. The system services will automatically restart.
Using Cisco Unified Communications Operating System Administration interface:

Change the host name using Cisco Unified Communications Operating System Administration interface of
the publisher server:

a) Choose Settings > IP > Ethernet.
b) Change the host name.
c) Click Save. The system services will automatically restart.

Step 6 Reboot all the servers in the cluster including the publisher using the CLI command utils system restart.
If you do not reboot the subscriber, all the services on the publisher may not start properly.Note
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Step 7 From the publisher node, run CLI command utils dbreplication reset all to resetupUnified CMdatabase
replication across the entire cluster.

Step 8 From the publisher node, run CLI command utils uccx dbreplication reset to setup Unified CCX
database replication across the cluster.

Step 9 On changing the host name, License MAC changes. Rehost the new license for the new license MAC. Old
license enters its grace period.

Step 10 Verify the status of SocialMiner.

Change Host Name for Subscriber Server in HA Deployment

Use this procedure to change the host name of a subscriber server in a HA deployment.

Procedure

Step 1 Change the DNS record of the subscriber server to point to the new host name. Ensure that you correctly
update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the utils network host <IP Address> and
show tech network hosts CLI commands on all the cluster nodes.

Step 3 To update new host name of the subscriber in publisher, enter the following CLI command on the publisher
server:
utils uccx modify remote_hostname <Old_hostname_of_Subscriber> <New_hostname_of_Subscriber>

The following output displays:

admin:utils uccx modify remote_hostname abcd-efg-h1 ijkl-mno-p2

Old Remote hostname: abcd-efg-h1
New Remote hostname: ijkl-mno-p2

This command should be executed only in case you are changing Hostname
of remote server.
Are you sure you want to run this command?
Continue (y/n)?

Enter y and press Enter.

Step 4 To change the host name of the subscriber server, perform either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

Using CLI commands:
a) Run the following CLI command on the subscriber server:
set network hostname

The following output displays:

admin:set network hostname

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.
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Continue (y/n):
Continue (y/n)?y
*** W A R N I N G ***
This command will cause the system to restart
=======================================================
Note: Please verify that the new ip address is unique

across the cluster and, if DNS services are
utilized, any DNS configuration is completed
before proceeding.
To recognize the new ip address all nodes within
the cluster will have to be manually rebooted.

=======================================================
Continue (y/n)?y

Enter y and press Enter. The system services will automatically restart.

Using Cisco Unified Communications Operating System Administration interface:

Change the host name using Cisco Unified Communications Operating System Administration interface of
the subscriber server:

a) Choose Settings > IP > Ethernet.
b) Change the host name.
c) Click Save. The system services will automatically restart.

Step 5 Restart all the servers in the cluster using the CLI command utils system restart .
If you do not reboot the subscriber, all the services on the publisher may not start properly.Note

Step 6 From the publisher node, run CLI command utils dbreplication reset all to resetupUnified CMdatabase
replication across the entire cluster.

Step 7 From the publisher node, run CLI command utils uccx dbreplication reset to setup Unified CCX
database replication across the cluster.

Step 8 Verify the status of SocialMiner.

Verify Proper Function of System after IP Address/host name Change
After you change the IP addresses/host names of your cluster, complete the following tasks:
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Procedure

Step 1 Ensure that all the servers in the cluster are up and available.
Step 2 Check the DB replication status as described in Step 3 of Prepare System for IP Address/host name Change,

on page 142 to ensure all the servers are replicating database changes successfully.
Step 3 Run a manual DRS Backup and ensure that all nodes and active services are successfully backed up.
Step 4 Run the CLI command utils diagnose module validate_network through platform CLI on all nodes in

the cluster to ensure network connectivity and DNS server configuration are intact.
Step 5 If you have changed the IP address to move the Unified CCX server to a different network, then any firewall

configuration on the other network must be changed to permit or deny traffic from the new IP address.
Step 6 If you have created any DSN using old IP address, change the DSN to point to the new IP. For example, the

DSN created for Wallboard.
Step 7 Update the new IP address in the following web pages as well:

•Work Flow Configuration > User Interface > Browser Setup - URL and Home Page

•Work Flow Configuration > HTTP Action - Host

•Work Flow Configuration > IPC Action - IP Address

• Update the Recording configuration and the Cisco SocialMiner configuration in the Unified CCX
Administration page on the Publisher server.

Step 8 For Cisco Finesse and Unified Intelligence Centers users, delete the certificates entries for the old hostname/IP
Address from the web browser before you log in to Cisco Finesse Agent Desktop or Unified Intelligence
Center.

Exit Unified CCX Administration
To exit Unified CCX Administration without closing your web browser, you can do either of the following:

You can also exit Unified CCX Administration by closing your web browser.Note

Procedure

Step 1 Click the Logout link displayed in the top right corner of any Cisco Unified CCX Administration web page
Step 2 Choose System > Logout from the Unified CCX Administration menu bar.

The system logs you out of Unified CCX and displays the Unified CCX Authentication web page.
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C H A P T E R  11
Unified CCX Reporting

• Reporting Administration on Unified CCX, page 157

• Reporting Administration on Unified Intelligence Center, page 196

Reporting Administration on Unified CCX

Import of Stock Reports
To apply a patch if you import stock reports from Unified Intelligence Center, then run the CLI command
utils uccx synctocuic permission all to reset the permissions of the user groups. For more information, see
the “Command line interface” section of the Cisco Unified Contact Center Express Operations Guide, located
at http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_maintenance_guides_list.html.

Do not create a sub-category under the Stock category as the permissions for the Stock category is
automatically reset at midnight.

Note

Unified CCX Historical Reports
Historical reports are the preconfigured reports in Unified Intelligence Center. These reports access past data
from the historical data source to display information for the specified period of time.

Unified CCX Historical Datastore
In a Unified CCX Cluster, there can be one or more Historical datastores.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

The Historical Unified CCX Datastore can be co-located with the Unified CCX.
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In a Unified CCX High Availability server with co-resident Cisco Unified Intelligence Center, Cisco
Unified Intelligence Center will intelligently point to the appropriate datasource. This will require no
manual configuration during failover or in island mode scenario. For more information about Historical
datastore, see Cisco Unified Contact Center Express Serviceability Administration Guide.

Note

Historical Reporting Configuration
The Unified CCX Historical Reporting subsystem provides you with a way to set up and manage the purging
of the Historical Reporting databases.

Setting up Unified CCX for Historical Reporting consists of the following tasks:

1 Database Server Configuration, on page 297

2 Configure Automatic Purging, on page 160

Configure Database Server Limits

To limit the performance impact of historical reporting on a particular Unified CCX server, you can configure
a maximum number of five client/scheduler database connections per server.

To do so, complete the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > Historical Reporting > Database Server
Configuration.
The Database Server Configuration web page opens with the following fields:

DescriptionField

The host name or IP Address of the database server.Server Name

The maximum number of client and scheduler
connections that can access the Historical Reports
Database server.

There is a limit of instances for the reporting client
sessions and the scheduler sessions based on the load
that can be run on each server. The following are the
limits:

• Standalone Setup—1 to 8 instances

• High Availability Setup—1 to 16 instances

Maximum DB Connections for Report Clients
Sessions

Step 2 Enter a value in theMaximum DB Connections for Report Client Sessions field next to a Server Name.
Step 3 Click Update.
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The configuration changes take effect.

View Historical Reports

You can view historical reports through the Unified Intelligence Center.

Procedure

Choose Tools > User Management > Reporting Capability View
The User Configuration web page opens.

Purge of Historical Data
As the Unified CCXEngine runs, it collects information about the status and performance of the Unified CCX
system. Historical information is stored in a database that can then be accessed to provide reports (see the
Cisco Unified Contact Center Express Historical Reporting Guide for more information about Unified CCX
Historical Reports).

When the database approaches its maximum size, some or all of the data in it must be removed. Removing
data from a database is called purging.

When the system purges data, it removes data from the db_cra database. It determines what information to
purge based on the number of months you specify and on the current date. For example, if you instruct the
system to purge data older than 12 months, a purge on January 15 will purge data older than January 15 of
the previous year.

When you purge data, you permanently delete it. If you want to keep data that will be purged, back up
the database.

Note

Unified CCXAdministration provides the following features for purging historical reports from the database:

• Daily comparison of the size of the database to a user-specified maximum size

• User-specified time at which the system purges data

• Automatic purging of the database when it exceeds the user-specified maximum sizes

• Automatic purging of the database based on user-specified parameters

• Manual purging of the database

Not configuring the Purge parameters may make your database to be overloaded with large number of
records. This leads to call data not being written to database.

Caution

Cisco Unified CCX Administration Guide, Release 11.0(1)    
159

Unified CCX Reporting
Unified CCX Historical Reports



Configure Automatic Purging

The Unified CCX Engine performs automatic purging each day at a preset time.

To help keep your system running most efficiently, schedule automatic purging to run when your system is
least busy. By default, daily purges are scheduled to run at 12:00 a.m. (00:00 Hrs), but you can change this
time.

The system bases its purging activities on a variety of parameters. You can change the default value for any
parameter as needed.

The following section contains the procedure for setting the daily purge schedule and auto purge.

Configure Purge Schedule Configuration Parameters
You can change the time of day that the system assesses the need to purge data and the age of data to purge.

When data is purged, the Unified CCX sends a “Database purged” message. This message announces that a
purge has taken place and includes an explanation of the purging activity. If the database is approaching its
maximum size, then the Unified CCX sends the following message - “Database approaching maximum size”.
The system can send notifications through the following two methods:

• Syslog (system log)

• SNMP traps

To set the purge schedule configuration parameters, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > Historical Reporting > Purge Schedule
Configuration.
The Purge Schedule Configuration area opens. The following fields are displayed in the Purge Schedule
Configuration area.

DescriptionField

Purge Schedule

Time of day for the daily purge along with the time
zone. The time that appears here is based on the
primary time zone, which is specified during initial
setup of Unified CCX Administration.

In a High Availability over WAN deployment, the
purge schedule will happen at the time zone of the
primary node.

Unified CCX to Unified Intelligence Center
sync runs as part of the purge. It
synchronizes the users, teams and grants
Live Data report permissions.

Note

Daily purge at

Data can persist for a number of months before being
purged.

Purge data older than

   Cisco Unified CCX Administration Guide, Release 11.0(1)
160

Unified CCX Reporting
Unified CCX Historical Reports



DescriptionField

The total duration for which the purge process should
run.

Purge run time

Auto Purge Configuration

Percentage of the maximum database size at which
an automatic purge is initiated (as compared to the
total available size).

Initiate automatic purge when database exceeds

Percentage of the maximum extents size of any table
above which an automatic purge is initiated.

Initiate automatic purge when extent size exceeds

Age of data to be purged.Auto purge data for the oldest

Step 2 From the drop-down list in the Daily purge at field, choose a time of day at which the system determines if
purging is necessary.

Step 3 From the drop-down list in the Purge data older than field, choose the required number of months.
If the system determines that purging is necessary, it will purge both databases of data that is older than the
number of months specified in this field.

Step 4 From the drop-down list in the Purge run time field, specify the required number of hours.
If the system determines that purging is necessary, it will purge both databases of data within the specified
duration of time.

Step 5 From the drop-down list in the Initiate automatic purge when database size exceeds field, accept the default,
or choose another number.

Step 6 From the drop-down menu in the Auto purge data for the oldest field, accept the default of 15, or choose
another number.

Step 7 From the drop-down list in the initiate automatic purge when extent size exceeds field, accept the default , or
choose another number.

Step 8 Click Update icon that displays in the tool bar in the upper, left corner of the window or the Update button
that displays at the bottom of the window.
The new purge schedule configuration is added to the Unified CCX system.

Purge Manually

You can manually purge the databases at any time. This action will not affect the automatic purging schedule.

Support for High Availability is available only in multiple-server deployments.Note

To manually purge historical data, complete the following steps.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > Historical Reporting > Purge Now.
The Purge Now web page opens. The Purge data older than field is displayed in the Purge Now web page.
You can specify this field in months and days.

Step 2 From the drop-down list in the Purge data older than N months field, keep the default (13 months) or specify
the required number of months.
If the system determines that purging is necessary, it will purge both databases of data that is older than the
number of months specified in this field.

The Initiate automatic purge when database exceeds field displays the current historical database size as
compared to the total available size.

Step 3 From the drop-down list in the Purge data older than N days field, keep the default (15 days) or specify the
required number of days.
If the system determines that purging is necessary, it will purge both databases of data that is older than the
number of days specified in this field.

Step 4 From the drop-down list in the Purge run time, keep the default (7 hours) or specify the required number of
hours.
If the system determines that purging is necessary, it will purge both databases of data within the specified
duration of the time .

Step 5 Click Purge Now.
The database purge is initiated in the server and the Purge Now area refreshes.

File Restore
Use the File Restore menu option to restore the database records written to HR files when the database goes
down.

Unified CCX Real-Time Reports
When the Unified CCX system is configured and functioning, you can run reports to monitor real-time activity
using the Unified CCX Administration web interface.

Youmust be logged into the Unified CCXAdministration web interface to run Unified CCX real-time reports.

The following sections provide more information about real-time Unified CCX data:

Available Unified CCX Real-Time Reports
Unified CCX real-time reporting provides real-time reports you can use to monitor Unified CCX system
activity. The following table briefly describes each of these reports.
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DescriptionReport

Provides information about currently active applications.Application Tasks

Provides a summary of specific application activity.Application Tasks
Summary

Provides a list of all applications loaded on the Unified CCX server.Applications

Provides information for call contacts, email contacts, and HTTP contacts. Also
provides the total number of contacts.

Calls made by the Outbound subsystem will not be displayed in the
Contacts Summary Real-Time Report.

Note

Contacts Summary

Provides information about currently active contacts.Contacts

Provides information about Chat CSQ activity. This report is available only if
Unified CCX has been configured.

Chat CSQ Cisco Unified
Contact Center Express
Stats

Provides information about Chat Unified CCX resources activity.Chat Resource Cisco
Unified Contact Center
Express Stats

Provides information about CSQ activity. This report is available only if Unified
CCX has been configured.

CSQ Cisco Unified
Contact Center Express
Stats

Provides information about configured data source names (DSNs).Data Source Usage

Provides information about currently active Engine tasks.Engine Tasks

Provides information about real-time Unified CCX information for the Outbound
preview dialer.

Preview Outbound
Campaign Cisco Unified
Contact Center Express
Stats

Provides real-time statistics on IVR and agent based progressive and predictive
Outbound campaigns since the statistics were last reset.

This report will be available only if you have an Outbound license on
top of the Unified CCX premium license in your Unified CCX.

Note

Outbound Campaign
Stats

Provides real-time statistics across all IVR and agent based progressive and
predictive Outbound campaigns since the statistics were last reset.

This report will be available only if you have an Outbound license on
top of the Unified CCX premium license in your Unified CCX.

Note

Overall Outbound Stats

Provides information about Chat Unified CCX resources and contact information.
This report is available only if Unified CCX has been configured.

Overall Chat Cisco
Unified Contact Center
Express Stats
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DescriptionReport

Provides information about Unified CCX resources and calls. This report is
available only if Unified CCX has been configured.

Overall Cisco Unified
Contact Center Express
Stats

Provides information about Unified CCX resources activity.Resource Cisco Unified
Contact Center Express
Stats

Provides information on all active sessions.Sessions

Related Topic

Report Menu, on page 168

Open Real-Time Reports
Real-Time reporting is available from the Unified CCX Administration web interface.

Real-Time Reporting requires the Java plug-in. If the Java plug-in is not already installed on the PC on which
you are viewing the reports, the Unified CCX system automatically installs it when you choose Tools > Real
Time Reporting.

If you are using Firefox, you must manually install the correct version of JRE to use real-time reports.Note

The Application Reporting web page is a stand-alone component of the Unified CCXAdministration interface.
It has its own menu bar, which replaces the Unified CCX Administration menu bar.

To open real-time reporting, complete the following steps.

Procedure

Step 1 If you are running Real-Time Reporting for the first time on this system, log into Unified CCXAdministration
as an Administrator.
The system prompts you to download the Java plug-in; follow the prompt instructions.

After you perform the initial download of the Real-Time Reporting Java plug-in, non-Administrative
users can access Real-Time Reporting on this system.

Note

Step 2 Choose Tools > Real-Time Reporting from the Unified CCX Administration menu bar.
The Application Reporting web page opens in a new window. The real-time reporting tool requires a Java
plug-in. If the plug-in is not installed on the machine you are using, the Unified CCX system prompts you to
accept the automatic installation of the plug-in. If you do not accept the installation, you cannot use real-time
reporting.
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Run Reports
Open the real-time reporting tool from the Unified CCX Administration web interface to run reports.

To run a real-time report, complete the following steps.

Procedure

Step 1 From the Application Reporting menu bar, choose Reports.
Step 2 From the Reports menu, choose the report to run.

The report opens in the Application Reporting window.

View Detailed Subreports
You can view more detailed information for selected items in these four reports:

• Application Tasks report

• Contacts report

• Applications report

• Sessions report

To view detailed subreports, complete the following steps.

Procedure

Step 1 Run the Application Tasks, Contacts, Applications, or Sessions report.
Step 2 Click a line in the report for which you want to view more detailed information. For example, click an email

address in the Contacts report.
Step 3 From the Application Reporting menu bar, choose Views and click the subreport that you want to run.

You can also open a subreport by right-clicking the selected item and choosing a subreport.

The subreport opens.

Print Reports
To facilitate printing, you can open a printable version of a report.

To print a report, complete the following steps.
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Procedure

Step 1 Run a report.
Step 2 From the Application Reporting menu, choose Tools > Open Printable Report.

A printable version of the report opens in a separate window.

Step 3 Print the report using your browser print functionality.

Reset Report Statistics
The Unified CCX system automatically resets all statistics each day at midnight. You can reset the accumulated
statistics manually at any time. Resetting statistics does not reset active statistics, such as active contacts and
active tasks.

To reset report statistics, complete the following steps.

Procedure

Step 1 From the Application Reporting menu bar, choose Tools > Reset All Stats.
The Reset Stats dialog box opens for you to confirm the reset.

Step 2 Click Yes.
Accumulated statistics are reset.

Clear Contact Option for Stuck Calls
You may sometimes see a Contact/Call as waiting in Real Time Reports in CSQ Stats, and even though there
are available Agents in the queue, the call does not seem to get routed to these Agents. The waiting time for
the Queued call accumulates and will not clear even if the user activates “Reset All Stats” option from the
Real-Time Reporting menu.

To enable clearing such stuck call entries from the system, Unified CCX system provides the Clear Contact
option. This has the ability to clear stuck calls in the system without requiring a restart of the engine.

Set Report Options
You can set the following reporting options:

• Refresh interval

• Number of times that the Unified CCX Administration web interface should attempt to reconnect to the
Unified CCX server

•Whether logged off users appear in reports
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To set report options, complete the following steps.

Procedure

Step 1 From the Application Reporting menu bar, choose Settings > Options.
The Options dialog box opens.

Step 2 From the Polling Interval drop-down menu, choose the refresh rate in seconds.
Step 3 From the Server Connect Retry Count drop-down menu, choose the number of times that the Unified

CCX Administration web interface should attempt to reconnect to the Unified CCX server.
Step 4 From the Show Logged Off Resources drop-down menu, choose whether logged-off agents appear in reports.
Step 5 Click Apply to apply the settings.

Set Report Appearance
You can select from three report appearances:

•Windows, which displays reports in colors based on your Windows settings

• Motif, which displays reports in purple and menu items in brown

• Metal, which displays reports in grey and menu items in black

To set the report appearance:

Procedure

Choose Settings from the Application Reporting menu bar and click the appearance that you want.

Application Reporting User Interface

Support for High Availability and remote servers is available only in multiple-server deployments.Note

When you chooseTools >Real-TimeReporting from the Unified CCXAdministrationmenu, the Application
Reporting tool opens a web page in a new window.

The Application Reporting tool menu bar contains the following options:

• Report—Choose this option to display a list of the available top-level real-time reports.

• Tools—Choose this option to reset all the statistics and refresh connections.

• Settings—Choose this option to set the look and feel of the real-time Reporting client, set the polling
(refresh) interval times, and set the amount of times the server will attempt to reconnect.

• Help—Choose this option to display system information and to access Unified CCX online help.
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Report Menu

All real-time reports display a Last Updated At field, which indicates the time of the snapshot. All
summary reports display both a start time (which indicates when the summary statistics started being
collected) and the current time. All real-time reports display a Connected or Not Connected status for each
node in the cluster.

Note

The Report menu provides access to a variety of top-level reports. It contains the following menu options:

• Contacts Summary Real-Time Report, on page 169

• Application Tasks Summary, on page 171

• Application Tasks Real-Time Report, on page 171

• Engine Tasks Real-Time Report, on page 172

• Contacts Report, on page 172

• Applications Report, on page 176

• Sessions Report, on page 176

• Data Source Usage Report, on page 177

• Overall Cisco Unified Contact Center Express Stats Report, on page 177

• CSQ Cisco Unified Contact Center Express Stats Report, on page 181

• Preview Outbound Campaign Cisco Unified Contact Center Express Stats Report, on page 182

• Outbound Campaign Stats Report, on page 187

• Overall Outbound Stats Report, on page 189

• Resource Cisco Unified Contact Center Express Stats Report, on page 190

• Failover Behavior for Unified CCX Stats, on page 192

High Availability (HA) Setup
In an HA setup, real-time reports obtain data from both nodes in the cluster.

Note • Support for High Availability and remote servers is available only in multiple-server deployments.

• In case of island mode where each node (on either side of the network) assumes mastership and
handles calls, the real-time reports may not report accurate data.

Failover in a two-node cluster is available for Unified IP IVR reports as described in the following table.

Node 2 StatusNode 1 StatusConnection StatusFailover Scenario

Node ID current/start-timeNode ID current/start-timeFully ConnectedBoth nodes are up
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Node 2 StatusNode 1 StatusConnection StatusFailover Scenario

Node ID Not ConnectedNode ID current/start-timePartially ConnectedNode 1 is up

Node 2 is down

Node ID current/start-timeNode ID Not ConnectedPartially ConnectedNode 1 is down

Node 2 is up

Node ID Not ConnectedNode ID Not ConnectedNot ConnectedBoth nodes are down

Unified CCX real-time reports obtain data only from the current master node—failover in a two-node cluster
is available as described in the following table.

Node 2 StatusNode 1 StatusConnection StatusFailover Scenario

Node ID Not ConnectedNode ID current/start-timeFully ConnectedBoth nodes are up
Node 1 is master

Node ID Not ConnectedNode ID current/start-timeFully ConnectedNode 1 is master

Node 2 is down

Node ID current/start-timeNode ID Not ConnectedFully ConnectedNode 1 is down

Node 2 is master

Node ID Not ConnectedNode ID Not ConnectedNot ConnectedBoth nodes are down

Contacts Summary Real-Time Report
Use the Contacts Summary report to view specific contact information for call contacts, email contacts, HTTP
contacts, and total number of contacts.

To access the Contacts Summary real-time report, chooseReports >Contacts Summary from the Application
Reporting menu bar.

You display the data on this report as numbers or percentages by clicking the Display Value/Display %
toggle button.

Note

The following fields are displayed on the Contacts Summary report.

DescriptionField

Active contacts that are currently running.Active

Number of inbound contacts since the statistics were last reset.Inbound

Number of outbound contacts since the statistics were last reset.Outbound
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DescriptionField

Number of connected contacts since the statistics were last reset.

Provides a total for contacts that are connected to resources (for example, a call connected
to an ACD agent).

Connected

Number of terminated contacts since the statistics were last reset.

This row reports contacts that are ended normally by the application (for example, a
caller hangs up and the application terminates), indicating whether the contact was
terminated:

• Locally—On the local server.

• Remotely—On a remote server in the cluster.

Use the + toggle button to access these
statistics.

Note

Terminated

Number of rejected contacts since the statistics were last reset.

This row reports contacts that are not accepted and processed (as a result, for example,
of insufficient resources or the rejection of the contact based on some customer-defined
logic). Indicates the reason code for the reject:

• Channels busy

• No channel license

• No trigger

Use the + toggle button to access these
statistics.

Note

Rejected

Number of aborted contacts since the statistics were last reset.

This row reports contacts improperly ended by a task associated with the application
(as when, for example, the system generates an exception or can not invoke the
application because of some error in the application) and includes the associated Java
exception code.

Java exception codes are dynamic, as they can be generated from a variety of
sources.

Note

Use the + toggle button to access these
statistics.

Note

Aborted

Number of handled contacts since the statistics were last reset.

This row reports contacts that are explicitly marked “Handled” by the application
(typically when the application connects the contact to a Unified CCX agent).

Handled

Number of abandoned contacts since the statistics were last reset.

This row reports contacts that end without being marked “Handled” by the application.
Abandoned
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Application Tasks Summary
Use the Application Tasks Summary report to display statistics that summarize the activity of specific
applications.

To access the Application Tasks Summary real-time report, choose Reports > Application Tasks Summary
from the Application Reporting menu bar.

The following fields are displayed on the Application Tasks Summary report.

DescriptionField

Names of the applications that are running or have run.Application Name

Currently running applications.Running

Applications that have stopped running.Completed

Number of times an application was invoked since the statistics were last reset.Total

Application names configured from the Unified CCX Administration.DTMF VB and AA

Displays the failover connection status. The possibilities are: Fully connected, Partially
connected, and Not connected. See the following tables for detailed status information
for Unified IP IVR and Unified CCX reports.

Status

Application Tasks Real-Time Report
Use the Application Tasks real-time report to view information about currently active applications.

To access the Application Tasks report, chooseReports >Application Tasks from the Application Reporting
menu bar. The following fields are displayed on the Application Tasks report.

DescriptionField

Unique application task ID.ID

Unique ID for a server in the cluster.Node ID

Name of the application.Application

Time when the application task started.Start Time

Length of time that the application has been active.Duration

If this report indicates that an application is running for an unusually long time, there may be a problem
with the application. The application script may not include error handling that prevents infinite retries if
a call is no longer present. If the application does not receive a disconnect signal after a call, the application
repeatedly retries to locate the call, and causes the application to run for an unusually long time. To prevent
this problem, include the proper error handling in the application script.

Note
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Engine Tasks Real-Time Report
Use the Engine Tasks real-time report to view information about currently active Engine tasks.

To access the Engine Tasks report, choose Reports > Engine Tasks from the Application Reporting menu
bar.

The following fields are displayed on the Engine Tasks report.

DescriptionField

Unique identifier of the engine task.

If the engine task is the main task running the application and the parent ID is empty,
its identifier will match the Application Task Identifier.

ID

Unique identifier for the parent of the engine task (if any).Parent ID

Unique identifier for a server in the cluster.Node ID

IP address identifying the server in the cluster.Server IP Address

Name of the script that is running the task (if the task is running a Unified CCX
script).

Script

Time that the task started.Start Time

Length of time the task has been active.Duration

Contacts Report
Use the Contacts real-time report to view information for all the active contacts for all servers across clusters.

Support for High Availability and remote servers is available only in multiple-server deployments.Note

To access the Contacts report, choose Reports > Contacts from the Application Reporting menu bar.

You can access detailed information about specific contacts listed on the Contacts web page by performing
one of the following procedures:

• Call Contacts Detailed Info Report, on page 173

• Email Detailed Info Report, on page 174

• HTTP Detailed Info Report, on page 174

The following fields are displayed on the Contacts report.

DescriptionField

Unique identifier representing a contact.ID

Type of contact: Unified CM Telephony call, Cisco agent call, orType
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DescriptionField

Unique identifier provided by the particular type of contact. For example, for a call contact,
this identifier would represent the Unified CM global call ID.

Impl ID

Unique identifier for a server in the cluster.Node ID

Time stamp when the contact was created.Start Time

Length of time that the contact is active.Duration

If True, the contact is handled; if False, the contact is not handled.Handled

If True, the contact is aborted with a default treatment; if False, the contact is not aborted.Aborting

Name of the application currently managing the contact.Application

Unique identifier of the application task that is currently responsible for the contact.Task

Unique identifier of the session currently managing the contact (if any).Session

The information displayed is dependent on the type of contact selected. Depending on the type of call,
some fields may not be supported and will appear blank.

Note

Call Contacts Detailed Info Report
Use the Call Contacts Detailed Info real-time report to view all information related to the call contact.

To access the Call Contacts Detailed Info report, right-click a specific call contact record on the Contacts
report; information for that specific record displays.

The following fields are displayed on the Call Contacts Detailed Info report.

DescriptionField

Current state of the contact.State

If True, this call was received by the Unified CCX server; if False, this call
was placed as an outbound call by an application.

Inbound

The selected language context of the call.Language

Unique identifier of the associated application.Application ID

Called number for this call leg from the perspective of the called party.Called Number

Dialed number for this call leg from the perspective of the calling party.Dialed Number

Calling number of the originator of this call.Calling Number
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DescriptionField

Automatic number identification.ANI

Dialed number identification service.DNIS

Caller ID.CLID

Information on how the call contact arrived in the system.Arrival Type

Number from which the last call diversion or transfer was invoked.Last Redirected Number

Originally called number.Original Called Number

Originally dialed number.Original Dialed Number

Automatic Number Identification information indicator digit codes.ANI Digits

Entered digits that were gathered by the network before the call was received.CED

Email Detailed Info Report
Use the Email Detailed Info real-time report to view all information related to the email contact.

To access the Email Detailed Info report, right-click a specific email contact record on the Contacts report;
information for that specific record displays.

The following fields are displayed on the Email Detailed Info report.

DescriptionField

Current state of the contact.State

If True, this email message was received by the Unified CCX server; if False, this
email was created by an application.

Inbound email messages are not currently
supported.

Note

Inbound

Selected language context of the email message.Language

Unique identifier of the associated application.Application ID

Sender of this email message.From

All the recipients of this email message.To

“Subject” field of this email message.Subject

List of all attachments (file names) associated with this email message.Attachments

HTTP Detailed Info Report
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Use the HTTP Detailed Info real-time report to view all information related to the HTTP contact.

To access the HTTP Detailed Info report, right-click a specific HTTP contact record in the Contacts report;
information for that specific record displays.

The following fields are displayed on the HTTP Detailed Info report.

DescriptionField

Current state of the contact.State

If True, this HTTP request was received by the Unified CCX server; if False, this
HTTP request was created by an application.

This information will always be reported as True, because the Unified
CCX server does not currently track outbound HTTP requests in this way.

Note

Inbound

Language currently associated with the HTTP request.Language

Unique identifier of the associated application.Application ID

Name of the authentication scheme used to protect the servlet; for example,
“BASIC” or “SSL.”

Authentication Type

Length, in bytes, of the request body, which is made available by the input stream,
or -1 if the length is not known.

This length is the same as the value of the CGI2 variable
CONTENT_LENGTH.

Note

Character Encoding

MIME type of the body of the request, or null if the type is not known.

This is the same as the value of the CGI variable CONTENT_TYPE.Note

Content Length

Type of HTTP contact request.Content Type

Preferred language for client content (the language that the client accepts for its
content), based on the Accept-Language header.

Request Language

Any extra path information associated with the URL the client sent when the HTTP
request was made.

Path Info

Name and version of the protocol the request uses in the form:
protocol/majorVersion.minorVersion; for example, HTTP/1.1

This value is the same as the value of the CGI variable
SERVER_PROTOCOL.

Note

Protocol

IP address of the client that sent the request

This value is the same as the value of the CGI variable REMOTE_ADDR.Note

Remote Address

Fully qualified name of the client that sent the request, or the IP address of the
client, if the name cannot be determined

This value is the same as the value of the CGI variable REMOTE_HOST.Note

Remote Host
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DescriptionField

Login of the user making this request, if the user has been authenticated.Remote User

HTTP session ID as specified by the client.Requested Session ID

Section of the URL of the HTTP request, from the protocol name up to the query
string in the first line of the HTTP request.

Request URL

2 CGI = Common Gateway Interface

Applications Report
Use the Applications real-time report to view all the applications loaded on the server.

To access the Applications report, chooseReports >Applications from the Application Reporting menu bar.

The following fields are displayed on the Applications report.

DescriptionField

Unique name of the currently loaded application.Name

Application ID.ID

Type of application that is currently running (for example, a Cisco Script Application).Type

Description of the application as entered on the Unified CCX Administration web site.Description

If True, the application is enabled; if False, the application is disabled.Enabled

Maximum number of simultaneous task instances that can run simultaneously on the
Unified CCX server.

Max. Sessions

If True, the application is valid; if False, the application is invalid.3Valid

3 An application is valid if it was successfully loaded and initialized from its configuration. At any time, an application can become invalid if it internally fails
to be refreshed.

Sessions Report
Use the Sessions real-time report to view real-time information on all the active sessions.

To access the Sessions report, choose Reports > Sessions from the Application Reporting menu bar.

The following fields are displayed on the Sessions report.

DescriptionField

Session ID.

This identifier is guaranteed to remain unique for a period of 12months.Note

ID

User- or system-defined identifier that maps to this session.Mapping ID
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DescriptionField

Unique identifier for a server in the cluster.Node ID

Sessions that were created as a result of consult calls propagated in the system.Parent

Creation time of the session.Creation Time

Current state of the session.

When marked IDLE, the session is subject to being “garbage collected” by the
system after a specified period of time. In addition, a session is IN_USE if it
still has a contact associated or a child session.

Note

State

Length of time that the session has been idle.Idle Time

Data Source Usage Report
Use the Data Source Usage real-time report to view real-time information on all configured Data Source
Names (DSNs).

To access the Data Source Usage report, chooseReports >Datasource Usage from the Application Reporting
menu bar.

The following fields are displayed on the Data Source Usage report.

DescriptionField

Name of the data source, as configured through the Unified CCXAdministration
web interface.

Data Source Name

Number of connections available.Available Connections

Number of busy connections.

Busy + available = Maximum number of connections
configured.

Note

Busy Connections

Number of times the database connections have been used up since the statistics
were last reset.

Checkouts Granted

Number of times the Database connections have been denied since the statistics
were last reset.

Checkouts Denied

Overall Cisco Unified Contact Center Express Stats Report
Use the Overall Cisco Unified Contact Center Express Stats real-time report to view real-time Unified CCX
resource and call information.
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Unified CCX reports contain information for calls that have been queued in one or more CSQs. If a call
is not queued (for example, the caller hangs up before being queued), the reports do not display data for
that call.

Note

Unified CCX reports retrieve the following statistics:

• Unified CCX statistics from the current Master node.

• Unified IP IVR statistics from all nodes in the cluster.

To access the Overall Unified CCX Stats report, choose Reports > Overall Cisco Unified Contact Center
Express Stats from the Application Reporting menu bar.

Preview Outbound durations are updated when the preview outbound call disconnects and all agents
(resources) involved in the call move out of the Work and Talking state.

Note

The following fields are displayed on the Overall Cisco Unified Contact Center Express Stats report.

DescriptionField

Resource Information

Number of CSQs currently configured. If a CSQ is added or removed, this statistic
reflects that change.

CSQs

Number of resources currently logged in.Logged-in Resources

Number of resources currently talking.

This number includes resources in Talking, Work, and Reserved
states.

Note

Talking Resources

Number of resources currently ready.Ready Resources

Number of resources currently not ready.Not Ready Resources

Call Information— Inbound

Number of total contacts that have arrived since the statistics were last reset. This
includes contacts that are waiting, contacts connected to a resource, and contacts
that have disconnected.

If a resource transfers to or conferences with a route point, this value increases.

Total Contacts

Number of contacts waiting to be connected to a resource.

A contact is shown as waiting until the call is answered by the agent.
This means that, even if the phone is ringing at the agent, the contact will
still show as waiting in RTR.

Note

Contacts Waiting

Displays the wait time for the oldest contact in the queue.Oldest Contact in Queue
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DescriptionField

Number of contacts that have been handled by a resource.Contacts Handled

Number of contacts that have arrived and disconnected before being connected
to a resource.

Contacts Abandoned

Average duration (in seconds) that resources spend talking on Unified CCX
contacts. Talk duration starts when a contact first connects to a resource and ends
when the contact disconnects from the last resource to which it was connected.

Talk duration does not include hold time.

Avg Talk Duration

Average wait time (in seconds). It begins when the contact enters the system and
ends when the contact stops waiting. Wait duration does not include hold time.
The time a contact spends on a CTI port prior to getting queued is included in this
report.

Avg Wait Duration

Longest talk duration (in seconds) of a contact. Talk duration does not include
hold time.

Longest Talk Duration

Longest wait (in seconds) for a contact to be connected to a resource.Wait duration
does not include hold time.

Longest Wait Duration

Call Information— Preview Outbound

Total number of preview outbound calls currently previewed or connected to
agents.

Active

Total number of preview outbound calls currently previewed but have not been
accepted, rejected. or closed by the agents.

Preview

Total number of preview outbound calls currently connected to agents. When an
agent conferences in other agents, the call is counted once towards the total number
of connected calls.

Connected

Total number of preview outbound calls offered. A call is considered offered
when it is presented to an agent. A contact that is presented to an agent,
skipped/rejected by that agent, and then presented to the same agent or to another
agent is counted twice towards the number of calls offered. Offered = Accepted
+ Rejected + Closed + Timed-out.

Offered

Total number of preview outbound calls accepted. A call is considered accepted
if an agent has clicked Accept when presented the call. A call that is presented to
an agent, skipped/rejected by that agent, presented to another agent, and then
accepted by that other agent is counted once towards the number of calls accepted.

Accepted
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DescriptionField

The number of preview outbound calls that were skipped or rejected by an agent.
This means that the agent selected Reject, Skip, or Cancel Reservation. These
contacts will be dialed again. If a contact is rejected by multiple agents, this field
increments each time the contact is rejected.

The number Rejected is also incremented each time an agent drops the preview
call while it is ringing at the customer’s contact.

Rejected

The number of preview outbound contacts that were closed by agents. This means
that the agent selected Skip-Close or Reject-close. These contacts will not be
dialed again.

Closed

Total number of preview outbound calls that timed out. A call is considered timed
out when it is presented to an agent and not accepted, rejected, or closed within
the allocated time. These contacts will be dialed again. If a contact timed out
multiple agents, this field is incremented each time the contact is timed out for
each agent.

Timed-Out

The number of preview outbound calls that were dialed to an invalid number.
This means that the agent accepted the call (by clicking Accept), got connected
to the customer, and selected the Invalid Number option from the contact
Reclassification drop down. It also includes the number of preview outbound calls
that failed at the network level.

The agent can manually reclassify the contact as Invalid Number while
the customer contact is on the call or when the agent has gone into the
Work state after the call.

Note

Invalid Number

The number of preview outbound calls that ended in successful customer contact.
This means that an agent accepted the call (by clicking Accept) and selected a
classification of Voice (default) or Do Not Call for this contact.

Voice

The number of preview outbound calls that connected to an answering machine
for this campaign. This means that the agent accepted the call (by clicking Accept),
got connected to the answering machine and selected the Answering Machine
option from the contact Reclassification drop down.

The agent can manually reclassify the contact as Answering Machine
while the customer contact is on the call or when the agent has gone into
the Work state after the call.

Note

Answering Machine

The number of contacts marked for callback. This means that the agent accepted
the call (by clicking Accept), got connected to the contact, the contact requested
a callback, and the agent selected the CallBack option. A call that is accepted by
an agent, marked for callback, later presented to and accepted by another agent
(at the callback time), and marked for callback again is counted twice towards
the number of callback calls.

Requested Callback
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DescriptionField

The average time in HH:MM:SS (hours, minutes, seconds) that agents spend
talking on outbound calls. The durations consider all calls that were Agent
Accepted and classified as Voice. If a preview outbound call is transferred or
conferenced to a route point, this average outbound talk duration does not include
the talk time of agents who handle the call after it came through the route point.
Instead, the talk time is included in the inbound talk duration.

Avg Outbound Talk
Duration

The longest talk duration of a preview outbound call in HH:MM:SS (hours,
minutes, seconds). The durations consider all calls that were Agent Accepted and
classified as Voice.

Longest Outbound Talk
Duration

CSQ Cisco Unified Contact Center Express Stats Report
Use the CSQ Cisco Unified Contact Center Express Stats real-time report to view real-time information.

Unified CCX reports contain information for calls that have been queued in one or more CSQs. If a call
is not queued, the reports do not display data for that call. .

Note

To access the CSQ Cisco Unified Contact Center Express Stats report, chooseReports >CSQCisco Unified
Contact Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the CSQ Cisco Unified Contact Center Express Stats report.

DescriptionField

Name of the CSQ.Name

Number of resources who are in the talking, ready, and not ready states, and the
number of resources logged in for this CSQ. Values for the four items are separated
by colons. Values are displayed in the same order that the items appear in the
column heading.

This number includes resources in Talking, Work, and Reserved states.
If you are logged into the Unified CCX Administration web interface as
a Supervisor and opening the Real-Time Reporting plug-in, you will be
able see all the logged in agents from all the teams independent of team
membership.

Note

Talking/Ready
Resources/Not Ready
Resources/Logged-In
Resources

Number of total contacts since the statistics were last reset for this CSQ.Total Contacts

Number of contacts waiting to be connected to a resource in this CSQ.

This column also displays how long the oldest contact has been waiting.

Contacts Waiting

Duration of longest currently waiting contact.Contacts [oldest contact
in queue]

Number of contacts that have been handled by this CSQ.Contacts Handled

Number of contacts that have been abandoned by this CSQ.Contacts Abandoned
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DescriptionField

Number of contacts that have been dequeued from this CSQ.Contacts Dequeued

Average time (in seconds) agents in this CSQ spent talking to contacts.Avg Talk Duration

Average wait time (in seconds). It begins when the call was queued (when you
execute the “Select Resource” step) and ends when the call reaches the agent.
Wait duration does not include hold time.The time a contact spends on a CTI port
prior to getting queued is not included in this wait time.

Avg Wait Duration

Longest time (in seconds) agents in this CSQ spend talking to contacts.Longest Talk Duration

Longest wait (in seconds) for a contact to be connected to a resource.Longest Wait Duration

Preview Outbound Campaign Cisco Unified Contact Center Express Stats Report
Use the Preview Outbound Campaign Cisco Unified Contact Center Express Stats real-time report to view
real-time Unified Contact CCX information for the Outbound preview dialer.

To access the PreviewOutbound Campaign Cisco Unified Contact Center Express Stats report, chooseReports
> Preview Outbound Campaign Cisco Unified Contact Center Express Stats from the Application
Reporting menu bar.

The following fields are displayed on the PreviewOutbound Campaign Cisco Unified Contact Center Express
Stats report.

DescriptionField

The name of the preview outbound campaign.Campaign

The current activation state of the preview outbound campaign:

• Running: an active preview outbound campaign

• Stopped: an inactive preview outbound campaign

Status

Total number of outbound calls currently previewed by or connected to agents for this preview
outbound campaign. Active Calls = Previewed + Connected.

Active

Total number of outbound calls currently previewed but have not been accepted, rejected or
closed by the agents as part of this preview outbound campaign.

Preview

Total number of outbound calls currently connected to agents for this preview outbound
campaign. When an agent conferences in other agents, the call is counted once towards the
total number of connected calls.

Connected

Total number of outbound calls offered for this preview outbound campaign. A call is
considered offered when it is presented to an agent as part of this preview outbound campaign.
A contact that is presented to an agent, rejected by that agent, and then presented to the same
agent or to another agent is counted twice towards the number of calls offered. Offered =
Accepted + Rejected + Closed + Timed-out.

Offered
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DescriptionField

Total number of outbound calls accepted for this preview outbound campaign. A call is
considered accepted if an agent has clicked Accept when presented the call. A call that is
presented to an agent, rejected by that agent, presented to another agent, and then accepted
by that other agent is counted once towards the number of calls accepted.

Accepted

The number of outbound calls that were rejected by an agent as part of this preview outbound
campaign. This means that the agent selected Reject or Cancel Reservation. These contacts
will be dialed again. If a contact is rejected by multiple agents, this field increments each
time the contact is rejected.

The number Rejected is also incremented each time an agent drops the preview call while it
is ringing at the customer contact.

Rejected

The number of outbound contacts that were closed by agents as part of this preview outbound
campaign. This means that the agent selected Reject-close. These contacts will not be dialed
again.

Closed

Total number of outbound calls that timed out. A call is considered timed out when it is
presented to an agent and not accepted, rejected, or closed within the allocated time. These
contacts will be dialed again. If a contact times out for multiple agents, this field is
incremented each time the contact is timed out for each agent.

Timed-Out

The number of outbound calls that were dialed to an invalid number for this preview outbound
campaign. This means that the agent accepted the call (by clicking Accept), got connected
to the customer, and selected the “Invalid Number” option from the contact Reclassification
drop down. It also includes the number of outbound calls that failed at the network level.

The agent can manually reclassify the contact as Invalid Number while the customer
contact is on the call or when the agent has gone into the Work state after the call.

Note

Invalid
Number

The number of outbound calls that ended in successful customer contact. This means that
an agent accepted the call (by clicking Accept) and selected a classification of Voice or Do
Not Call for this contact.

Voice

The number of outbound calls that connected to an answering machine for this preview
outbound campaign. This means that the agent accepted the call (by clicking Accept), got
connected to the answering machine and selected the Answering Machine option from the
contact Reclassification drop down.

The agent can manually reclassify the contact as Answering Machine while the
customer contact is on the call or when the agent has gone into the Work state after
the call.

Note

Answering
Machine

The number of contacts marked for callback for this preview outbound campaign. This means
that the agent accepted the call (by clicking Accept), got connected to the contact, the contact
requested a callback, and the agent selected the CallBack option. A call that is accepted by
an agent, marked for callback, later presented to and accepted by another agent (at the callback
time), and marked for callback again is counted twice towards the number of callback calls.

Requested
Callback
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DescriptionField

The average time in HH:MM:SS (hours, minutes, seconds) that agents spend talking on
outbound calls for this preview outbound campaign. The durations consider all calls that
were Agent Accepted and classified as Voice. If a call is transferred or conferenced back to
the route point, the preview outbound campaign talk duration does not handle the talk time
of agents who handle the call after it came through the route point.

Avg Talk
Duration

The longest talk duration of an outbound call in HH:MM:SS (hours, minutes, seconds) for
this preview outbound campaign. The durations consider all calls that were Agent Accepted
and classified as Voice.

Longest Talk
Duration

Chat CSQ Cisco Unified Contact Center Express Stats Report
Use the Chat CSQ Cisco Unified Contact Center Express Stats real-time report to view real-time queue
information. This report is available in Cisco Unified CCX Premium license package.

Unified CCX reports contain information for a chat contact that are queued with a specific CSQ. If a
contact is not queued, the reports do not display data for that chat contact.

Note

To access the Chat CSQ Cisco Unified Contact Center Express Stats report, choose Reports > Chat CSQ
Cisco Unified Contact Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the Chat CSQ Cisco Unified Contact Center Express Stats report.

DescriptionField

Name of the chat CSQName

Number of resources who are in the Busy, Ready, and Not Ready states, and the number
of agents logged in for this chat CSQ. Values for the four items are separated by colons.
Values are displayed in the same order that the items appear in the column heading.

If you are logged in to the Unified CCX Administration web interface as a
supervisor and you open the Real-Time Reporting plug-in, you can see all the
logged-in agents from all the teams.

Note

Busy Resources/
Ready Resources/
Not Ready
Resources/
Logged-In
Resources

Number of total contacts presented to this queue since last reset of statistics.Total Contacts

Number of contacts waiting in this queue with the duration of longest waiting contact
in this queue.

Contacts Waiting
[Oldest Contact in
Queue]

Number of contacts that have been handled by this queue since last reset of statistics.Contacts Handled

Number of contacts that have been abandoned in this queue since last reset of statistics.Contacts
Abandoned

Average time (in HH:MM:SS) agents in this CSQ spent chatting with contacts.Avg Contact
Handling Duration
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DescriptionField

Average wait time (in HH:MM:SS) a contact spent in queue waiting for an agent.Avg Wait Duration

Longest time (in HH:MM:SS) agents in this CSQ spent chatting with contacts.Longest Contact
Handling Duration

Longest wait (in HH:MM:SS) for a contact to be connected to an agent.Longest Wait
Duration

Chat Resource Cisco Unified Contact Center Express Stats Report
Use the Chat Resource Cisco Unified Contact Center Express Stats real-time report to view real-time Unified
CCX chat resource information. This report is available in Cisco Unified CCX Premium license package.

To access the Chat Resource Cisco Unified Contact Center Express Stats report, choose Reports > Chat
Resource Cisco Unified Contact Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the Chat Resource Cisco Unified Contact Center Express Stats report:

DescriptionField

Unique identifier of the resource.Name (ID)

Current state of the resource.State

Number of active contacts that the agent is handling.Current Active
Contacts

Length of time (in HH:MM:SS) the resource has remained in the current state.Duration in State

Average time the agent spent with contacts. The resource busy duration is the elapsed
time between the resource accepting the contact and completing the chat by clicking
End.

AvgResource Busy
Duration

Longest time the agent spent with a contact. The resource busy duration is the elapsed
time between the resource accepting the contact and completing the chat by clicking
End.

Longest Resource
Busy Duration

Number of contacts that have been presented to this resource.Contacts Presented

Number of contacts that have been handled by this resource.Contacts Handled

Overall Chat Cisco Unified Contact Center Express Stats Report
Use the Overall Chat Cisco Unified Contact Center Express Stats real-time report to view real-time Unified
CCX resource and contact information. This report is available in Cisco Unified CCX Premium license
package.
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Unified CCX reports contain information for contacts that have been queued in one or more CSQs. If a
contact is not queued, the reports do not display data for that contact.

Note

To access the Overall Chat Unified CCX Stats report, chooseReports > Overall Chat Cisco Unified Contact
Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the Overall Chat Cisco Unified Contact Center Express Stats report.

DescriptionField

Resource Information

Number of chat CSQs currently configured. If a chat CSQ is added or removed, this
statistic reflects that change.

CSQs

Number of resources currently logged in.Logged-in
Resources

Number of resources currently busy.Busy Resources

Number of resources currently ready.Ready Resources

Number of resources currently not ready.Not Ready
Resources

Contact Information

Number of total contacts that have arrived since the statistics were last reset. This
includes contacts that are waiting, contacts connected to a resource, and contacts that
have disconnected.

Total Contacts

Number of contacts waiting to be connected to a resource.

A contact is shown as waiting until the contact is answered by the
agent.

Note

Contacts Waiting

Displays the wait time for the oldest contact in the queue.Oldest Contact in
Queue

Number of contacts that have been handled by a resource.Contacts Handled

Number of contacts that have arrived and disconnected before being connected to a
resource.

Contacts
Abandoned

Average duration (in HH:MM:SS) that resources spent chatting on Unified CCX
contacts. Chat duration starts when a contact first connects to a resource and ends when
the contact disconnects from the resource to which it was connected.

Avg Contact
Handling Duration

Average wait time (in HH:MM:SS). It begins when the contact enters the system and
ends when either the contact is connected with an agent or if contact was disconnected.

Avg Wait Duration
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DescriptionField

Longest contact handling duration (in HH:MM:SS) of a contact.Longest Contact
Handling Duration

Longest wait (in HH:MM:SS) for a contact to be connected to a resource.Longest Wait
Duration

Outbound Campaign Stats Report
If you have an Outbound license, use the Outbound Campaign Stats report to view real-time statistics on each
IVR-based and agent-based progressive and predictive Outbound campaign configured in Unified CCX. This
report will be available only if you have an Outbound license on top of Unified CCX premium license in your
Unified CCX.

To access the Outbound Campaign Stats report, choose Reports > Outbound Campaign Stats from the
Application Reporting menu bar. The following fields are displayed on the Outbound Campaign Stats report.

The call related fields display the data from the time the statistics were last reset.Note

DescriptionField

The name of the IVR-based or agent-based progressive or predictive campaign.Campaign
Name

The current activation state of the campaign:

• Running: an active IVR-based or agent-based progressive or predictive campaign.

• Stopped: an inactive IVR-based or agent-based progressive or predictive campaign.

Status

The dialer type of the campaign, which can be one of the following:

• IVR Progressive

• IVR Predictive

• Agent Progressive

• Agent Predictive

Campaign Type

The total number of attempted calls.

If there are no customer abandoned calls, then Attempted will be equal to sum of the
following counters:

Voice + Answering Machine + Invalid Number + Fax/Modem + No Answer + Busy +
Failed.

Attempted
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DescriptionField

The total number of calls that are connected to live voice.

The call will be marked as System Abandoned after it has been marked as Voice
and Active due to any of the following reasons:

Note

•Whenever there is an exception while executing some steps in an IVR script
in case of IVR-based campaigns. For example, if there is any codecmismatch
issue, there will be an exception in the Accept Step. In such cases, the same
call will be marked in the following three categories voice, active, and system
abandoned.

•Whenever the call that is ringing on the agent's phone fails in case of
agent-based campaigns.

Voice

The total number of calls that reached an answering machine.Answering
Machine

The total number of calls that reached an invalid number:

• A failed call when the gateway returns an invalid or not found error.

Invalid Number

The total number of calls that reached fax or modem.Fax/Modem

The total number of calls that were not answered within the time configured for the No
Answer Ring Limit field in the Add New Campaign web page.

No Answer

The total number of calls that reached a busy destination.Busy

The total number of calls that failed due to any one of the following reasons:

• Dialer asked the Gateway to cancel a call that was dialed out, but not connected.

• Gateway has declined the call.

• Gateway failure or configuration issues at the Gateway.

• Gateway is down.

Failed

The total number of calls that were connected to IVR ports or agents.

All the voice calls that will be connected to Outbound IVR ports or agents will be marked
as active. If you have selected AnsweringMachine Treatment or Abandoned Call Treatment
as "Transfer to IVR," the answering machine calls and abandoned calls that are getting
transferred to Outbound IVR ports will also be marked as active.

Active

The total number of calls that were disconnected by the customer or agent within the
Abandoned Call Wait Time configured in Add New Campaign web page.

Customer
Abandoned

The total number of calls that were abandoned due to any of the following reasons:

• Non-availability of ports or agents.

• Any issues at system level.

System
Abandoned
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DescriptionField

Abandon Rate = (System Abandoned/Voice)*100Abandon Rate
(in %)

Note • If you have selected AnsweringMachine Treatment as "End Call" for an IVR or agent based outbound
campaign through Campaign Configuration web page, then Voice = Active + System Abandoned.

• If you have selected Answering Machine Treatment or Abandoned Call Treatment as "Transfer to
IVR" for an IVR or agent based outbound campaign through Campaign Configuration web page,
then Voice + Answering Machine = Active + System Abandoned.

Overall Outbound Stats Report
If you have an Outbound license, you can use the Overall Outbound Stats report to view real-time statistics
across all IVR-based and agent-based progressive and predictive campaigns since the statistics were last reset.
This report will be available only if you have an Outbound license on top of Unified CCX premium license
in your Unified CCX.

To access the Overall Outbound Stats report, chooseReports >Overall Outbound Stats from the Application
Reporting menu bar. The following fields are displayed on the Overall Outbound Stats report for all the
configured IVR-based and agent-based Outbound campaigns.

The call related fields display the data from the time the statistics were last reset.Note

DescriptionField

The total number of attempted Outbound calls.Attempted

The total number of Outbound calls that were connected to live voice.Voice

The total number of Outbound calls that reached answering machine.Answering
Machine

The total number of Outbound calls that reached an invalid number.Invalid Number

The total number of Outbound calls that reached fax or modem.Fax/Modem

The total number of Outbound calls that were not answered.No Answer

The total number of Outbound calls that reached a busy destination.Busy

The total number of failed Outbound calls for all IVR and agent based Outbound campaigns.Failed

The total number of Outbound calls that were connected to Outbound IVR ports or agents.Active
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DescriptionField

The total number of Outbound calls that were abandoned by the customer or disconnected
by the agent.

Customer
Abandoned

The total number of Outbound calls that were abandoned by the system.System
Abandoned

Resource Cisco Unified Contact Center Express Stats Report
Use the Resource Cisco Unified Contact Center Express Stats real-time report to view real-time Unified
Contact CCX agent information.

To access the Resource Cisco Unified Contact Center Express Stats report, chooseReports >Resource Cisco
Unified Contact Center Express Stats from the Application Reporting menu bar.

If multiple lines are configured for an agent, only the calls on the agent's primary extension are reported
in Resource Cisco Unified Contact Center Express Stats report.

Note

The following fields are displayed on the Resource Cisco Unified Contact Center Express Stats report.

DescriptionField

Unique identifier of the agent.Name (ID)

Current state of the agent.State

Amount of time (in seconds) the agent has remained in the current state.Duration in State

Number of contacts presented to the agent.Contacts Presented

Number of contacts handled by the agent.Contacts Handled

Average time (in seconds) the agent spent in talking state.Avg Talk Duration

Average time (in seconds) the agent keeps calls on hold.Avg Hold Duration

Longest time (in seconds) the agent spent in talking state.Longest Talk Duration

Longest time (in seconds) the agent keeps a call on hold.Longest Hold Duration

Total number of preview outbound calls offered to the agent. A call is considered
offered when it is presented to an agent. The number of calls offered is counted
twice if a contact that is presented to an agent is skipped/rejected by that agent
and then the contact is presented to the same agent or to another agent. Offered
= Accepted + Rejected + Closed + Timed-out.

Outbound Offered
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DescriptionField

Total number of outbound calls accepted by the agent. For transferred or
conferenced outbound calls, the call is considered accepted if it is answered by
the agent.

A preview outbound call is considered accepted if an agent has clicked Accept to
accept the call and then the system places the call to the customer. The number
of calls accepted is counted once if a call that is presented to an agent is
skipped/rejected by that agent and then the call is presented to another agent who
accepts the call.

A progressive or predictive outbound call is considered accepted if an agent has
answered a live voice call that is presented to the agent (if Agent AutoAnswer is
disabled).

Outbound Accepted

The number of preview outbound calls skipped/rejected by the agent. This means
that the agent selected Reject, Skip, or Cancel Reservation. These contacts will
be dialed again.

The number of calls rejected is also incremented each time an agent drops the
preview call while it is ringing at the customer’s contact.

Outbound Rejected

The number of contacts closed by the agent for preview outbound. This means
that the agent selected Skip-Close or Reject-close. These contacts will not be
dialed again.

Outbound Closed

Total number of preview outbound calls that timed out. A call is considered timed
out when the call is presented to an agent but not accepted, rejected, or closed
within the allocated time. These contacts will be dialed again. If a contact timed
out for multiple agents, this field is incremented each time the contact is timed
out for each agent.

Outbound Timed-Out

The number of preview outbound calls that ended in successful customer contact
for the agent. This means that the agent accepted the call (by clicking Accept)
and selected a classification of Voice or Do Not Call for this contact.

Outbound Voice

The average time in HH:MM:SS (hours, minutes, seconds) that the agent spends
in talking state for outbound calls. This talk duration also includes the time spent
on outbound calls that were transferred or conferenced to a route point.

For preview outbound, the talk duration considers all calls that were Agent
Accepted and classified as Voice.

Outbound Avg Talk
Duration

The average time in HH:MM:SS (hours, minutes, seconds) that the agent spent
in holding an outbound call.

For preview outbound, the hold duration considers all calls that were Agent
Accepted and classified as Voice.

Outbound Avg Hold
Duration
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DescriptionField

The longest time in HH:MM:SS (hours, minutes, seconds) that the agent spent in
talking state for an outbound call .

For preview outbound, the talk duration considers all calls that were Agent
Accepted and classified as Voice.

Outbound Longest Talk
Duration

The longest time in HH:MM:SS (hours, minutes, seconds) that the agent spent in
holding an outbound call.

For preview outbound, the hold duration considers all calls that were Agent
Accepted and classified as Voice.

Outbound Longest Hold
Duration

Failover Behavior for Unified CCX Stats
All failovers, regardless of whether the Unified CCX Engine is restarted, will cause the Unified CCX stats to
reset.

The Unified IP IVR stats do not reset in all cases if the Unified CCX Engine is not restarted on a node.
However, the node loses its active server status. The Unified IP IVR stats on that node will not be reset.

Tools Menu

The Tools menu gives you access to the following Application Reporting tools:

• Reset All Stats—Choose this option to reset all statistics.

• Open Printable Report—Choose this option to get a printable report of all currently active contacts in
the system.

• Refresh Connections—Choose this option to refresh connections with the Unified CCX system.

• Clear Contact—Choose this option to clear contacts/calls that have been stuck in the system for a long
time.

Reset All Statistics
Use the Reset All Stats option to reset all statistics accumulated since the last time the statistics were reset. It
will not reset active statistics, such as active contacts, tasks, and so on.

The Unified CCX system automatically resets all statistics each day at midnight.Note

Procedure

Choose Tools > Reset All Statistics from the Application Reporting menu bar.

Open Printable Report
Use the option to get a printable report of all currently active contacts in the system.

To get a printable report:
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Procedure

Choose a real-time report from the Report menu option and then Tools > Open Printable Report from the
Application Reporting menu bar.

Refresh Connections
To refresh connections with the Unified CCX system:

Procedure

Choose Tools > Refresh Connections from the Application Reporting menu bar.
The Unified CCX system refreshes all connections.

Clear Contact Menu
You can use the Clear Contact menu option to clear contacts in the following three situations:

Clear Stuck Calls from Sontacts Real-Time Report
To clear stuck calls or contacts from the Unified CCX system:

Procedure

Step 1 Choose the contact from Reports > Contacts.
Step 2 From the Application Reportingmenu bar, chooseTools >Clear Contact. A Clear Call dialog box is displayed

to warn you. If you want to continue with the clear action, click No. To cancel the action, click Yes.
Step 3 Click No to proceed with the clear action. A Clear Contact dialog box is displayed for you to confirm the

action. You can click Yes to proceed or No to cancel.
Step 4 Click Yes. The Unified CCX system removes the contact from all its queues.

Clear Stuck Calls from Overall Cisco Unified CCX Stats
To clear stuck calls/contacts from the Unified CCX system:

Procedure

Step 1 Choose Reports > Overall Cisco Unified Contact Center Express Stats.
Step 2 Choose the contact from Views and click Overall Waiting Contacts Info.

Please note that the Overall Waiting Contacts Info menu option displays only those calls that are
queued in CSQs and not agent-based routing calls.

Note

Step 3 From the Application Reporting menu bar, choose Tools and click Clear Contact. A Clear Call dialog box
is displayed to warn you. If you want to continue with the clear action, click No. To cancel the action, click
Yes.

Step 4 Click No to proceed with the clear action. A Clear Contact dialog box is displayed for you to confirm the
action. You can click Yes to proceed or No to cancel.

Step 5 Click Yes. The Unified CCX system removes the contact from all its queues.
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Clear Stuck Calls from CSQ Cisco Unified CCX Stats
To clear stuck calls or contacts from the Unified CCX system:

Procedure

Step 1 Choose Reports > CSQ Cisco Unified Contact Center Express Stats.
Step 2 Choose the contact from Views and click CSQWaiting Contacts Info.
Step 3 From the Application Reportingmenu bar, chooseTools >Clear Contact. A Clear Call dialog box is displayed

to warn you. If you want to continue with the clear action, click No. To cancel the action, click Yes.
Step 4 Click No to proceed with the clear action. A Clear Contact dialog box is displayed for you to confirm the

action. You can click Yes to proceed or No to cancel.
Step 5 Click Yes. The Unified CCX system removes the contact from all its queues.

Views Menu

The Views menu allows you to access more detailed information for the following reports: The Application
Tasks report, the Contacts report, the Applications report, the Sessions report, Overall Cisco Unified Contact
Center Express Stats report, and the CSQ Cisco Unified Contact Center Express Stats report.

For some reports, detailed information is also available by right-clicking a record in that report.Note

The Views menu contains different options, depending on the report you have chosen. Possible options are:

• Contacts by Application Task ID—Choose this option to view contacts according to Application Task
ID numbers.

• Engine Tasks by Application Task ID—Choose this option to view Engine tasks according to
Application Task ID numbers.

• Detailed Info—Choose this option to view more detailed information on selected reports.

• Application Tasks by Application Name—Choose this option to view application tasks by application
name.

• Contacts by Session ID—Choose this option to view contacts by session ID.

• OverallWaiting Contacts Info—Choose this option to view detailed information for the overall waiting
contacts. To clear stuck calls in this view, see Scenario 2 in Clear contact menu option.

• CSQWaiting Contacts Info—Choose this option to view detailed information for the CSQ waiting
contacts. To clear stuck calls in this view, see Scenario 3 in Clear contact menu option.

Application Tasks
You can obtain reports based on the application task ID associated with application tasks.

Contacts by Application Task ID
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This report displays the same report as the Contact report with the exception that the Contacts by Application
Task ID report has been filtered using only the contact currently being managed by the selected application
task.

Engine Tasks by Application Task ID
This report displays the same report as the Engine Task reports except that the Engine Tasks by Application
Task ID report has been filtered to display only the engine tasks that are associated with the application task.

Contacts
When you use the Views options with the Contacts report, the Views menu contains only the Detailed Info
option.

The Detailed Info option provides various detailed information, depending on the type of contact selected.
For example, if the contact is a call, the Calling Party number, the Called Number, and so on, are displayed
for that particular call.

Applications
When you use the Views options with the Application reports, the Views menu contains only the Application
Tasks by Application Name option.

The Application Task By Application Name report displays the same report as the Application Task report
except that the Application Task By Application Name report is filtered using only the active application tasks
associated with this application.

Sessions
You can obtain reports based on the session ID associated with a session.

Contacts by Session ID
This report displays the same report as the Contact report with the exception that the Contacts By Session ID
report is filtered using only the contacts associated with the selected session.

Detailed Info
Detailed info displays the time the session was created and its current state.

Settings Menu

The Settings menu of the Application Reporting menu bar allows you to adjust various settings of the Real
Time Reporting tool.

The Settings menu contains the following menu options:

• Options—Choose this option to set the polling (refresh) interval times and to set the amount of times
the server will attempt to reconnect.

•Window—Choose this option to display reports in colors based on your Windows settings.

•Motif—Choose this option to display reports in purple and menu items in brown.

•Metal—Choose this option to display reports in grey and menu items in black.

Options Menu
Choose Settings and click Options to access the Options dialog box. Use the Options dialog box to set the
polling (refresh) interval time, set the number of times the server will attempt to reconnect, and specify whether
logged off agents appear in reports.

Cisco Unified CCX Administration Guide, Release 11.0(1)    
195

Unified CCX Reporting
Unified CCX Real-Time Reports



The following fields are displayed in the Options dialog box.

DescriptionField

Time between two requests to the server for new statistics by the client.Polling Interval

The number of times that the Unified CCX Administration web interface
should attempt to reconnect to the Unified CCX server.

If an error occurs, an Error dialog box opens to alert you that the
server is not communicating with the web interface.

Note

Server Connect Retry Count

Specifies whether logged off agents appear in reports.Show Logged Off Resources

Click Apply to submit configuration changes.

Reporting Administration on Unified Intelligence Center

Overview
Unified Intelligence Center is the default reporting solution for Unified CCX. Unified Intelligence Center is
a comprehensive, end-to-end reporting solution.

Do not access Unified Intelligence Center until you complete the post installation tasks for Unified CCX.Note

Live Data reports can only be run by agents, supervisors, and reporting users.Note

The limit for the maximum number of users, who can concurrently run Live Data reports, is 42 .Note

For more information, see the following guides:

• Cisco Unified Contact Center Express Report User Guide, located at: http://www.cisco.com/en/US/
products/sw/custcosw/ps1846/products_user_guide_list.html.

• Cisco Unified Contact Center Express Report Developer Guide, located at: http://www.cisco.com/en/
US/products/sw/custcosw/ps1846/products_programming_reference_guides_list.html

Historical Reporting Client (HRC) is not available from 10.0(1).Note

Cisco Finesse
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You can configure the Live Data reports that are to be displayed in the gadgets of the Cisco Finesse desktops.

Start Unified Intelligence Center

Procedure

Step 1 Open a web browser.
Step 2 Access http://<host address> and click Cisco Unified Contact Center Express Reporting.

Host address is the DNS name or IP address of the Unified CCX
node.

Note

Step 3 Enter your username and password.
Step 4 Click Log In.

Administrator Overview
Access to the functions in the Unified Intelligence Center reporting application is controlled by the one or
more users who have the user role of Security Administrator.

The initial, default Security Administrator is the user defined as the System Application User during the
installation.

Security Administrators can:

• Create and maintain users.

• Assign User Roles—User roles are assigned to users to control access to drawers and what objects the
user can create.

• Assign users to User Groups.

• Create and maintain user groups.

• Assign Permissions—Whereas User Roles are associated with people, permissions are associated with
objects (Dashboards, Reports, Report Definitions, Data Sources, Value Lists, and Collections).

• Use the Run As feature to verify other users' permissions.

Security Overview
Unified Intelligence Center security offers multi-layered and flexible functionality that allows a security
administrator to create a flat or a tiered structure of access to Unified Intelligence Center functions, based on
the organization's needs.

A user's access to Unified Intelligence Center functions is based on:

• Login authentication.
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• License type under which the user's organization runs Unified Intelligence Center. For example,
organizations that use a Standard license cannot access the Report Definition functions.

• User Role (a user can have one, some, or all seven User Roles).

• User Groups in which user is a member.

• For an object the user can access, the object-level permissions assigned by the person who created that
object.

User List
User List page opens from the Security drawer. If a user who does not have the Security Administrator user
role accesses this page, that user can see all the parameters except the user roles. The user cannot change his
role or group membership.

When Security Administrators access this page, they can see all existing users; can create users, modify or
delete users, review or edit user information, and use theRunAs feature to work in Cisco Unified Intelligence
Center as a user.

Table 10: Fields on User List Page

ExplanationField

Check the check box to display users who are currently active.Only show currently active
users

Use this filter field to narrow the list of names or to move to a specific name.Name Contains

The domain and user name (domain\name).User Name

The user's first name.First Name

The user's last name.Last Name

You can perform the following actions on the user lists page:

• Create—Opens the User Information page.

• Edit—Select a user name and click Edit to edit the User Information page.

• Delete—Select a user and click Delete to delete the user.

• Run As—Select a user and click Run As to refresh the Cisco Unified Intelligence Center reporting
interface.

• Refresh—Refreshes the page to show any latest changes to the User List.

• Page—Click the arrow to move to the next page of the User List.

• Help—Opens online help.

• X—Closes the page.
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Create a User
To create a user, perform the following procedure:

Procedure

Step 1 Navigate to Security > User List.
Step 2 Under the General Information tab, perform the following:

a) In the User Name field, enter the domain and user name (domain\name).
b) In the Alias field, enter the alias name for this user.
c) Check the User is active check box to enable the user to log in and remain active.

If the check box is unchecked, the user cannot log
in.

Note

d) In the First Name field, enter the first name of the user.
e) In the Last Name field, enter the last name.
f) In theOrganization field, enter the company name or other descriptive text to be associated with the user,

such as region or Line of Business.
g) In the Email field, enter the email address of the user.
h) In the Phone field, enter a phone number for the user. This can be the user's personal phone number or an

emergency contact.
i) In the Description field, enter the description of the user.
j) In the Time Zone field, choose the time zone that you want to use in the report from the drop-down list.

This time zone is also used for the user's scheduled reports and takes precedence over the time zone used
by the report server.

If this field is left blank, the system uses the time zone of the report
server.

Note

k) For Start Day of the Week, perform the following:

• Select Locale Based to select starting day of the week based on locale.

• Select Custom Settings to choose one of the seven days of the week from the drop-down list.

Start Day Of TheWeek is used in Scheduled Report, Report Views, and Permalink.Note

l) In the Roles field, select and assign one or more roles for this user.
If the Security Administrator adds or changes User Roles, the change does not take effect until the user
logs out and then logs in again.

m) In the Permissions field, choose the user's permission setting preference for My Group when creating
new objects. My Group is the object owner's default group.

Settings for My Group configures whether other users who belong to this user's default group
can write, or execute the objects. Higher level permissions persist and override other permissions.

Note

Step 3 Under the Groups tab, you can determine which groups this user is a member of and how to add group
membership(s) for a user. You can view the following:

•My Group: This field shows the user's default group. The Security Administrator can change it. The
group is represented as “My Group” for the user.
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• Available Groups: This list shows all the groups that have been created and that the user is not yet a
member of. You can use arrows to move groups between columns.

• Selected Groups: This column shows all the groups that the user is a member of. You can use arrows
to move groups between columns.

By default, every user has AllUsers in their Selected Groups column. You cannot remove the
AllUsers group from the Selected Groups column.

Note

User Groups
User Groups page opens from the Security drawer. Use it to see the existing groups, to create or delete groups,
and to review or edit group information.

The following are the two default groups created by the system:

• The AllUsers group is supplied by Unified Intelligence Center. All users belong to this group by default.

• The Administrators group consists of administrators.

Table 11: Fields on the User Groups Page

ExplanationField

Use this filter field to narrow down the list of group names or to move to a
specific name.

Name Contains

Name of the group.Name

The full name shows the child relationship of a group, as indicated by a dot
separator.

For example, if the default group for Group3 is Group1, and Group1 is a top
level group (does not have a parent), then the Full Name of Group1 isGroup1.
The Full Name of Group 3 is Group1.Group3.

Full Name

Description text of the group.Description

Yu can perform the following actions on the User Groups page:

• Create—Opens the Group Information page.

• Edit—Select the group name and click Edit to open the Group Information page.

• Delete—Select the group name and click Delete.

• Refresh—Refreshes the page to show any changes to the Group List.

• Help—Opens online help.

• X—Closes the page.
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About User Groups
User Groups are constructs that allow security administrators to partition Unified Intelligence Center
functionality.

Creating User Groups expedites the process of provisioning users when multiple users need the same access
to dashboards and reports, or when users require distinct permissions and features based on regional or
organizational requirements.

User groups have no impact on how data is stored in the database. They are used only for assigning permissions
to all the user members of the group through one operation instead of repeating the same operation for each
user.

System-Defined All Users Group

All users are automatically a member of the system-defined All Users group.

All Users always appears on the Manage User Groups window. The security administrator cannot delete it.

System-Defined Administrator User Group

The security administrator is automatically a member of the system-defined Administrators group and can
add other security administrators to it.

Additional Security Administrators must be added to the Administrators group. Having the role does not
automatically make them members of that group.

Customer-Defined User Groups

Security administrators can create any number of user groups and can add users to them. From those other
user groups, one is designated as the user's Group (also calledMy Group).

Default Group

After creating the customer-defined groups, the security administrator can add a user to any of these groups
and can configure one of them as the user's default Group (My Group). The All Users group can also be
selected as the default group.

The owner of an object can set permission for its Group. Only the Security Administrator can set extra
permissions to other groups or individual users on the User Permissions page. A user's access permission to
an object is the highest level of the permission that user gets from all the permission sources.

Create a User Group
To create a user group, perform the following:

Procedure

Step 1 Navigate to Security > User Groups.
Step 2 Under the General Information tab, perform the following:

a) In theGroup Name field, enter the name of the group. This field is available only when you create a new
group.
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b) In the Description field, enter or modify text to describe this group

Step 3 Under the Groups tab, perform the following:
a) Default Group—From the drop-down list, enter the default group.
b) Available Groups—Lists the groups that were created and that are available for this group to become a

child of. Click > or < to move just that group or groups.
c) Selected Groups—Lists the groups that this group is a child of. Click > or < to move just that group or

groups.

Step 4 Under the Groups Members tab, perform the following:
a) Under Users tab:

• Available Users—Lists all the users that were created and that are available to be children of this
group. Click > or < to move just that group or groups.

• Selected User Members—Lists the users that are currently children of this group. Click > or < to
move just that group or groups.

b) Under Groups tab:

• Available Groups—Lists all the groups that were created and that are available to be children of
this group. Click > or < to move just that group or groups.

• Selected Groups Members—Lists the groups that are currently children of this group. Click > or
< to move just that group or groups.

Step 5 Click Save to update new entry or changes to the fields.
Step 6 Click Cancel to cancel or close the page.

Manage User Permissions
Use this page to set extra permissions to Groups or to individual users.

User permissions page has the following tabs:

About Permissions
User Roles are associated with people and permissions are associated with objects. Unified Intelligence Center
objects are Dashboards, Reports, Report Definitions, Data Sources, Categories, Value Lists, and Collections.

Permissions:

• EXECUTE:When the user has EXECUTE permissions for an object, that user can perform some actions
that depend on the object.

For example, with EXECUTE permission, a user can run, print, and refresh a report, open and refresh
a dashboard and run a dashboard slide show, and see a Value List query. EXECUTE permission includes
the read permission.
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Permissions set on categories are not recursive. For all entities under Dashboard, Report,
or Report Definition types, you need separate EXECUTE/WRITE permissions.

Note

•WRITE: When the user has WRITE permission for an object, that user can alter, rename or delete the
object. For example, With WRITE permission, you Save As, import, and export reports; you can edit a
data source and can delete a custom Value List. WRITE permission also includes EXECUTE and read
permission.

If no check boxes are selected when setting permission for an object, the user has no
access privileges to the object.

Note

The following rules are applicable for all category trees in Unified Intelligence Center—Reports, Report
Definitions, Dashboards.

• To delete an entity, you need WRITE permissions for the entity and the entity's parent category.

• To delete a category, you need WRITE permissions for the category, the category's parent, and all the
categories and/or entities belonging to the category.

• A user can only Edit or Save an entity even if the immediate parent category has noWRITE permissions.

• A user can only use the Save As feature if the entity has no WRITE permissions enabled.

• Any category owner within the Imported Report Definitions can delete a category if the administrator
provides explicit WRITE permissions on the Imported Report Definitions category.

Permissions are combined and the highest level prevails.

A user receives permission for an object from different sources. Permission can be inherited from the AllUsers
group, the Default Group (My Group), or the permission assigned by the Security Administrator. Among all
these permissions, the highest level permission is used when the user accesses the object.

User Roles and Permissions
Your User Role allows you to “open” the drawer that corresponds to that role. If you have EXECUTE
permission, you can create objects for that drawer. For example, if you are a Dashboard Designer, you can
create dashboards on the Available Dashboards page.

When you create an object, you are the owner of that object. You have WRITE permission for the object, and
you can set the permissions for that object for users in your Group only.

If the object is still a work-in-progress and you do not want anyone to access it yet, you can make it “private”
by leaving all permissions unchecked for both the All Users and the Groups.

When the object is ready, set your default Group (My Group) permissions to EXECUTE or even WRITE.
For example, if you create a Dashboard for your Group and the dashboard has notes, you might want others
in your Group to update the notes.

Even though you are a Dashboard Designer, if the Available Dashboards page contains dashboards created
by (owned by) other Dashboard Designers, you may not be able to see those dashboards, based on your Group
permissions and on the object-level permissions those owners have set for their dashboards.
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Assigned Group Permissions

Procedure

Step 1 Select the object type in the Permissions For panel. For Dashboard, Report or Report Definition type, you
can select a category or an object within a category. For other object types, select an object from the list. All
the groups that have already been assigned permissions for the object are displayed in the Group permissions
for the selected item panel.

Step 2 Select a group in the All Groups panel. All user members of this group are displayed in the All Users for the
selected group panel.

Step 3 Click Set Permissions. Check the level you want for the group (Execute, Write), and click OK.
Step 4 TheGroup Permissions for the selected item panel updates to include the group and its assigned permission

you defined in Step 3.

If the Security Administrator adds or changes User Permissions, the change may not occur immediately.Note

Table 12: Fields on the Group Members Tab

DescriptionField

Click the drop-down list to select the objects for which you want to set
permissions. Options are: Data Sources, Report Definitions, Reports,
Dashboards, Value Lists, and Collections.

Selecting an object type refreshes the panel to show the list of items or
categories for that object.

Permissions For panel (top left)

This panel shows the available User Groups. Highlighting a user group
refreshes the page to display an All Users for Selected Group panel that
lists the member of the group.

All Groups panel (top right)

This panel shows all members in the group that is highlighted in the All
Groups panel above.

All Users for the Selected Group
panel (bottom right)

Click this option to open a dialog box where you select the permission
level for the selected object in the Permissions For panel and the selected
group in the All Groups panel.

Set Permissions button

This panel shows the groups that have already been assigned permission
for the selected object, and their permission level.

Group Permissions for the selected
item
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Assigned User Permissions

Procedure

Step 1 Select the object type in the Permissions For panel. For Dashboard, Report, or Report Definition type, you
can select a category or an object within a category. For other object types, select an object from the list. All
the users that have already been assigned permission for the object are displayed in the User permissions for
the selected item panel.

Step 2 Select a user name in the User List panel.
Step 3 Click Show Groups to see the groups for which this user is a member.
Step 4 Click Set Permissions, check the level you want for this user (Execute, Write), and click OK.

The All Permissions for the selected item panel refreshes to show the user permissions you have added or
changed for this user in steps 3 and 4.

DescriptionField

Click the drop-down arrow to select the kinds of object for which you want
to set permissions. Options are Data Sources, Report Definitions, Reports,
Dashboards, Value Lists, Collections, and System Collections.

Selecting an object type refreshes the panel to show the list of items or
categories for that object.

Permissions For panel (top left)

This panel shows current users. Filter the list and select one or many user
names.

User List panel (top right)

Click this option to show the All Groups for the selected user panel.Show Groups button

This panel shows all groups to which the highlighted username in the User
List panel above is a member.

All Groups for the selected User
(bottom right)

Click this option to open a dialog box where you select the permission
level for the object (Execute, Write).

Set Permissions button

This panel shows users who have permission for the object, and the level
of permissions they have.

All Permissions for the selected
item

You cannot change the permission for the owner of an object. The owner always hasWrite permission
for the object. For example, if a user is the owner of Report 1, then that user has WRITE permission
for Report 1, and no one else can change the permission to EXECUTE.

Note

Run As
Security Administrators can select a name on the User List page and clickRun As. This refreshes the Unified
Intelligence Center web page so that it reflects the interface that user has when logged in.
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Use this tool to verify that the User Roles and permissions are configured properly.

Note •When you Run As another user, the top of the page shows both your Logged In identity and your
Run As identity.

• You cannot Run As yourself.

• You can Run As one level of user. A Security Admin cannot Run As User A and, as User A, then
Run As User B.

To leave Run As mode, click Stop Run As at the top of the page.

Audit Trail Logging in Cisco Unified Intelligence Center
Unified Intelligence Center now supports Audit Trail Logging. This feature allows you to view the sequence
of audit records of the transactions related to create, update, modify, and delete that are performed on the
entities of a Unified Intelligence Center server. You can view the audit trails using the Audit Trail stock report.
Only System Administrators can access and view this feature by default. However, a System Administrator
can then give permissions to other Unified Intelligence Center users to use this feature.

Localization of Audit Trail report is not supported.Note

View Audit Trail Logging in Unified Intelligence Center

Procedure

Step 1 Log in to the Unified Intelligence Center Reporting Interface.
Step 2 Navigate to Reports > Stock > Intelligence Center Admin and click Audit Trail. The system opens the

Audit Trail Report Filter window.
Step 3 Specify the required filter criteria and click Run. The system displays the Audit Trail report based on the

filter criteria that you specified.

Audit Trail Report
Views: This report has three grid views - Non-grouped, Groupby – EntityName, Groupby –Username.
Grouping: This report has two grouped views - grouped and sorted by User and Entity Name. The third view
is un-grouped which is also the default view for this report.

Value List: CUIC Users, CUIC Operations, CUIC Entity Types.

Database Schema Tables from which data is retrieved:

• CUICAUDITLOG
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• CUICLOGEDENTITY

Security Considerations
If you make the user a member of one or more other groups, make one of those groups the user's default group,
and set the permissions for the default group higher than those of the AllUsers group.

Higher permissions for the default group prevail over permissions in the AllUsers group. Individual user
permissions prevail over group permissions.
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C H A P T E R  12
Unified CCX Outbound Dialer Configuration

• Outbound Feature for Unified CCX, page 209

• Supported Dialers and Dialing Modes for Outbound, page 213

• Configure Outbound Subsystem in Unified CCX, page 214

• Configure General Outbound Properties, page 214

• Configure Application and Trigger for Outbound Campaign, page 219

• Add New Campaign, page 219

• Import Contacts for Campaign, page 229

• Enable Campaigns, page 230

• Outbound Subsystem and Time Detection, page 231

• Add Area Codes, page 232

• Call Status Values, page 232

• Call Result Values, page 234

• Reclassification Status Behavior, page 235

• Call Retrieval Priority, page 236

• Failover and System Restarts, page 237

Outbound Feature for Unified CCX
The Outbound feature provides outbound dialing functionality in addition to existing Unified CCX inbound
capabilities.

The Unified CCX Direct Preview Outbound feature is bundled along with the Unified CCX Premium license
package. The Unified CCX IVR and Agent Progressive and Predictive Outbound feature is available with the
Unified CCX Outbound license. When you upload the Premium license, the Outbound subsystem will
automatically appear in the Subsystems menu. With this Outbound feature, you can maintain high agent
productivity by configuring contact centers for automated Outbound activities to perform Outbound calls.
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Outbound Characteristics
The Outbound feature has the following characteristics:

• An Outbound subsystem that can be monitored from the control center

• IVR and Agent Progressive and Predictive Outbound

• Dialing modes - Direct preview, Progressive and Predictive

• Unified CCX Administration web pages, REST API to configure the Outbound feature

• Outbound Historical reports

• Outbound Live Data reports (Unified Intelligence Center)

• Real-Time reports are part of the Unified CCX Administration GUI real-time reporting applet

Calls made by the Outbound subsystem will not be displayed in the Contacts Summary
Real-Time Report

Note

• Access to real-time Outbound data from the GetReportingStatistics step for Direct Preview Outbound

Unified CCX Requirements
To use the Outbound feature, you must adhere to the following requirements:

Unified CCX Licensing Requirements

The licensing requirements for Outbound feature in Unified CCX will vary depending on the dialing modes.

• For Unified CCX Outbound Direct Preview Dialer—The Unified CCX Outbound Direct Preview
Dialer feature is automatically available with Premium license package without any additional license.
It is no longer available with Enhanced license.

• For Unified CCX Outbound IVR Dialer—You need to upload an Outbound license on top of the
Unified CCX premium license with the required number of IVR ports that you would like to use for the
Outbound feature.

• For Unified CCX Outbound Agent Dialer—You need to upload an Outbound license on top of the
Unified CCX premium license with the required number of agent seats that you would like to use for
the Outbound feature.

The sum of inbound and outbound IVR ports should be less than or equal to a maximum number of IVR
ports supported for your hardware model.

Note

You can view the licensed IVR ports for outbound and inbound and the dedicated ports for both outbound
and inbound calls by navigating to System > License Information > Display License(s) submenu from the
Unified CCX Administration menu bar.
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Scenario 1:

If your Contact Center is already utilizing maximum licensed IVR ports supported for your hardware model,
then:

• Inbound calls will take precedence over the configured Outbound IVR calls.

• If IVR ports are dedicated for a campaign, then the Outbound IVR ports available for the campaign will
be gradually incremented as and when the inbound ports become free.

For example, if you have an UCS C220 hardware that supports maximum of 300 IVR ports and if you have
200 premium seats, then the current licensed IVR ports = 300 (Minimum of [seats*2, maximum supported
for platform]).

In this case, if you upload an Outbound add-on license for 100 IVR ports and add 3 campaigns with 20
dedicated ports each running at the same time, then the 60 Outbound IVR ports will be available to the
campaigns only when the number of inbound ports are freed up to support the Outbound IVR calls.

In other words, if the number of inbound ports that are used during the outbound IVR campaign time is 280,
then only 20 Outbound IVR ports will be available to the campaigns. The number of Outbound IVR ports
will be gradually incremented depending on the availability of free inbound ports.

Scenario 2:

If your Contact Center is close to utilizing the maximum IVR ports supported for your hardware model, then:

• Inbound calls will take precedence over the configured Outbound IVR calls.

• If IVR ports are dedicated for a campaign and if you reach the maximum inbound call limit, then the
Outbound IVR ports available for the campaign will be gradually incremented as and when the inbound
ports become free.

For example, if you have an UCS C220 hardware that supports a maximum of 300 IVR ports and if you have
130 premium seats, then the current licensed IVR ports = 260 (Minimum of [seats*2, max supported for
platform]).

In this case, if you upload an Outbound add-on license for 50 IVR ports and add 2 campaigns with 25 dedicated
ports each running at the same time and if you reach the inbound call limit of 260 during the outbound IVR
campaign time, then only 40 ports (300-260) will be freed up initially for Outbound IVR calls. The number
of Outbound IVR ports will be gradually incremented depending on the availability of free inbound ports.

Scenario 3:

If your Contact Center is using fewer ports than the maximum licensed ports supported for your hardware
model, then the number of available IVR ports for inbound will continue to remain the same.

For example, if you have an UCS C220 hardware that supports maximum of 300 IVR ports and if you have
60 premium seats, then the current licensed IVR ports = 120 (Minimum of [seats*2, max supported for
platform]).

In this case if you upload an Outbound add-on license for 50 IVR Outbound ports, and add 2 campaigns with
20 dedicated ports each running at the same time, then Unified CCX will support 40 IVR Outbound calls, and
the inbound port limit will continue to be 120 as the sum of both inbound and outbound ports (160) are within
the maximum licensed ports (300) for the platform.

The total number of dedicated IVR ports in all the IVR campaigns must be less than twice the number of
Premium Seats that is equivalent to the Total Licensed Inbound IVR ports.

Note
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Unified CCX Subsystem Requirements

• The Outbound subsystem must be IN SERVICE.

• The RmCm subsystem must be IN SERVICE.

• The Unified CM Telephony subsystem must be IN SERVICE.

• The Unified CCX Database must be IN SERVICE.

Geographic Region Support

• The Outbound feature can be used in any geographic region supported by Unified CCX. The area codes
and time zones mapping for North America are automatically prepopulated in the system. The system
uses this information to determine the time zone of a customer’s phone number.

• For regions outside North America, administrators must enter the mapping of the international area
codes and their time zones using the Unified CCX Administration GUI or REST API.

• The national do_not_call list is not supported in this release. Be sure to abide by the national do_not_call
list.

In this guide, the underscore character linking each word differentiates the national do_not_call list from
the Outbound subsystem's Do Not Call list.

Note

Outbound Components
This section provides details about the following Outbound feature components:

• Unified CCX Administration—Enables the Outbound subsystem configuration, creates campaigns, and
imports contacts to generate the dialing list.

• Outbound subsystem—Is responsible for the following tasks:

◦Manages campaigns

◦Maintains Outbound system configurations

◦Manages the dialing list

◦Reserves agents

◦Makes Outbound calls

◦Updates the call data in the dialing list based on the outcome of the call

◦Decides which contact records to retrieve from a campaign

The Outbound subsystem views campaigns as logical entities that group a set of contacts together in a dialing
list. Campaigns deliver outgoing calls to agents. Agents are assigned to campaigns using CSQs.
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Supported Dialers and Dialing Modes for Outbound
In addition to the existing Direct Preview Outbound dialer option, Unified CCX supports IVR-based and
agent-based dialing. If you select the IVR-based option for a campaign, the outbound calls are handled by
IVR scripts. If you select the agent-based option for a campaign, the outbound calls are handled by agents.
Typical applications include appointment and bill-payment reminders.

Unified CCX Outbound Dialing Modes
The Outbound feature in Unified CCX Release supports the following dialing modes:

• Direct preview dialing mode

• Progressive dialing mode

• Predictive dialing mode

For agent predictive and agent progressive outbound calls, disable the Call Waiting option on the agent's
phone to allow agents to preview a customer call on Cisco Finesse before the call is placed. The Call
Waiting option must be disabled (default) in Unified Communications Manager on each Outbound agent
phone to ensure that every customer call successfully transfers to an available agent.

Tip

When an Outbound call is transferred or conferenced to another agent, the second or subsequent agents are
not counted towards the number of Outbound licenses. For example, if you have five seats licensed for
Outbound and Agent1 gets an Outbound call, Agent1 accepts the call and conferences in Agent2 and Agent3.
Now, three agents are on one Outbound call but only Agent1 is considered an Outbound agent and you are
only using one licensed seat. Consequently, your system allows four more Outbound calls to agents.

Direct Preview Dialing Mode
The direct preview dialing mode allows agents to preview a customer call on Cisco Finesse before the call is
placed. The advantage of this mode is that an agent is already on the call when the customer answers and can
quickly begin talking with the customer immediately.

Progressive Dialing Mode
In the Progressive Dialing mode, you can specify a fixed number of lines that will always be dialed per
available IVR port or per available agent. You can configure the progressive dialer settings for each campaign
while creating the campaign through Unified CCX Application Administration web interface. You can also
update the configuration at a later date.
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Predictive Dialing Mode
The Predictive Dialing mode works similar to the Progressive Dialing mode in terms of dialing the Outbound
calls. The difference remains in tuning the lines per port or per agent depending on the abandoned call-rate
thus eliminating manual intervention as in the case of the Progressive Dialer.

In other words, in the Predictive Dialing mode, the Dialer adjusts the number of customers to dial per available
IVR port or per available agent. The number of lines to dial is calculated by an algorithm and gets updated
automatically.

Configure Outbound Subsystem in Unified CCX
Procedure

Step 1 Configure the general properties of the outbound subsystem. SeeConfigure General Outbound Properties.
Step 2 (Optional) If the dialing list contains contacts outside of North America or if Unified CCX is installed outside

of North America, manually add the area codes and their corresponding time zones. See Add New Area
Code.

Step 3 Configure the SIP Gateway parameters to enable communication between Unified CCX and the SIP gateway
for IVR and agent-based progressive and predictive campaigns. See Configure SIP Gateway.

Step 4 Configure the campaign. See Add New Campaign.

Configure General Outbound Properties
General Outbound properties refer to the settings that is common for all the campaigns.

Area code and long distance prefix configuration changes made to the Outbound subsystem do not take
effect for the calls/contacts that are currently in the Outbound subsystem’s memory. For example, if you
change the long distance prefix or local area code, the contacts that are already in the Outbound subsystem's
memory will continue to use the old long distance prefix and local area code.

Caution

To configure general Outbound properties, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > General.
The General Configuration web page opens.

Step 2 Specify the following fields in the General Configuration section:
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DescriptionField

The time range during which a customer can be called. This time range supersedes
the time range of the individual campaigns and ensures that a customer is never
called outside the legally allowed time range for that country. This is a mandatory
field.

For example, in the USA, the Federal Communications Commission (FCC) specifies
the legal time range as 8 AM to 9 PM. This does not apply to callbacks, since the
customer explicitly requested to be called at a certain time. This time range is always
converted to the local time for each contact record.

Default = 8:00 AM to 9:00 PM (USA FCC regulations)

Customer Dialing
Time Range (hh:mm)

Start Time/End Time

If an agent does not respond to the Outbound preview call on Cisco Finesse within
the timeout duration that is specified in this field, the system sets the agent to the
Not Ready state.

If an agent does not respond to the Outbound progressive or predictive call on
Finesse within the timeout duration that is specified in this field, then the call is
dropped. The system sets the agent to the Ready or Not Ready state depending on
the option that is selected for Agent State after Ring No Answer field in the System
Parameters Configuration Web Page. This is a mandatory field.

Default = 60 seconds, Range = 5 to 3600 seconds.

Note • This field is used only when Agent AutoAnswer is disabled for
agent-based progressive and predictive outbound campaigns.

• If the Unified CCX Engine or Finesse restarts when a call is being
presented to an agent, then the timeout value specified in the Outbound
Call Timeout field will not be applicable for that call.

Outbound Call
Timeout (seconds)

The number to prefix to the phone number for dialing outgoing calls (also referred
to as switch prefix). This number can have any numeric value, including 0 or leading
zeros.

Dialing Prefix

The number to prefix to the phone number for dialing long distance. This number
can have any numeric value, including 0 or leading zeros.

Long Distance Prefix

The number to prefix to international phone numbers. This number can have any
numeric value, including 0 or leading zeros.

International Prefix

The area code of the Unified CCX server location. This number can have any numeric
value, including 0 or leading zeros.

Local Area Code

If this box is checked, the local area code is included when dialing the phone numbers
within this area code. If it is unchecked, then the local area code is stripped from
the phone number before dialing the local numbers. It is expected that when contacts
are imported into the system, the phone numbers include the area code. For
international phone numbers, the country code must be included when importing
contacts.

DoNot Remove Local
Area Code When
Dialing
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DescriptionField

This field will be displayed only if you check the Do Not Remove Local Area
Code When Dialing check box. For local numbers, the long distance prefix will
be prefixed only if this check box is checked.

The long distance prefix will be prefixed to the phone number for all non-local
numbers (the numbers that do not start with local area code) irrespective of the
status (checked/unchecked) of this check box.

Include Long Distance
Prefix

If this box is checked, any agent-based progressive or predictive campaign call that
gets transferred to the agent is automatically answered by Unified CCX. This check
box is checked by default.

In addition to checking the Agent AutoAnswer box, it will also be required to
implement a desktop workflow that would execute this task. Else the agent would
still need to manually answer the call.

Note • Either check this option in Unified CCX, or set Auto Answer to 'yes'
in Unified Communications Manager. Do not select both of these
options.

• It is recommended to enable Agent Autoanswer so that the call
presented to the agent is automatically answered. A beep tone notifies
the agent that the call has been answered.

• If the workflow is enabled, it will be executed irrespective of the
status (Checked/unchecked) of the AutoAnswer check box.

Agent AutoAnswer

Assigned CSQs are CSQs that are used by the Outbound subsystem. This is a
mandatory field. To allocate CSQs for Outbound:

1 Select a CSQ in the Available CSQs list.

2 Select a value from the% of Logged in Agents for Outbound drop-down list
to indicate what percentage of the CSQ is allocated for Outbound.

3 Click the left arrow icon to move the CSQ to the Assigned CSQs list.

The selected CSQ is removed from the Available CSQs box and appears in the
Assigned CSQs box with the percentage allocation in parentheses next to the CSQ
name.

Assigned CSQs

The Available CSQs pane displays all CSQs configured in the CSQ Configuration
page under the RmCm subsystem configuration.

Available CSQs

The % of Logged in Agents for Outbound field indicates the percentage of logged
in agents in each of the selected CSQs that are allocated for handling Outbound
calls.

The CSQ allocation percentage is defined at the global level and not at a
campaign level. For example, if a CSQ has 100 agents and 20% are allocated
for Outbound, a pool of 20 agents are shared among the Outbound
campaigns. In the AddNewCampaign web page, you can specify the CSQs
to assign to a campaign.

Note

% of Logged in
Agents for Outbound
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Step 3 ClickUpdate icon that is displayed in the tool bar in the upper, left corner of the window or theUpdate button
that is displayed at the bottom of the window.
The System Options components are now updated.

Callbacks
A customer can request a callback at a specific callback phone number and also specify the time/date of the
callback. The Outbound subsystem stores this information (the callback phone number, date, time) in the
dialing list table.

The Outbound subsystem handles the callback as follows:

• Convert to GMT—The callback date and time specified with respect to the customer's time zone is
converted to GMT time zone and then stored in the database.

• Agent not Available—When the Outbound subsystem looks up the database for contacts, it first checks
the callbacks. The default callback time limit is 15 minutes (can be changed) before and after the
customer-specified time. If an agent is available, then the Outbound subsystem places the callback. If
an agent is not available, the Outbound subsystem retries agent availability (agent state) after 10 minutes.

• Missed Callbacks—If the Unified CCX system is unable to process a callback request in the specified
time, you have three action options:

◦Reschedule it to the same time on the next business day.

◦Mark it as another retry (the callback phone number is removed and the callback date time is
ignored). In this case, it moves out of the call back state and into the retry state.

◦Close the record (never dialed again).

The selected status for the Missed Callbacks is applied at midnight.Note

• Agent reclassifications—If calls were retrieved and presented to the agent and if the agent reclassifies
it (for example, changed it to answering machine status), then the call status is updated to the answering
machine.

Outbound Area Code Functionality
In the Outbound option, the area code determines the geographical location of the phone number you dial,
which correspondingly provides the Greenwich Meridian Time (GMT) zone. The db_cra database contains
a mapping of the area codes to the time zones.

The U.S. area code mappings are provided along with the product. International customers should provide
their own data and add it to the database.
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Configuration Updates
Whenever Outbound parameters are modified in the Unified CCX Administration GUI, the changes take
effect immediately. If a new CSQ is added using the Subsystems >RmCm >Contact Service Queuesmenu
option, it is instantly displayed in the list of available CSQs in the General configuration page in the Unified
CCX Administration GUI, as this list is dynamically updated. If a CSQ is modified and if this impacts the
allocation of agents, the Outbound subsystem is aware of this change as it refreshes the list of agents in each
relevant CSQ periodically.

• If a configuration change affects the Outbound contacts dialing process (for example, if a campaign is
disabled or a CSQ is removed from a campaign), the Outbound subsystem stops processing the Outbound
contacts, recalls these contacts to the database, and resets the call status to Pending.

• If a campaign start time is changed, the Outbound subsystem checks if the campaign is enabled. If it is
enabled, and if the new start time is after the current time, it performs the following actions:

◦Sends a recall contact message to the Outbound subsystem passing the campaign ID.

◦For all Outbound contacts for this campaign in the Outbound subsystem's memory that are waiting
to be dialed out, it resets all Outbound contacts to the Pending state and clears them from memory.

If the campaign is disabled or if the new start time is before the current time, the Outbound subsystem
ignores this change.

• If campaign end time is changed, the Outbound subsystem checks if the campaign is enabled. If it is
enabled, and if the new end time is before the current time, it performs the following actions:

◦Sends a recall contact message to the Outbound subsystem passing the campaign ID.

◦For all the Outbound contacts for this campaign in Outbound subsystem's memory that are waiting
to be dialed out, it resets all the Outbound contacts to the Pending state and clears them from
memory.

If the campaign is disabled or if the new end time is after the current time, the Outbound subsystem
ignores this change.

• If a CSQ is deleted from a campaign or if the CSQ itself is deleted, the Outbound subsystem sends a
recall contacts message with the csq ID of the deleted CSQ. It also reallocates any Outbound contacts
in its memory that are currently allocated to this CSQ among the other existing CSQs for this campaign.

CSQ Agent Pool Allocation
You need to specify a percentage of total agents in the assigned CSQs to be allocated for Outbound calls. This
pool of agents is shared by all Outbound campaigns.

The CSQs for Outbound are the same as the CSQs for inbound. If you need more CSQs, you must first
configure them in Unified CCX and assign the required CSQs for agents as required by your configuration,
before allocating them.

Tip
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Configure Application and Trigger for Outbound Campaign
For IVR campaigns, configure application and trigger before you create the campaign.

For an agent-based predictive campaign and an agent-based progressive campaign, configure the application
and trigger if you configure the answering machine and the abandoned call treatment to transfer to IVR.

Procedure

Step 1 Create a Call Control Group for Outbound type with the required number of IVR ports to be used for outbound
campaigns. See Add New Call Control Group.

Step 2 Create an application, which will be used for the outbound campaign. SeeCisco Applications Configuration.
Step 3 Create a trigger and assign the newly created Outbound Call Control group to this trigger. See Cisco

Applications Configuration.
Step 4 Create a new progressive or predictive outbound campaign. See Add New Campaign.
Step 5 Import contacts for the campaign. See Import Contacts for Campaign.

Add New Campaign
Use the Campaign component to configure properties for the campaign, including the campaign name and
description, CSQ selection, and the time range when a campaign can call contacts.

Complete the following steps to define or modify the settings that apply to a campaign.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > Campaigns.
The Campaign web page opens, displaying the details of existing campaigns, if any. Click an existing campaign
to view or update the configuration settings for the campaign.

Step 2 Click theAdd New icon in the tool bar in the upper, left corner of the window or the Add New button at the
bottom of the window.
Add a New Campaign web page opens up where you can specify the campaign type and the dialer type for
the campaign using the following fields.

You need to upload an Outbound license on top of the Premium license for Unified CCX to create
a campaign for Outbound.

Note

DescriptionField

Select the type of the campaign
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DescriptionField

Type of the campaign to be used for outbound calls. You can specify any one of the
following two campaign types:

• Agent-based—If you select this, all the outbound calls in a campaign will be
handled by the available agents.

• IVR-based—If you select the IVR-based option, the outbound calls in a campaign
will be handled by the IVR scripts.

Campaign Type

Select the type of dialer for the campaign

The dialer type options available for a campaign will vary depending on the selected
Campaign Type.

• If you select Agent-based campaign type, then you can select any one of the
following dialer types:

◦Direct Preview (default)

◦Progressive

◦Predictive

• If you select IVR-based campaign type, then you can select any one of the
following dialer types:

◦Progressive (default)

◦Predictive

Description

Once the campaign is created, you cannot change the Campaign Type and Dialer
Type.

Note

After you select the campaign type and dialer type, clickNext to continue. The Campaign Configuration web
page opens, displaying the following three column headings:

• Parameter Name

• Parameter Value

• Suggested Value

You can specify values for a new campaign or modify values for an campaign using the fields listed in the
Parameter Value column. See the table below for a list of fields along with their description.

The Suggested Value displays the default configuration value for each campaign. You can refer to these values
if you want to revert any changes made to one or more parameters listed in the Campaign Configuration web
page.

DescriptionField

Name of the campaign (must be a unique identifier). This is a mandatory field.Campaign Name
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DescriptionField

Indicates the current state of the campaign to the Outbound subsystem.

Yes = The campaign is currently active.

No = The campaign is currently inactive (default).

Enabled

Description of the campaign.Description

Indicate the time range during which the campaign runs. These are mandatory fields.
The name of the primary time zone is also displayed adjacent to these two field values.

Default = 8:00 AM - 9:00 PM Pacific Standard Time (USA FCC regulations).

Start Time/End
Time (hh:mm) AM
PM Time Zone

The campaign calling number is the number that will be displayed to the contact. This
number is used by the dialer. This is a mandatory field.

This field is not available if you have selected the direct preview dialer type
for an agent based campaign.

Note

Campaign Calling
Number

The maximum number of times the Outbound subsystem attempts to dial a contact
beyond which the call status will be marked as closed. You can choose this value from
the drop-down list box.

Default = 3, Range = 1 to 3.

MaximumAttempts
to Dial Contact

The time period before and after the scheduled callback time during which the
Outbound subsystem attempts to dial out a callback. For example, if a callback was
scheduled for 9:30 am and if the Callback Time Limit is set to 15 minutes, then the
Outbound subsystem calls the customer anytime between 9:15 am to 9:45 am.

This field is also used to determine the dialing time range for the Retries settings in
the Add New Campaign web page.

Default = 15 minutes, Range = 1 to 60 minutes.

Callback Time Limit

Fields displayed only if you have selected IVR-based campaign type

This is the JTAPI trigger associated with this campaign. There will one-to-onemapping
between a campaign and an application trigger. Only those triggers that are not
associated with any other campaigns are displayed in the trigger list.

Application Trigger

The name of the application associated with the above-mentioned JTAPI trigger. This
field is auto-populated.

Application Name

Fields displayed only if you have selected Agent-based campaign type
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DescriptionField

If the agent is not available to handle the call, you can choose to abandon the call or
transfer it to IVR by selecting the desired radio button in this field. If you choose to
transfer the call to IVR, a trigger field and an application name field appears for
selection.

The trigger field is a drop-down list of JTAPI triggers associated with this campaign.
There is one-to-one mapping between a campaign and a trigger. Only those triggers
that are not associated with any other campaigns are displayed in the trigger list.

The application name is associated with the above-mentioned JTAPI trigger. This
field is auto-populated.

Transfer to IVR radio button is enabled by default.

Note • This field is not applicable if you have selected the Direct Preview
dialer type for an agent-based campaign.

• If the agent is available to handle the call and if Unified CCX fails to
transfer the call to the agent, then the call is dropped and will not be
transferred to the IVR port.

Abandoned Call
Treatment

The CSQs from which agents are selected for Outbound calls for this campaign. This
is a mandatory field.

Note • For agent selection, the CSQs are used in the order in which they are
assigned to the campaign.

• CSQs that are associated with agent-based progressive or predictive
campaigns cannot be shared across any other campaigns.

• CSQs that are associated with direct preview campaigns can be shared
only across other direct preview campaigns and not with agent-based
progressive and predictive campaigns.

Assigned CSQs

For direct preview campaigns—CSQs that are allocated for outbound but not assigned
to any progressive or predictive agent-based campaign.

For progressive and predictive agent-based campaigns—CSQs that are allocated for
outbound and not assigned to any other campaign.

Available CSQs

Fields displayed only if you have selected Direct Preview dialer type for an Agent-based campaign
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DescriptionField

The number of contact records the Outbound subsystem retrieves from the database
in bulk for dialing. The allowed values are 1–100. This is a mandatory field. For
example, if 50 records are retrieved in bulk for campaign1 and 10 for campaign2 and
they are running at the same time, the Outbound subsystem attempts to place 50
Outbound calls for campaign1 and 10 Outbound calls for campaign2. The number of
Outbound calls actually placed for each campaign depends upon the number of agents
available for the respective campaigns.

Once all the records retrieved for a campaign have been dialed, the Outbound
subsystem retrieves another batch of records for that campaign. Over a period of time,
it is likely that more contacts would have been called from campaign1 than from
campaign2.

If two campaigns run simultaneously and share CSQs or agents, the records in both
campaigns may not be processed at the same rate even if their contact cache sizes are
identical. It is possible that more records from one of these two campaigns is processed
before the other.

Default = 20, Range = 1 to 100

Contact Records
Cache Size

If you select Yes, then the Outbound subsystem retries the contact after all the callbacks
and pending contacts for the campaign are dialed out.

Default = No

AnsweringMachine
Retry

The following fields in Dialing Options are displayed if you have selected IVR-based campaign type
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DescriptionField

Number of dedicated IVR ports that you want to reserve for this campaign based on
the number of CTI ports available in the outbound call control group for the campaign
duration. That is, the total number of dedicated IVR ports for the selected campaign
cannot exceed the maximum licensed ports for outbound IVR minus the sum total of
IVR ports dedicated to other campaigns running at the same time.

You can enter or update this value for a campaign only after associating a trigger with
the campaign. Default value = 0, Range = 0 to number of available ports for the
campaign duration.

For example, if you have a medium or large profile VM, which supports maximum
of 300 IVR ports with 50 licensed ports for outbound IVR and you have already
dedicated:

• 20 ports for Campaign1, which runs between 10–12 pm

• 10 ports for Campaign2, which runs between 2–4 pm, then the number of
dedicated IVR ports that you can enter in this field for a new campaign cannot
exceed:

◦30 ports if the new campaign runs between 10–12 pm and

◦40 ports if the new campaign runs between 2–4 pm and

◦50 ports if the new campaign runs during any time other than 10–12 pm
and 2–4 pm

If the number of configured ports for a campaign is greater than the available number
of licensed ports at the specified campaign time, then an alert message stating the
same will be shown while saving the campaign.

Ensure that few IVR ports from the total number of licensed IVR ports are
left free if you want to use the "Transfer to IVR" option available in the
answering machine treatment and abandoned call treatment fields for
agent-based progressive and predictive outbound campaigns.

Note

See Unified CCX Requirements, on page 210 to know how the licensed IVR ports
are distributed between the inbound and outbound IVR calls in different scenarios.

Number of
Dedicated Ports
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DescriptionField

Number of lines to be dialed for each port. The dialer will try to connect as many live
voices to the available port(s) where IVR script is playing and it will disconnect the
remaining calls. The probability of abandoned calls increases geometrically as the
lines per port increases.

In an IVR based progressive campaign, you can configure the number of lines to dial
per port at a time. The dialer will determine the number of calls to dial based on the
following calculation - Lines per port * Available number of ports.

In an IVR based predictive campaign, this is the seed value that is passed to the
predictive algorithm. Initially the dialer starts dialing with this value.

If you change this value in the middle, the predictive algorithm will take the
updated value in this field during the next iteration.

Note

This is a mandatory field.

Default value = 1.5; Range = 1 to 3.

Lines Per Port (1-3)

The following fields in Dialing Options are displayed if you have selected Agent-based campaign type

Number of lines to be dialed for each agent. The dialer will try to connect as many
live voices to the available agent(s) and it will disconnect the remaining calls. The
probability of abandoned calls increases geometrically as the lines per agent increases.

In an agent-based progressive campaign, you can configure the number of lines to
dial per agent at a time. The dialer will determine the number of calls to dial based
on the following calculation - Lines per agent * Available number of agents.

In an agent-based predictive campaign, this is the seed value that is passed to the
predictive algorithm. Initially the dialer starts dialing with this value.

If you change this value in the middle, the predictive algorithm will take the
updated value in this field during the next iteration.

Note

This is a mandatory field.

Default value = 1.5; Range = 1 to 3.

This field is not applicable if you have selected the Direct Preview dialer
type for an agent-based campaign.

Note

Lines Per Agent
(1-3)

Determines the action that should be taken on the contacts that were not called back.
The three options for this field are:

• Reschedule for same time next business day (default)

• Mark it for a retry

• Close the record.

Callback Missed

The following fields in Dialing Options are common if you have selected Progressive or Predictive
dialer type for IVR-based and Agent-based campaigns
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DescriptionField

Determines whether a low volume call should be treated as voice or disconnected.
Select Yes or No radio button accordingly.

Default is Yes, which means low volume calls are handled as voice and they are
connected to an IVR port or an agent.

Handle LowVolume
as Voice

If the outbound call detects an answering machine, you can choose to end the call or
transfer it to IVR by selecting the desired radio button in this field.

For agent-based campaigns, if you choose to transfer the call to IVR, a trigger field
and an application name field appears for selection.

The trigger field is a drop down list of JTAPI triggers associated with this campaign.
There is one-to-one mapping between a campaign and a trigger. Only those triggers
that are not associated with any other campaigns are displayed in the trigger list.

The application name is associated with the above-mentioned JTAPI trigger. This
field is auto-populated.

Transfer to IVR radio button is enabled by default.

AnsweringMachine
Treatment

The following fields in Dialing Options are common if you have selected Predictive dialer type for
IVR-based and Agent-based campaigns

The number of calls that were answered by live voice that the predictive algorithm
should consider for each iteration. This is directly proportional with the correction
frequencymade in the Lines Per Port or Lines Per Agent parameter. This is a mandatory
field. Default value = 100, Range = 10 to 1000.

It is advisable not to change this
value.

Note

Predictive
Correction Pace
(10-1000)

The Gain parameter controls the size of the lines per port or lines per agent corrections.
This is directly proportional to the size of the lines per port or lines per agent correction.

This is a mandatory field. Default value = 1.0, Range = Greater than 0 to 1.0.

It is advisable not to change this
value.

Note

Predictive Gain

Call abandon percentage, which should be within the limit specified by Federal Trade
Commission (FTC). This is a mandatory field.

Default value - 3%, Range 0-100%. This means that no more than three percent of
calls that are answered by a person are abandoned, measured per day per calling
campaign.

Call Abandon Limit
(0-100)

The following field in Dialing Options is displayed only if you have selected Predictive dialer type for
an IVR-based campaign

Maximum number of lines to be dialed for each port. You can configure the maximum
number of lines that can be dialed per port and the predictive algorithm ensures that
it does not exceed this number.

This is a mandatory field. Default value = 3.0, Range = 1 to 3.

MaximumLines Per
Port (1-3)

   Cisco Unified CCX Administration Guide, Release 11.0(1)
226

Unified CCX Outbound Dialer Configuration
Add New Campaign



DescriptionField

The following field in Dialing Options is displayed only if you have selected Predictive dialer type for
an Agent-based campaign

Maximum number of lines to be dialed for each agent. You can configure themaximum
number of lines that can be dialed per agent and the predictive algorithm ensures that
it does not exceed this number.

This is a mandatory field. Default value = 3.0, Range = 1 to 3.

MaximumLines Per
Agent (1-3)

Dial Settings (displayed if you have selected IVR-based or Agent-based campaign types)

The duration for which the progressive/predictive dialer should allow the customer
phone to ring before disconnecting an unanswered call.

The duration is calculated from the time the dialer receives the ringing message from
the gateway. If the dialer does not receive any ringing message from the gateway
within the time duration entered for this field, then the dialer waits for the same time
duration one more time before disconnecting the call.

For example, if you have configured the value for NoAnswer Ring Limit as 30 seconds,
then the dialer will wait for 60 seconds before disconnecting the call.

Default = 15 seconds, Range = 1 to 60 seconds.

This field is also used to determine the reservation timeout for agent-based
progressive or predictive campaigns. If the agent does not receive any
outbound calls, then the agent continues to remains in the reserved state up
to maximum time duration of twice the value configured in the No Answer
Ring Limit field.

For example, if you have configured the value for No Answer Ring Limit as
30 seconds, then the range for reservation timeout is calculated as 30 to 60
(30 * 2) seconds.

Note

No Answer Ring
Limit

For IVR-based progressive and predictive outbound campaigns, if the customer
disconnects the call within the time set here, then the call is classified as customer
abandoned.

For agent-based progressive and predictive outbound campaigns, if the customer or
the agent disconnects the call within the time set here, then the call is classified as
customer abandoned.

This is a mandatory field.

Default value = 2 seconds, Range = 1 to 10 seconds.

Abandoned Call
Wait Time

Retries (displayed if you have selected IVR-based or Agent-based campaign types): Set the value for
the following four fields as “0” if you want to disable retry option for an existing IVR or agent based outbound
campaign.

The time duration for the below fields is calculated as the value entered for each field, plus or minus
the value entered for the Callback Time Limit field in the Add New Campaign web page.

Note
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DescriptionField

The time duration (in minutes) for which the dialer waits before calling back a
no-answer call.

Default value = 60 minutes.

No Answer Delay

The time duration (in minutes) for which the dialer waits before calling back a busy
telephone number.

Default value = 60 minutes.

Busy Signal Delay

• For IVR-based progressive and predictive outbound campaigns, if a customer
abandons a call, the time duration (in minutes) after which the dialer should call
the customer back.

• For agent-based progressive and predictive outbound campaigns, if a customer
or an agent abandons a call, the time duration (in minutes) after which the dialer
should call the customer back.

Default value = 0

Customer
Abandoned Delay

If the dialer abandons a call, the time duration (in minutes) after which the dialer
should call back the customer.

Default value = 0

Dialer Abandoned
Delay

Step 3 ClickAdd or Save to save the configuration changes.While saving a new or updated campaign, the Outbound
subsystem validates the Session values in the application and trigger pages based on following criteria, and
it might display an alert message to increase Session value in application and trigger pages:

• In case of a Progressive campaign, the outbound subsystem checks whether the Lines Per Port * Dedicated
Port for IVR-based campaigns and Lines Per Agent * Dedicated Agent for agent-based campaigns is
greater than the minimum of the Session value in application and trigger.

• In case of a Predictive campaign, the outbound subsystem checks whether the maximum Lines Per Port
* Dedicated Port for IVR-based campaigns and maximum Lines Per Agent * Dedicated Agent for
agent-based campaigns is greater than minimum of the Session value in application and trigger.

You should increase the Session values in the application and trigger to the suggested value in the alert message
to reduce the number of abandoned calls in an Outbound campaign.

Once you create a campaign, you need to import contacts for the campaign.
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Import Contacts for Campaign

Cisco recommends that you import a total of 10,000 contacts for a campaign at any given time. If you
wish to import more contacts, import them in chunks of 10,000 contacts. You can have a total of 1 million
remaining contacts for a campaign.

Attention

To import additional contacts, ensure that the total count of additional and remaining contacts for a campaign
does not exceed 1 million. The import process is rejected if the total count is greater than 1 million. Import
contacts using a comma-separated plain text file with .txt extension. The contacts file should be ASCII-encoded
or UTF-8 encoded if it contains special characters (for example, if the contact names are in Chinese, Russian,
Japanese and so on).

When contacts are imported, the contact's text file is checked for duplicate entries. If the phone01 value of a
contact matches the phone01, phone02, or phone03 values of another contact in the contacts list being imported,
then the previous contact is overwritten with the new contact.

You must verify all the contacts against the national do_not_call list before importing them.Caution

In this guide, the underscore character linking each word differentiates the national do_not_call list from
the Outbound subsystem's Do Not Call list.

Note

Each time contacts are imported, they are appended to the existing list of contacts for the selected campaign.
If the new list contains a contact with the same phone01 value as the phone01, phone02, or phone03 value,
or the same phone02 value as the phone01, phone02, or phone03 value, or the same phone03 value as the
phone01, phone02, or phone03 value, of an existing contact, the existing contact is overwritten with the
new contact information. The call history for the contact (if any) is retained.

Tip

To import contacts for a selected campaign, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > Campaigns.
The Campaigns web page opens, displaying the details of existing campaigns.

Step 2 Click the hyperlink below the Name column for the campaign for which you want to import the contacts.
The Campaign Configuration web page opens for the selected campaign.

Step 3 Click Import Contacts. The Import Contacts web page opens.
Step 4 Specify a file name to import the contacts from the fields being imported.

A contact list can contain up to 7 fields:

• AccountNumber - The account number of a contact. The account number can be a maximum length of
25 characters.
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• FirstName - The first name of a contact. The first name can be a maximum length of 50 characters.

• LastName - The last name of a contact. The last name can be a maximum length of 50 characters.

• Phone1 - The phone number for the contact. This field can be 28 characters long and must be a valid
phone number. Phone1 is mandatory and must be specified.

• Phone2 - The phone number for the contact. This field can be 28 characters long and must be a valid
phone number.

• Phone3 - The phone number for the contact. This field can be 28 characters long and must be a valid
phone number.

• DialTime - The time to dial a number for individual contacts on the current date. The format to be used
for this field is HH:MM. For example, to specify the dialing time as 08:25 am, the dial time field value
should be 08:25 and for 03:45 pm, the dial time field value should be 15:45. This field is applicable only
for UCCX Agent Preview campaigns.

Step 5 Navigate to the directory that contains the imported fields in the same order as they appear in the text file.

Allow Duplicate Contacts: Selecting this option will allow duplicate contacts from a particular file to be
imported or from an already imported file. By default this option is unchecked.

What to Do Next

While uploading outbound contacts in a HA over WAN deployment of Unified CCX, if all the contacts that
are being uploaded exist in the database and are being modified, follow these guidelines to avoid long delays:

• Upload the contacts during non-peak hours.

• Upload in batches of 500 contacts or less.

Enable Campaigns
You must verify that the configured campaigns are active and that the start and end times for the enabled
campaigns are specified as required.

To verify the state of the required campaign, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > Campaigns.
The Campaigns web page opens, displaying following information for the existing campaigns:

DescriptionField

Name of the campaign.Name

Start Time and End Time fields indicate the time range during which the campaign
runs.

Start Time/End Time
(hh:mm) AM PM
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DescriptionField

The Remaining Contacts field indicates the number of contacts that are yet to be
dialed for each campaign. In addition to the contacts that have not been dialed, this
number also includes contacts that have requested a callback and contacts that will
be tried again because of unsuccessful prior attempt(s) (for example, the contact
was busy or unavailable). A detailed breakdown of the pending contacts is provided
in the Printable Reports page for each campaign.

Remaining Contacts

The Enabled field indicates to the Outbound subsystem whether this campaign is
currently active.

Enabled

Denotes whether a specific campaign is IVR-based or Agent-based. The existing
campaigns will be marked as Agent-based after an upgrade.

Campaign Type

Click Delete icon next to the name of the campaign that you want to delete.Delete

Step 2 Verify that the Enabled field is set to TRUE and that the start and end times are specified as required.

Outbound Subsystem and Time Detection
The Outbound subsystem uses the area code of a contact's phone number to determine the time zone of the
contact's calling area. The contact's phone number can also be in E.164 format.

The subsystem provides the mapping for North American area codes to their corresponding time zones. The
default North American area codes are used to determine the time zone for phone numbers that are not in the
E.164 format (for example, 234-567-8900). The Area Codes web page allows you to add, modify, and delete
any area-code-to-time-zonemapping. Some area codes extend across multiple time zones. For such area codes,
you can edit the default time zone for that area code and specify a different one, if required.

Changes to area codes take affect the next time you import contacts. For example, if the time zone of area
code 603 is changed from 16 to 17, contacts already present in the system that have an area code of 603
continue to have the GMT Offset of 16. Any contacts with area code 603 that are imported after the area code
change have 17 for the GMT Offset.

When Outbound contacts are imported into the database, all contacts are assigned a GMT time zone for the
three phone numbers provided. The Outbound subsystem determines this GMT time zone by extracting the
area code of each phone number and checking it against the Area Codes table to obtain the corresponding
time zone. If the area code cannot be matched, the Outbound subsystem uses the local time zone and Daylight
Savings Time (DST) setting of the server. The Outbound subsystem also considers the DST to determine if
an Outbound contact can be called at a given time.

The Outbound subsystem ensures that the contacts are dialed at valid times. For Outbound contacts which
have been scheduled for callback, the scheduled callback time is converted to GMT time zone and stored in
the callbackDateTime field in the database.

For pending records, the Outbound subsystem ensures that Outbound contacts are called only within the
Customer Dialing Time Range (hh:mm) detected by the MinCustomerDialTime and MaxCustomerDialTime,
as per federal regulations. You can configure this time in the Unified CCX Administration GUI.
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Add Area Codes

Area code and long distance prefix configuration changes made to the Outbound subsystem do not take
effect for calls/contacts currently in the Outbound subsystem's memory. For example, if you change the
long distance prefix or local area code, the contacts already in the Outbound subsystem's memory will
continue to use the old long distance prefix and local area code.

Caution

The Outbound subsystem provides all of the mappings fromNorth American area codes to their corresponding
time zones at the time of product release. The Area Codes page allows the administrator to add, modify, and
delete any area-code-to-time-zone mappings.

Some area codes extend across multiple time zones. For such area codes, an administrator can edit the default
time zone for that area code and specify a different one, if required.

The Area Codes Management page allows users to find, add, delete, and modify the mapping of area codes
and time zones. The Outbound subsystem uses the area code of a contact's phone number to determine the
time zone of the contact's calling area. This page can also be used for adding international area codes.
International area codes must include the country code and the city code.

To add an area code, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > Area Codes.
The Area Codes Management web page opens.

Step 2 In the Area Code field, specify a unique identifier for the area code. This field can have any numeric value,
including 0 or leading zeros. This is a mandatory field.

Step 3 Click the Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add
New button that is displayed at the bottom of the window.
The new Area Code information is updated.

Call Status Values
For each contact, the call statuses and their corresponding values are recorded in the database and described
in the following table:

DescriptionValue (stored
in database)

Call Status

The call is pending. This is the initial state for all records.1Pending

The record was retrieved by the Outbound subsystem for dialing.2Active

The record is closed (not dialed).3Closed
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DescriptionValue (stored
in database)

Call Status

The record is marked for a callback.4Callback

Maximum attempts have been reached for this record (considered closed).5Max Calls

The record is redialed immediately whenever there is anymiss in the callbacks
for Retries with Delay.

6Retry

If the Outbound subsystem was restarted with records in the Active (2) state,
they are moved to this state.

7Unknown

The record is redialed as it was either busy, no answer, customer abandoned
or system abandoned. Retry time is set as per the corresponding configuration
in Unified CCX Application Administration web interface.

8Retries with
Delay

Contact States Reset at Midnight
The Outbound subsystem performs the following actions at midnight:

• The DialingListConfig records with a call status of Unknown are reset to Pending.

Outbound contacts with a call status of Unknown indicate that the these contacts were
retrieved from the database but the system went down before they could be dialed out.

Note

• Missed callback records (dialingListConfig records that have call status callback and a callBackDateTime
smaller than the current time) are updated depending on the missed callback action configured in the
Unified CCX Administration GUI.

◦MissedCallbackAction: Reschedule (for the same time on the next business day)

◦MissedCallbackAction: Retry (sets the call status to Retry and retries at the start of next business
day)

◦MissedCallbackAction: Close (sets the call status to Closed)

◦Dialing list records with a call status of Closed or Max_Calls are moved to a separate historical
data table

The records marked as closed todaywill be moved the next day at midnight. For example,
the records closed on 4th June will be moved on 5th June at midnight.

Note

◦Dialing list records with a call result of Do Not Call are not deleted, as these records are exported
to a text file.
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• The DialingListConfig records with a call status of “Retries with delay” and which could not be retried
due to lapsed time are marked for immediate retry at midnight.

•When the Unified CCX engine goes from offline to online (for example, the standby server becomes
active [online] if the active [first] server fails), the dialing list records with a status of Unknown are reset
to Pending.

Call Result Values
For each contact, the call results (as marked by the agent on Finesse or automatically deleted by the system)
and their corresponding values are recorded in the database and described in the following table:

DescriptionValue (stored
in database)

Call Result

Customer answered and was connected to agent.1Voice

Fax machine or modem detected.2Fax

Answering machine detected.3Answering machine

Number reported as invalid by the network.4Invalid

Number successfully contacted but wrong number.6Wrong Number

Number successfully contacted but reached the wrong person.7Customer Not Home

Customer requested callback.8Callback

Agent skipped or rejected the preview call.9Agent Rejected

Agent skipped or rejected the preview call with the close option
(not dialed).

10Agent Closed

Busy tone detected.11Busy

Agent did not respond to the preview call within the time out
duration.

You can configure the time out duration using the Preview
Call Timeout field detailed in the Configure General
Outbound Properties.

Note

12Ring No Answer

This value should not be written to the database; this is for internal
use only.

13Callback Failed

Callback missed and marked for Retry.14Callback Missed

Customer phone timed out either due to Ring No Answer (RNA)
or Gateway failure.

15Timeout
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DescriptionValue (stored
in database)

Call Result

Call was abandoned because IVR port was unavailable or Unified
CCX failed due to transfer the call to the IVR port.

16Call Abandoned

Call failed due any one of the following reasons:

• Dialer asked the Gateway to cancel a call that has not yet
been placed

• Gateway has declined the call

• Gateway is down or Gateway has timed out while placing
the call

• Gateway failure or configuration issues at the Gateway.

17Call Failed

Customer abandoned as customer disconnected the call within the
time limit as configured in “Abandoned CallWait Time” in Unified
CCX Application Administration web interface.

18Customer Abandoned

Reclassification Status Behavior
When the Outbound contacts are imported into the database from the Unified CCX Administration GUI, the
call status column in the Dialing List table is assigned the default value of 1 (Pending), indicating that these
Outbound contacts are yet to be dialed. When the Outbound subsystem retrieves a batch of contacts from the
database, the call status is set to 2 (Active). After a call is placed to the Outbound contact, the call status is
set to 3 (Closed) and the call result is set to 1 (Voice), as all Outbound calls are classified by the agent desktop
as voice by default. If the agent clicks the reclassification button on the agent desktop and reclassifies the call
as answering machine/fax/busy/invalid or selects the callback button and schedules a callback, the Outbound
subsystem updates the call result field accordingly and, based on the call result, it also updates the call status.

The following table describes the relationship between call status and call result values and the resulting
behavior of the system. The values in brackets are the actual values stored in the database.

The following information is applicable only for Preview Dialer.Note

BehaviorCall StatusCall Result

This contact is not dialed again.Closed (3)Voice (1)

This contact is retried, using a different phone number provided
for this contact. If alternate phone numbers are not available, the
call status is closed.

Retry (6)Fax (2)

This contact is retried, with the same phone number as before.Retry (6)Answering machine (3)
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BehaviorCall StatusCall Result

This contact is retried, using a different phone number provided
for this contact. If alternate phone numbers are not available, the
call status is closed.

Retry (6)Invalid (4)

This contact is not dialed again.Closed (3)Do Not Call (5)

This contact is retried, using a different phone number provided
for this contact. If alternate phone numbers are not available, the
call status is closed.

Retry (6)Wrong Number (6)

Retry (6)CustomerNotHome (7)

This contact is dialed again using the number stored in the
callbackNumber column, at the time stored in callbackDateTime
column.

Callback (4)Callback (8)

This contact is presented to another agent.Active (No
change)

Reject or Skip (9)

This contact is not dialed again.Closed (5)Reject-Close or
Skip-Close

This contact is retried, with the same phone number as before.Retry (6)Busy

The call status is set to 5 (Closed) when the Outbound contact is no longer dialed for this campaign. This
happens when a call was successfully placed (call result is voice) and also when an agent selects Skip-Closed,
Reject-Closed, or Do Not Call. This also happens automatically if the system reaches the maximum attempts
limit for an Outbound contact, which means that the system tried dialing the Outbound contact the maximum
number of times configured in the Unified CCX Administration GUI.

Call Retrieval Priority
While retrieving Outbound contacts from the database, records that have scheduled callbacks have priority
as the callback time must be adhered to. Outbound contacts are retrieved in the following order of priority:

• Priority 1—Outbound contacts with scheduled callback (call status = 4) and the current time is within
the CallbackTimeLimit configured on the Campaigns page (default value is15 minutes) of the scheduled
callback time.

• Priority 2—Outbound contacts to be retried after a specific delay. This is not applicable for direct preview
campaigns (call status = 8).

• Priority 3—Outbound contacts in the Pending state (call status = 1).

• Priority 4:—Outbound contacts in the Retry state (call status = 6).
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Failover and System Restarts
Outbound contacts with an Active call status during a failover indicate that these contacts were retrieved from
the database but the system went down either before they could be dialed or after they were dialed but before
the call status and call result columns were updated. When the system restarts, the call status for all such
Outbound contacts is changed to 7 (Unknown). All Outbound contacts in the Unknown state will be reset to
the Pending state (should be retrieved for dialing again) at midnight every night.

If there is an Outbound call in progress during a failover, they cannot be dialed again, as the call status is set
to Closed as soon as an Outbound call is placed and these records will not be retrieved for dialing again when
the system comes back. However, if the failover happened before the system could update the call status to
Closed, these records remain in the Active state and are marked Unknown so they transition to Pending state
after midnight. Once they are in the Pending state, they will be dialed again.
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C H A P T E R  13
Cisco Unified Contact Center Express Supervisor
and User Options Plug-Ins

The following sections provide detailed information on the additional plug-in options provided by the Unified
CCX.

• About User Management, page 239

• About Unified CCX User Capabilities, page 239

• Unified CCX Supervisor Web Interface, page 241

• Unified CCX User Options Web Interface, page 242

About User Management
In earlier versions of Unified CCX, many user parameters like user ID, password, and pin were configured
from the Unified CM Administrator. Some Unified CCX-related user parameters were configured through
the Unified CCX Administration.

In Unified CCX, all Unified CCX user roles (capabilities) are consolidated into one User Configuration area.

The Unified CM user details are stored in the Unified CM database.

About Unified CCX User Capabilities
The capability for each user refers to the Unified CCX access level assigned for each user. Unified CCX users
can be assigned to one of the following four roles (or capabilities):

• Administrator

• Supervisor

• Historical Report User

• Agent

Each of these roles are described in this section.
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Administrator Privileges
A Unified CCX Administrator is a user with complete access to the Unified CCX Administration and has the
authority to configure the entire system. An Administrator can also be assigned a combination of other roles.

The Administrator can turn on/off the authority of a Supervisor to manage the teams and agents.

Supervisor Privileges
Supervisors can additionally modify and view skills, view the list of all teams for which this user is the
supervisor, view the skills, CSQs, and resource groups configured in this system, view and manage resources,
and configure the teams that they are to manage.

Unified CCX provides three types of supervisors:

• Application Supervisor: A basic supervisor role applicable to a Unified CCXApplication serverwithout
a Unified CCX license. An application supervisor can only view reports.

• ACD Supervisor: A supervisor with an agent role. This role is applicable to a Unified CCXApplication
server with any Unified CCX license. An ACD supervisor can administer teams/agents and also view
reports. Thus Unified CCX enables dynamic reskilling, the ability by which an ACD supervisor can add
or remove skills from an agent without an administrator privilege.

Depending on the license allowed, Unified CCX Supervisors have the following privileges:

• View reports through Unified Intelligence Center web client.

• View agents and CSQ being monitored. This is only for a remote Supervisor.

• View the list of all teams for which this user is the Supervisor.

• Configure the teams managed by the Supervisor.

• View the skills, CSQs, and Resource Groups configured in this system.

The RmCmmenu can be viewed by the Supervisor only when any of the following two options are selected
as the parameter value for the Supervisor Access field located in System > System Parameters >
Application Parameters:

- Access to all Teams

- Access to Supervisor's Teams only

Note

• View and manage all the resources.

Historical Report User Privileges
A user with a historical report role can view various historical reports. The number and types of reports allowed
to be viewed depends on the licenses available on a given Unified CCX system.
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Agent Privileges

An agent capability is only available with a Unified CCX license.Note

Unified CM users in Unified CCX are assigned an agent role when an agent extension is associated to the
user in the Unified CM User Configuration page. Consequently, this role can only be assigned or removed
for the user using Unified CM Administrator End User Configuration web page. These users can not be
assigned or removed in Unified CCX Administration.

Unified CCX Supervisor Web Interface
Use the Unified CCX Supervisor web page to:

• View and monitor permitted agents

• View and monitor permitted CSQs

• Access real-time reports, tools, and settings

Access Unified CCX Supervisor Web Page
To access the Unified CCX Supervisor web page, perform the following steps:

Procedure

Step 1 Ensure supervisor capability is assigned to the user designated as supervisor (see Supervisor Privileges and
User View Submenu).

If the supervisor is assigned administrator capability as well, the Unified CCXAdministration window
is opened instead of the Supervisor web page.

Note

Step 2 From a web browser on any computer on your network, enter the following case-sensitive URL:

https://<servername>/appadmin

In this example, replace <servername> with the hostname or IP address of the required Unified CCX server.

If you have already accessed the Unified CCX Administration application or Supervisor web page in
the browser, be sure to logout from the current session using Logout link displayed in the top right
corner of any Cisco Unified CCX Administration web page or System > Logout and login with
respective user credentials.

Tip

The Unified CCX Supervisor web page appears.
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Unified CCX User Options Web Interface
Use the Unified CCX User Options web page to perform:

• Unified CCX downloads

• Alternate pronunciations for call by name

• Access the Unified CM User web page

Access Unified CCX User Options Web Page
To access the Unified CCX User Options web page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration, enter http://<Cisco Unified CCX IP address>/appuser.
Step 2 If prompted to do so, enter your User ID and Password.

The Unified CCX User Options web page appears.

Step 3 When finished, click Logout.

Add Alternative Pronunciations
Alternative Pronunciations for Call by Name is an independent feature located on the Unified CCX User
Options Welcome web page. This feature lets you add one or more alternate pronunciations for your first or
last name and is useful if callers might refer to you by more than one name. For example, if your first name
is Bob, you might add the alternate pronunciations “Bob” and “Bobby”. Similarly, if your last name is Xhu,
you might add the alternate pronunciation “Xhu”.
To access the Alternative Pronunciations for Call by Name web page, perform the following steps:

Procedure

Step 1 In the Cisco Unified CCX User Options Welcome web page, choose User Options > Alternative
Pronunciations for Call by Name.
The Alternate Pronunciations web page appears.

Step 2 In the First Name field, you can enter an alternate pronunciation of your first name. For example, if your name
is “Mary,” you might enter “Maria.”

Step 3 Click Add>>.
The name moves to a list of alternate first name pronunciations.

Step 4 Repeat Steps 2 and 3 as needed to add other alternate pronunciations.
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To remove an alternate pronunciation for your first name, click the alternate pronunciation and then click
Remove.

Step 5 In the Last Name field, you can enter an alternate pronunciation of your last name. For example, if your last
name is “Smith,” you might enter “Smitty.”

Step 6 Click Add>>.
The name moves to a list of alternate last name pronunciations.

Step 7 Repeat Steps 5 and 6 as needed to add other alternate pronunciations.
To remove an alternate pronunciation of your last name, click the alternate pronunciation and then click
Remove.

Step 8 Click Save to apply the changes.

Access Unified CM User Options Page
To access the Unified CM User Options web page, perform the following steps:

Procedure

Step 1 In the Unified CCXUser OptionsWelcomeweb page, chooseUser Options >Cisco Unified CMUser Page.
The Unified CM User Options Log On dialog box appears.

Step 2 Enter your Unified CM user ID and password, and then click Log On.
The Unified CM User Options web page appears.

Step 3 Click the option you want.
Step 4 When finished, click Logout.

Cisco Unified CCX Administration Guide, Release 11.0(1)    
243

Cisco Unified Contact Center Express Supervisor and User Options Plug-Ins
Access Unified CM User Options Page



   Cisco Unified CCX Administration Guide, Release 11.0(1)
244

Cisco Unified Contact Center Express Supervisor and User Options Plug-Ins
Access Unified CM User Options Page



C H A P T E R  14
System Menu

The Systemmenu of the Unified CCXAdministration system provides options for performing system-related
tasks. Depending on the product package you purchased, the System menu contains some or all of the
following menu options:

• Access Server Menu, page 245

• Unified CM Configuration, page 247

• Recording Configuration, page 247

• Custom File Configuration, page 248

• Standalone Cisco Unified Intelligence Center Configuration, page 248

• License Information, page 248

• Language Information, page 249

• Logout Menu, page 250

Access Server Menu
Choose System > Server from the Cisco Unified CCX Administration menu bar to access the List Servers
web page. Use the List Servers web page to view, add, remove, and view servers in the cluster.

Before installing Unified CCX on the second node, you must configure the second server using this
procedure. Installation of second node will fail if you do not perform this configuration.

Note

To view, modify, or delete the server configuration information of any server, click the respective hyperlink
in the Host Name/IP Address field. The Server Configuration web page opens to display Host Name/IP
Address, IPv6 Address (for dual IPv4/IPv6), MAC Address, and Description of the server. Update the values
in the fields and click Save to save the changes. Click Delete to delete the configuration information of a
server.
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You cannot delete the publisher.Note

Configure Server
To configure a new server that needs to be added to form a Unified CCX cluster for a High Availability setup,
complete the following steps.

Procedure

Step 1 Click the Add New icon in the toolbar in the upper left corner of the List Servers web page or the Add New
button at the bottom of the List Servers web page to add the new server.
The Server Configuration web page appears.

Note • TheAddNew button is disabled when two servers are added to the cluster in a High Availability
setup.

• A warning message appears when you click the Add New button without having a High
Availability license.

Step 2 Complete the following fields:
DescriptionField

Hostname or IP address of the server that you want
to add.

Host Name/IP Address

IPv6 address of the server that you want to add.
This field is required only when IPv6 is
enabled on the Unified CCX server.

Note
IPv6 Address (for dual IPv4/IPv6)

MAC address of the server that you want to add.MAC Address

Description of the server that you want to add.Description

Step 3 Click Add to add details of the new server.

Configure IPv6 Address
Follow this procedure to configure IPv6 addressing.

Procedure

Step 1 On the List Servers page, click on the server name link to edit the server details.
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The Server Configuration web page opens.

Step 2 Enter the IPv6 address or remove it in the IPv6 Address (for dual IPv4/IPv6) field.
Step 3 Click Save to add the IPv6 address.

What to Do Next

Login to Cisco Unified CCX Serviceability page and click Tools>Control Center - Network Services.
Restart the Cisco Unified Intelligence Center Reporting service.

Eventhough the CTI ports are registered with dual stack or only with IPv6, this is displayed as IPv4 in the
Call Manager.

Note

Unified CM Configuration
Use the Unified CM Configuration web page to update the following information:

• AXL authentication

• Unified CM Telephony subsystem

• RmCm Provider configuration from within Unified CCX.

Choose System > Unified CMConfiguration from the Unified CCX Administration menu bar to access the
Unified CM Configuration web page.

Recording Configuration
Use the Recording Configuration web page to configure the host names, user name, and password to connect
to the recording server such as Cisco MediaSense.

Youmust configure recording server details in Unified CCX so that supervisors can search and play recordings
based on various filter criteria.

Choose System > Recording Configuration from the Unified CCX Administration menu bar to access the
Recording Configuration web page.

This web page displays currently configured recording server details.

User name must be a MediaSense API user. API user name is a Unified CM end user, who is configured
in Cisco MediaSense as a MediaSense API user.

Note

For information about Cisco MediaSense API User Configuration, see MediaSense Installation and
Administration guide at http://www.cisco.com/en/US/products/ps11389/tsd_products_support_series_home.html
.
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Custom File Configuration
Use the Custom Classes Configuration web page to specify the classpath for custom classes.

Choose System >Custom File Configuration from the Unified CCX Administration menu bar to access the
Custom Classes Configuration area.

Restart Unified CCX engine and Unified CCX administration services to use the custom files in scripts.Note

Standalone Cisco Unified Intelligence Center Configuration
To access the Cisco Unified Intelligence Center standalone configuration webpage, perform the following
steps:

Procedure

Step 1 Click System > Standalone CUIC configuration for configuring standalone CUIC.
Step 2 Enter FQDN (Fully Qualified Domain Name), DataSource Name, Username, and Password of standalone

CUIC.
Step 3 Click Save.

A Status message will be displayed.
Asterisk (*) indicates the required fields.
If the configuration is successful, a status message will be displayed. If the configuration is not
successful, an error message will be displayed. This can be due to:

Note

• An error in input validation (DataSource Name, Username or Password).

• A failure in connectivity between the CUIC and the Unified CCX servers.

The user name of the data source configured in standalone Cisco Unified Intelligence Center will be
modified to uccxhrc after a Unified CCX failover. This is an expected behavior and will not have any
impact on the execution of reports from standalone Cisco Unified Intelligence Center.

Note

License Information
Use the License Information web pages to display the cluster licensing information and to upload additional
licenses.

Choose System > License Information > Add License(s) or Display License(s) from the Cisco Unified
CCX Administration menu bar to access the License Information web pages.
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Add Licenses
From the Unified CCX Administration menu bar:

Procedure

Step 1 Choose System > License Information > Add License(s).
The License Information web page displays.

Step 2 In the License File field, enter the path for the license file or click Browse to locate the license file. Select the
required license file and click Open.
Use this page to specify a license file and upload it to Unified CCX.

Display Licenses
From the Unified CCX Administration menu bar:

Procedure

Choose System > License Information > Display License(s).
The License Information web page opens, displaying the details of the Configured License such as the license
type, number of IVR ports, number of seats, maximum number of agents, and so on.

The License Information page displayed on click ofDisplay License(s)menu option will also specify
the expiry date in case of time-bound licenses.

Note

For Unified CCX, if you have a premium license with an outbound license, this web page will display:

• The number of licensed IVR ports and dedicated IVR ports for IVR outbound.

• The number of licensed agent seats and concurrent agent seats for progressive and predictive agent
outbound.

The number of In Use IVR ports and In Use agent seats are displayed only for the master
node.

Note

Language Information
Customized Unified CCX languages such as American English, Canadian French, and so on are installed with
Unified CCX.

Use the Languages Configuration web page to:

• Enable languages that can be used to play prompts and grammars through Cisco Unified IP IVR.
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Choose System > Language Information from the Cisco Unified CCX Administration menu bar to access
the Languages Configuration web page. The Languages Configuration web page opens to display the following
fields and buttons.

DescriptionField

IVR Language Configuration

Language that you wish to use with Unified IP IVR. You can select the language from
the drop-down list. You can also specify the group and country-specific information
for the language by selecting the desired radio button and check box respectively. Some
languages have only one choice. US English (en_US) is the default.

Language

Default IVR Language Configuration

System default language setting, which could be either one of the selected IVR languages
or country-specific or a user-defined language entered using the Edit button. This is a
mandatory field and you can choose from the drop-down list. Click Edit to add a new
Language option.

Default: English (United States) [en_US]

Default Language

Logout Menu
To exit Unified CCXAdministration without closing your web browser, you can perform one of the following:

• Choose System > Logout from the Unified CCX Administration menu bar.

• Click the Logout link displayed in the top right corner of any Cisco Unified CCX Administration web
page.

The system logs you out of Unified CCX and displays the Unified CCX Authentication web page.

You can also exit Unified CCX Administration by closing your web browser.Note
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C H A P T E R  15
Applications Menu

The Applications menu on the top contains the following menu options:

• Application Management—to add, configure, copy, delete, or refresh a specific application

• Script Management—to add a new script and to view, refresh, upload, or delete an existing script

• Prompt Management—to display, modify, or delete existing prompts, and to add new prompts

• GrammarManagement—to display, modify, or delete existing grammars, and to add new grammars

• DocumentManagement—to display, modify, or delete existing documents, and to add new documents

• AARManagement—to upload AAR files to Unified CCX

The following sections describe the menu options:

• Access Application Management Menu, page 251

• Manage Scripts, page 252

• Prompt Management, page 252

• Grammar Management, page 253

• Document Management, page 253

• AAR Management, page 254

Access Application Management Menu
TheApplicationManagement menu option in the Unified CCXAdministrationweb interface contains options
for configuring and managing the applications the Unified CCX system uses to interact with contacts and
perform a wide variety of functions.

To access the Application Management web pages, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Application Management.
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The Applications Configuration web page opens, displaying a list of applications that are currently configured
on your Unified CCX server.

Step 2 Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New
button that displays at the bottom of the window to add a new application. Add a New Application web page
opens.

Step 3 Select the type of application that you want to create from the Application Type drop-down list.

Manage Scripts
Use the Script Management web page to add a new script and to rename, refresh, or delete an existing script.
Unified CCX applications are based on scripts created in the Unified CCX Editor.

To create a new subfolder under the default folder, perform the following steps:

Procedure

Step 1 To access the Script Management web page, choose Applications > Script Management from the Unified
CCX Administration menu bar.
The Script Management web page opens, displaying the default directory that contains the scripts uploaded
to the repository.

Step 2 Click the Create New Folder icon that displays in the toolbar in the upper left corner of the window or the
Create New Folder button that displays at the bottom of the window.
The Create New Folder dialog box opens.

Step 3 Enter a name of the new subfolder in the Folder Name field and click Create.
Once the folder is successfully created, the dialog box refreshes with the following message:

Folder successfully created

Step 4 Click the Return to Script Management button to return to the default folder's updated Script Management
page. You can create any number of folders within the default folder.

Prompt Management
Several system-level prompt files are loaded during Unified CCX installation. However, any file you create
must be made available to the Unified CCX Engine before a Unified CCX application can use them. This is
done through the Unified CCX cluster's Repository datastore, where the prompt files are created, stored, and
updated.

You can use a custom script or the Unified CCX Administration to upload a prompt.Note
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To access the Prompt Management page, choose Applications > Prompt Management from the Unified
CCX Administration menu bar.

The Prompt Management web page contains the following icons and buttons:

• Create Language—Click theCreate Language icon that displays in the toolbar in the upper left corner
of the window or the Create Language button that displays at the bottom of the window to create a
new language folder.

• Upload Zip Files—Click the Upload Zip Files icon that displays in the toolbar in the upper left corner
of the window or the Upload Zip Files button that displays at the bottom of the window to upload a
new prompt or zip file.

SeeManage Prompt Files section to know more about the different fields in this page and how to rename,
refresh, or delete existing prompts.

Grammar Management
Several system-level grammar files are loaded during Unified CCX installation. However, any file you create
must be made available to the Unified CCX Engine before a Unified CCX application can use them. This is
done through the Unified CCX cluster's Repository datastore, where the grammar files are created, stored,
and updated.

To access the GrammarManagement page, chooseApplications >GrammarManagement from the Unified
CCX Administration menu bar.

The Grammar Management web page contains the following icons and buttons:

• Create Language—Click theCreate Language icon that displays in the toolbar in the upper left corner
of the window or the Create Language button that displays at the bottom of the window to create a
new language folder.

• Upload Zip Files—Click the Upload Zip Files icon that displays in the toolbar in the upper left corner
of the window or the Upload Zip Files button that displays at the bottom of the window to upload a
new grammar or zip file.

Document Management
Several system-level document files are loaded during Unified CCX installation. However, any file you create
must be made available to the Unified CCX Engine before a Unified CCX application can use them. This is
done through the Unified CCX cluster's Repository datastore, where the document files are created, stored,
and updated.

To access the DocumentManagement page, chooseApplications >DocumentManagement from the Unified
CCX Administration menu bar.

The Document Management web page contains the following icons and buttons:

• Create Language—Click theCreate Language icon that displays in the toolbar in the upper left corner
of the window or the Create Language button that displays at the bottom of the window to create a
new language folder.
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• Upload Zip Files—Click the Upload Zip Files icon that displays in the toolbar in the upper left corner
of the window or the Upload Zip Files button that displays at the bottom of the window to upload a
new document or zip file.

AAR Management
Use the AAR Management web page to upload an AAR file to Unified CCX.

To access the AAR Management web page, choose Applications > AARManagement from the Unified
CCX Administration menu bar. The AAR Management web page appears.
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C H A P T E R  16
Subsystems Menu

The Subsystems menu of the Unified CCX Administration web interface provides access to the subsystems
that are licensed for your Unified CCX system.

The Unified CCX system uses subsystems for communicating with other services. Depending on the Unified
CCX package you have installed, the Subsystems menu may contain some or most of the following menu
options:

• Cisco Unified CM Telephony—to enter Unified CM Telephony provider information, Computer
Telephony Interface (CTI) port group information, Unified CM Telephony trigger information, and to
resynchronize Unified CM Telephony information.

• RmCm—to set up your Unified CCX resources.

• Chat / Chat and Email—allowsUnified CCX to configure andmanage chat and email CSQs, configure
mail server and SocialMiner, predefined responses for chat and email, channel parameters, chat widget
list, and teams.

• Outbound—to configure contact centers for automated outbound activities.

• Database—to configure the Unified CCX system to communicate with database servers.

• HTTP—to configure the Unified CCX Engine to respond to requests from a variety of web clients,
including computers and IP phones.

• eMail—to configure the Unified CCX Engine to communicate with your email server and enable your
applications to create and send email.

• CiscoMedia—to configure Cisco Media Termination (CMT) dialog groups that can be used to handle
simple Dual-Tone Multi-Frequency (DTMF) based dialog interactions with customers.

•MRCPASR—to configure theMRCPAutomated Speech Recognition (ASR) subsystem, which allows
users to navigate through a menu of options using spoken responses to prompts.

•MRCP TTS—to configure the MRCP Text-to-Speech (TTS) subsystem, which converts plain text
(UNICODE) into spoken words to provide a user with information or to prompt a user to respond to
an action.

• Unified CM Telephony Menu, page 256

• RmCm Menu, page 259

• Chat and Email Menu Options, page 262
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• Outbound Menu, page 274

• Database Menu, page 279

• HTTP Menu, page 282

• eMail Menu, page 283

• Cisco Media Menu, page 283

• MRCP ASR Menu, page 283

• MRCP TTS Menu, page 284

Unified CM Telephony Menu
The Unified CCX system uses the Unified CM Telephony subsystem of the Unified CCX Engine to send and
receive call-related messages from the Unified CM Computer Telephony Interface (CTI) Manager.

To access the Unified CM Telephony Configuration web pages, choose Subsystems > Cisco Unified CM
Telephony from the Unified CCX Administration menu bar.

The Unified CM Telephony Configuration menu contains the following submenu options:

• Unified CM Telephony Provider—Choose this option to enter Unified CM Telephony provider
information.

• Unified CM Telephony Call Control Group Configuration—Choose this option to configure CTI
port groups for applications.

• UnifiedCMTelephonyTriggerConfiguration—Choose this option to configureUnified CMTelephony
triggers for applications.

• Data Synchronization—Choose this option to check and synchronize data components like Unified
CM Telephony Users (JTAPI Application Users), Unified CCX Triggers/Route points, and Call Control
Groups between Unified CCX and Unified CM.

• Cisco JTAPI Resync—Choose this option to resynchronize Cisco JTAPI Client versions.

• Advanced Settings—Choose this option to configure advanced settings for the Cisco Unified CM
Telephony client.

Unified CM Telephony Provider Configuration
To access this configuration area, choose Subsystems > Cisco Unified CM Telephony > Provider from the
Unified CCX Administration menu bar. The Cisco Unified CM Telephony Provider web page opens.

Use the Unified CMTelephony Provider Configurationweb page to view andmodify the primary and secondary
location of your Unified CM Telephony provider, and user prefix.

Unified CM Telephony Call Control Group Configuration
Choose Subsystems > Cisco Unified CM Telephony > Call Control Group from the Unified
CCX Administration menu bar to access the Unified CM Telephony Call Control Group list web page. Use
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the Unified CM Telephony Call Control Group Configuration web pages to display, add, modify, and delete
information about the call control group.

To add a new Unified CM Telephony Call Control Group, click the Add New icon or button on the Unified
CM Telephony Call Control Group Configuration web page.

To modify an existing Unified CM Telephony Call Control Group, click any hyperlink within the Ports List
table entry; the Cisco Unified CM Telephony Call Control Group Configuration web page opens.

Unified CM Telephony Triggers Configuration
Choose Subsystems > Cisco Unified CM Telephony > Unified CM Telephony > Triggers from the Cisco
Unified CCX Administration menu bar to configure Unified CM Telephony Triggers.

The Cisco Unified CM Telephony Trigger Configuration web page opens where you can view, add, modify,
and delete Unified CM Telephony triggers. To add a Unified CM Telephony trigger, click the Add New icon
or button. The Cisco Unified CM Telephony Trigger Configuration web page opens.

Synchronize Unified CM Telephony Data
From Unified CCX Release 9.0(1), you can configure the telephony data synchronization through a new web
page called Cisco Unified CM Telephony Data Synchronization.

The data synchronization process ensures that data components like Unified CM Telephony Users (JTAPI
Application Users), Unified CCX Triggers/Route points, and Call Control Groups between Unified CCX and
Unified CM are in sync, without any inconsistency.

Data Check displays whether the selected data components are in synch or not between Unified CCX and
Unified CM. If you find any inconsistency, click Data Resync to rectify the issue. To check and synchronize
the JTAPI data components between Cisco Unified CM and Cisco Unified CCX, perform the following steps:

It is important that you plan to perform this task during off peak hours to avoid hampering routine contact
center operations.

Caution

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco Unified CM Telephony >
Data Synchronization.
The Cisco Unified CM Telephony Data Synchronization page appears.

Step 2 Select one or more of the following three components by checking the corresponding check boxes:

• Call Control Group(s)

• Trigger(s)

• CM Telephony User(s)

Step 3 Click Data Check or Data Resync. Once you click Data Check or Data Resync, a confirmation message
dialog box appears prompting you to either proceed or cancel. Click OK to continue.

Cisco Unified CCX Administration Guide, Release 11.0(1)    
257

Subsystems Menu
Unified CM Telephony Triggers Configuration



Once you click OK in the confirmation message for Data Check or Data Resync, you will not be
allowed to cancel the process.

Note

Step 4 The Cisco Unified CM Telephony Data Synchronization web page continues to update until the Data Check
or Data Resync process is complete. On completion of the Data Check or Data Resync process, the result is
displayed in the same web page in a tree structure. The result for each selected component is displayed in
collapsed format with a tick mark if no mismatch is found. Click the arrow adjacent to each selected component
to expand and view the detailed results.
If any mismatch is found in the elements of the selected component, the results for those components are
displayed automatically in an expanded format.

If you had multiple device pools (for Call Control Groups) in your older versions of Unified CCX
setup, performing Data Resync after an upgrade would merge all multiple device pools to a single
default device pool. However, you can manually assign a different device pool to the Call Control
Group if the default device pool is not the intended one.

Note

Unified CM Telephony Cisco JTAPI Resync
Choose Subsystems > Cisco Unified CM Telephony > Cisco JTAPI Resync from the Cisco Unified CCX
Administration menu bar to resynchronize the JTAPI client version on the Unified CCX with the JTAPI
version on the Unified CM. You can view the status of Cisco JTAPI client resynchronization in this web page.

If the Unified CCX detects a mismatch, the system downloads and installs the compatible or JTAPI client
required installer version. Restart the Unified CCX Engine to view these configuration changes.

The JTAPI client update happens only on the local node and not on the second node in case of High Availability
deployment.

Unified CM Telephony Advanced Settings
Choose Subsystems > Cisco Unified CM Telephony > Advanced Settings from the Cisco Unified CCX
Administration menu bar to configure advanced settings for the Unified CM Telephony Client.

Use the Unified CM Telephony Advanced Settings web page to update the following information:

• Periodic Wakeup Interval (seconds): Select the check box before Enable Periodic Wakeup prior to
updating the existing value in this field.

• Queue Size Threshold: Select the check box before Enable Queue Stats prior to updating the existing
value in this field.

• CTI Request Timeout (sec)

• Provider Open Request Timeout (sec)

• Provider Retry Interval (sec)

• Server Heartbeat Interval (sec)

• Route Select Timeout (ms)

• Post Condition Timeout

• Use Progress As Disconnect
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Click theUpdate icon that displays in the toolbar in the upper left corner of the window or theUpdate button
that displays at the bottom of the window to save the changes. Restart the Unified CCX Engine to view these
configuration changes.

In case of High Availability deployment, the changes are propagated to the second node. If the second node
cannot be contacted, an alert message indicating that the update has failed on the remote node is displayed.

RmCm Menu
Use the RmCmConfiguration web page to configure skills groups, resources, resource groups, Contact Service
Queues (CSQs), and RM (Resource Manager) Unified CM Telephony providers. To access the Unified CCX
Configuration web page, choose Subsystems > RmCm from the Unified CCX Administration menu bar.

The RmCm menu contains the following submenu options:

• Skills—Click this submenu to create skills. This option is available only with the Unified CCXEnhanced
and Unified CCX Premium license packages.

• Resources—Click this submenu to assign a resource group and skills to agents.

• Resource Groups—Click this submenu to create resource groups.

• Contact Services Queues (CSQs)—Click this submenu to configure CSQs.

• RmCmProvider—Click this submenu to configure the RM (ResourceManager) Unified CMTelephony
provider for the RmCm subsystem.

• Assign Skills—Click this submenu to assign skills and a resource group to agents in bulk.

• Agent Based Routing Settings—Click this submenu to send a call to a specific agent, rather than to
any agent available in a CSQ.

• Teams—Click this submenu to create or associate teams with various agents, CSQs, and supervisors.

Skill Configuration
Use the Skills page to add, modify, or delete skill.

Choose Subsystems > RmCm > Skills from the Unified CCX Administration menu bar to access the Skills
summary web page.

Add New Skill
Use the Skill Configuration area to add a new skill name.

Procedure

Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New
button that displays at the bottom of the window to access the Skill Configuration area.
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Modify Skills
Click the required skill in the Skill name column on the Skill Configuration web page to access the Skill
Configuration area.

Procedure

Click the Open Printable Report of this Skill Configuration icon to view a list of the resources associated
with that skill.

Resources Configuration
Use the Resources Configuration area to assign a resource group, to assign skills to a resource, and to assign
an alias to the agent. When the agent is on chat, the alias of the agent is displayed to the customer.

To access this configuration area, choose Subsystems > RmCm > Resources from the Unified
CCX Administration menu bar. The main area of the Resources area of the Unified CCX Configuration web
page contains a list of resources (if configured).

Click theOpen Resources Summary Report icon to open the Resources Summary Report in a new window.
For each resource, this report lists the resource groups associated with the resource, the Unified CCX extension
of the resource, and the number of CSQs and team to which the resource is assigned.

Modify Resource
Use the Resource Configuration area to modify resource configuration.

To access the Resource Configuration area, click any of the required resource in the Resource area of the
Unified CCX Configuration summary web page.

Procedure

Click the Open Printable Report of this Resource Configuration icon to open a Resource Report for the
agent. The Resource Report lists each agent resource ID, resource name, Unified CCX extension, resource
group, automatic available status, skills, CSQs, and team.

Resource Group Configuration
Use the Resource Group Configuration web page to display and modify the names of existing resource groups
and to add new resource groups.

Choose Subsystems >RmCm >ResourceGroups from the Unified CCXAdministrationmenu bar to access
the Resource Groups web page.

Add New Resource Group
Use the Resource Configuration area to enter resource group name in the Resource Group Name field.
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Procedure

Add a new Resource Groups by clicking Add New icon or button in the Resource Group area of the Unified
CCX Configuration web page.

Modify Existing Resource Groups
Use the Resource Modification page to change or update the resource group name into the Resource Group
Name field.

Modify an existing Resource Group by clicking the required resource group in the Resource Groups area. In
the Resource Group Configuration area, change the Resource Group and update.

Procedure

Click theOpen Printable Report of this Resource Group Configuration icon to view a list of the available
resources for this resource group.

Contact Service Queues Configuration
Use the Contact Service Queues area of the Unified CCX Configuration web page to display existing CSQs,
delete a CSQ, and add a new CSQ.

To access the Contact Service Queues area, choose Subsystems > RmCm > Contact Service Queues from
the Unified CCX Administration menu bar.

Add a CSQ
Use the Contact Service Queues Configuration area to add a new CSQ.

To access the Contact Service Queues Configuration area, click the Add New icon or button in the Contact
Service Queues area of the Unified CCX Configuration web page.

To open the Contact Service Queue Report for the required CSQ, click the Open Printable Report of this
CSQ Configuration icon from the Contact Service Queues Configuration area.

RmCm Provider Configuration
Use the RmCmProvider area of the Unified CCXConfigurationweb page to identify the Unified CMTelephony
user for the Resource Manager.

Choose Subsystems >RmCm >RmCmProvider from the Unified CCXAdministration menu bar to access
the RmCm Provider web page.

Skills Configuration Assignment
Use the Assign Skills area of the Unified CCX Configuration web page to modify an existing resource group
and skill configuration or to assign new resource groups and skills to all or selected agents.
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Choose Subsystems > RmCm > Assign Skills from the Unified CCX Administration menu bar to access
this configuration area.

This web page also contains the following icons and buttons:

• Add Skill—to add new skills or resource groups to all or selected agents.

• Remove Skill—to remove skills of all or selected agents.

Add Skills
When you click the Add Skill button in the Assign Skills area of the Unified CCX Configuration web page,
the Add Skill area opens. Use the Add Skill area to add a resource group and skills to the selected agents.

Remove Skills
When you click the Remove Skill button in the Assign Skills area of the Unified CCX Configuration web
page, the Remove Skill area opens. Use the Remove Skill area to remove skills of all or selected agents.

Agent Based Routing Settings Configuration
Use the Agent Based Routing Settings area of the Unified CCXConfiguration web page to configure Automatic
Work and Wrapup Time.

Choose Subsystems >RmCm >Agent BasedRouting Settings from the Unified CCXAdministrationmenu
bar to access this configuration area.

Teams Configuration
Use the Teams area of the Unified CCX Configuration web page to create or associate teams with various
agents, CSQs, and supervisors.

Choose Subsystems > RmCm > Teams from the Unified CCX Administration menu bar to access this
configuration area.

Add New Team
Click the Add New icon or button on the Teams summary web page. The Team Configuration page appears.

Click theOpen Printable Report of this TeamConfiguration icon in the Teams web page to open the report
in a new window and send it to a printer.

Chat and Email Menu Options

Tip • The Chat and Email option is available with Unified CCX Premium license package.
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To access either of these menu options, choose Subsystems > Chat and Email as applicable.

The Chat and Email menu contains the following submenu options:

• SocialMiner Configuration—Choose this option to configure the SocialMiner parameters. This page
also displays the overall health of SocialMiner.

•Mail Server Configuration—Choose this option to configure the mail server. This page is available
on the Unified CCX node with a premium license.

• Contact Service Queues—Choose this option to configure chat and Email CSQs. You can configure
the email CSQs on the Unified CCX node with a premium license.

• Predefined Responses—Choose this option to define the chat and email predefined responses that are
available in the Manage Chat and Email gadget on the Finesse Agent Desktop.

• Channel Parameters—Choose this option to configure channel parameters.

• Chat Widget List—Choose this option to configure and manage chat web forms.

• Teams—Choose this option to configure teams.

SocialMiner Configuration
Use the SocialMinerConfigurationweb page to configure Cisco SocialMiner. Youmust configure information
on this web page to enable the chat and email features.

This option is available only with the Unified CCX Premium license package. The email feature support for
Unified CCX depends on the SocialMiner version. For information about feature compatibility, see the ,
located at: http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX.

On an high availability setup, after the Add to Cluster operation is successful, the following message is
displayed:

In case of HA, configure the SocialMiner on secondary node after adding
to cluster in the secondary node.

Note

Every time you navigate to this page, the state of feeds, campaigns, and notifications rules are validated for
chat and email, the connectivity to the email server is checked, and the web page shows the appropriate status.
Icons are used as visual indicators to display the status of each service. Hover the cursor over the icon to
display a tool tip that explains the reason for the current state. As part of validation, Unified CCX checks the
following:

• SocialMiner XMPP Service

Unified CCX checks the connectivity with the SocialMiner XMPP service. If the XMPP service is down,
the following message is displayed:

SocialMiner XMPP service is not accessible. Check the logs for more
details.

• SocialMiner Tomcat Service

Unified CCX checks the connectivity with the SocialMiner Tomcat service. If the Tomcat service is
down, the following message is displayed:
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Unable to communicate to the SocialMiner on the IP address(Hostname)
provided. Please verify whether SocialMiner is running on this IP
address(Hostname) or check the network connection and make sure that
SocialMiner is reachable from CCX.

• SocialMiner Status

◦Feeds
Unified CCX validates the status of the intended chat and email feeds in SocialMiner.

• —All the feeds are operating normally in SocialMiner.

• —One or more feeds mismatch with SocialMiner.

• —All the feeds are missing in SocialMiner.

◦Campaigns
Unified CCX validates the status of the intended chat and email campaigns in SocialMiner.

• —All the campaigns are operating normally in SocialMiner.

• —One or more campaigns mismatch with SocialMiner.

• —All the campaigns are missing in SocialMiner.

◦Notifications
Unified CCX validates the status of the intended chat and email notifications in SocialMiner.

• —All the notifications are operating normally in SocialMiner.

• —One or more notifications mismatch with SocialMiner. This status icon also appears
after configuration, when no chat and email contact is injected yet. The status will change to
normal after successful injection of chat and email contact.

• —All the notifications are missing in SocialMiner.

◦Email Server
Unified CCX checks the connectivity with the email server.

• —Email server is operating normally.

• Not Configured—Channel provider is not configured.

• Not Applicable—The following are the reasons for the current state:

• Cisco Finesse is not active.

• Email CSQ is not configured.

• SocialMiner version is incompatible with the Email feature.

• —Unable to reach the email server.
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Procedure

Step 1 From the Unified CCXAdministration menu bar, choose Subsystems >Chat > SocialMiner Configuration
OR Subsystems > Chat and Email > SocialMiner Configuration as applicable.
The SocialMiner Configuration web page appears.

Step 2 Complete or modify the following fields for SocialMiner:
DescriptionField

IP address or fully qualified domain name of the SocialMiner server. For example,
192.168.1.5 or host.example.com.

IP Address / Host Name

Username of the SocialMiner administrator.User Name

Password of the SocialMiner administrator.Password

Unified CCX and SocialMiner servers must have DNS entries. SocialMiner must be accessible to
Unified CCX by hostname. If the entries are not valid, an error is displayed.

Note

Step 3 Click Save to save the changes.
If you see an error message, click Save to re-create feeds, campaigns, and notifications for chat and email in
SocialMiner.

Reinject Email Contacts
Emails may be parked in SocialMiner due to component failures or if the email server is down or not reachable.
You can ensure that these emails are attended to when the services are restored by reinjecting the email
contacts.

Procedure

To reinject the email contacts back to Unified CCX, click Subsystems > Chat and Email > SocialMiner
Configuration > Reinject.

The SocialMinerConfigurationweb page is reloaded, but the configuration is not updated.Note

Chat Transcripts
You can search and retrieve stored chat transcripts. You can search by username (chat.agentName) and alias
(chat.agentNickname). For more information on how to perform a default search or a field-specific search,
see the “Search” section of the Cisco SocialMiner User Guide or the SocialMiner interface online help.

For information on how to change chat storage space and calculate the disk space that you need to store data
for a specific duration, see the online help that is available for the SocialMiner interface or see the Cisco
SocialMiner User Guide, located at:
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http://www.cisco.com/c/en/us/support/customer-collaboration/socialminer/products-user-guide-list.html

Mail Server Configuration
Use theMail Server Configuration web page to configure the mail server. This web page is available on
the Unified CCX node with a premium license.

Before You Begin

• Execute the commands set-service msExchangeIMAP4 -startuptype automatic, and start-service
msExchangeIMAP4 on Microsoft Exchange to set the Microsoft Exchange IMAP4 service to start
automatically.

• Execute the command set-service msExchangeIMAP4BE -startuptype automatic, and execute
start-service msExchangeIMAP4BE (for Microsoft Exchange 2013) on Microsoft Exchange to set
the Microsoft Exchange IMAP4 Back End service to start automatically.

• Create accounts and email addresses to be used for CSQ creation.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Chat and Email >Mail Server
Configuration.
TheMail Server Configuration web page opens.

Step 2 Complete or modify the following fields for the mail server:
DescriptionField

Incoming (Secure IMAP)

Fully qualified domain name (FQDN) of the incoming (IMAP) server. Do not enter
the IP address.

Host Name

Port number that is used to connect to the IMAP server.

The default port number is 993.

Port Number

Outgoing (Secure SMTP)

FQDN of the outgoing (SMTP) server. Do not enter the IP address.Host Name

Port number that is used to connect to the SMTP server.

The default port number is 587.

Port Number

Description of the mail server.Description

Step 3 Click Update to save the changes.
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Contact Service Queues Configuration

Before You Begin

• You must create a skill before creating a CSQ. For information about creating a skill, see Skills
Configuration, on page 88.

• Before creating an email CSQ, you must have configured the mail server .

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Chat > Contact Service Queues or
Subsystems > Chat and Email > Contact Service Queues as applicable.
The Contact Service Queues (CSQs) web page opens and displays the information for existing chat and email
CSQs if any.

Step 2 To add a new chat or email CSQ, click the Add New icon that appears in the toolbar in the upper left corner
of the window or the Add New button that appears at the bottom of the window.
The Contact Service Queues web page opens.

Step 3 Specify the following fields:
DescriptionField Name

Name for the CSQ.CSQ Name

Resource selection criteria chosen for the chat CSQ.

• Longest Available—Selects the agent who has been in the Available state for
the longest amount of time.

•Most Skilled—Used for expert agent chat distribution. Selects the agent with
the highest total competency level. The total competency level is determined
by adding the agent's competency levels for each assigned skill that is also
assigned to the CSQ.

◦Example 1: If Agent1 is assigned Skill1(5), Skill2(6), and Skill3(7) and
CSQ1 specifies Skill1(min=1) and Skill3(min=1), the total competency
level for Agent1 for CSQ1 is 12.

◦Example 2: If Agent1 is assigned Skill1(5) and Skill2(6), and Skill3(7)
and CSQ1 specifies Skill1(min=1), only, the total competency level for
Agent1 for CSQ1 is 5.

If two agents score equal in the primary selection criteria, the agent who
was updated first is assigned to the incoming chat.

Note

Resource Selection
Criteria
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Table 13: CSQ Type—Chat

DescriptionField Name

Choose Chat.CSQ Type

Table 14: CSQ Type—Email

DescriptionField Name

Choose Email.

You can create up to 100 email CSQs. If you exceed the limit, the following
error is displayed:

Cisco Unified CCX supports a maximum of 100 Email
CSQs. Exceeded maximum limit for Email CSQs.

Note

CSQ Type

Fully Qualified Domain Name (FQDN) of email server. This field displays the mail
server that you configured.

Mail Server

The email address to which emails are sent or retrieved.Email username

Password for email account.Email password

The folder that holds the email messages in the email server.

Default value = Inbox

Folder Name

Frequency in seconds to fetch emails from the server.

Default value = 600, Range = 10 to 86400

Poll Interval
(Seconds)

Specify the time in minutes from when the emails are to be fetched.

Default value = 120, Range = 10 to 43200

For example, if you specify 120 minutes, this field fetches the emails from the last
two hours.

Snapshot Age
(Minutes)

Step 4 Click Next.
The Skill Association for CSQ area opens with the newly assigned CSQ name.

You can create up to 100 email CSQs. If you exceed the limit, the following error is displayed:

Cisco Unified CCX supports a maximum of 100 Email CSQs. Exceeded
maximum limit for Email CSQs.

Note

Step 5 From the Available Skills list, choose the skill that you want to associate with the CSQ by clicking it. To
choose more than one skill, press the Ctrl key and click the skills that you want to associate with the CSQ.

Step 6 Click Add.
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The chosen skill and the minimum competence level for that skill are displayed in the right pane under the
heading Selected.

To delete the skill from the Skills Required list, click theDelete icon next toMinimumCompetence.Note

Step 7 Specify a minimum competence level for the skill assigned to the CSQ.
Step 8 To view the associated resources, click Show Resources.
Step 9 Click Save to save the changes for the CSQ.

The newly added CSQ appears in the List of CSQs.

You can create up to 100 email CSQs. If you exceed the limit, the following error is displayed:

Cisco Unified CCX supports a maximum of 100 Email CSQs. Exceeded
maximum limit for Email CSQs.

Note

You can sort the CSQs by title by clicking the CSQ Name header and by type by clicking the CSQ Type
header.

Step 10 To view the printable report and associated resources, click the CSQ for which you want view the report and
the associated resources and then click Open Printable Report.

To delete a CSQ, click the CSQ that you want to delete and then click Delete. A warning dialog box
appears, asking you to confirm the deletion. To delete, click OK.

Note

Deletion of the chat CSQ affects the associated chat web forms. After deleting, modify the
corresponding chat web form configurations and generate the HTML code.

Caution

Predefined Responses
To access the predefined responses, choose Subsystems > Chat > Predefined Responses OR Subsystems
> Chat and Email > Predefined Responses as applicable.

Use the Predefined Responses page to configure and manage chat and email predefined responses. You can
add a maximum of 500 chat and email predefined responses in total. These predefined responses are available
in the Manage Chat and Email gadget on the Finesse Agent Desktop.

You can configure the responses to be available either to all the agents or only to the agents that are associated
with specific CSQs.

Predefined Response Configuration
Using this web page, you can add, modify, and delete predefined responses.

You can add a maximum of 500 chat and email predefined responses in total.

To modify an existing predefined response, click the Title header for the predefined response that you
want to modify. To delete an existing predefined response, click theDelete icon for the predefined response
that you want to delete.

Note
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Chat > Predefined Responses OR
Subsystems > Chat and Email > Predefined Responses as applicable.
The Predefined Responses web page opens, displaying the information for existing responses, if any.

Step 2 Click the Add New icon that is displayed in the toolbar in the upper left corner of the window or the Add
New button that is displayed at the bottom of the window to create a new response.
The Predefined Response web page opens.

Step 3 Specify the following information:
DescriptionField

Unique identifier of the predefined response.

The special characters angle brackets (< >), parentheses ( ( ) ), double
quotation marks (" "), and pipe symbol (|) are not allowed.

Note

Title

Types of media.Type

Description for the predefined response.

• Rich Text Editor is available to create an HTML-based email predefined
response.

Use the supported tags as provided in the Rich Text Editor for formatting
purpose.

• Plain Text Editor is available to create a chat predefined response.

The special characters angle brackets (< >), parentheses ( ( ) ), double
quotation marks (" "), and pipe symbol (|) are not allowed in Plain Text
Editor for Chat Predefines Response.

The maximum characters limit for predefined response for chat and
email is 1500.

In case of email, rich text is supported and includes the HTML tag
characters for representing rich text.

Note

Response Description

Choose a tag for the predefined response.

• Global for all CSQs: The predefined response is available to all the agents
that are associated with all the CSQs.

• Customize (Maximum 10 CSQs): The predefined response is available
only to the agents that are associated with the selected CSQs.

If you choose this option, select the CSQs from the Available CSQs pane,
and then click the left arrow to assign them.

Tags

Step 4 Click Save.
The newly added predefined response appears with the assigned tags in the List of Predefined Responses.
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You can sort the predefined responses by title by clicking the Title header and by type by clicking the Type
header.

Channel Parameters
Use the Channel Parameters web page to configure channel parameters.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Chat > Channel Parameters OR
Subsystems > Chat and Email > Channel Parameters as applicable.
The Channel Parameters Configuration web page opens.

Step 2 Use this web page to specify or modify the following fields for channel parameters:
DescriptionField

The time for an agent to respond to the chat request after which, the chat request is
routed back to the chat queue.

No Answer Timeout
(Seconds)

The time after which the customer initiates a chat and, if an agent is not joined, the
customer gets a message as per the configuration in the Chat Web Form
Configuration page. But an agent can still join the chat after this timeout. The default
timeout is one minute and the maximum timeout value allowed is 60 minutes.

Join Timeout
(Minutes)

The customer inactivity time after which, the system ends the chat. This timeout is
on the customer side only.

The agent gets a message "You are alone in the chat room. Click End to close
the chat interface.".

The customer gets a message "Warning: the server connection was lost due to
an inactivity timeout or connection failure.".

Inactivity Timeout
(Minutes)

Click Yes if agents are allowed to handle a chat session during a voice call.

This setting takes effect when the agent ends the current voice
call.

Note

Offer Chat Contact
When On Voice Call

Click Yes if agents are allowed to handle a voice call during a chat session.

This setting takes effect when the agent receives a new incoming
chat.

Note

Offer Voice Call
When On Chat

Number of chat sessions (ranging from 1 to 5) that an agent is allowed to handle.MaximumNumberOf
Chat Sessions Per
Agent
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DescriptionField

Number of Email sessions (ranging from 1 to 5) that an agent is allowed to handle.MaximumNumberOf
Email Sessions Per
Agent

Specify the amount of time for which an email message waits in a specific agent
CSQ.

Sticky email routing (Last-agent email routing) is a mechanism to route an email
message to the agent who handled the last leg of the email conversation.

When an email message, which is part of an ongoing conversation, comes in and
the agent who handled the last leg of the conversation is not available, then the email
does not wait indefinitely in that agent queue. After the configured time expires, the
email message is placed on the intended CSQ to be handled by any available agent.

Last-agent email routing is not available if the customer changes the subject
line of the email message.

Note

Default = 4 hours, Range = 1 to 120 hours.

Sticky Email Timeout
(Hours)

Step 3 Click Save to save the changes for the channel parameters.
If any of the above parameters are changed during the call center operation, the updated values are
not applied to the existing contacts in the system. The changed parameters will affect only the new
contacts coming into the system.

Note

List Chat Web Forms
Use the chat widgets to generate HTML code that can be hosted on the customer website. Use the List Chat
Web Forms page to configure and manage chat web forms. To access the chat web forms, choose Subsystems
> Chat > Chat Widget List OR Subsystems > Chat and Email > Chat Widget List as applicable.

Chat Web Form Configuration
You can add, modify, and delete chat web forms.

To modify an existing chat web form, click the web form. To delete an existing chat web form, click the
delete icon.

Note

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Chat > Chat Widget List OR
Subsystems > Chat and Email > Chat Widget List as applicable .
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The List Chat Web Forms web page opens, displaying the information for existing Chat Web Forms, if any.

Step 2 Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New
button that displays at the bottom of the window to create a new chat web form.
The Chat Web Form Configuration web page opens

Step 3 Specify the following information:
DescriptionFieldPage Area

Unique identifier of the chat widget.NameWidget Details

Chat widget description.Description

Location of the logo file that is displayed in the widget.

The custom logo size will be resized to 300 x 300 pixel
by default.

Note

Logo URL

Message that is displayed to the customer when the customer
starts a chat session.

Default message: “Welcome. Please wait while we connect you
to a customer care representative.”

Widget Wait
Message

Message that is displayed to the customer when a chat request
is not handled within the set time.

Default message: “All customer care representatives are busy.
Please wait or try again later.”

Join Time-out
Message

Message that is displayed to the customer when Unified CCX
or chat service is not available to handle chat requests.

Default message: “Sorry, the chat service is currently not
available. Please try again later.”

Error Message

Step 4 Select the desired fields from theAvailable Fields and move it to the Selected Fields in the User Form Fields
area.

Step 5 Click theAdd Custom Field button if you want to create new field(s) in addition to the list of available fields.
The Explorer User Prompt dialog box opens.

Step 6 Enter the name of the new custom field in the text box and click OK.
The new custom field should appear in the list of Selected Fields.

Step 7 Click Next.
The Add problem Statement CSQ mapping area opens.

Step 8 Add the problem statement for the chat web form and map the same with an existing chat CSQ.
Step 9 Click any of the following:

• Click the Add More button if you want to add more problem statements and associate the same with
chat CSQs.
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• Click the Delete button subsequent to the CSQ List if you want to delete the problem statement.

Step 10 Click Next.
The Web Form Preview area displays a preview of how the chat web form will look after it is created. It will
display all the fields that you had selected for the user form and problem statements along with CSQmapping.

Step 11 Click any of the following:

• Click the Back button if you want to modify the configuration of the chat web form.

• Click the Finish button if you want to generate the web form code.

Teams
Choose Subsystems > Chat > Teams OR Subsystems > Chat and Email > Teams as applicable from the
Unified CCX Administration menu bar to access this configuration area.

The team configuration for chat is the same as it is for voice.Note

Outbound Menu
Use the Outbound Configuration web page or REST API to provision outbound dialing functionality feature.

The Outbound menu option will be displayed when you upload the Cisco Unified Premium license.

General Configuration
Choose Subsystems >Outbound >General from the Cisco Unified CCXAdministration menu bar to access
the General Configuration web page.

Use this web page to add or modify Outbound dialing preferences.

Campaign Configuration
Choose Subsystems > Outbound > Campaigns from the Cisco Unified CCX Administration menu bar to
access the Campaigns web page. You can create and schedule a campaign, modify the settings that apply to
a campaign, and import a list of contacts (in bulk from a text file) into the Unified CCX database for each
campaign using this web page.

You can define any one of the following two types for a campaign:

• Agent-based - If you select this campaign type, all the outbound calls will be handled by the available
agents.
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• IVR-based - In this campaign type, the outbound calls will be handled by the IVR scripts.

The existing campaigns will be marked as Agent-based after an upgrade from Unified CCX versions prior
to 9.0(1).

Note

Add New Campaigns
To configure the properties for direct preview, progressive and predictive agent-based campaigns, for campaign
name and description, callback settings, skill group selection, time range, dialing options, retry settings, and
the dial settings, click Add New icon or button in the Campaigns web page.

Import Contacts
To import contacts for a selected campaign, click the hyperlink for the required campaign under the Name
column and click Import Contacts. This will open the Import Contacts window through which you can import
contacts.

TheOpen Printable Report for this Campaign Configuration icon provides the following information for
the selected campaign in addition to call-specific information, which varies depending on the selected dialer
type for outbound:

• Campaign Name

• Enabled - Yes or No

• Description

• Start Time of the campaign

• End Time of the campaign

• Contact Records Cache Size

• Remaining Contacts

Delete Contacts
To ensure that a contact does not get called again for subsequent campaigns, you must delete the contact from
all campaigns to which it belongs.

Click Delete All Contacts icon or button in the Campaign Configuration web page to delete all contacts of
a particular campaign. Once you click Delete All Contacts, you will see a dialog box with the message “This
campaign will be disabled and all its contacts will be permanently deleted. Continue?” with OK and Cancel
buttons.

If you clickOK, the Outbound subsystem checks whether the contacts are used in an active Outbound campaign.
If the contacts are used as part of an active Outbound campaign, you will see the following alert message in
the status bar at the top of the Campaign Configuration web page: “Campaign is active. Cannot remove contacts
from an active campaign. Disable the campaign and try again.” In such cases, disable the campaign first and
then try deleting all contacts. ClickCancel if you do not want to delete all contacts for the specific campaign.
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Area Code Management
Use this page to manually add new area codes, update existing area codes, and to add international area codes.

Add New Area Code
The Area Codes Management page allows you to find, add, delete, and modify the mapping of area codes
and time zones. The dialer uses the area code of a contact phone number to determine the time zone of the
contact calling area.

Configure SIP Gateway
You can use the SIPGateway Configuration web page to add or modify the parameters that enable the Outbound
subsystem of Unified CCX to communicate with the SIP gateway. You can also update the parameters specific
to Call Progress Analysis functionality of the gateway using this web page.

Call Progress Analysis is a feature of the SIP gateway by which it determines whether the outcome of a call
is an answering machine, live voice, fax, or beep tone and so on. The SIP gateway performs call progressive
analysis of the call and informs the outcome of the call to Unified CCX.

It is mandatory to configure the SIP Gateway used by the Outbound subsystem to place calls in case of
IVR-based and agent-based progressive and predictive Outbound campaigns.

Note

Follow this procedure to configure the SIP gateway parameters through Unified CCX Administration web
interface:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > SIP Gateway
Configuration.
The SIP Gateway Configuration web page opens.

Step 2 Click Update to save the configuration changes.
The new SIP gateway configuration is added to the Unified CCX system.

Step 3 Click Cancel to restore the default settings.

SIP Gateway Configuration Web Page
The SIP Gateway Configuration web page.

DescriptionField

Gateway Configuration
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The HostName or IP Address of the SIP Gateway in
the Unified CCX server, which will be used by the
Outbound subsystem to place calls for the predictive
or progressive campaigns.

Gateway Hostname/IP Address

The SIP port used by the gateway to communicate
with Unified CCX. The default value is 5060.

Gateway Port

The port number to be used on the Unified CCX
server to communicate with the gateway.

Default = 5065, Range = 1025-32767 or 61001-65535

Local CCX Port

This read-only field provides a description of the
owner for this connection. The default value is
Cisco-UCCX/8.5.

Local User Agent

The protocol required to send SIP messages. You can
select any one of the following protocols:

• TCP - Transport Control Protocol or

• UDP - User Datagram Protocol

The default value is UDP.

Transport(TCP/UDP)

Call Progress Analysis Configuration (displays the parameter name, parameter value, and suggested
value for the following fields)

The amount of time that the signal must be silent after
speech detection to declare a live voice (in
milliseconds).

Default = 375 milliseconds, Range = 10-1000
milliseconds

Minimum Silence Period (10-1000)

Maximum amount of time (from the moment the
system first detects the speech) during which analysis
will be performed on the input audio.

Default = 2500 milliseconds, Range = 1000-10000
milliseconds

Analysis Period (1000 - 10000)

The amount of time to wait when it is difficult for the
dialer to determine voice or answering machine.

Default = 3000 milliseconds, Range = 1000-10000
milliseconds

Maximum Time Analysis (1000-10000)
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Amount of time that the signal must be active before
being declared speech. Anything less is considered
as a glitch.

Default = 112 milliseconds, Range = 50-500
milliseconds

Minimum Valid Speech Time (50-500)

This is the amount of time the gateway will look for
a terminating beep once an answering machine has
been detected.

Default = 15000 milliseconds, Range = 1000-60000
milliseconds

Maximum Term Tone Analysis (1000-60000)

Dial Peer Configuration for Outbound
Dial peer configuration is required to transfer the outbound calls to the IVR ports and agents in case of
progressive and predictive outbound campaigns. The dial peer maps to the CUCM trigger for IVR-based
campaigns and to the agent extension for agent-based campaigns.

When you configure voice-network dial peers, the key commands that you must configure are the
destination-pattern and session-target commands.

IVR

For IVR-based progressive and predictive campaigns, the destination-pattern command specifies the Unified
CMTelephony Trigger associated with the IVR campaign. The session-target command specifies a destination
address for the voice-network peer.

Agent

For agent-based progressive and predictive campaigns, the destination-pattern command specifies the agent
extension. The session-target command specifies a destination address for the voice-network peer.

For Extend and Connect, the destination-pattern should specify the destination address of the CTI Remote
Device (CTIRD). See the Cisco Unified TAPI Developers Guide for Cisco Unified Communications Manager
at http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_guides_list.html for more
information on CTIRD.

Disable Hunting for Agent-Based Outbound Calls

When the agent does not answer a live voice call within the time limit configured for Outbound Call Timeout
in General Configuration web page then the call has to be dropped. If hunting is not disabled on the gateway,
the call is not dropped and is forwarded to the agent extension.

The gateway receives a 403 forbidden error message and hunts for the “preference 2 dial peer.” The gateway
forwards the call to the agent extension using the “ preference 2 dial peer.”Hence, the call is seen on the agent
desktop and the state of the agent is changed to Ready or Not Ready depending on the option selected for the
Agent State after Ring No Answer field in System Parameters Configuration web page.

To disable hunting for the gateway, use no voice hunt 57 command (57 maps to 403 forbidden in SIP).
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This is a global configuration to restrict the gateway from hunting for all 403 forbidden error messages.Note

Translation of Phone Numbers

Unified CCX does not support the translation or modification of the phone number that it uses to dial out
outbound calls. Any “voice translation rules” configured in the gateway that modifies the phone number are
not supported. If the phone number is translated, then those calls are not treated as agent-based outbound calls.

You can use either of the below two supported methods to modify a dialed number in the gateway:Note

• To remove the initial digits of the phone number use forward-digits or digit-strip in the dial peer
configuration.

• To add a prefix to the phone number use prefix in the dial peer configuration.

See the Dial Peer Configuration on Voice Gateway Routers at http://www.cisco.com/en/US/products/sw/
custcosw/ps1844/prod_installation_guides_list.html for detailed information on dial peers.

Database Menu
The Unified CCX system uses the Database subsystem of the Unified CCX Engine to communicate with
database servers, to obtain information that can be relayed to callers or to make application decisions. The
Database subsystem enables the Unified CCX applications to obtain information from data sources, which
are databases configured to communicate with the Unified CCX system.

The Database menu contains the following options, which are explained below:

• Datasource

• Parameters

• Drivers

DataSource
Use the DataSources web page to add a new data source, display, modify, or delete existing datasources.

Choose Subsystems > Database > DataSource from the Cisco Unified CCX Administration menu bar to
access the DataSources web page.

New DataSource
Follow this procedure from the DataSources web page to add a new DataSource:
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Procedure

Click the Add New icon that displays in the toolbar in the upper left corner of the window or the button that
displays at the bottom of the window to add a new data source.
The DataSource Configuration web page opens.

Add New Database Driver
Follow this procedure to add a new jdbc driver:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Database > Drivers.
The Driver List web page opens up displaying a list of uploaded driver class file names along with a Delete
icon.

Step 2 Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New
button that displays at the bottom of the window to add a new driver class name.
The Driver Management web page opens.

Step 3 Specify a valid JDBC driver jar file in the Driver File field or click Browse to locate the driver file.
The driver file is validated before uploading.

Step 4 Choose the supported class name for the new driver from the Driver Class Name drop-down list box.
Step 5 Click Upload to save the new driver to the database.

Tip • Contact your database vendor to know the appropriate JDBC driver versions that is compatible
with your Enterprise database server. Though multiple jdbc driver versions are supported, the
following table lists the JDBC drivers that have been tested with different databases.

•While uploading com.ibm.db2.jcc.DB2Driver, if your IBM DB2 deployment also requires a
license Jar to be in the application's classpath, upload the license Jar as a Custom Jar File using
the procedure detailed in Specify CustomClasspath Entries. Then, restart the Unified CCXEngine
on all nodes through Unified CCX Serviceability.

Table 15: JDBC Driver Versions Tested with Enterprise Database

Tested JDBC DriversDatabases

ojdbc6.jarOracle 11g R2

jTDS 1.2.2, jconn2.jarSybase Adaptive Server 12

db2jcc4.jarIBM DB2 8.2

jTDS 1.2.2MS SQL Server 2000

jTDS 1.2.2MS SQL Server 2005
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jTDS 1.2.5MS SQL Server 2008

jTDS 1.2.5MS SQL Server 2012

Driver
Use the Driver List web page to upload new drivers, or to view and delete existing drivers.

Add New Database Driver
Follow this procedure to add a new jdbc driver:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Database > Drivers.
The Driver List web page opens up displaying a list of uploaded driver class file names along with a Delete
icon.

Step 2 Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New
button that displays at the bottom of the window to add a new driver class name.
The Driver Management web page opens.

Step 3 Specify a valid JDBC driver jar file in the Driver File field or click Browse to locate the driver file.
The driver file is validated before uploading.

Step 4 Choose the supported class name for the new driver from the Driver Class Name drop-down list box.
Step 5 Click Upload to save the new driver to the database.

Tip • Contact your database vendor to know the appropriate JDBC driver versions that is compatible
with your Enterprise database server. Though multiple jdbc driver versions are supported, the
following table lists the JDBC drivers that have been tested with different databases.

•While uploading com.ibm.db2.jcc.DB2Driver, if your IBM DB2 deployment also requires a
license Jar to be in the application's classpath, upload the license Jar as a Custom Jar File using
the procedure detailed in Specify Custom Classpath Entries. Then, restart the Unified CCX
Engine on all nodes through Unified CCX Serviceability.

Table 16: JDBC Driver Versions Tested with Enterprise Database

Tested JDBC DriversDatabases

ojdbc6.jarOracle 11g R2

ojdbc14.jarOracle 10g R2
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ojdbc14.jarOracle 10g XE

jTDS 1.2.2, jconn2.jarSybase Adaptive Server 12

db2jcc4.jarIBM DB2 8.2

jTDS 1.2.2MS SQL Server 2000

jTDS 1.2.2MS SQL Server 2005

jTDS 1.2.5MS SQL Server 2008

jTDS 1.2.5MS SQL Server 2012

HTTP Menu
The Unified CCX system uses the HTTP subsystem of the Unified CCX Engine to add components to the
Unified CCX Engine that allow applications to be triggered in response to requests from a variety of web
clients, including computers and IP phones.

HTTP Configuration
Use the HTTP Trigger Configuration web pages to display, add, modify, and delete existing HTTP triggers.

Choose Subsystems > HTTP from the Cisco Unified CCX Administration menu bar to access the HTTP
Trigger Configuration web page.

Add New HTTP Trigger
To add a new HTTP trigger:

Procedure

Click the Add New icon or button on the HTTP Trigger Configuration web page to access the HTTP Trigger
Configuration web page.
To modify an existing trigger, click any hyperlink within the HTTP Trigger List table; the HTTP Trigger
Configuration web page opens.
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eMail Menu
The Unified CCX system uses the eMail subsystem of the Unified CCX Engine to communicate with your
email server and enable your applications to create and send email. The email configuration identifies the
default email address and server to be used for sending email (including e-pages and faxes) and for receiving
acknowledgments.

This email subsystem is not related to agent email-based routing.Note

Choose Subsystems > eMail from the Cisco Unified CCX Administration menu bar to access the eMail
Configuration web page. You must configure email functionality so that Unified CCX scripts created with
the email steps will function correctly.

Cisco Media Menu
Choose Subsystems > Cisco Media from the Unified CCX Administration menu bar to access the Cisco
Media Termination Dialog Group Configuration web page.

The Unified CCX system uses the Media subsystem of the Unified CCX Engine to configure Cisco Media
Termination (CMT) dialog groups that can be used to handle simple Dual-Tone Multi-Frequency (DTMF)
based dialog interactions with customers. A dialog group is a pool of dialog channels in which each channel
is used to perform dialog interactions with a caller.

To modify an existing CMT dialog group, click any hyperlink within the trigger's summary table entry; the
Cisco Media Termination Dialog Group Configuration web page opens.

To add a new CMT dialog group, click the Add New icon or button in the Cisco Media Termination Dialog
Group Configuration web page. The Cisco Media Termination Dialog Group Configuration web page opens.

MRCP ASR Menu
TheUnified CCX system uses theMRCPASR (Automatic Speech Recognition) subsystem to allow navigation
through a menu of options by speaking instead of pressing keys on a touch-tone telephone.

MRCP ASR Provider
Choose Subsystems >MRCP ASR >MRCP ASR Provider from the Cisco Unified CCX Administration
menu bar to configure information about the vendor of your speech server, including the number of licenses,
and the grammar type.

To modify an existing ASR Provider information, click any hyperlink within the provider's summary table
entry; the ASR Provider Configuration web page opens.

To add a new ASR Provider information, click the Add New icon or button.
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MRCP ASR Servers
Choose Subsystems >MRCP ASR >MRCP ASR Servers from the Cisco Unified CCX Administration
menu bar to configure your speech server name, port location, and available languages.

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Server.Note

Tomodify an existing ASR Server, click any hyperlink within the server summary table entry; the ASR Server
Configuration web page opens.

To add a new ASR Server, click the Add New icon or button.

MRCP ASR Dialog Groups
Use the MRCP ASR Dialog Group Configuration web page to display, add, modify, and delete information
about MRCP ASR dialog control groups, which enable Unified CCX applications to use speech recognition.

Choose Subsystems >MRCP ASR >MRCP ASR Dialog Groups from the Cisco Unified CCX
Administration menu bar to configure the MRCP ASR dialog control groups.

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Group.Note

To modify an existing MRCP ASR Dialog Group, click any hyperlink within the group summary table entry;
the MRCP ASR Dialog Control Group Configuration web page opens.

To add a new MRCP ASR Group, click the Add New icon or button.

MRCP TTS Menu
The Unified CCX system uses the MRCP (Text-to-Speech) subsystem to convert plain text (UNICODE) into
spoken words to provide a user with information or to prompt a user to respond to an action.

MRCP TTS Providers
Use the MRCP TTS Provider Configuration web pages to display, add, modify, and delete information about
your TTS Provider.

Choose Subsystems >MRCP TTS >MRCP TTS Provider from the Cisco Unified CCX Administration
menu bar to configure information about the vendor of your TTS system.

To modify an existing MRCP TTS Provider, click any hyperlink within the provider summary table entry;
the MRCP TTS Provider Configuration web page opens.

   Cisco Unified CCX Administration Guide, Release 11.0(1)
284

Subsystems Menu
MRCP ASR Servers



MRCP TTS Servers
Use the MRCP TTS Server Configuration web page to display, add, modify, and delete the text-to-speech
server name, port location, and available language.

To modify an existing MRCP TTS Server, click any hyperlink within the server summary table entry; the
MRCP TTS Server Configuration web page opens.

To add a newMRCP TTS Server, clickAdd New icon or button in the MRCP TTS Server Configuration web
page.

Related Topic

Provision MRCP TTS Servers, on page 81

MRCP TTS Default Genders
Use theMRCP TTS Default Genders Configuration web page to display or modify the gender setting for each
Locale. You can modify the default gender setting for the Locales specified during TTS Server provisioning
using this page. Click the Update icon or button to save the changes.

Related Topic

Provision MRCP TTS Default Genders, on page 83
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C H A P T E R  17
Wizards Menu

TheWizards menu of the Unified CCXAdministration web interface provides access to the wizards available
for your Unified CCX system.

In each Wizard web page, you are provided with a list of procedures and a description for each procedure
in the main pane.

Click the Exit icon in the toolbar in the upper left corner of the window or the Exit button that displays at
the bottom of the window to exit the wizard at any time and to go to the main Unified CCX Administration
menu bar. Click Next to go to the next wizard menu option.

The Unified CCX system contains the following options in the Wizards menu:

• Application Wizard, page 287

• RmCmWizard, page 288

Application Wizard
Application Configuration is one of the very basic requirements in Unified CCX Administration. You must
complete several steps in the suggested order to successfully complete Application Configuration.

To access the Application Wizard, selectWizards > Application Wizard > Description of Steps from the
Unified CCX Administration menu bar. The Application Configuration Wizard: Description of Steps web
page opens up, displaying the different steps to perform the configuration, along with a brief description of
each step as shown in the following bulleted list.

Click Next to proceed to the subsequent steps from the main Application Configuration Wizard web page or
jump directly to any step usingWizards > Application Wizard and clicking the desired submenu (see
Configure Unified CCX Applications).

• Scripts—In this step, you can view a list of existing custom scripts. When you click the Next button
from the main Application Configuration Wizard web page, you are transferred to Script Management
web page, which lists the available scripts, provides links to create a folder, and uploads custom scripts.
Scripts can be uploaded as either a single script file or a zip file of scripts. You can upload multiple
scripts in this step (see Script Management).

• Prompts—In this step, you can view a list of existing custom prompts. The Prompt Management web
page lists the available prompts, provides links to create new folders, and uploads custom prompts.
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Prompts can be uploaded as either a single prompt file or a zip file of prompts. You can upload multiple
prompts in this step (seeManage Prompt Files).

• Grammars—In this step, you can view a list of existing custom grammar files that are used to recognize
and respond to caller prompts. The Grammar Management web page lists the available grammars,
provides the links to create new folders, and uploads custom grammars. Grammars can be uploaded as
either a single grammar file or a zip file of grammars. You can upload multiple grammars in this step
(seeManage Grammar Files).

• Documents—In this step, you can view a list of existing custom documents such as .txt, .doc, .jsp, or
.html, custom classes, and Java Archive (JAR) files that allow you to customize the performance of your
Unified CCX system. The Document Management web page lists the available documents, provides the
links to create new folders, and uploads custom documents. Documents can be uploaded as either a
single document file or a zip file of documents. You can upload multiple documents in this step (see
Manage Document Files).

• Application Configuration—In this step, you can select the type of application to be configured using
Add a New Application page. Click Next to provide configuration details for the selected application
type. Each application can be any combination of the scripts, prompts, grammars, and documents on
file. By default, the uploaded script, prompt, document and grammar are selected, if applicable. You
can create multiple applications in this step (see About Unified CCX Applications).

• Triggers—In this step, you can create different types of triggers for the applications that were created
in the previous step using the Trigger Configuration page. More than one trigger can be created for one
application. By default, the application configured in the previous step is automatically selected. On
providing the Directory Number, device name and language, the trigger configuration is complete. You
can create multiple triggers in this step (see Application Triggers).

Selecting the type of the trigger concludes the Application Configuration wizard process.

RmCm Wizard
RmCm Configuration is a commonly performed procedure in the contact center environment. You must
complete several steps in the suggested order to successfully complete RmCm Configuration. The RmCm
Configuration wizard leads you through the suggested steps.

The RmCmWizard option is available with all Unified CCX license packages.Note

To access the ApplicationWizard, selectWizards >RmCmWizard > Description of Steps from the Unified
CCX Administration menu bar. The Application Configuration Wizard: Description of Steps web page opens
up displaying the different steps in which you can perform the configuration along with a brief description of
each step as shown in the bulleted list below.

Click Next to proceed to the subsequent steps from the main RmCmWizard web page or jump directly to
any step usingWizards > RmCmWizard and clicking the desired submenu.

• Add a Skill—Choose this submenu to configure the skills to be associated with the user. In this step,
you are transferred to the RmCm > Skills web page. Repeat this step to create multiple skills.

• Add a Resource Group—Choose this submenu to upload multiple custom scripts. In this step, you are
transferred to the Resource Group Configuration web page, where you can enter the Resource Group
Name.
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• AddResources—Choose this submenu to create resource groups that will later be assigned to resources.
In this step, you are transferred to RmCmWizard - User Configuration web page, which has a hyperlink
to Add resources in Unified CM. This link invokes Unified CM automatically (see the following
related topics):

• RmCm Provider Configuration, on page 261

• Unified Communications Manager for Unified CCX Configuration, on page 30

• Add Supervisors—Choose this submenu to assign supervisor privileges to a user. In this step, you are
transferred to the User Management web page, which allows you to search for a specific user.

• Configure Resources—Choose this submenu to add or remove skills that are associated with resources.
In this step, you are transferred to the RmCm Configuration Resources web page, which lists the
configured resources. Resources can be modified together to obtain the same skills, or they can be
modified separately to be assigned different skills.

•Modify Existing Contact Service Queues—Choose this submenu to modify skills that are associated
with a contact service queue. In this step, you are transferred to the RmCmConfiguration Contact Service
Queue web page, which lists the configured CSQs.

• Add a Contact Service Queue—Choose this submenu to add contact service queues. Skills or resource
groups are associated to these contact service queues to filter out the resources. In this step, you are
transferred to the RmCm Configuration Contact Service Queue Configuration web page, which allows
you to add CSQs.

•Modify Existing Teams—Choose this submenu to modify agents in existing teams. In this step, you
are transferred to the RmCm Configuration Contact Teams web page, which lists the configured teams.

• Add a Team—Choose this submenu to create new teams and associate those teams with new agents.
In this step, you are transferred to the RmCmConfiguration TeamConfiguration web page, which allows
you to create new teams.

• Create an Application—On completing the RmCm configuration, you can optionally proceed to the
Application Wizard configuration.
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C H A P T E R  18
Tools Menu

The Tools menu of the Unified CCX Administration web interface provides access to system tools you can
use to perform a variety of administrative tasks and contains the following menu options:

• Plug-ins—to download plug-ins that you can use to enhance the Unified CCX Engine.

• Real-Time Reporting—to generate reports that provide detailed information about the status of your
Unified CCX system.

• Real-Time Snapshot Config—to configure the Unified CCX database connection to a wallboard
display.

• Historical Reporting—to perform Historical Reporting tasks, including configuring the database
server, synchronizing data, configuring users, installing client software, and purging your database.

• User Management—to assign access levels to administrators and supervisors.

• Password Management—to reset passwords for external database access users like workforce
management, historical reporting user and so on.

•W1 Upgrade—to show if you have selected "Upgrade from a previous Unified CCX release" option
during initial Appadmin setup in a single-node or high availability deployment.

The following sections describe the various menu options.

• Plug-Ins Menu, page 291

• Real-Time Reporting Menu, page 292

• Real-Time Snapshot Config Menu, page 292

• Historical Reporting Menu, page 296

• User Management Menu, page 299

• Password Management, page 303

Plug-Ins Menu
The Unified CCX system includes software components called plug-ins that you can use to enhance the
Unified CCX Engine. You can download these plug-ins from the Plug-ins web page.
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To access the Plug-ins web page, choose Tools > Plug-ins from the Unified CCX Administration menu bar.

The Plug-ins web page contains one or more of the following hyperlinks (depending on the Unified CCX
package you have purchased):

• Cisco Unified CCX Editor—Click this hyperlink to install the client-side Unified CCX Editor. For
more information, see the Cisco Unified Contact Center Express Getting Started with Scripts and Cisco
Unified Contact Center Express Editor Step Reference Guide.

Do not install the Unified CCX editor on the same machine as the Cisco Unity Editor. Both editors cannot
coexist on the same machine.

Caution

• Cisco Unified CCX Real-Time Monitoring Tool for Windows—Click this hyperlink to install
client-side Unified CCX Serviceability Real-Time Monitoring Tool (RTMT) for Windows. This tool
monitors real-time behavior of the components in a Unified CCX cluster. RTMT uses HTTP/HTTPS
and TCP to monitor device status, system performance, device discovery, and CTI applications. It also
connects directly to devices by using HTTP/HTTPS for troubleshooting system problems. This plug in
is available only for users with administrator capability.

To download on Windows, right-click Download hyperlink and select Save Target As
option.

Note

• Cisco Unified CCXReal-TimeMonitoring Tool for Linux—Click this hyperlink to install client-side
Unified CCX Serviceability Real-TimeMonitoring Tool (RTMT) for Linux. RTMT uses HTTP/HTTPS
and TCP to monitor device status, system performance, device discovery, and CTI applications. It also
connects directly to devices by using HTTP/HTTPS for troubleshooting system problems. This plug in
is available only for users with administrator capability.

Real-Time Reporting Menu

While Unified CM supports Unicode characters in first and last names, those characters become corrupted
in Unified CCX Administration web pages for RmCm configuration, and Real Time Reporting.

Caution

The Real-Time Reporting tool is a Java applet that you can use to generate a variety of reports that provide
detailed information about the status of your Unified CCX system. You use the Application Reporting web
page to access the Real-Time Reporting tool.

To access the Application Reporting web page, choose Tools > Real Time Reporting from the Unified
CCX Administration menu bar.

Real-Time Snapshot Config Menu
Many call centers use wallboards to display their real-time reporting status. Wallboards can display data such
as available agents in CSQs, call volumes, talk times, wait times, and number of handled calls. You can enable
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the Unified CCX system to write Unified CCX real-time information to a database that can then be displayed
on a wallboard.

You must purchase the wallboard separately, and configure and control it with its own wallboard software.
Wallboard software and hardware are supported by the third-party wallboard vendors, not by Cisco.

You must install the wallboard software on a separate machine or desktop, not on the Unified CCX server.
During installation of your wallboard software, you must configure your wallboard software to access the
Unified CCX database. To do this, you must assign a DSN, User ID, and password.

Note

Use the Real-Time Snapshot Writing Configuration for Wallboard web page to enable the system to write
data to the wallboard system.

To access the Real-Time SnapshotWriting Configuration forWallboard web page, chooseTools >Real Time
Snapshot Config from the Unified CCX Administration menu bar.

The following fields are displayed on the Real-Time SnapshotWriting Configuration forWallboard web page.

DescriptionField

If checked, the system writes the data to the database. If not checked, the system
does not write the data to the database.

The default is disabled.

Data Writing Enable

Sets the refresh interval for the wallboard data. Valid options: 5, 10, 15, 20, and
25.

Data Writing Interval

If checked, writes information about each CSQ to the RtCSQsSummary table in
the Unified CCX database.

Cisco Unified CCX
CSQs Summary

If checked, writes overall Unified CCX system summary to the RtICDStatistics
table in the Unified CCX database.

Cisco Unified CCX
System Summary

Wallboard System

IP addresses of the servers running the Wallboard software pointing to the HDS
Database Server, which contains the Wallboard Real-Time Snapshot data. If you
have multiple Wallboard servers, you can list their IP addresses in this field
separated by commas.

Server Name

For details about the information written to the RtCSQsSummary and RtUnified CCXStatistics database
tables, see the Cisco Unified Contact Center Express Database SchemaGuide. Only the RtCSQsSummary
and RtICDStatistics statistics tables can be used in wallboard queries. Use of historical reporting tables
in wallboard queries is not supported.

Note

See http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_device_support_tables_list.html
for compatibility information.
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Create System DSN for Wallboard
You can create a system Data Source Name (DSN) on your Windows server by performing the following
procedure.

Procedure

Step 1 Install the wallboard software and IBM Informix ODBC Driver (IDS Version 3.0.0.13219 and above) on the
wallboard client desktop.

You can download the Informix ODBC driver from the following URL: http://
www14.software.ibm.com/webapp/download/search.jsp?rs=ifxdl. Download the IBM Informix Client
Software Development Kit (CSDK) Version 3.00 or higher for the operating system you are installing
with the wallboard client. More information about the CSDK can be found at the following URL:http:/
/www.ibm.com/software/data/informix/tools/csdk/.

Note

Step 2 Select Start > Settings > Control Panel.
Step 3 From the Control Panel menu, select Administrative Tools > Data Sources ODBC to launch the OBDC

Data Source Administrator.
Step 4 Click the System DSN tab. Then click Add to open the Create New Data Source dialog box.
Step 5 Scroll down to locate and select the IBM INFORMIX ODBC DRIVER.
Step 6 Click Finish to open the IBM Informix Setup dialog box.
Step 7 On the General tab, enter and apply a Data Source Name and Description.
Step 8 On the Connection tab, enter the values for the fields as shown in the table below:

DescriptionField

This is the instance name of the Informix database.

Informix database instance name can be formed using Host Name of the Unified
CCX server by following these conventions:

• Convert all upper case letters to lower case.

• Replace hyphens with underscore.

• Add the letter “i” as a prefix to the instance name, if the hostname starts with
a number.

• Append the letters “_uccx” to the instance name.

For example, if the hostname is “802UCCX-Ha-Node1”, enter
“i802uccx_ha_node1_uccx” in the Server Name field.

Server Name

Enter the hostname of the primary Unified CCX server.Host Name

Enter 1504.Service

Enter onsoctcp.Protocol

Leave blank.Options
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DescriptionField

Enter db_cra.Database Name

Enter uccxwallboard. This is the user id of the Unified CCX database created for
wallboard.

User ID

The password for the wallboard user that has been configured. You can change the
password by going to Tools > Password Management submenu option from the
Unified CCX Administration menu bar.

Password

Step 9 Click Apply.
Step 10 Click the Environment tab and enter the values for the following fields:

DescriptionField

Enter en_US.UTF8.Client Locale

Enter en_US.UTF8.Database Locale

Step 11 Click OK.
Step 12 Return to the Connection tab and click Apply and Test Connection.

If the phrase “Test completed successfully” is returned, click OK.
If the test is unsuccessful, return to the configuration sequence and fix any errors.

Wallboard Software in High Availability (HA) Deployment
If you use wallboard software in an High Availability (HA) deployment of Unified CCX and do not want any
manual intervention in case of failover, you must upgrade your wallboard software.

Upgraded wallboard software should have a new service which periodically requests Unified CCX server for
database mastership information using REST API (URL - http://<Unified CCX server IP
Address>/uccx/isDBMaster). During failover, this new service in wallboard will update DSN registry to use
new database master server.

REST API can be requested only from wallboard servers configured through Tools > Real Time Snapshot
Config web page from the Unified CCX Administration menu bar.

Use Upgraded Wallboard Software with New Service in HA Deployment

If you use wallboard software in a High Availability (HA) deployment of Unified CCX, you must work with
your wallboard vendor to use the new API exposed by Unified CCX.

Wallboard software with the new service ensures that the wallboard server always displays data from the
master database server of Unified CCX and no manual intervention is required. Follow this procedure to
complete the setup:
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Procedure

Step 1 Create DSN using secondary server information and modify the same DSN using primary server information.
This will create sqlhost entries for both the servers in a registry at
HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts.

Step 2 Configure the wallboard software with new service as described in the wallboard software documentation.
Step 3 Configure information of both the Unified CCX servers with new service of wallboard as described in the

wallboard software documentation.

What to Do Next

After you complete this procedure, no manual intervention is required in case of failover.

Use Wallboard Software (without New Service) in HA Deployment

If you use the existing wallboard software without the new service in an High Availability (HA) deployment
of Unified CCX, you must complete the following actions:

Procedure

Step 1 Create DSN using secondary server information and modify the same DSN using primary server information.
This will create sqlhost entries for both the servers in a registry at
HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts.

Step 2 Configure the wallboard software as described in the wallboard software documentation.
Step 3 Whenever there is a failover, you must manually change the DSN registry entry as follows:

a) Enter http://<Unified CCX server IP Address>/uccx/isDBMaster in a web browser from any wallboard
client to know whether the requested Unified CCX IP address server has a database master or not.

b) On failover, change SERVER value to master DB instance name in registry of DSN under
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI

c) You can find the exact database instance name at
HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts

Historical Reporting Menu

While Unified CM supports Unicode characters in first and last names, those characters become corrupted
in Unified CCX Administration web pages for RmCm configuration, and Real Time Reporting.

Caution

Use the areas of the Historical Reporting Configuration web page to perform a variety of tasks, including
configuring users, installing client software, and purging your database.
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To access the different Historical Reporting Configuration options, choose Tools > Historical Reporting
and click any of the following submenu options from the Unified CCX Administration menu bar:

• Database Server Configuration—to configure the database server to specify the reporting options
provided to the user.

• SMTPConfiguration—to configure the email server used to email scheduled Cisco Unified Intelligence
Center (CUIC) reports.

• Purge Schedule Configuration—to automatically purge data as per the following configurations:

◦Timing of the purge

◦Automatic purge configuration

• Purge Now—to manually purge data.

• File Restore—to restore database records written to HR files when the database goes down.

For additional information on Historical Reporting, see Cisco Unified Contact Center Express Historical
Reporting Guide.

Note

Database Server Configuration
Use the Database Server Configuration area to specify themaximumnumber of client and scheduler connections
that can access the database server.

SMTP Configuration
Use SMTP Server Settings area to configure the email server used to email scheduled Cisco Unified Intelligence
Center (CUIC) reports.

This page is enabled only if you select Cisco Unified Intelligence Center Reporting Client in the Reporting
Configuration page.

Note

The following fields are displayed in the SMTP Server Settings area:

DescriptionField

The host name or IP address of the SMTP serverHost/IP Address

The email address that is to appear in the From field of emails sent by the
Scheduler

Unified CCX supports alphanumeric IDs and special characters (only
hyphen "-", underscore "_", and dot ".").

Note

From email address

Check this if you use a proxy server to reach your SMTP serverUse Email Proxy
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DescriptionField

The hostname or IP address of the proxy server used to reach the SMTP serverEmail Proxy Hostname

The port used to connect to the SMTP proxy serverEmail Proxy Port

Check this if your SMTP server expects to receive username/password credentialsUse SMTPAuthentication

If you check the Authenticate checkbox, enter the username that is to be
authenticated

SMTP Username

If you check the Authenticate checkbox, enter the password that is to be
authenticated

SMTP Password

You will not be able to save the SMTP configuration if Cisco Unified Intelligence Center service on the
publisher node is down.

Note

Purge Schedule Configuration Option
Use the Purge Schedule Configuration area to select a user for whom you want to choose a reporting package
for the Unified CCX Historical Reports system.

ChooseTools >Historical Reporting >Purge Schedule Configuration from theUnified CCXAdministration
menu bar to access the Purge Schedule Configuration web page.

The Historical Reporting Configuration web page opens, enabling you to configure the following:

• Daily purge schedule

• Automatic purge (you can specify how long records should persist before the system purges them)

Purge Now Option
Use the Purge Now area to manually purge data.

Choose Tools > Historical Reporting > Purge Now from the Unified CCX Administration menu bar to
access the Purge Now area.

File Restore Option
Use the File Restore area to restore the database records written to HR files when the database goes down.

In case of an High Availability setup, files from both the nodes are restored to the HR Database of the first
and second node respectively. If it is unable to connect to the second node, you will see an alert message
stating that the remote node is not reachable. When the second node comes up, the restored data will be
replicated but you must repeat this Restore operation to restore the HR files, if any, on the second node.
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Procedure

Step 1 Choose Tools > Historical Reporting > File Restore from the Unified CCX Administration menu bar to
access the Historical Reporting Configuration web page.

Restore Now radio button is enabled by default on this
page.

Note

Step 2 Click the Start icon that displays in the toolbar in the upper left corner of the window or the Start button that
displays at the bottom of the window to restore the database records.
You can view the status of the restore operation on this page.

User Management Menu
The User Management menu option allows you to assign access levels to Unified CCX system administrators
and supervisors.

When you configure a Unified CCX supervisor, you are configuring users who can access the Unified CCX
Supervisor web pages. You are not creating a supervisor for Unified CCX.

Only administrators can update the Unified CCX system. You must select at least one administrator, so
that someone is available to perform updates.

Note

Do not edit users, teams and permissions in Unified Intelligence Center. The Unified CCX to Unified
Intelligence Center sync runs as part of daily purge and synchronizes these settings on Unified Intelligence
Center according to Unified CCX settings.

Attention

Procedure

Choose Tools > User Management and click any of the following submenu options from the Unified
CCX Administration menu bar to assign administrative privileges to administrators and supervisors:

• User View Submenu, on page 300

• Name Grammar Generator Configuration, on page 300

• Spoken Name Upload Submenu, on page 301

• Administrator Capability View Menu, on page 301

• Supervisor Capability View Menu, on page 302

• Reporting Capability View Menu, on page 302

• Agent Capability View Menu, on page 303
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User View Submenu
From the Unified CCX Administration menu bar, choose Tools > User Management > User View to access
the User Configuration web page.

Use this page to view existing users and assign administrative privileges to administrators and supervisors.
You can provide a search string based on a user ID; for example, if you provide the search string as

• “*Agent1”, it will display user IDs ending with Agent1

• “Agent1*”, it will display user IDs starting with Agent1

• “Agent1”, it will display user IDs that contain Agent1.

All the columns are hyperlinked to the user configuration page.

This search bar will search the users only by last name or user ID. Do not use the first name for searching.Note

Name Grammar Generator Configuration
Use the Name Grammar Generator Configuration web page to define scheduling information for the Name
Grammar Generator.

From the Unified CCX Administration menu bar, choose Tools > User Management > Name Grammar
Generator Configuration to access Name Grammar Generator Configuration area.

Name Grammars must be generated if you wish to use the Name to User Step with ASR. The Name Grammar
Generator scans the User Directory and creates a speech recognition grammar containing every user in the
directory. These grammars are saved in the grammar repository.

You may use the Name Grammar Generator Configuration page to run the Name Grammar Generator or
schedule it to run at some later time. The page also displays the date and time that the NameGrammar Generator
was last run and the completion status of that run.

The following fields are displayed on the Name Grammar Generator web page.

DescriptionField

How often Name Grammar Generator is automatically run. Valid options:
Never, Daily, and Weekly. This is a mandatory field.

Frequency

Time of day to run the task. This is a mandatory field.Run task on (hrs of day)

Day of week to run the task. This is a mandatory field.Run task on (day of week)

Date of last generation of name grammar.Last Completed on

The status after the last name grammar generation. (Display only.)Last Completion Result
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DescriptionField

Select one or more grammar variants to generate from the check box next to
the following three options:

• OSR 3.1.x

• 2003 SISR

• Nuance

Grammar Variant

Running status of the Name Grammar Generator. (Display only.)Current Status

Click the Generate Name Grammar Now icon or button to trigger the Name Grammar Generator.

Clicking Generate Name Grammar Now will not apply changes to the scheduling configuration; you
must click Update to apply scheduling changes.

Note

Spoken Name Upload Submenu
When a caller requests to be transferred to a specific extension, Unified CCX applications can playback a
recording of the spoken name of the person to whom the caller has called. These spoken name recordings are
stored as .wav files and managed by the Spoken Name Upload tool of the Unified CCX Administration web
interface.

To access the Spoken Name Prompt Upload web page, choose Tools > User Management > Spoken Name
Upload from the Unified CCX Administration menu bar.

The Spoken Name Prompt Upload web page also contains the Click Here for Recording Information icon
and button, which displays a .htm page in your browser with more information on recording spoken name
prompts.

Administrator Capability View Menu
From the Unified CCX Administration menu bar, choose Tools > User Management > Administrator
Capability View to access the capability view for the Administrator User Management area.

This web page contains a pane for users identified as Unified CCX Administrator and another pane with the
list of Available Users. Based on your requirements, you can move users back and forth between these two
panes by clicking the arrows in either direction. Click Update to save the changes.

Note • You cannot assign Administrator capability to a user ID that is the same as the application
administrator user ID created during the Unified CCX installation. If you assign Administrator
capability to such a user ID, an error appears.
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Supervisor Capability View Menu
From the Unified CCXAdministrationmenu bar, chooseTools >UserManagement > Supervisor Capability
View to access the capability view for the Supervisor User Management area.

This web page contains a pane for users identified as the Unified CCX Supervisor and another pane with the
list of Available Users. Based on your requirements, you can move users back and forth between these two
panes by clicking the arrows in either direction.

For a supervisor to access Unified Intelligence Center Live Data reports, an extension should be assigned
to the supervisor.

Note

You cannot assign Supervisor capability to a user ID that is the same as the application administrator user
ID created during the Unified CCX installation. If you assign Supervisor capability to such a user ID, an
error appears.

Note

Reporting Capability View Menu
From the Unified CCXAdministrationmenu bar, chooseTools >UserManagement >Reporting Capability
View to access the capability view for the Historical Report Users area.

The capability view for the Reporting Management web page contains a pane for users identified as Unified
CCX Historical Report Users and another pane with the list of Available Users. Based on your requirements,
you can move users back and forth between these two panes by clicking the arrows in either direction.

You cannot assign Reporting capability to a user ID that is the same as the application administrator user
ID created during the Unified CCX installation. If you assign Reporting capability to such a user ID, an
error appears.

Note

The following users can access Unified Intelligence Center:
Available reportsAccessRoles

• Historical reports

• Live Data reports

Super userApplication
administrator

• Historical reports

• Live Data reports

Unified CCX administrator must assign
this role to a user.

Reporting user

Live Data reportsUnified CCX administrator must assign
this role to a user.

Supervisor
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Available reportsAccessRoles

Agent-specific Live Data reportsUnified CCX administrator must assign
this role to a user.

Agent

Agent Capability View Menu
From the Unified CCX Administration menu bar, choose Tools > User Management > Agent Capability
View to access the capability view for Unified CCX agents.

The capability view for the Agent User Management web page contains a pane for users identified as Unified
CCX Agents and another pane with the list of Available Users. Based on your requirements, you can move
users back and forth between these two panes by clicking the arrows in either direction.

Password Management
From the Unified CCX Administration menu bar, choose Tools > Password Management to access the
password management web page.

You can set or reset the passwords for the following external database users using this web page:

DescriptionUsernameUser

This user can connect to
Configuration and Historical
databases and has read-only access
to RtICDStatistics and
RtCSQsSummary tables.

uccxwallboardWallboard

uccxrecordingRecording SFTP

uccxworkforceWorkforce Management

This user can connect to
Configuration, Historical, and
Repository databases and has the
following privileges:

• read-only access to
Historical, Configuration, and
Repository tables

• execute stored procedures

• create new stored procedures

uccxhruserHistorical Reporting

uccxsctSystemCall Tracking (part of Real
Time Monitoring Tool/ Analysis
Manager)
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Click Save icon that displays in the toolbar in the upper left corner of the window or the Save button that
displays at the bottom of the window. An error message appears if the old and new passwords are same for
any of the users.

To remove the data entered and to retain the existing passwords, click the Clear button.

Note • The maximum length of the password entered is limited to 80 characters.

• A new password cannot be one of the last five passwords used.

• There is no default password set. You must manually reset it for the first time.

In case of a High Availability deployment, the password change will not be propagated to the second node.
You must access the Administration web interface of the second node manually to change the password. In
an HA setup, you can see Check Consistency icon or button in the Password Management page. Use this
button to check and confirm whether the passwords between the two nodes match or not. You can see the
status of the password check in the Password Management page.
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C H A P T E R  19
Help Menu

The Help Menu of the Unified CCX Administration web interface provides access to online help for the
Unified CCX system.

Use the Help menu to access configuration procedures and descriptions of Unified CCX components.

The Help menu contains the following menu options:

• Contents and Index—Choose this option to view the entire Unified CCX Administrator Guide online
help system and index.

• For this page—Choose this option to view context-sensitive help.

• Troubleshooting Tips—Choose this option to view the troubleshooting wiki page for suggestions on
how to solve problems that may arise in the performance of your Unified CCX system.

• Unified CCX Documentation on Cisco.com—Choose this option to view the documentation index
page.

• About—Choose this option to view Unified CCX version information.

The following sections describe the Help menu options.

• Contents and Index, page 305

• For This Page Menu, page 306

• Troubleshooting Tips Menu, page 306

• Unified CCX Documentation Link, page 306

• About Menu, page 307

Contents and Index
To view the entire Unified CCX Administrator Guide online help system and index, chooseHelp >Contents
and Index from the Unified CCX Administration menu bar. The Unified CCX Administrator Guide Online
Help window opens.

When you click any topic in the top pane, the section of the online help that corresponds to that topic appears
in the bottom pane.
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The following table describes the menu options in the Unified CCXAdministrator Guide Online Help window.

DescriptionMenu Option

Returns you to the previous page.Back

Leads you to the next page.Forward

Prints the help document.Print

Opens a PDF version of the Cisco Unified CCX Administration
Guide.

View PDF

Displays the index and contents of the Unified CCX Administrator
Guide online help files in a separate web page. The index is displayed
in the left pane while the contents are displayed in the right pane in
the online help page.

Contents and Index

For This Page Menu
To access context-sensitive help, open the web page for which you want help and choose Help > For This
Page from the Unified CCXAdministration menu bar. The Unified CCXAdministration online help displays
information that is specific to the open web page.

Troubleshooting Tips Menu
The Unified CCX system provides the Troubleshooting Tips tool as a way for you to search the troubleshooting
wiki page for suggestions on how to solve problems that may arise in the performance of your Unified CCX
system.

For more information, see the TroubleshootingWiki page: http://docwiki.cisco.com/wiki/Troubleshooting_
Unified_Contact_Center_Express.

Note

To access the Troubleshooting Tips wiki page, choose Help > Troubleshooting Tips from the Unified
CCX Serviceability Administration menu bar.

Unified CCX Documentation Link
To access the complete Unified CCX documentation set for Unified CCX, and Unified IP IVR, choose Help
> Cisco Unified CCX Documentation on Cisco.com from the Unified CCX Administration menu bar. A
new browser window opens to display the following documentation index page: http://www.cisco.com/en/
US/products/sw/custcosw/ps1846/tsd_products_support_series_home.html.
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About Menu
To access Unified CCX version information, choose Help > About from the Unified CCX Administration
menu bar. The Unified CCX Administration web page opens, displaying version information and package
information.
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C H A P T E R  20
Cisco Mobile Skill Manager

The Unified CCX supervisor can use the Cisco Mobile Skill Manager on a smart phone to remotely manage
the skill data of all associated agents. This application is not a native one and can run on smart phone browsers.

The devices with the following operating systems are supported:

• For Apple devices using iOS - 5.x and above with Safari browser

• For Android devices - 2.x and above with default browser

The following sections provide procedures to allow you to access Cisco Mobile Skill Manager, such as
modify the team; add and delete new skills, add, delete and update skills of agents; and view skills and agents.

• Access Mobile Skill Manager, page 309

• Adding Skills Using Cisco Mobile Skill Manager, page 310

• Searching Skills Using Cisco Mobile Skill Manager, page 311

• View Details of Resources Assigned to Supervisor, page 311

• View Resources Assigned to Supervisor, page 312

• Search Resources Using Cisco Mobile Skill Manager, page 312

• Modify Resource Team, page 312

• Assign Skill Competency to Resource, page 313

• Unassign Skill Competency of Resource, page 313

Access Mobile Skill Manager
Pre-requisites

Cisco Mobile Skill Manager allows you as the supervisor to manage the skill data associated with an agent.
You can also modify the agent team, and add and delete new skills. Before you access the Cisco Mobile Skill
Manager, make sure

• the supervisor capability is assigned to you. To knowmore on supervisor options, see sections Supervisor
Privileges and User View submenu option, in this guide.
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• Cisco Tomcat and Cisco Unified Cluster View Daemon services are up and running.

Follow the steps below to login to Cisco Mobile Skill Manager from your smart phone:

1 Open Cisco Mobile Skill Manager home page from your mobile smart phone browser and enter the
following case-sensitive URL: https://<ipaddress>/mobileskillmanager

In this example, replace <ipaddress> with the IP address of the required Unified CCX server.

2 In the Security Alert dialog box that displays, click the appropriate button.

3 In the Cisco Mobile Skill Manager authentication page, enter the supervisor credentials, and click Sign
In.

A window with the Resources and Skills links is displayed.

• Resources: This link is used to access the Resources page. This page displays the resources assigned
to you.

• Skills: This link is used to access the Skills page. You can add a new skill or delete an existing skill
from this page.

4 Select either depending on what you want to do. Individual tasks related to these two choices are provided
separately.

Adding Skills Using Cisco Mobile Skill Manager
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Skills.
Step 3 In the Skills page, enter the name of the skill in the edit box and click the Add button.

A dialog box confirming the successful addition of skill is displayed.

Step 4 Click OK.
The dialog box closes and the Skills page refreshes to display the updated list of skills.
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Searching Skills Using Cisco Mobile Skill Manager
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Skills.
Step 3 In the Skills page, enter the skill to be searched in the search filter box.
Step 4 If the skill exists, the same will be displayed.

View Details of Resources Assigned to Supervisor
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.

The Resources page launches to display all resources assigned to the supervisor.

Step 3 Click the selected resource name. The Resource details page launches and lists the following details of the
selected resource.

DescriptionField

Displays the full name of the resource.Full Name

Displays the user id of the resource.User Id

Displays the IPCC extension of the resource.IPCC Extension

Link to launch the Teams page which displays the team to which the resource
is assigned.

Team

Link to launch the Assigned skills page which displays the skills assigned to
the resource.

Skills
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View Resources Assigned to Supervisor
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.

The Resources page launches to display all resources assigned to the supervisor.

Search Resources Using Cisco Mobile Skill Manager
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.
Step 3 In the Resources page, enter the name of the agent, that you want to search, in the Search box.

The agent information is displayed.

Modify Resource Team
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.

The Resource page launches and all resources assigned to the supervisor are displayed.

Step 3 Click the resource name to launch the Resource details page.
Step 4 In the Resource details page, click Teams.

The Teams page launches to display all the teams configured in the Cisco CCX system.

Step 5 Click the team name, then in the confirmation box click OK.
A window displays the successful modification of the team.

Step 6 To return back to the Agents Details page, click OK.
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Assign Skill Competency to Resource
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.

The Resource page displays all the resources assigned to the supervisor.

Step 3 Click the resource name to display the Resource details window.
Step 4 Click Skill.

All skills configured in Unified CCX are displayed.

Step 5 To set the competency level for a particular skill, select the value from the drop down list displayed against
each skill.

Step 6 Click the Update button located at the top of the window.
A dialog box displays the successful assignment of a skill to a resource.

Step 7 Click OK to be redirected to the Resources Details page.

Unassign Skill Competency of Resource
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.

Example:

The Resources page launches displaying names of all resources assigned to the supervisor.

Step 3 Click on a resource name to launch the Resources details page.
Step 4 Click Skills.

The skills page with all skills configured in Unified CCX is displayed.

Step 5 To unassign the competency level for a particular skill, select the value NA from the drop-down list for that
resource.

Step 6 Click the Update button that displays at the top of the window.

Example:

A dialog box shows the success of the task, that is unassigning a skill.

Step 7 Click OK to return to the Resource Details page.
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C H A P T E R  21
Cisco Finesse

• Introduction, page 315

• Cisco Finesse Administration Console, page 316

• Cisco Finesse Agent and Supervisor Desktop , page 384

• Call Manager-Based Call Recording Using Cisco MediaSense, page 384

Introduction
Cisco Finesse is a next-generation agent and supervisor desktop designed to provide a collaborative experience
for the various communities that interact with your customer service organization. It helps improve the customer
experience while offering a user-centric design to enhance customer care representative satisfaction as well.

Cisco Finesse provides:

• A browser-based administration console and a browser-based desktop for agents and supervisors; no
client-side installations required.

• A single, customizable "cockpit", or interface, that gives customer care providers quick and easy access
to multiple assets and information sources.

• REST APIs that simplify the development and integration of value-added applications and minimize
the need for detailed desktop development expertise.

Finesse configuration changes are permitted on only the primary server. Access to Finesse administration
console on the secondary server is read-only.

When you attempt to save the changes in Finesse administration console on the secondary node, you receive
a message that administration on the secondary node is read-only.
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Cisco Finesse Administration Console

Getting Started
This chapter describes the interfaces that you use to configure, administer, and maintain Cisco Finesse and
describes how to access them.

Administration Tools

Cisco Finesse Administration Console

The Cisco Finesse administration console is a web-based interface used to configure system settings in Cisco
Finesse. The administration console contains tabs that you click to access the various administration features.
The tab names and the tasks that you can perform on each tab are as follows:

• Settings: IP Phone Agent Settings, and Context Service Management.

• Call Variables Layout:Manage the call variables and ECC variables that appear on the agent desktop
call control gadget.

• Desktop Layout:Make changes to the default desktop layout for agents and supervisors.

• Phone Books: Add, edit, or delete phone books or phone book contacts.

• Reasons: Add, edit, or delete Not Ready reason codes, Sign Out reason codes, or Wrap-Up reasons.

• Team Resources: Assign desktop layouts, phone books, reason codes, and wrap-up reasons to specific
teams.

•Workflows: Create and manage workflows and workflow actions.

The features you configure in the administration console are case-sensitive. For example, you can create two
workflows named WORKFLOW and workflow or two phone books named BOOK and book.

Sign In to Cisco Finesse Administration Console
You can access the Cisco Finesse administration console only through HTTPS.

When you sign in to Finesse, always use the fully qualified domain name (FQDN) of the Finesse server in
the URL, not the server IP address or hostname.

Procedure

Step 1 Direct your browser to https://FQDN:8445/cfadmin, where FQDN is the fully qualified domain name of your
primary server.

Step 2 On the Sign-In page, in the ID field, enter the Application User ID that was established during the installation.
Step 3 In the Password field, enter the Application User password that was established during the installation.
Step 4 Click Sign In.
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A successful sign-in launches an interface with defined administration gadgets and a Sign Out link.

Account Locked After Five Failed Sign In Attempts
If an administrator tries to sign in to the Finesse administrator console (or diagnostic portal) with the wrong
password five times in a row, Finesse blocks access to that user account for a period up to 30 minutes. For
security reasons, Finesse does not alert the user that their account is locked. They must wait 30 minutes and
try again.

Similarly, if agents or supervisors sign in to the desktop five times in a row with the wrong password, Finesse
blocks access to that user account. However, in this case, the lockout period is only 5 minutes. This restriction
also applies when agents and supervisors sign in using the mobile agent or Finesse IP Phone Agent (IPPA).

When an agent or supervisor account is locked, subsequent attempts to sign in, even with correct credentials,
reset the lockout period to 5 minutes again. For example, if a locked user tries to sign in again after only
4 minutes, the lockout period is reset and the user must wait another 5 minutes. This reset does not apply
to the administrator account.

Note

To view whether a user account is locked, enter the following CLI command:

file get activelog desktop recurs compress

Then extract the zipped output, and search the catalina.out logs (opt/cisco/desktop/finesse/logs/catalina.out)
for the following message referring to the locked username:

An attempt was made to authenticate the locked user "<username>"

Manage System Settings

For information about Finesse IP Phone Agent Settings, seeManage Finesse IP Phone Agent.Note

Context Service Settings
Cisco Context Service is a cloud-based omnichannel solution for Cisco Unified Contact Center Express. It
enables you to capture your customer’s interaction history by providing flexible storage of customer-interaction
data across any channel.

Context Service works out of the box with Cisco Customer Collaboration products. Context Service also
provides an SDK interface for integration with your own applications or third-party applications to capture
end-to-end customer-interaction data.

For more information about Context Service and to check service availability, see
https://help.webex.com/community/context-service.
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Context Service Network Connectivity Requirements

Context Service is a cloud-based service and requires call center components using Context Service to be able
to connect to the public Internet.

Context Services uses port 443 (HTTPS).

Whitelist these URLs in your firewall to allow your Contact Center components to connect to, and receive
data from the Internet.

• *.webex.com

• *.wbx2.com

• *.ciscoccservice.com

Note • Youmust use wildcard URLs in your whitelist because Context Service is accessed through multiple
subdomains. Context Service subdomain names can dynamically change.

Configure Context Service Settings

Use the Context Service Management gadget to register Finesse and Unified CCX with the Context Service.

Procedure

Step 1 If you are not already signed in, sign in to the Finesse administration console.
Step 2 To register Finesse and Unified CCX with the Context Service, in the Context Service Management gadget,

click Register.
For more information about Context Service registration, see http://docwiki.cisco.com/wiki/Context_Service.

Step 3 If after a successful registration you want to deregister Finesse and Unified CCX from the Context Service,
click Deregister.

Manage Call Variables Layouts

Call Variables Layouts
You can use the Call Variables Layouts gadget to define how call variables appear on the Finesse agent
desktop. You can configure up to 200 unique Call Variables Layouts (one default layout and 199 custom
layouts). As part of this functionality:

• Each layout has a name (required) and description (optional).
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• After an upgrade from a release earlier than Cisco Finesse Release 11.0, Finesse migrates the previously
configured default layout and assigns it the default name (Default Layout) and description (Layout used
when no other layout matches the user layout Custom/ECC Variable).

• You can change the name and description of the default Call Variables Layout.

• You cannot delete the default Call Variables Layout.

• Finesse appends (Default) to the name of the default Call Variables Layout.

• To display a custom Call Variables Layout, in the Unified CCX routing script set the user.layout ECC
variable to the name of a configured Call Variables Layout. In this case, if no custom layouts match the
user.layout value (or no custom layouts are configured), Finesse displays the default layout.

Call Variables
Each Call Variables Layout supports one variable in the header of the call control gadget and up to a total of
20 variables in two columns below the header (up to 10 in each column). You can use call variables, Extended
Call Context (ECC) variables, or the following Outbound Option ECC variables.

• BACampaign

• BAAccountNumber

• BAResponse

• BAStatus

• BADialedListID

• BATimeZone

• BABuddyName

• BACustomerNumber

Columns can be empty.

To enable Outbound Option data to appear in Cisco Finesse, the administrator must edit the Default layout
to include some or all Outbound Option variables.

Configure Call Variables Layouts

Procedure

Step 1 From the Manage Call Variables Layouts gadget:

• To create a new Call Variables Layout, click New.

• To modify an existing Call Variables Layout, choose a layout from the list, and click Edit (or click
Delete to remove it).

Step 2 Under Create New Layout (or under Edit <layout name> when editing an existing layout):

• Enter a name for the Call Variables Layout (maximum 40 characters).

Cisco Unified CCX Administration Guide, Release 11.0(1)    
319

Cisco Finesse
Manage Call Variables Layouts



• Enter a description of the Call Variables Layout (maximum 128 characters).

Step 3 Under Call Header Layout:

• Enter the display name that you want to appear in the header of the Call Control gadget on the Finesse
desktop, for example, Customer Name (maximum 50 characters).

• From the drop-down list, choose the call variable or Outbound Option ECC variable that you want to
appear in the header, for example, callVariable3 (maximum 32 characters).

Step 4 In the Call Body Left-Hand Layout and Call Body Right-Hand Layout areas:
a) Click Add Row to add a new row (or click the “X” to delete a row).
b) For each row:

• Enter the display name that you want to appear on the desktop, for example, Customer Name
(maximum 50 characters).

• Enter the corresponding call variable or Outbound Option ECC variable from the drop-down list
(maximum 32 characters).

Step 5 Click Save to save the changes, or Cancel to discard the changes.
When you modify the Call Variables Layout of the agent desktop, the changes you make take effect
after three seconds. However, agents who are signed in when the changes are made must sign out
and sign back in to see those changes reflected on their desktops.

Note

Step 6 To view the latest configured Call Variables Layout, click Refresh from the Manage Call Variables Layouts
gadget.
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Add ECC Variables to Call Variables Layout

Cisco Finesse only supports Latin1 characters for ECC variables. Other Unicode characters are not
supported. For example, if you add an ECC variable that contains Chinese characters to the call variable
layout, it may not appear correctly on the agent desktop.

Note

Procedure

Step 1 In the header or the row where you want the ECC variable to appear, from the Variable drop-down list, choose
Custom.
The Custom/ECC Variable Entry dialog box appears.

Step 2 In the Custom/ECC Variable Name field, enter the name of the ECC variable you want to appear on the agent
desktop.

Step 3 Click Set.
The ECC variable now appears in the Variable drop-down list for selection.

Assign Call Variables Layouts

Procedure

Step 1 In the CCX Editor's Expanded Call Variables tab, create an ECC variable called user.layout in the Set
Enterprise Call Info Step used in the CCX routing script.

If both a user.layout and a user.Layout are specified, Finesse will prioritize user.layout over
user.Layout. If the layout specified in the user.Layout or user.layout is not found, Finesse will use
the Default layout.

Note
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Step 2 Set the value of user.layout to the name of the call variables layout that should be used. The layout name
should match the name of a call variables layout that was created on the Call Variables Layout tab in Finesse
Administration.

Manipulate Call Variables Layouts with a Workflow
You can manipulate the call variables layout that an agent sees when a call arrives by using a workflow. To
do so, configure an HTTP Request workflow action and set the value of the ECC variable user.Layout to the
name of the custom layout to display.

For information about how and when workflows are executed, seeWorkflows and Workflow Actions.

For more details, see the section, "Adding an HTTP Request Workflow Action" in the white paper Cisco
Finesse: How to Create a Screen-Pop Workflow.

Manage Desktop Layout
You can define the layout of the Finesse desktop on the Desktop Layout tab.

Requirements, such as processor speed and RAM, for clients that access the Finesse desktop can vary.
Desktops that receive events for more than one agent (such as agent and supervisor desktops running Live
Data reports that contain information about other agents and skill groups) require more processing power
than desktops that receive events for a single agent.

Factors that determine how much power is required for the client include, but are not limited to, the
following:

Important

• Contact center traffic

• Additional integrated gadgets in the desktop (such as Live Data reports or third-party gadgets)

• Other applications that run on the client and share resources with the Finesse desktop

Finesse Desktop Layout XML
The Finesse Layout XML defines the layout of the Finesse desktop, including tab names and the gadgets that
appear on each tab.

Use the Manage Desktop Layout gadget to upload an XML layout file to define the layout of the Finesse
desktop for agents and supervisors.

Actions on the Manage Desktop Layout gadget:

• Finesse Default Layout XML: Expands to show the layout XML for the default Finesse desktop.

• Restore Default Layout: Restores the Finesse desktop to the default layout.

• Save: Saves your configuration changes.

• Revert: Retrieves and applies the most recently saved desktop layout.
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Default Layout XML
The Finesse default desktop layout XML for Unified CCX contains optional tabs and gadgets forMediaSense,
Web Chat and Email, and notes that describe how to modify the layout for your deployment type.

Remove the comments from the optional gadgets and tabs that you want to appear on the Finesse desktop.

Remove any gadgets or tabs that you do not want to use.

Line breaks and spaces that appear in the following text are provided only for readability and must not be
included in the actual code.

Note

<finesseLayout xmlns="http://www.cisco.com/vtg/finesse">
<layout>

<role>Agent</role>
<page>

<gadget>/desktop/gadgets/CallControl.jsp</gadget>
<!--

The following Gadget is used for WebChat and Email. It is *ONLY* supported with
WebChat and Email. If you are not using WebChat and Email, then remove it. If you
are using WebChat or Email, include this Gadget in the Desktop Layouts used by
Teams associated with chat and email CSQs. To include this functionality:

1) Remove these comments leaving the gadget

RESTRICTIONS:
- The NonVoiceControl gadget must be configured as a page level gadget
- The NonVoiceControl gadget must not be configured in a column

<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>
-->

</page>
<tabs>

<tab>
<id>home</id>
<label>finesse.container.tabs.agent.homeLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId=76D964AD10000140000000830A4E5E6F&
filterId=AgentCSQStats.csqName=CL&compositeFilterId=
AgentCSQStats.AgentIds.agentId=loginId</gadget>
<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId=5C626F9C10000140000000600A4E5B33&
filterId=ResourceIAQStats.resourceId=CL</gadget>

</gadgets>
</column>

</columns>
</tab>
<tab>

<id>myStatistics</id>
<label>finesse.container.tabs.agent.myStatisticsLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=150&
viewId=67D4371110000140000001080A4E5E6B&
filterId=ResourceIAQStats.resourceId=loginId</gadget>
<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=420&
viewId=5D411E8A10000140000000230A4E5E6B&
filterId=AgentStateDetailStats.agentID=loginId</gadget>

</gadgets>
</column>
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</columns>
</tab>
<tab>

<id>manageCustomer</id>
<label>finesse.container.tabs.agent.manageCustomerLabel</label>
<gadgets>

<gadget>/desktop/gadgets/CustomerContext.xml</gadget>
</gadgets>

</tab>
<!--

The following Tab and Gadget are used for WebChat and Email. They are *ONLY*
supported with WebChat and Email. If you are not using WebChat or Email, then remove
them. If you are using WebChat or Email, include this Gadget in the Desktop Layouts
used by Teams associated with chat or email CSQs. To include this functionality:

1) Remove these comments leaving the tab and gadget
2) Replace all instances of "my-socialminer-server" with the Fully Qualified

Domain Name of your SocialMiner Server.
3) [OPTIONAL] Adjust the height of the gadget by changing the "gadgetHeight"

parameter.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented
prerequisite steps.

RESTRICTIONS:
- The multisession-reply-gadget must not be configured as a page level gadget
- The multisession-reply-gadget must not be configured in a column

<tab>
<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.agent.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/
gadgets/multisession-reply-gadget.jsp?gadgetHeight=430
</gadget>

</gadgets>
</column>

</columns>
</tab>

-->
</tabs>

</layout>
<layout>

<role>Supervisor</role>
<page>

<gadget>/desktop/gadgets/CallControl.jsp</gadget>
<!--

The following Gadget is used for WebChat and Email. It is *ONLY* supported with
WebChat and Email. If you are not using WebChat and Email, then remove it. If
you are using WebChat or Email, include this Gadget in the Desktop Layouts used
by Teams associated with chat or email CSQs. To include this functionality:

1) Remove these comments leaving the gadget

RESTRICTIONS:
- The NonVoiceControl gadget must be configured as a page level gadget
- The NonVoiceControl gadget must not be configured in a column

<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>
-->

</page>
<tabs>

<tab>
<id>manageTeam</id>
<label>finesse.container.tabs.supervisor.manageTeamLabel</label>
<columns>

<column>
<gadgets>

<gadget>/desktop/gadgets/TeamPerformance.jsp</gadget>
</gadgets>

</column>
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</columns>
</tab>
<tab>

<id>teamData</id>
<label>finesse.container.tabs.supervisor.teamDataLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=620&
viewId_1=7291DCB410000140000000890A4E5B33&
filterId_1=ResourceIAQStats.resourceId=CL&
viewId_2=728283C210000140000000530A4E5B33&
filterId_2=ResourceIAQStats.resourceId=CL</gadget>

<!--
The following Gadget is used for WebChat. It is *ONLY* supported with WebChat. If
you are not using WebChat, then remove it. If you are using WebChat, include this
Gadget in the Desktop Layouts used by Teams associated with chat CSQs. To include
this functionality:

1) Remove these comments leaving the gadget

<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId=F2F1FC17100001440000014E0A4E5D48&
filterId=ChatAgentStats.agentId=CL</gadget>

-->
<!--

The following Gadgets are used for Predictive/Progressive/Preview Agent Outbound.
To include this functionality:
1) Remove these comments leaving the gadget

<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId=FD919FB9100001440000005D0A4E5B29&
filterId=ResourceIAQStats.resourceId=CL</gadget>
<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId=FD919FB510000144000000470A4E5B29&
filterId=ResourceIAQStats.resourceId=CL</gadget>

-->
</gadgets>

</column>
</columns>

</tab>
<tab>

<id>queueData</id>
<label>finesse.container.tabs.supervisor.queueDataLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://localhost:8444/cuic/gadget/
LiveData/LiveDataGadget.jsp?gadgetHeight=620&
viewId_1=C8E2DB1610000140000000A60A4E5E6B&
filterId_1=VoiceIAQStats.esdName=CL&
viewId_2=9A7A14CE10000140000000ED0A4E5E6B&
filterId_2=VoiceCSQDetailsStats.agentId=CL&
compositeFilterId=VoiceCSQDetailsStats.
AgentVoiceCSQNames.agentVoiceCSQName=CL&
viewId_3=C8EF510810000140000000EB0A4E5E6B&
filterId_3=VoiceIAQStats.esdName=CL&
viewId_4=C8EE241910000140000000C30A4E5E6B&
filterId_4=VoiceIAQStats.esdName=CL</gadget>

<!--
The following Gadget is used for WebChat. It is *ONLY* supported with WebChat. If
you are not using WebChat, then remove it. If you are using WebChat, include this
Gadget in the Desktop Layouts used by Teams associated with chat CSQs. To include
this functionality:

1) Remove these comments leaving the gadget

<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=E42ED788100001440000007B0A4E5CA1&
filterId=ChatQueueStatistics.queueName=CL</gadget>
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-->
</gadgets>

</column>
</columns>

</tab>
<tab>

<id>manageCustomer</id>
<label>finesse.container.tabs.supervisor.manageCustomerLabel</label>
<gadgets>

<gadget>/desktop/gadgets/CustomerContext.xml</gadget>
</gadgets>

</tab>
<!--

The following Tab and Gadget are used for WebChat and Email. They are *ONLY*
supported with WebChat and Email. If you are not using WebChat or Email, then remove
them. If you are using WebChat or Email, include this Gadget in the Desktop Layouts
used by Teams associated with chat or email CSQs. To include this functionality:

1) Remove these comments leaving the tab and gadget
2) Replace all instances of "my-socialminer-server" with the Fully Qualified

Domain Name of your SocialMiner Server.
3) [OPTIONAL] Adjust the height of the gadget by changing the "gadgetHeight"

parameter.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented
prerequisite steps.

RESTRICTIONS:
- The multisession-reply-gadget must not be configured as a page level gadget
- The multisession-reply-gadget must not be configured in a column

<tab>
<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.supervisor.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/
gadgets/multisession-reply-gadget.jsp?gadgetHeight=430
</gadget>

</gadgets>
</column>

</columns>
</tab>

-->
<!--

The following Tab and Gadget are for MediaSense. They are *ONLY* supported with
MediaSense. If you are not using MediaSense, then remove them. If you are using
MediaSense and wish to show Recording Management, then do the following:

1) Remove these comments leaving the tab and gadget
2) Replace all instances of "my-mediasense-server" with the Fully Qualified

Domain Name of your MediaSense Server.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented
prerequisite steps.

<tab>
<id>manageRecordings</id>
<label>finesse.container.tabs.supervisor.manageRecordingsLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-mediasense-server:8440/ora/gadget/
MediaSenseGadget.xml</gadget>

</gadgets>
</column>

</columns>
</tab>

-->
</tabs>
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</layout>
</finesseLayout>

Update Default Desktop Layout
When you modify the layout of the Finesse desktop, the changes you make take effect on the desktop after
10 seconds. However, agents who are signed in when the changes are made must sign out and sign back in
to see those changes reflected on the desktop.

The call control gadget is only supported at the page level. You must ensure that the call control gadget
(<gadget>/desktop/gadgets/CallControl.jsp</gadget>) is placed within the <page></page> tag for it to
work correctly. Do not place this gadget within a <tab></tab> tag.

Note

Procedure

Step 1 In the Finesse Layout XML area, make changes to the XML as required.

Example:
If you want to add a new tab called Reports, add the following XML within the tabs tags under the
<role>Agent</role> tag.

<tab>
<id>reports</id>
<label>Reports</label>
</tab>

If you want to add this tab to the supervisor desktop, add the XML within the tabs tags under the
<role>Supervisor</role> tag.

To add a gadget to a tab, add the XML for the gadget within the gadgets tag for that tab.

<gadgets>
<gadget>http://<ipAddress>/gadgets/<gadgetname>.xml</gadget>

</gadgets>

Replace <ipAddress> with the IP address of the server where the gadget resides.

If you want to add multiple columns to a tab on the Finesse desktop, add the gadgets for each column within
the columns tags for that tab. You can have up to four columns on a tab.

<tab>
<id>tab-id</id>
<label>Tab Label</label>
<columns>

<column>
<gadgets>

<gadget>/gadget/1/url.xml</gadget>
<gadget>/gadget/2/url.xml</gadget>

</gadgets>
</column>
<column>

<gadgets>
<gadget>/gadget/3/url.xml</gadget>
<gadget>/gadget/4/url.xml</gadget>

</gadgets>
</column>
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</columns>
</tab>

Step 2 Click Save.
Finesse validates the XML file to ensure that it is valid XML syntax and conforms to the Finesse schema.

Step 3 After you save your changes, if you want to revert to the last saved desktop layout, click Revert. If you want
to revert to the default desktop layout, click Restore Default Layout.

XML Schema Definition
Youmust ensure the XML you upload conforms to the XML schema definition for Finesse. The XML schema
definition for Finesse is as follows:

<?xml version="1.0" encoding="ISO-8859-1" ?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"

targetNamespace="http://www.cisco.com/vtg/finesse"
xmlns="http://www.cisco.com/vtg/finesse"
elementFormDefault="qualified">

<!-- definition of role type -->
<xs:simpleType name="role">
<xs:restriction base="xs:string">

<xs:enumeration value="Agent"/>
<xs:enumeration value="Supervisor"/>
<xs:enumeration value="Admin"/>

</xs:restriction>
</xs:simpleType>

<!-- definition of simple elements -->
<xs:element name="id">
<xs:simpleType>
<xs:restriction base="xs:string">
<xs:pattern value="[a-zA-Z]([-_:\.a-zA-Z0-9])*"/>

</xs:restriction>
</xs:simpleType>

</xs:element>

<xs:element name="label">
<xs:simpleType>

<xs:restriction base="xs:string">
<xs:minLength value="1" />

</xs:restriction>
</xs:simpleType>

</xs:element>

<xs:element name="gadget">
<xs:simpleType>

<xs:restriction base="xs:anyURI">
<xs:minLength value="1" />

</xs:restriction>
</xs:simpleType>

</xs:element>
<xs:element name="role" type="role"/>

<xs:element name="gadgets"> <!-- Grouping of a set of gadgets -->
<xs:complexType>

<xs:sequence maxOccurs="unbounded">
<!-- No limit to number of gadget URIs for now -->
<xs:element ref="gadget"/> <!-- URI of the gadget xml -->
</xs:sequence>

</xs:complexType>
</xs:element>
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<xs:element name="page"> <!-- Grouping of a set of persistent gadgets -->
<xs:complexType>

<xs:sequence maxOccurs="unbounded">
<!-- No limit to number of gadget URIs for now -->
<xs:element ref="gadget"/> <!-- URI of the gadget xml -->
</xs:sequence>

</xs:complexType>
</xs:element>

<xs:element name="tab">
<xs:complexType>

<xs:sequence>
<xs:element ref="id"/> <!-- Id of the tab selector in the desktop -->
<xs:element ref="label"/> <!-- Label of the tab selector -->
<xs:element ref="gadgets" minOccurs="0" maxOccurs="1"/>
</xs:sequence>

</xs:complexType>
</xs:element>

<xs:element name="tabs"> <!-- Grouping of tabs -->
<xs:complexType>

<xs:sequence maxOccurs="unbounded">
<!-- No limit to number of tabs for now -->
<xs:element ref="tab"/>
</xs:sequence>

</xs:complexType>
</xs:element>

<xs:element name="layout">
<xs:complexType>

<xs:sequence>
<xs:element ref="role"/> <!-- Type of the role -->
<xs:element ref="page"/> <!-- List of page gadgets -->
<xs:element ref="tabs"/> <!-- Grouping of tabs for this particular role -->
</xs:sequence>

</xs:complexType>
</xs:element>

<xs:element name="finesseLayout"> <!-- Layout of the desktop -->
<xs:complexType>

<xs:sequence maxOccurs="3">
<!-- only support 3 roles for now -->
<xs:element ref="layout" />
</xs:sequence>

</xs:complexType>
</xs:element>

</xs:schema>

Add Web Chat and Email to Finesse
The Cisco Finesse default layout XML contains commented XML code for Web Chat and Email gadgets
available for the Finesse desktop. Each gadget or tab is surrounded by comment characters (<!-- and -->)
and comments that describe what the tab or gadget is for and how to add it to the desktop.

The Chat and Email Control gadget is only supported at the page level. You must ensure that the Chat
and Email Control gadget (<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>)
is placed within the <page></page> tag. Placing this gadget within a <tab></tab> tag is not supported.

Note

The procedure that you follow depends on your deployment. The following table describes when to use each
procedure.
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When to useProcedure

Follow this procedure if you want to add Web Chat
and Email to the Finesse desktop after a fresh
installation or after an upgrade if you have not
customized the default desktop layout.

Add Web Chat and Email to the default desktop
layout.

Follow this procedure if you want to add Web Chat
and Email and have customized the desktop layout.

AddWeb Chat and Email to a custom desktop layout.

Follow this procedure if you want to add Web Chat
and Email to the desktop only for specific teams.

Add Web Chat and Email to a team layout.

After you add the Web Chat and Email gadgets, sign in to the Finesse desktop and make sure they appear
the way you want. Agents who are signed in to Finesse when you change the desktop layout must sign
out and sign back in to see the change on their desktops.

Note

Add Web Chat and Email to the Default Desktop Layout

If you upgraded from a previous release but do not have a custom desktop layout, click Restore Default
Layout on the Manage Desktop Layout gadget and then follow the steps in this procedure.

Note

Procedure

Step 1 In the Finesse administration console, click the Desktop Layout tab.
Step 2 To add the Chat and Email Control gadget to the agent desktop, look for the following under the

<role>Agent</role> tag and within the <page></page> tag:
<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

Step 3 Remove the comments and comment characters (<!-- and -->) that surround the gadget, leaving only the
gadget (<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>).

Step 4 To add the Manage Chat and Email tab and gadget to the agent desktop, look for the following within the
<tabs></tabs> tag:
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.agent.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

   Cisco Unified CCX Administration Guide, Release 11.0(1)
330

Cisco Finesse
Manage Desktop Layout



</columns>
</tab>

Step 5 Remove the comments and comment characters (<!-- and -->) that surround the tab.
Step 6 Replace my-socialminer-server in the gadget URL with the fully-qualified domain name (FQDN) of your

SocialMiner server.
Step 7 Optionally, change the height of the Manage Chat and Email gadget.

Example:
The height specified in the gadget URL is 430 pixels. If you want to change the height, change the gadgetHeight
parameter in the URL to the desired value. For example if you want the gadget height to be 600 pixels, change
the code as follows:
<gadget>https://my-socialminer-server/multisession/ui/gadgets/

multisession-reply-gadget.jsp?gadgetHeight=600</gadget>
The default and minimum height of the Manage Chat and Email gadget is 430 pixels. If you do not specify a
value for the gadgetHeight parameter or if you specify a value that is less than 430, the gadget defaults to 430
pixels.

An agent can be configured to handle up to five chat contacts and five email contacts at a time. If
the agent has the maximum number of contacts on the desktop, not all contacts are visible. If your
agents are configured to handle the maximum number of contacts, you must increase the height of
this gadget to a minimum of 570 pixels to ensure there is enough space for all of the contacts to
appear.

Note

Step 8 To add the Chat and Email Control gadget to the supervisor desktop, look for the following under the
<role>Supervisor</role> tag and within the <page></page> tag:
<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

Step 9 Remove the comments and comment characters (<!-- and -->), leaving only the gadget
(<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>).

Step 10 To add the Live Data report for Agent Chat Statistics to the supervisor desktop, look for the following:
<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=F2F1FC17100001440000014E0A4E5D48&
filterId=ChatAgentStats.agentId=CL</gadget>

Step 11 Remove the comments and comment characters (<!-- and -->), leaving only the gadget.
Step 12 To add the Live Data report for Chat Queue Statistics to the supervisor desktop, look for the following:

<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=E42ED788100001440000007B0A4E5CA1&
filterId=ChatQueueStatistics.queueName=CL</gadget>

Step 13 Remove the comments and comment characters (<!-- and -->), leaving only the gadget.
Step 14 To add the Manage Chat and Email tab and gadget to the supervisor desktop, look for the following within

the <tabs></tabs> tag:
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.supervisor.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
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</column>
</columns>

</tab>

Step 15 Remove the comments and comment characters (<!-- and -->) that surround the tab.
Step 16 Replace my-socialminer-server in the gadget URL with the fully-qualified domain name (FQDN) of your

SocialMiner server.
Step 17 Optionally, change the height of the Manage Chat and Email gadget.
Step 18 Click Save.

Add Web Chat and Email to a Custom Desktop Layout

Procedure

Step 1 In the Finesse administration console, click the Desktop Layout tab.
Step 2 Click Finesse Default Layout XML to show the default layout XML.
Step 3 Copy the XML code for the Chat and Email Control gadget for the agent desktop.

<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

Step 4 To add the gadget to the agent desktop, paste the code within the <page></page> tags under the Call Control
gadget as follows:
<role>Agent</role>
<page>

<gadget>/desktop/gadgets/CallControl.jsp</gadget>
<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

</page>

Step 5 To add the gadget to the supervisor desktop, paste the code within the <page></page> tags under the Call
Control gadget as follows:
<role>Supervisor</role>
<page>

<gadget>/desktop/gadgets/CallControl.jsp</gadget>
<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

</page>

Step 6 Copy the code for the agent Manage Chat and Email tab and gadget from the default layout XML.
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.agent.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>

Step 7 Paste the code within the <tabs></tabs> tag for the agent role after the Manage Call tab:
<tab>

<id>manageCall</id>
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<label>finesse.container.tabs.agent.manageCallLabel</label>
</tab>
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.agent.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>

Step 8 Replace my-social-miner-server with the FQDN of your SocialMiner server.
Step 9 Optionally, change the height of the Manage Chat and Email gadget.

Example:
The height specified in the gadget URL is 430 pixels. If you want to change the height, change the gadgetHeight
parameter in the URL to the desired value. For example if you want the gadget height to be 600 pixels, change
the code as follows:
<gadget>https://my-socialminer-server/multisession/ui/gadgets/

multisession-reply-gadget.jsp?gadgetHeight=600</gadget>
The default and minimum height of the Manage Chat and Email gadget is 430 pixels. If you do not specify a
value for the gadgetHeight parameter or if you specify a value that is less than 430, the gadget defaults to 430
pixels.

An agent can be configured to handle up to five chat contacts and five email contacts at a time. If
the agent has the maximum number of contacts on the desktop, not all contacts are visible. If your
agents are configured to handle the maximum number of contacts, you must increase the height of
this gadget to a minimum of 570 pixels to ensure there is enough space for all of the contacts to
appear.

Note

Step 10 Copy the code for the Live Data gadgets for Agent Chat Statistics and Chat Queue Statistics from the default
layout XML.
<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=F2F1FC17100001440000014E0A4E5D48&
filterId=ChatAgentStats.agentId=CL</gadget>
<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=E42ED788100001440000007B0A4E5CA1&
filterId=ChatQueueStatistics.queueName=CL</gadget>

Step 11 Paste the code for these gadgets within the <gadgets></gadgets> tags for the tabs on which you want them
to appear.

Step 12 Copy the code for the supervisor Manage Chat and Email tab and gadget from the default layout XML.
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.supervisor.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
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multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
</gadgets>

</column>
</columns>

</tab>

Step 13 Paste the code within the <tabs></tabs> tag for the supervisor role after the Manage Call tab:
<tab>

<id>manageCall</id>
<label>finesse.container.tabs.supervisor.manageCallLabel</label>

</tab>
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.supervisor.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>

Step 14 Replace my-social-miner-server with the FQDN of your SocialMiner server.
Step 15 Optionally, change the height of the gadget.
Step 16 Click Save.

Add Web Chat and Email to a Team Layout

Procedure

Step 1 In the Finesse administration console, click the Desktop Layout tab.
Step 2 Click Finesse Default Layout XML to show the default layout XML.
Step 3 Copy the XML code for the Chat and Email Control gadget for the agent desktop and paste it into a text file.

<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

Step 4 Copy the code for the agent Manage Chat and Email tab and gadget and paste it into your text file.
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.agent.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>
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Step 5 Copy the code for the Live Data gadgets for Agent Chat Statistics and Chat Queue Statistics and paste it into
your text file.
<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=F2F1FC17100001440000014E0A4E5D48&
filterId=ChatAgentStats.agentId=CL</gadget>
<gadget>https://localhost:8444/cuic/gadget/LiveData/
LiveDataGadget.jsp?gadgetHeight=310&
viewId=E42ED788100001440000007B0A4E5CA1&
filterId=ChatQueueStatistics.queueName=CL</gadget>

Step 6 Copy the code for the supervisor Manage Chat and Email tab and gadget and paste it into your text file.
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.supervisor.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>

Step 7 Click the Team Resources tab.
Step 8 Select the team from the list of teams for which you want to add Web Chat and Email.
Step 9 Check the Override System Default check box.
Step 10 In the Resources for <team name> area, click the Desktop Layout tab.
Step 11 To add the Chat and Email Control gadget to the agent desktop, copy the code for the gadget from your text

file and paste it within the <page></page> tags under the Call Control gadget as follows:
<role>Agent</role>
<page>

<gadget>/desktop/gadgets/CallControl.jsp</gadget>
<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

</page>

Step 12 To add the gadget to the supervisor desktop, paste the code within the <page></page> tags under the Call
Control gadget as follows:
<role>Supervisor</role>
<page>

<gadget>/desktop/gadgets/CallControl.jsp</gadget>
<gadget>https://localhost/agentdesktop/gadgets/NonVoiceControl.xml</gadget>

</page>

Step 13 To add the Manage Chat and Email tab and gadget to the agent desktop, copy the code from your text file and
paste it within the <tabs></tabs> tag for the agent role after the Manage Call tab:
<tab>

<id>manageCall</id>
<label>finesse.container.tabs.agent.manageCallLabel</label>

</tab>
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.agent.manageNonVoiceMediaLabel</label>
<columns>

<column>
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<gadgets>
<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>

Step 14 Replace my-social-miner-server with the FQDN of your SocialMiner server.
Step 15 Optionally, change the height of the Manage Chat and Email gadget.

Example:
The height specified in the gadget URL is 430 pixels. If you want to change the height, change the gadgetHeight
parameter in the URL to the desired value. For example if you want the gadget height to be 600 pixels, change
the code as follows:
<gadget>https://my-socialminer-server/multisession/ui/gadgets/

multisession-reply-gadget.jsp?gadgetHeight=600</gadget>
The default and minimum height of the Manage Chat and Email gadget is 430 pixels. If you do not specify a
value for the gadgetHeight parameter or if you specify a value that is less than 430, the gadget defaults to 430
pixels.

An agent can be configured to handle up to five chat contacts and five email contacts at a time. If
the agent has the maximum number of contacts on the desktop, not all contacts are visible. If your
agents are configured to handle the maximum number of contacts, you must increase the height of
this gadget to a minimum of 570 pixels to ensure there is enough space for all of the contacts to
appear.

Note

Step 16 To add the Live Data gadgets for Web Chat and Email to the supervisor desktop:
a) Copy the code for the Agent Chat Statistics Live Data gadget from your text file and paste it within the

<gadgets></gadgets> tags for the tab on which you want it to appear.
b) Copy the code for the Chat Queue Statistics Live Data gadget from your text file and paste it within the

<gadgets></gadgets> tags for the tab on which you want it to appear.

Step 17 To add the Manage Chat and Email tab gadget to the supervisor desktop, copy the code from your text file
and paste it within the <tabs></tabs> tag for the supervisor role after the Manage Call tab:
<tab>

<id>manageCall</id>
<label>finesse.container.tabs.supervisor.manageCallLabel</label>

</tab>
<tab>

<id>manageNonVoiceMedia</id>
<label>finesse.container.tabs.supervisor.manageNonVoiceMediaLabel</label>
<columns>

<column>
<gadgets>

<gadget>https://my-socialminer-server/multisession/ui/gadgets/
multisession-reply-gadget.jsp?gadgetHeight=430</gadget>

</gadgets>
</column>

</columns>
</tab>
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Step 18 Replace my-social-miner-server with the FQDN of your SocialMiner server.
Step 19 Optionally, change the height of the gadget.
Step 20 Click Save.

Live Data Gadgets
Cisco Finesse for Unified CCX supports Live Data gadgets. Live Data gadgets display information about the
current state of the contact center. The gadgets receive data from the real-time data source at frequent intervals
and display reports in grid format only.

Cisco Unified Intelligence Center provides Live Data real-time reports that you can add to the Cisco Finesse
agent and supervisor desktop.

This feature provides the following access:

• Agents can access the Live Data agent reports.

• Supervisors can access the Live Data supervisor reports.

Gadgets URLs for Reports

The following table displays gadgets URLs for reports.
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Gadget URLsTabIs the
Report
Available
in
Default
Layout ?

Report ViewReportsUsers

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=76D964AD10000140000000830A4E5E6F
&filterId=AgentCSQStats.csqName
=CL&compositeFilterId
=AgentCSQStats.AgentIds.agentId
=loginId</gadget>

HomeYesAgent CSQ
Statistics Report

Agent CSQ
Statistics Report

Agent

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=420&viewId
=5D411E8A10000140000000230A4E5E6B
&filterId=AgentStateDetailStats.agentID
=loginId</gadget>

My
Statistics

YesAgent State Log
Report

Agent State Log
Report

Agent

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=150&viewId
=67D4371110000140000001080A4E5E6B
&filterId=ResourceIAQStats.resourceId
=loginId</gadget>

My
Statistics

YesAgent Statistics
Report

Agent Statistics
Report

Agent

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=5C626F9C10000140000000600A4E5B33
&filterId=ResourceIAQStats.
resourceId=CL</gadget>

HomeYesAgent Team
Summary Report

Agent Team
Summary Report

Agent

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=FD919FB9100001440000005D0A4E5B29
&filterId=ResourceIAQStats.
resourceId=CL</gadget>

Team
Data

NoReport since
midnight

Agent Outbound
Team Summary
Report

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=FD919FB510000144000000470A4E5B29
&filterId=ResourceIAQStats.
resourceId=CL</gadget>

Team
Data

NoShort and long
term average

Agent Outbound
Team Summary
Report

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=120&viewId
=F2F1FC17100001440000014E0A4E5D48
&filterId=ChatAgentStats.
agentId=CL</gadget>

Team
Data

NoChat Agent
Statistics Report

Chat Agent
Statistics Report

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=120&viewId
=E42ED788100001440000007B0A4E5CA1
&filterId=ChatQueueStatistics.
queueName=CL</gadget>

Queue
Data

NoChat CSQ
Summary Report

Chat CSQ
Summary Report

Supervisor

NoSupervisor
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Gadget URLsTabIs the
Report
Available
in
Default
Layout ?

Report ViewReportsUsers

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=5C90012F10000140000000830A4E5B33
&filterId=ResourceIAQStats.
resourceId=CL</gadget>

—Team State
Report

Team State
Report

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=728283C210000140000000530A4E5B33
&filterId=ResourceIAQStats.
resourceId=CL</gadget>

Team
Data

YesReport since
midnight

Team Summary
Report

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=7291DCB410000140000000890A4E5B33
&filterId=ResourceIAQStats.
resourceId=CL</gadget>

Team
Data

YesShort and long
term average

Team Summary
Report

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=9A7A14CE10000140000000ED0A4E5E6B
&filterId=VoiceCSQDetailsStats.
agentId=CL&compositeFilterId
=VoiceCSQDetailsStats.AgentVoiceCSQNames.
agentVoiceCSQName=CL</gadget>

Queue
Data

YesVoice CSQ
Agent Detail
Report

Voice CSQ
Agent Detail
Report

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=C8E2DB1610000140000000A60A4E5E6B
&filterId=VoiceIAQStats.
esdName=CL</gadget>

Queue
Data

YesSnapshotVoice CSQ
Summary

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=C8EE241910000140000000C30A4E5E6B
&filterId=VoiceIAQStats.
esdName=CL</gadget>

Queue
Data

YesShort and long
term average

Voice CSQ
Summary

Supervisor

<gadget>https://localhost:8444/cuic
/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=310&viewId
=C8EF510810000140000000EB0A4E5E6B
&filterId=VoiceIAQStats.
esdName=CL</gadget>

Queue
Data

NoReport since
midnight

Voice CSQ
Summary

Supervisor

Gadgets Customization

You can use optional query parameter to adjust height of the gadgets.
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Query Parameter
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=200&viewId=5C626F9C10000140000000600A4E5B33&filterId=ResourceIAQStats.resourceId=CL</gadget>

Add Live Data Gadgets to Desktop Layout

The Cisco Finesse default layout XML contains commented XML code for the Live Data gadgets available
for Cisco Finesse desktop. Perform the following steps to add Live Data gadgets to desktop layout:

Procedure

Step 1 Sign in to Cisco Finesse administration console.
Cisco Finesse home page appears.

Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the gadget URL for the report you want to add from Live Data Gadgets.

Example:
To add the Agent Report, copy the following:
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight
=150&viewId=67D4371110000140000001080A4E5E6B&filterId=ResourceIAQStats.resourceId=loginId</gadget>

Step 5 Paste the gadget URL within the tab tags where you want it to appear.

Example:
To add the report to the home tab of the agent desktop:
<finesseLayout xmlns="http://www.cisco.com/vtg/finesse">
<layout>
<role>Agent</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>
</page>
<tabs>
<tab>
<id>home</id>
<label>finesse.container.tabs.agent.homeLabel</label>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight
=310&viewId=76D964AD10000140000000830A4E5E6F&filterId=AgentCSQStats.csqName
=CL&compositeFilterId=AgentCSQStats.AgentIds.agentId=loginId</gadget>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight
=310&viewId=5C626F9C10000140000000600A4E5B33&filterId
=ResourceIAQStats.resourceId=CL</gadget>
</gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight
=150&viewId=67D4371110000140000001080A4E5E6B&filterId=ResourceIAQStats.resourceId
=loginId</gadget>

</tab>
<tab>
<id>myStatistics</id>
<label>finesse.container.tabs.agent.myStatisticsLabel</label>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight
=600&viewId=5D411E8A10000140000000230A4E5E6B&filterId=AgentStateDetailStats.agentID
=loginId</gadget>
</gadgets>
</tab>
<tab>
<id>manageCall</id>
<label>finesse.container.tabs.agent.manageCallLabel</label>
</tab>
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</tabs>
</layout>
<layout>
<role>Supervisor</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>
</page>

Step 6 Click Save. Cisco Finesse validates the XML file to ensure that it is valid XML syntax and conforms to the
Cisco Finesse schema.

Step 7 To verify, log in to Cisco Finesse agent desktop as agent/Cisco Finesse supervisor desktop as supervisor and
check the reports.

Add Customized Live Data Gadgets to Desktop Layout

This procedure explains how to create gadget URLs for customized Live Data reports, which are copied from
stock reports, and add them to desktop layout.

The new gadget renders the report only when the appropriate permission on that report is given in Cisco
Unified Intelligence Center.

Note

Procedure

Step 1 Copy the gadget URL of the stock report that you want to customize from Live Data Gadgets and paste it in
a text editor.

Example:
Consider the URL shown here as the gadget URL. Copy and paste it in a text editor. The underlined ID is the
value of viewID.
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310
&viewId=5C626F9C10000140000000600A4E5B33&filterId=ResourceIAQStats.resourceId=CL</gadget>

Step 2 In Cisco Unified Intelligence Center, in the Edit view of the customized report, select the view for which you
want to create the gadget URL and then click Links.
The HTML Link field displays the permalink of the customized report.

Step 3 Copy the permalink of the customized report from the HTML Link field and paste it in a text editor, then
copy the viewID value from this link.

Example:
Copy the underlined viewID value from the permalink of the customized report.
https://<Server Name>:8444/cuic/permalink/PermalinkViewer.htmx?
viewId=5C90012F10000140000000830A4E5B33&linkType=htmlType&viewType=Grid

Step 4 Replace the viewID value in the gadget URL with the viewID value from the permalink of the customized
report.

Example:
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The customized gadget URL appears as shown here after replacing the viewID value with the viewID value
of the customized report.

<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310
&viewId=5C90012F10000140000000830A4E5B33&filterId=ResourceIAQStats.resourceId=CL</gadget>

Step 5 Add the customized gadget URL to Desktop Layout in the Finesse administration console and save.
Step 6 Log in to Finesse desktop and check the report.

Live Data Reports
Cisco Unified Intelligence Center provides Live Data real-time reports that you can add to the Finesse desktop.

Configure Live Data Reports with Multiple Views

Cisco Finesse allows you to display multiple Live Data reports or views on a single gadget. Supervisors can
select the desired view to display from a drop-down list on the gadget toolbar, which lists up to five report
views in Report Name - View Name format.

This procedure describes how to addmultiple Live Data views to the Finesse desktop layout using the viewId_n
and filterId_n keys. You can specify up to five report views to appear in your gadget. The first view among
the five is the default view. There is no defined order for how the remaining views are displayed.

Finesse still supports the display of a single gadget using a single viewId. However, if you specify the single
viewId along with multiple viewId_n keys, the multiple views are used and the single viewId is ignored.

To make sure the modified gadget renders in the Finesse desktop, you must give the appropriate permission
for that report in Unified Intelligence Center.

Note

Procedure

Step 1 For each report or view that you want to include in the gadget, obtain the associated viewId from the permalink
for the view:
a) In Unified Intelligence Center, in Edit view of the report, select the desired view then click Links.

The HTML Link field displays the permalink of the customized report.

b) Copy the permalink of the customized report from theHTML Link field, and paste it in a text editor, and
then copy the viewID value from the permalink and save it.

Example:
Copy the viewId, which is underlined in this example, from the permalink for the report.

https://<Server Name>:8444/cuic/permalink/PermalinkViewer.htmx?
viewId=5C90012F10000140000000830A4E5B33&linkType=htmlType&viewType=Grid

Step 2 From the Finesse default layout XML, copy the gadget URL for one of the Live Data reports and paste it into
a text editor.
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Example:
Copy the URL for the Agent Skill Group for HTTPS from the default layout XML and paste it into a text
editor:

<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId_1=9AB7848B10000141000001C50A0006C4&filterId_1=agent.id=CL%20teamName</gadget>

Step 3 To update the URL to refer to a different report view, populate the viewId_1 value (after the equal sign) with
the desired viewId obtained in step 1.

Example:
The following shows the URL updated with the example viewId copied from step 1.

<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId_1=5C90012F10000140000000830A4E5B33&filterId_1=agent.id=CL%20teamName</gadget>

Step 4 For each additional view you want to include:
a) At the end of the URL, copy and paste the viewId_1 and agentId_1 strings with a leading ampersand.

Example:

<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId_1=5C90012F10000140000000830A4E5B33&filterId_1=agent.id=CL%20teamName&
viewId_1=5C90012F10000140000000830A4E5B33&filterId_1=agent.id=CL%20teamName</gadget>

b) Update the copied viewId_1 and filterId_1 in the URL to the next available integer (in this example,
viewId_2 and filterId_2).

Example:

<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId_1=5C90012F10000140000000830A4E5B33&filterId_1=agent.id=CL%20teamName&
viewId_2=5C90012F10000140000000830A4E5B33&filterId_2=agent.id=CL%20teamName</gadget>

c) Populate the copied viewId value (after the equal sign) with the value defined in the permalink for the
desired report (in this example, 99E6C8E210000141000000D80A0006C4).

Example:

<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&
viewId_1=5C90012F10000140000000830A4E5B33&filterId_1=agent.id=CL%20teamName&
viewId_2=99E6C8E210000141000000D80A0006C4&filterId_2=agent.id=CL%20teamName</gadget>

d) Make sure that the filterId value matches the type required by the report type, as follows:

• Agent Reports: filterId_N=agent.id=CL%20teamName

• Agent Skill Group Reports: filterId_N=agent.id=CL%20teamName

• Skill Group Reports: filterId_N=skillGroup.id=CL%20teamName

• Precision Queue Reports: filterId_N=precisionQueue.id=CL%20teamName

Step 5 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 6 Add the customized gadget URL to the desktop layout XML in the Manage Desktop Layout gadget and click

Save.
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After you add the gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without the need to scroll.

Agents who are signed in when you change the desktop layout must sign out and sign back in to see
the change on their desktops.

Note

Manage Phone Books
On the Phone Books tab of the Cisco Finesse administration console, you can create and manage global and
team phone books and phone book contacts. Global phone books are available to all agents; team phone books
are available to agents in that specific team.

Phone Books and Contacts
Finesse supports the following number of phone books:

• 10 global phone books

• 300 team phone books

The system supports a total of 50,000 contacts. The total number of contacts per agent across all phone books
is limited to 1500.

Use theManage Phone Books gadget to view, add, edit, or delete phone books and phone book contacts. Click
the Name or Assign To headers to sort the phone books in ascending or descending order. Click the last Name,
First Name, Number, or Note headers to sort the contacts in ascending or descending order.

The following table describes the fields on the Manage Phone Books gadget.

ExplanationField

The name of the phone book. The name must be unique, and can be a maximum
length of 64 alphanumeric characters.

Name

Indicates if the phone book is global (All Users) or team (Teams).Assign To

The last name of a contact. The last name can be a maximum length of 128
characters. This field is optional.

Last Name

The first name of a contact. The first name can be a maximum length of 128
characters. This field is optional.

First Name

The phone number for the contact. The phone number can be 1-32 characters long
and cannot be blank.

Number

Optional text that describes the contact. The note can be a maximum length of
128 characters.

Note
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Actions on the Manage Phone Books gadget:

• New: Add a new phone book or contact

• Edit: Edit an existing phone book or contact

• Delete: Delete a phone book or contact

• Refresh: Reload the list of phone books or contacts from the server

• Import: Import a list of contacts to the phone book

• Export: Export a list of contacts from the phone book

Add Phone Book

Procedure

Step 1 In the Manage Phone Books gadget, click New.
The Manage Phone Books area appears.

Step 2 In the Name box, enter a name for the phone book.
Phone book names can be a maximum length of 64
characters.

Note

Step 3 In the Assign To box drop-down list, select All Users if the phone book is global or Teams if the phone book
is available to specified teams.

Step 4 Click Save.

Edit Phone Book

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book you want to edit.
Step 2 Click Edit.

The Edit Phone Books area appears.

Step 3 In the Name field, enter the new name for the phone book. If you want to change who can access the phone
book, in the Assign To field drop-down list, choose All Users or Teams.

Step 4 Click Save.
If you change the Assign To field from Teams to All Users, a message appears that asks you to confirm the
change. Click Yes to confirm.
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Delete Phone Book

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book that you want to delete.
Step 2 Click Delete.

A question appears asking you to confirm that you want to delete the selected phone book.

Step 3 Click Yes to confirm the deletion of the selected phone book.

Import Contacts
The Import function allows you to replace all the contacts in a phone book with a new list of contacts, or to
populate a new phone book with contacts.

The import list must be in the specified comma separated values (CSV) format, and can contain a maximum
of 1500 contacts. Import lists that contain more than 1500 contacts are rejected with an error message.

The CSV file contains the fields described in the following table.

Permitted CharactersCan Be
Blank?

Max
Length

Field

Alphanumeric characters

The CSV file that contains the contacts to import must use either
Latin or UTF-8 encoding.

Note

Yes128First Name

Yes128Last Name

No32Phone
Number

Yes128Notes

The following is an example of a phone book CSV file:
"First Name","Last Name","Phone Number","Notes"
"Amanda","Cohen","6511234",""
"Nicholas","Knight","612-555-1228","Sales"
"Natalie","Lambert","952-555-9876","Benefits"
"Joseph","Stonetree","651-555-7612","Manager"

A phone book CSV file must conform to this format and include the headers in the first line. During import,
the file is scanned for illegal characters. If any are found, they are replaced with question marks.

Exported CSV files always show each field enclosed in double quotes, as in the preceding example, to
ensure that any commas or double quotes that are part of the actual filed data are not mistaken for field
delimiters. If your data does not include these characters, you can omit the double quotes in files you
prepare for importing.

Note
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Procedure

Step 1 In the Manage Phone Books gadget, select the phone book into which you want to import a list of contacts.
Step 2 Click Import.

The Import Contacts area appears.

Step 3 Click Browse and navigate to the location of the CSV file containing the contacts you want to import.
The CSV file must use Latin or Unicode-8
encoding.

Note

Step 4 Click OK.

Export Contacts
The Export function allows you to extract a list of contacts from an existing phone book. The exported list is
saved in CSV format.

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book that contains the contacts you want to export.
Step 2 Click Export.

A message is displayed asking if you want to open or save the file.

The default name for an export file is
PhoneBookContacts.csv.

Note

Step 3 Click Open to open the CSV file in Excel, or click the Save drop-down list and choose Save, Save as, or
Save and open, as desired.

Step 4 A message appears that gives you the option to view the downloaded file, open the folder into which the
download was saved, view the Internet Explorer View Downloads window, or dismiss the message without
viewing the file.

Add Contact

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book to which you want to add a contact.
The List of Contacts for <phone book name> area appears.

Step 2 Click New.
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The New Contact area appears.

Step 3 Complete the fields. The First Name, Last Name, and Note fields are optional and have a maximum length
of 128 characters. The Number field is required and has a maximum length of 32 characters.

Step 4 Click Save.

Edit Contact

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book that contains the contact you want to edit.
The List of Contacts for <phone book name> area appears.

Step 2 Select the contact you want to edit.
Step 3 Click Edit.

The Edit Contact area appears.

Step 4 Edit the fields that you want to change. The First Name, Last Name, and Note fields are optional and have a
maximum length of 128 characters. The Number field is required and has a maximum length of 32 characters.

Step 5 Click Save.

Delete Contact

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book that contains the contact you want to delete.
The List of Contacts for <phone book name> area appears.

Step 2 Select the contact that you want to delete.
Step 3 Click Delete.

A question appears asking you to confirm that you want to delete the selected contact.

Step 4 Click Yes to confirm the deletion of the selected contact.

Manage Reasons
The Reasons tab on the Cisco Finesse administration console allows you to view, add, edit, and delete Not
Ready reason codes, Sign Out reason codes, and Wrap-Up reasons.
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Certain reason codes are reserved and cannot be used.

For Unified CCX systems, these reserved reason codes are as follows: 0, 22, and 33.

Note

Not Ready Reason Codes
Not Ready reason codes represent reasons that agents can select when they change their state to Not Ready.

Use the Manage Reason Codes (Not Ready) gadget to view, add, edit, or delete Not Ready reason codes.
Click the Reason Label or Reason Code headers to sort the Not Ready reason codes by label or reason code
in ascending or descending order. Click the Global header to sort reason codes by whether they are global
(Yes) or not (No).

Not Ready reason codes can be global (visible to all agents) or team (visible only to agents on specified teams).

Finesse supports a total of 200 Not Ready reason codes. In addition, Finesse supports a maximum of 100
global Not Ready reason codes, and 100 Not Ready team reason codes. The team reason codes can be
mapped to any team, and the same reason code can be mapped to multiple teams.

Note

The following table describes the fields on the Manage Reason Codes (Not Ready) gadget.

ExplanationField

The label for the Not Ready reason code.Reason Label

The label has a maximum length of 40 characters and should be unique for each
Not Ready reason code. Both alphanumeric and special characters are supported.

A code for the Not Ready reason.Reason Code

The value of the code must be between 1 and 999 and must be unique.

Yes/No. Indicates if the reason code is available globally to all agents (Yes) or to
specific teams of agents (No).

Global?

In previous releases, Finesse did allow you to create multiple Not Ready reason codes with the same code
or with code values greater than 999. If you upgraded from a previous release, you may have Not Ready
reason codes in your database that violate the new rules. After you complete the upgrade, find the codes
and edit them to give them unique values within the supported range. You can find the codes by clicking
on the Reason Code header to sort the codes by their value.

Note

Actions on the Manage Reason Codes (Not Ready) gadget:

• New: Add a new Not Ready reason code

• Edit: Edit an existing Not Ready reason code

• Delete: Delete a Not Ready reason code
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• Refresh: Reload the list of Not Ready reason codes from the server

When you add, edit, or delete a Not Ready reason code, the changes you make take effect on the Finesse
desktop after three seconds. However, agents who are signed in when the changes are made must sign out
and sign back in to see those changes reflected on their desktops.

Note

When an agent signs in to the Finesse desktop, the agent state is set to Not Ready. The agent can then choose
to go to Ready status or choose from one of the configured Not Ready reason codes from the agent state
drop-down list.

If an agent wants to change from Ready to Not Ready status, that agent can choose the appropriate Not Ready
reason code from the list of configured codes.

An agent who is on a call can select a state to be applied when the call is complete. For example, if an agent
wants to be in Not Ready state when the call ends, that agent can choose Not Ready from the drop-down list
while still on the call. The Finesse desktop shows the agent in Talking state and a pending state of Not Ready.

Pending state changes appear on the desktop while the agent's state is Talking (for example, on hold, in a
consult call, conference, or silent monitor call).

Add Not Ready Reason Code

Perform the following procedure to add a new Not Ready reason code.

Procedure

Step 1 In the Manage Reason Codes (Not Ready) gadget, click New.
The New Reason Code area appears.

Step 2 In the Reason Label box, enter a label for the reason code.
Not Ready reason code labels are limited to 40
characters.

Note

Step 3 In the Reason Code box, enter a reason code.
The code must be between 1 and 999 and must be
unique.

Ensure there are no leading or trailing spaces.

Note

Step 4 If the reason code is global, select the Global? check box. If the reason code is specific to a team, clear the
Global? check box.

By default, the Global? check box is
selected.

Note

Step 5 Click Save.
The Finesse server removes leading or trailing spaces before saving the Reason Label in the database.Note

Edit Not Ready Reason Code

Perform the following procedure to edit the label or code for an existing Not Ready reason code.
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Procedure

Step 1 In the Manage Reason Codes (Not Ready) gadget, select the reason code that you want to edit.
Step 2 Click Edit.

The Edit Reason Code area appears.

Step 3 If you want to change the label for the Not Ready reason code, in the Reason Label field, enter a new label
for the reason code. If you want to change the code, in the Reason Code field, enter the new code. If you want
to change who has access to the code, select or clear the Global? check box.

Step 4 Click Save.

Delete Not Ready Reason Code

An error may occur if an agent selects a Not Ready reason code after it has been deleted. Agents who are
signed in when you make changes to Not Ready reason codes must sign out and sign back in to see those
changes reflected on their desktops.

Note

Perform the following procedure to delete a Not Ready reason code.

Procedure

Step 1 In the Manage Reason Codes (Not Ready) gadget, select the Not Ready reason code that you want to delete.
Step 2 Click Delete.

A question appears asking you to confirm that you want to delete the selected reason code.

Step 3 Click Yes to confirm the deletion of the selected reason code.

Sign Out Reason Codes
Sign Out reason codes represent reasons that agents can select when they sign out of the Finesse desktop.

Use the Manage Reason Codes (Sign Out) gadget to view, add, edit, or delete Sign Out reason codes. Click
the Reason Label or Reason Code headers to sort the Sign Out reason codes by label or by reason code, in
ascending or descending order. Click the Global header to sort the reason codes by whether they are global
(Yes) or not (No).

Sign Out reason codes can be global (visible to all agents) or team (visible only to agents on specified teams).

Finesse supports a total of 200 Sign Out reason codes. In addition, Finesse supports a maximum of 100
global Sign Out reason codes, and 100 Sign Out team reason codes. The team reason codes can be mapped
to any team, and the same reason code can be mapped to multiple teams.

Note
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The following table describes the fields on the Manage Reason Codes (Sign Out) gadget.

ExplanationField

The label for the Sign Out reason code.Reason Label

The label has a maximum length of 40 characters and should be unique for each
Sign Out reason code. Both alphanumeric and special characters are supported.

A code for the Sign Out reason.Reason Code

The code must be between 1 and 999 and must be unique.

Yes/No. Indicates if the reason code is available globally to all agents (Yes) or
to specific teams of agents (No).

Global?

In previous releases, Finesse did allow you to create multiple Sign Out reason codes with the same code
or with code values greater than 999. If you upgraded from a previous release, you may have Sign Out
reason codes in your database that violate the new rules. After you complete the upgrade, find the codes
and edit them to give them unique values within the supported range. You can find the codes by clicking
on the Reason Code header to sort the codes by their value.

Note

Actions on the Manage Reason Codes (Sign Out) gadget:

• New: Add a new Sign Out reason code

• Edit: Edit an existing Sign Out reason code

• Delete: Delete a Sign Out reason code

• Refresh: Reload the list of Sign Out reason codes from the server

When you add, edit, or delete a Sign Out reason code, the changes you make take effect on the Finesse
desktop after three seconds. However, agents who are signed in when the changes are made must sign out
and sign back in to see those changes reflected on their desktops.

Note

When an agent clicks Sign Out on the desktop, any configured Sign Out codes appear in a drop-down list.
The agent can then choose the code that represents why that agent is signing out.

Add Sign Out Reason Code

Perform the following procedure to add a new Sign Out reason code.

Procedure

Step 1 In the Manage Reason Codes (Sign Out) gadget, click New.
The New Reason Code area appears.

Step 2 In the Reason Label box, enter a label for the reason code.
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Sign Out reason code labels are limited to 40
characters.

Note

Step 3 In the Reason Code box, enter a reason code.
The code must be between 1 and 999 and must be
unique.

Ensure there are no leading or trailing spaces.

Note

Step 4 If the reason code is global, select the Global? check box. If the reason code is specific to a team, clear the
Global? check box.

By default, the Global? check box is
selected.

Note

Step 5 Click Save.

Edit Sign Out Reason Code

Perform the following procedure to edit the label or code for an existing Sign Out reason code.

Procedure

Step 1 In the Manage Reason Codes (Sign Out) gadget, select the reason code that you want to edit.
Step 2 Click Edit.

The Edit Reason Code area appears.

Step 3 If you want to change the label of the Sign Out reason code, in the Reason Label field, enter a new label for
the reason code. If you want to change the code, in the Reason Code field, enter the new code. If you want to
change who has access to the code, select or clear the Global? check box.

Step 4 Click Save.

Delete Sign Out Reason Code

An error may occur if an agent selects a Sign Out reason code after it has been deleted. Agents who are
signed in when you make changes to Sign Out reason codes must sign out and sign back in to see those
changes reflected on their desktops.

Note

Perform the following procedure to delete a Sign Out reason code.

Procedure

Step 1 In the Manage Reason Codes (Sign Out) gadget, select the Sign Out reason code that you want to delete.
Step 2 Click Delete.
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A question appears asking you to confirm that you want to delete the selected reason code.

Step 3 Click Yes to confirm the deletion of the selected Sign Out reason code.

Wrap-Up Reasons
Wrap-Up reasons represent the reasons that agents can apply to calls. A Wrap-Up reason indicates why a
customer called the contact center. For example, youmay have oneWrap-Up reason for sales calls and another
for support calls.

You can configure Wrap-Up reasons to be available globally to all agents or only to specific teams.

Use the Manage Wrap-Up Reasons gadget to view, add, edit, or delete Wrap-Up reasons. Click the Reason
Label header to sort the Wrap-Up reasons in ascending or descending order.

Finesse supports a maximum of 100 global and 1500 teamWrap-Up reasons. No more than 100Wrap-Up
reasons can be assigned to any one team.

Note

If an agent is configured for wrap-up and selects a pending state during a call, when the call finishes that
agent goes into wrap-up and not the pending state selected during the call. The agent can end wrap-up by
either selecting a new state (Ready or Not Ready) or letting the wrap-up timer expire. If the agent selects
a new state, the new state overrides the pending state selected during the call. If the wrap-up timer expires,
the agent transitions to the pending state.

Note

The following table describes the fields on the Manage Wrap-Up Reasons gadget.

ExplanationField

The label for the Wrap-Up reason.Reason Label

This label must be unique for each Wrap-Up reason and has a maximum length of
39 bytes (which equals 39 US English characters). Both alphanumeric and special
characters are supported.

Yes/No. Indicates if the Wrap-Up reason is available globally to all agents (Yes)
or to specific teams of agents (No).

Global?

Actions on the Manage Wrap-Up Reasons gadget:

• New: Add a new Wrap-Up reason

• Edit: Edit an existing Wrap-Up reason

• Delete: Delete a Wrap-Up reason

• Refresh: Reload the list of Wrap-Up reasons from the server
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When you add, edit, or delete a Wrap-Up reason, the changes you make take effect on the agent or
supervisor desktop after three seconds. However, agents who are signed in when the changes are made
must sign out and sign back in to see those changes reflected on their desktops.

Note

Add Wrap-Up Reason

Perform the following procedure to add a new Wrap-Up reason.

Procedure

Step 1 In the Manage Wrap-Up Reasons gadget, click New.
The New Wrap-Up Reason area appears.

Step 2 In the Reason Label field, add a label for the Wrap-Up reason.
Wrap-Up reason labels are limited to 39
bytes.

Note

Step 3 If the Wrap-Up reason is global, select the Global? check box. If the Wrap-Up reason is specific to a team,
clear the Global? check box.

By default, the Global? check box is
selected.

Note

Step 4 Click Save.

Edit Wrap-Up Reason

Perform the following procedure to edit an existing Wrap-Up reason.

Procedure

Step 1 In the Manage Wrap-Up Reasons gadget, select the Wrap-Up reason that you want to edit.
Step 2 Click Edit.

The Edit Wrap-Up Reason area appears.

Step 3 In the Wrap-Up Reason Label field, enter the new label for the Wrap-Up reason. If you want to change who
has access to the Wrap-Up reason, select or clear the Global? check box.

Step 4 Click Save.

Delete Wrap-Up Reason

Perform the following procedure to delete a Wrap-Up reason.
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Procedure

Step 1 In the Manage Wrap-Up Reasons gadget, select the Wrap-Up reason that you want to delete.
Step 2 Click Delete.

A question appears asking you to confirm that you want to delete the selected Wrap-Up reason.

Step 3 Click Yes to confirm the deletion of the selected Wrap-Up reason.

Manage Team Resources
You can assign phone books, reason codes, wrap-up reasons, custom desktop layouts, and workflows to teams
on the Team Resources tab of the administration console.

Team Resources
Use the Manage Team Resources gadget on the Team Resources tab to assign and unassign phone books,
reasons, custom desktop layouts, and workflows to teams. Click the Name or ID header to sort the teams in
ascending or descending order.

The Manage Team Resources gadget contains six tabs, each enabling you to assign or unassign resources to
a team. The tabs are defined in the following table.

DescriptionTab Name

Use this tab to customize the desktop layout for the team. The default layout is
defined in the Manage Desktop Layout gadget. You can define one custom layout
for the team.

Desktop Layout
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DescriptionTab Name

Use this tab to assign and unassign phone books to the team. Only phone books that
are defined in the Manage Phone Books gadget as available to teams are available
for assignment.

Phone Books

Use this tab to assign and unassign Not Ready reason codes to the team. Only Not
Ready reason codes that are defined in the Manage Reason Codes (Not Ready)
gadget as available to teams (not global) are available for assignment.

Reason Codes (Not
Ready)

Use this tab to assign and unassign Sign Out reason codes to the team. Only Sign
Out reason codes that are defined in the Manage Reason Codes (Sign Out) gadget
as available to teams (not global) are available for assignment.

Reason Codes (Sign
Out)

Use this tab to assign and unassign Wrap-Up reasons to the team. Only Wrap-Up
reasons that are defined in the Manage Wrap-Up Reasons gadget as available to
teams (not global) are available for assignment.

Wrap-Up Reasons

Use this tab to assign and unassign workflows to the team. Only workflows that are
defined in the Manage Workflows gadget are available for assignment.

Workflows

Actions on the Manage Team Resources Gadget

• Add: Assign a phone book, reason, or workflow to the team

• Save: Save the phone book, reason, desktop layout assignment, or workflow to the team

• Revert: Cancel any changes made before they are saved

• Refresh: Refresh the list of teams

If you select a team and then click Refresh, the team is deselected and the Resources
area for that team disappears. The list of teams is refreshed and you must select a team
again.

Note

Add or Delete a Team When Database Is Not Accessible

If you add or delete a team when Finesse cannot access the Finesse database, those changes do not appear in
the Finesse administration console unless you restart Cisco Finesse Tomcat or the Cisco Unified CCXEngine.

Assign Phone Books and Reasons to Team

Procedure

Step 1 In the Manage Team Resources gadget, select a team.
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Tabs for each available resource appear.

Step 2 Click the tab for the resource you want to assign for the selected team.
The List of <resource> area appears.

Step 3 Click Add.
The Add <resource> popup appears.

Step 4 Select one or more resources from the list to assign them to the team.
Resources you assign are highlighted in blue in the Add <resources> popup and added to the List of <resources>
area.

Step 5 When you has finished assigning resources, click Save.
You can make changes on all resource tabs and then save them at the same time. If there is an error
on one resource tab but not others, the changes on the tabs with no errors are saved while the changes
on the tab with errors are not saved.

Note

Unassign Phone Books and Reasons from Team

Procedure

Step 1 In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

Step 2 Click the tab for the resource you want to unassign from the selected team.
The List of <resource> area appears.

Step 3 Click the red X next to the resource you want to unassign.
Step 4 Click Save.

Assign Custom Desktop Layout to Team
Perform the following procedure to create and assign a custom desktop layout to a team.

Procedure

Step 1 In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

Step 2 Click the Desktop Layout tab.
The Desktop Layout XML area appears. The area contains the default desktop layout XML.

Step 3 Select the Override System Default check box.
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The XML becomes editable.

Step 4 Edit the XML as desired.
Step 5 Click Save.

The custom desktop layout replaces the default desktop layout for the team after 10 seconds. If a supervisor
or agent is signed in when the change is saved, the change does not go into effect on their desktop until the
supervisor or agent signs out and signs in again.

If you clear the Override System Default check box, any changes you made to the XML are lost and
the XML in the editing pane reverts to the default desktop layout XML.

Note

Assign Workflows to Team

Procedure

Step 1 In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

Step 2 Click the Workflows tab.
The List of Workflows area appears.

Step 3 Click Add.
The Add Workflow popup appears.

Step 4 Select one or more workflows from the list to assign them to the team.
Workflows you assign are highlighted in blue in the AddWorkflows popup and added to the List ofWorkflows
area.

Step 5 Workflows are executed in the order in which they are listed. Use the up and down arrows to move a selected
workflow to the desired position in the list.

Step 6 When you has finished assigning workflows, click Save.
You can make changes on all resource tabs and then save them at the same time. If there is an error
on one resource tab but not others, the changes on the tabs with no errors are saved while the changes
on the tab with errors are not saved.

Note

Unassign Workflows from Team

Procedure

Step 1 In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

Step 2 Click the Workflows tab.
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The List of Workflows area appears.

Step 3 Click the red X next to the workflow you want to unassign.
Step 4 Click Save.

Manage Workflows
On the Workflows tab of the Cisco Finesse administration console, you can create and manage workflows
and workflow actions.

Workflows and Workflow Actions
You can use workflows to automate common repetitive agent tasks. A workflow has a unique name and a
helpful description. Use the Manage Workflows and Manage Workflow Actions gadgets to view, add, edit,
or delete workflows and workflow actions.

All workflows are team-level workflows. You cannot create a global workflow. If you need a global workflow,
create a team workflow and assign it to all teams.

Finesse supports the following number of workflows and workflow actions:

• 100 workflows per Finesse system

• 100 actions per Finesse system

• 20 workflows per team

• 5 conditions per workflow

• 5 actions per workflow

• 5 variables per action

Click the column headers to sort workflows and workflow actions in ascending or descending order.

The following table describes the fields on the Manage Workflows gadget.

ExplanationField

The name of the workflow. The name must be unique and can be a maximum
length of 40 characters.

Name

The description of the workflow. The description can be a maximum length of
128 characters.

Description

The following table describes the fields on the Manage Workflow Actions gadget.

ExplanationField

The name of the workflow action. The name must be unique and can be a
maximum length of 64 characters.

Name

   Cisco Unified CCX Administration Guide, Release 11.0(1)
360

Cisco Finesse
Manage Workflows



ExplanationField

The type of workflow. Possible values are Browser Pop, HTTP Request.Type

Actions on the Manage Workflows and Manage Workflow Actions gadgets:

• New: Add a new workflow or workflow action

• Edit: Edit an workflow or workflow action

• Delete: Delete a workflow or workflow action

• Refresh: Reload the list of workflows or workflow actions from the server

You can configure workflow actions to be handled by the Finesse desktop or in a third-party gadget. A
third-party gadget can be designed to handle the action differently than Finesse does.

Each workflow must contain only one trigger. Triggers are based on Finesse dialog events. Dialog events
include the following:

•When a call arrives

•When a call is answered

If you set a workflow to trigger when a call is answered, the workflow runs when an
agent answers an incoming call or makes an outgoing call, or when a customer answers
an Outbound Option call.

Note

•When a call ends

•When making a call

•While previewing a Direct Preview Outbound call.

The workflow engine uses the following simple logic to determine whether to execute a workflow:

• To determine whether a workflow should execute, its trigger set and conditions are evaluated against
each dialog event received.

• The workflow engine processes workflow events for the first call that matches any configured workflow's
trigger set and conditions. No other workflows run until this call has ended. If the agent accepts a second
call while still on the first call, workflows do not run on the second call even after the first call has ended.

Outbound Preview calls are an exception to this rule. You can have a workflow run
while the agent previews the call as well as when the agent accepts the call.

Note

• After a workflow for a particular trigger type (for example, Call Arrives) executes, it never triggers again
for the same dialog ID.

The workflow engine caches workflows for an agent when the agent signs in. Workflows do not change for
the agent until the agent signs out and signs in again or refreshes the browser.
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Workflows that trigger when a call arrives, when a call is answered, or when making a call run whenever
the browser is refreshed. When an agent refreshes the browser, the workflow engine sees the call as newly
arrived or newly made. If an HTTP request action is part of the workflow, the HTTP request is sent when
the agent refreshes the browser. Applications that receive the HTTP requests must account for this scenario.
Otherwise, undesired results may occur.

Note

An example of a workflow is a Call Arrival event that triggers an action that collects information from the
dialog event (for example, the ANI or customer information) and displays a web page containing customer
information.

You can filter trigger events by the value of the data that comes in the event. You can configure a workflow
to execute if any conditions are met or if all conditions are met.

Individual conditions consist of the following:

• A piece of event data to be examined, for example, DNIS or call variables

• A comparison between the event data and entered values (for example, contains, is equal to, is not equal
to, begins with, ends with, is empty, is not empty, and is in list)

When the trigger and its conditions are satisfied, a list of actions assigned to the workflow are executed. The
actions execute in the order in which they are listed.

Workflows run only for agents and supervisors who are Finesse users. The Workflow Engine is a JavaScript
library that runs client-side on a per-user basis within the Finesse desktop application. The desktop retrieves
the workflows to execute for a user from the server when the user signs in or refreshes the browser.

Changes made to a workflow or its actions while a user is signed in are not automatically pushed to that
user.

Note

It is possible to set workflows, conditions, and actions that are contradictory so that a workflow or action
cannot function. Workflows are not validated.

If multiple workflows are configured for a team, theWorkflow Engine evaluates them in the configured order.
TheWorkflow Engine ignores workflows with no actions. When theWorkflow Engine finds a workflow with
a matching trigger for the event and the workflow conditions evaluate to true, then that workflow is the one
used and subsequent workflows in the list are not evaluated. Workflows with no conditions evaluate to true
if the event matches the workflow trigger. All workflows are enabled by default. Only one workflow for a
specific user can run at a time.

The Workflow Engine retrieves dialog-based variables used in workflow conditions from the dialog that
triggered the workflow. If a variable is not found in the dialog, then its value is assumed to be empty.

The Workflow Engine executes the actions associated with the matched workflow in the order in which they
are listed. The Workflow Engine executes actions in a workflow even if the previously executed action fails.
Failed actions are logged.

The Finesse server controls which calls are displayed to the Finesse user. If the user has multiple calls, the
workflow applies only to the first call that matches a trigger. If the first call displayed does not match any
triggers but the second call does match a trigger, the Workflow Engine evaluates and processes the triggers
for the second call.

   Cisco Unified CCX Administration Guide, Release 11.0(1)
362

Cisco Finesse
Manage Workflows



A call is considered to be the first displayed call if it is the only call on the Finesse desktop when it appears.
If two calls on a phone are merged (as they are in a conference call), then the first displayed call flag value
of the surviving call is used.

If the user has a call when the user refreshes the browser, the Workflow Engine evaluates the call as it is. If
the dialog data (call variable values) change, the data may not match the trigger and conditions of the original
workflow. The data may match a different workflow or no workflows at all.

If the user has multiple calls when the user refreshes the browser, the Workflow Engine treats the first dialog
received from the Finesse server as the first displayed call. This call is not necessarily the same call that was
the first displayed call before the browser refresh. Dialogs received for any other call are ignored because
they are not considered first displayed calls. If dialogs for more than one call are received before theWorkflow
Engine is loaded after the browser refresh, no dialogs are evaluated because none are considered first displayed
calls.

Workflows run for both Finesse agents and supervisors. The team to which the supervisor belongs (as
distinguished from the team that the supervisor manages) determines which workflows run for the supervisor.
You may want to put the supervisors in their own team to keep agent workflows from being run for them.

Workflow Triggers and Outbound Calls

When you create a workflow specifically for Outbound Option calls, add a condition of BAStatus is not
empty (except for the Workflow Trigger 'When a call arrives' as BAStatus will be empty at that point of
time). This condition ensures that the workflow can distinguish Outbound Option calls from agent-initiated
outbound calls.

Note

The following table illustrates when workflows trigger in outbound call scenarios.

Progressive or Predictive
Outbound Call

Direct Preview Outbound CallWorkflow Trigger

Does not trigger.When the agent previews the call
(before the agent accepts or
rejects the call).

While previewing a call

Does not trigger.When the agent accepts the call.When a call arrives

When the customer answers the
call.

If the agent conferences in another
agent or transfers the call, the
workflow triggers for the agent
who is the recipient of the
conference or transfer.

When the customer answers the
call.

If the agent conferences in another
agent or transfers the call, the
workflow triggers for the agent
who is the recipient of the
conference or transfer.

When a call is answered

When the customer call is initiated
or when failover occurs during the
call.

When the customer call is
initiated.

When a call is made

When the customer call ends.When the customer call ends.When a call ends
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Add Browser Pop Workflow Action
The Browser Pop workflow action opens a browser window or tab on the user's desktop when workflow
conditions are met.

Whether the action opens a newwindow or tab on the desktop depends on the target user's browser settings.Note

Procedure

Step 1 In the Manage Workflow Actions gadget, click New.
The New Action area appears.

Step 2 In the Name box, enter a name for the action.
Workflow action names are limited to 64
characters.

Note

Step 3 From the Type drop-down list, select Browser Pop.
Step 4 From the Handled By drop-down list, select what will execute the action, either the Finesse Desktop or Other

(a third-party gadget).
Step 5 In the Window Name box, enter the name that serves as the ID of the window that is opened. Any action that

uses this window name reuses that specific window.
Window names are limited to 40 characters, and can be blank. If you leave the window name blank,
a new window opens every time the action runs.

Note

Step 6 Enter the URL of the browser window to open, and then click the tag icon at the right of the box and select
one or more variables from the drop-down list to add tags.

Example:

For every variable you select, you can enter test data in the Sample Data box. A sample URL is automatically
built in the Browser URL box below the Sample Data area. To test the URL, click Open to open the URL in
your browser.

Finesse does not validate the URL you
enter.

Note

Step 7 Click Save.

Add HTTP Request Workflow Action
The HTTP Request workflow action makes an HTTP request to an API on behalf of the desktop user.
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Procedure

Step 1 In the Manage Workflow Actions area, click New.
The New Action area appears.

Step 2 In the Name box, enter a name for the action.
A workflow action name can contain a maximum of 64 characters.

Step 3 From the Type drop-down list, select HTTP Request.
Step 4 From the Handled By drop-down list, select what will execute the action, the Finesse desktop or Other (a

third-party gadget).
Step 5 From the Method drop-down list, select the method to use.

You can select either PUT or POST.

Step 6 From the Location drop-down list, select the location.
If you are making the HTTP request to a Finesse API, select Finesse. If you are making a request to any other
API, select Other.

Step 7 In the Content Type box, enter the content type.
The default content type is application/xml, which is the content type for Finesse APIs. If you are using a
different API, enter the content types for that API (for example, application/JSON).

Step 8 In the URL box, enter the URL to which to make the request. To add variables to the URL, click the tag icon
at the right of the box and select one or more variables from the drop-down list.

Example:

The preceding example is the URL for a Finesse API. If you want to make a request to another API,
you must enter the entire URL (for example, http://googleapis.com).

Note

You can click the tag icon at the right of the box and select one or more variables from the drop-down list to
add tags to the URL. In the preceding example, to add the dialogId, click the tag icon and select dialogId from
the list.

Step 9 In the Body box, enter the text for the request. The body must match the content type (for example, if the
content types is application/xml, the body must contain XML. To add variables to the body, click the tag icon
at the right of the box and select one or more variables from the drop-down list.

Example:
To make an HTTP request to the Dialog - Start a recording API, enter the following into the Body box:

To add the extension, click the tag icon and select extension.

For every variable you add, you can enter test data in the Sample Data box.
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Step 10 Click Save.

Edit Workflow Action

Procedure

Step 1 In the Manage Workflow Actions gadget, select the action that you want to edit.
Step 2 Click Edit.

The Edit Action area appears.

Step 3 Edit the fields that you want to change.
Step 4 Click Save.

Delete Workflow Action

Procedure

Step 1 In the Workflow Actions gadget, select the action that you want to delete.
The Delete Action area appears.

Step 2 Click Delete.
A question appears asking you to confirm that you want to delete the selected action.

Step 3 Click Yes to confirm the deletion of the selected action.

Add Workflow

Procedure

Step 1 In the Manage Workflows gadget, click New.
The New Workflow area appears.

Step 2 In the Name box, enter the name of the workflow.
The name is limited to 40
characters.

Note

Step 3 In the Description box, enter a description of the workflow.
The description is limited to 128
characters.

Note
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Step 4 In the When to perform Actions drop-down list, select the event that triggers the workflow.
Step 5 In the How to apply Conditions box, select if all conditions are met, or if any conditions are met, and then

click Add Condition to add up to five conditions.

Example:
For example, you can specify that the action is taken when CallVariable 1 is equal to 123 and CallVariable 2
begins with 2.

Step 6 In the Ordered List of Actions area, click Add to open the Add Actions area. Click an action in this area to
add it to the Ordered List of Actions.

Step 7 Use the up and down arrows next to the Ordered List of Actions to move actions into the order in which they
should be performed.

Step 8 Click Save.
Step 9 Assign the workflow to one or more teams.

A workflow does not run until it is assigned to a
team.

Note

Edit Workflow

Procedure

Step 1 In the Manage Workflows gadget, select the workflow you want to edit.
Step 2 Click Edit.

The Edit Workflow area appears.

Step 3 Edit the fields that you want to change.
Step 4 Click Save.

Delete Workflow

Procedure

Step 1 In the Manage Workflows gadget, select the workflow that you want to delete.
The Delete Workflow area appears.

Step 2 Click Delete.
A question appears asking you to confirm that you want to delete the selected workflow.

Step 3 Click Yes to confirm the deletion of the selected workflow.
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Manage Security
The Cisco Finesse administration console and agent desktop support secure HTTP (HTTPS). To access the
administration console, enter the following URL in your browser (where FQDN is the fully qualified domain
name of your primary server):

https://FQDN:8445/cfadmin

Similarly, agents and supervisors can access their desktops as follows:

https://FQDN:8445/

For HTTPS access, you can eliminate browser security warnings by choosing to trust the self-signed certificate
provided with Finesse or uploading a CA certificate.

If you add custom gadgets that perform HTTPS requests to Finesse, you must add a certificate to the Finesse
server for that gadget.

Wildcard Certificates are not supported in Unified CCX.Note

HSTS
Finesse supports HTTP Strict Transport Security (HSTS) for increased security. HSTS is automatically enabled,
in which case the Finesse server sends HTTPS responses indicating to browsers that Finesse can only be
accessed using HTTPS. If users then try to access Finesse using HTTP instead of HTTPS, the browser changes
the connection to HTTPS before generating any network traffic. This functionality prevents browsers from
sending requests to Finesse using unencrypted HTTP before the server can redirect them.

Trust Self-Signed Certificate
Trust the self-signed certificate provided by Finesse to eliminate browser warnings each time you sign in to
the administration console or agent desktop.

If you are not using HTTPS or if you uploaded a CA certificate, you can skip this procedure.

Procedure

Step 1 In your browser, enter the URL for the administration console (https://FQDN of primary
server:portnumber/cfadmin) or the agent desktop (https://FQDN of primary server).

Step 2 Perform the steps in the following table for the browser you are using.
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DescriptionOption

1 A page appears that states there is a problem with the website's security certificate. Click
Continue to this website (not recommended). This action opens the sign in page for
the administration console (or agent desktop). A certificate error appears in the address
bar of your browser.

2 ClickCertificate Error, and then clickView Certificates to open the Certificate dialog
box.

3 In the Certificate dialog box, click Install Certificate. This action opens the Certificate
Import Wizard.

If you use Internet Explorer 11 withWindows 8.1, you must add Finesse to your
trusted sites before the Install Certificate option appears (Internet Options >
Security > Trusted Sites > Sites).

After you click Install Certificate, under Store Location, selectCurrent User
to install the certificate for the current user only, or select Local Machine to
install the certificate for all Windows users who use this computer.

Note

4 Click Next.

5 Select Place all certificates in the following store, and then click Browse.

6 Select Trusted Root Certification Authorities, and then click OK.

7 Click Next.

8 Click Finish.

9 If a Security Warning dialog box appears that asks if you want to install the certificate,
click Yes.

A Certificate Import dialog box that states the import was successful appears.

10 Click OK.

11 Enter your credentials, and then click Sign In.

If you use
Internet
Explorer:
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DescriptionOption

1 A page appears that states this connection is untrusted.

2 Click I Understand the Risks, and then click Add Exception.

3 In the Add Security Exception dialog box, ensure the Permanently store this exception
check box is checked.

4 Click Confirm Security Exception.

The page that states this connection is untrusted automatically closes and the
administration console (or agent desktop) loads.

5 Enter your credentials, and then click Sign In.

6 For the agent desktop only, an error appears that states Finesse cannot connect to the
Cisco Finesse Notification Service and prompts you to add a security exception for the
certificates issued by the Finesse server.

Click OK.

If you use
Firefox:

Obtain and Upload CA Certificate

This procedure only applies if you are using HTTPS.

This procedure is optional. If you are using HTTPS, you can choose to obtain and upload a CA certificate
or you can choose to use the self-signed certificate provided with Finesse.

Note

To eliminate browser security warnings each time you sign in, obtain an application and root certificate signed
by a Certificate Authority (CA). Use the Certificate Management utility from Cisco Unified Communications
Operating System Administration.

To open Cisco Unified Communications Operating System Administration, enter the following URL in your
browser:

https://hostname of primary UCCX server/cmplatform

Sign in using the username and password for the Application User account created during the installation of
Finesse.

You can find detailed explanations in the Security topics of the Cisco Unified Communications Operating
System Administration Online Help.

Note

Procedure

Step 1 Generate a CSR.
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a) Select Security > Certificate Management > Generate CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Generate CSR.

For information on updating Subject Alternate Names (SANs), refer to Configuration Examples
and TechNotes > Unified CCE Solution: Procedure to Obtain and Upload Third-Party CA
certificates.

Note

Step 2 Download the CSR.
a) Select Security > Certificate Management > Download CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Download CSR.

Step 3 Generate and download a CSR for the secondary Finesse server.
To open Cisco Unified Operating System Administration for the secondary server, enter the following URL
in the address bar of your browser:

https://hostname of secondary UCCX server/cmplatform

Step 4 Use the CSRs to obtain the CA root certificate, intermediate certificate, and signed application certificate
from the Certificate Authority.

To set up the certificate chain correctly, you must upload the certificates in the order described in
the following steps.

Note

Step 5 When you receive the certificates, select Security > Certificate Management > Upload Certificate.
Step 6 Upload the root certificate.

a) From the Certificate Purpose drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the root certificate file.
c) Click Upload File.

Step 7 Upload the intermediate certificate.
a) From the Certificate Purpose drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the intermediate certificate file.
c) Click Upload File.

Step 8 Upload the application certificate.
a) From the Certificate Purpose drop-down list, select tomcat.
b) In the Upload File field, click Browse and browse to the application certificate file.
c) Click Upload File.

Step 9 After the upload is complete, sign out from the Platform Admin page of Finesse.
Step 10 Restart Cisco Tomcat on the primary Unified CCX node.
Step 11 Restart Cisco Finesse Tomcat on the primary Unified CCX node.
Step 12 Restart Cisco Unified Intelligence Center Reporting Service.
Step 13 Restart Unified CCX Notification Service.

It is recommended to delete the self-signed certificates from the clients certificate store. Then close
the browser, relaunch, and reauthenticate.

Note

Step 14 Upload the application certificate to the secondary Unified CCX server.
You do not need to upload the root and intermediate certificates to the secondary Unified CCX server. After
you upload these certificates to the primary server, they are replicated to the secondary server.

Step 15 Restart Cisco Tomcat and Cisco Finesse Tomcat on the secondary Unified CCX node.
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Add Certificate for HTTPS Gadget
Add a certificate for a secure HTTP (HTTPS) gadget to allow the gadget to load into the Finesse desktop and
successfully perform HTTPS requests to the Finesse server.

This process allows HTTPS communication between the Finesse gadget container and the third-party gadget
site for loading the gadget and performing any API calls that the gadget makes to the third-party server.

A gadget that loads using HTTPS may still use HTTP communication between that gadget and the
application server where it resides. If all traffic must be secure, the gadget developer must ensure that
HTTPS is used to make API calls to the application server.

Note

The certificate must be signed with a common name. The gadget URL in the desktop layout must use the
same name (whether it uses an IP address or a fully qualified domain name) as the name with which the
certificate is signed. If the certificate name and the name in the gadget URL do not match, the connection is
not trusted and the gadget does not load.

To find the certificate name, enter the gadget URL in your browser. Click the lock icon in the address bar and
then click View Details. Look for the common name field.

The Finesse host must be able to resolve this name using the DNS host that was entered during installation.
To verify that Finesse can resolve the name, run the CLI command “utils network ping <hostname>”.

Procedure

Step 1 Download the tomcat.pem certificate from the third-party gadget host.
a) Sign in to Cisco Unified Operating System Administration on the third-party gadget host

(http://FQDN/cmplatform, where FQDN is the fully qualified domain name of the third-party gadget host).
b) Click Security > Certificate Management.
c) Click Find.
d) Click tomcat.pem.
e) Click Download and save the file on your desktop.

Step 2 Upload the certificate to the designated Finesse system.
a) Sign in to Cisco Unified Operating System Administration on the primary Unified CCX node

(http://FQDN/cmplatform, where FQDN is the fully qualified domain name of the Unified CCX node).
b) Click Security > Certificate Management.
c) Click Upload Certificate/Certificate Chain.
d) From the Certificate Name drop-down list, select tomcat-trust.
e) Click Browse and navigate to the tomcat.pem file that you downloaded in the previous step.
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f) Click Upload File.

Step 3 Restart Cisco Tomcat on the primary Unified CCX node.
Step 4 Restart Cisco Finesse Tomcat on the primary Unified CCX node.
Step 5 After synchronization is complete, restart Cisco Tomcat on the secondary Unified CCX node.
Step 6 Restart Cisco Finesse Tomcat on the secondary Unified CCX node.

Add Certificate for Multi-session Chat and Email
Add the SocialMiner certificate to the Finesse servers to allow communication between SocialMiner and
Finesse. After you complete this procedure, agents must accept certificates in the Finesse desktop before they
can use this gadget.

If SocialMiner is deployed with private certificates, agents cannot join chat rooms or reply to email messages
until they accept the SocialMiner certificates. If theManage Chat and Email gadget is deployed on theManage
Chat and Email tab of the Finesse desktop, agents may not realize that they need to accept the certificates.
Have agents check the tab where the gadget appears when they sign in to Finesse to make sure that certificates
are all accepted and the gadget loads correctly.

The steps to add a certificate for the Manage Chat and Email gadget are the same as the steps outlined in the
procedure Add Certificate for HTTPS Gadget.

The procedure to add a certificate for an HTTPS gadget refers to the third-party gadget host. To add a
certificate for chat and email, perform the applicable steps on the SocialMiner server.

Note

Manage Finesse IP Phone Agent

Finesse IP Phone Agent
With Finesse IP Phone Agent (IPPA), agents and supervisors can access Finesse features on their Cisco IP
Phones as an alternative to accessing Finesse through the browser. Finesse IPPA supports fewer features than
the Finesse desktop in the browser, but it does allow agents and supervisors to receive and manage Finesse
calls if they lose or do not have access to a computer.

Supervisor Tasks

Finesse IPPA does not support supervisor tasks such as monitor, barge, and intercept, but supervisors can
sign in and perform all agent tasks on their IP Phones.

Administration Tasks

After you configure Finesse IPPA, the administration tasks that you perform for the Finesse desktop also
apply for the supported Finesse IPPA features. For example, the Call Variables Layouts that you configure
for the desktop also apply for Finesse IPPA, although the column layout is modified to fit the IP Phone screen.
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Reason Code Limitations

• On the IP Phone, Finesse can display a maximum of 100 Not Ready,Wrap Up, or Sign Out reason codes.
If more than 100 codes are configured, the phone lists the first 100 applicable codes (global codes or
applicable team codes).

•When Finesse IPPA displays reason codes, some IP Phone models truncate the codes due to character
length limitations on the phone. To ensure they meet your requirements, verify the display of the reason
codes on all phone models in your environment.

HTTP Only

Finesse IPPA phone clients communicate with the Finesse server using HTTP only, whether or not HTTPS
access is enabled on Finesse.

Failure Behavior

Unlike the Finesse desktop, the Finesse IP Phone Agent does not automatically failover to the alternate Finesse
server. To resume normal operations in a failure scenario, the Finesse IPPA agents must exit from the current
Finesse IP Phone service and manually sign in to another configured Finesse service that connects to an
alternate Finesse server.

To ensure continued operations in a failure situation, you must configure at least two Finesse IP Phone services
in Unified CM, each pointing to different Finesse servers.

One Button Sign In
With One Button Sign In, you can set up the Finesse IPPA phones with prepopulated agent ID, extension,
and password. In this case, agents can sign in to Finesse on the IP Phone without credentials just by selecting
Cisco Finesse from the Services menu.

Alternatively, you can set up One Button Sign In and prepopulate only a subset of agent credentials. For
example:

• You can prepopulate only the agent ID and extension, forcing the agents to manually enter their password
at sign-in for increased security.

• You can prepopulate only the extension, forcing agents to manually enter their ID and password at
sign-in (useful for agents who share the same phone).

You can use Unified CM Administration to prepopulate the agent credentials, or you can set up the agents
with access to the Unified CM Self Care Portal to prepopulate their own credentials.

The following table shows examples of how you can assign the responsibility of defining agent credentials
to the administrator or the agent, or share that responsibility between them.

Entered at Sign-In
(by Agent)

Prepopulated in Self Care
Portal
(by Agent)

Prepopulated in Unified
CM Administration
(by Administrator)

Example Set Up

id

password

-extensionAdministrator populates
the extension only
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Entered at Sign-In
(by Agent)

Prepopulated in Self Care
Portal
(by Agent)

Prepopulated in Unified
CM Administration
(by Administrator)

Example Set Up

password-id

extension

Administrator populates
the ID and extension

-passwordid

extension

Agents enter password
only using Self Care
Portal

-id

extension

password

-Agents enter all
credentials using Self
Care Portal

passwordid

extension

-Agents enter ID and
extension only using Self
Care Portal

Finesse IP Phone Service Subscription Options
To set up access to Finesse on agent IP phones in Cisco Unified Communications Manager, you must create
the Finesse IP Phone service to which the phones can subscribe. To set up the Finesse service, you can choose
one of the following options:

• Set up an enterprise subscription to automatically subscribe all IP phones in the cluster to the Finesse
service. (Not supported with One Button Sign In.)

• Set up a manual subscription, and manually subscribe each IP phone to the Finesse service.

• Set up a manual subscription, and set up the agents with access to the Unified CM Self Care Portal to
subscribe to the Finesse service themselves.

The following table lists the Finesse IPPA configuration procedures and indicates which procedures are
required depending on the subscription option you choose.

Manual SubscriptionEnterprise SubscriptionFinesse IPPA Configuration
Procedures

Agents Manually Subscribe
Their Phones Using the Self
Care Portal

Administrator Manually
Subscribes the Phones

RequiredRequiredRequiredSet Up Application User, Web
Access, and HTTPS Server
Parameters, on page 376

RequiredRequiredRequiredConfigure Finesse IP Phone Service
in Unified CM, on page 377
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Manual SubscriptionEnterprise SubscriptionFinesse IPPA Configuration
Procedures

Agents Manually Subscribe
Their Phones Using the Self
Care Portal

Administrator Manually
Subscribes the Phones

Required only with One
Button Sign In

Required only with One Button
Sign In

Not applicableAdd Service Parameters for One
Button Sign In, on page 379

Optional. Allows the
administrator to enter agent
credentials for One Button
Sign In.

RequiredNot applicableSubscribe Agent Phones to Manual
Subscription Service, on page 381

RequiredOptional. Allows agents to enter
their own credentials for One
Button Sign In.

Not applicableSet Up Agent Access to the Self
Care Portal, on page 382

Set Up Application User, Web Access, and HTTPS Server Parameters
To support Finesse IPPA functionality, you must configure an application user in Unified Communications
Manager that is associated with all Finesse IPPA phones. And for proper Finesse IPPA operation, you must
also set the Web Access and HTTPS Server parameters in Unified CM.

These steps are required for both manual and enterprise subscriptions.

Before You Begin

Set up call capabilities for the agent phones in Cisco Unified Communications Manager.

Procedure

Step 1 Set the following parameters in Unified CM:

• Set theWeb Access parameter to Enabled.

• Set the HTTPS Server parameter to HTTP and HTTPS Enabled.

To set these parameters in Cisco Unified CM Administration, use either of the following pages:

• Phone Configuration page (Product Specific Configuration portion of page): choose Device > Phone.

• Enterprise Phone Configuration page: choose System > Enterprise Phone Configuration.

Step 2 Configure an application user in Unified Communications Manager.
a) In Cisco Unified Communications Manager Administration, select User Management > Application

User.
b) Click Add New.
c) Under User Information, enter a user ID and password for the new user.

The password must be 95 characters or less and must contain ASCII characters only.
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d) Under Device Information, in the Available Devices pane, select all phones that Finesse IP Phone Agents
will use and move them to the Controlled Devices pane using the arrows.

e) Under Permissions Information, click Add to Access Control Group.
f) From the list of search results, select Standard CTI Enabled and Standard CTI Allow Control Of All

Devices and then click Add Selected.
The application user is added to the Standard CTI Enabled and Standard CTI Allow Control Of All Devices
groups.

g) Click Save at the bottom of the page.
Create a new application user for the Finesse IP Phone Agent (FIPPA) control. Usage of the RMCM
User for Finesse IPPA is known to cause problems in the functionality.

Note

Step 3 Enter the application user's credentials in the Finesse IP Phone Agent Settings gadget.
a) Sign in to the Cisco Finesse Administration Console.
b) Choose Settings > IP Phone Agent Settings.
c) Under Phone URL Authentication Settings, enter the same username and password that you entered in

Unified CM for the application user.
The password must be 95 characters or less and must contain ASCII characters only.

d) Click Save.
e) Restart Cisco Finesse Tomcat on the primary Unified CCX node.
f) After replication is complete, restart Cisco Finesse Tomcat on the secondary Unified CCX node.

For information to check the replication status, see Step 3 of Prepare System for IP Address/host name
Change.

For UCCX deployments using Finesse IP Phone Agent (FIPPA) from 11.0 (1) onwards, the User
Device Profile (UDP) must be associated with the FIPPA Application User along with the physical
phones for agents using ExtensionMobility. The Finesse Service URLmust use the complete FQDN
of the UCCX server.

Note

Configure Finesse IP Phone Service in Unified CM
The following procedure describes the steps required for both manual and enterprise subscription.

Procedure

Step 1 Log in to the Cisco Unified Communications Manager Administration using administrator credentials.
Step 2 From the Communications Manager menu, select Device > Device Settings > Phone Services.
Step 3 On the IP Phone Services page, click Add New to create a new IP phone service.
Step 4 In the Service Name field, enter Cisco Finesse (or another service name that is appropriate for your

environment).
Step 5 In the Service URL field, enter:

http://Finesse FQDN:8082/fippa/#DEVICENAME#

where Finesse FQDN is the fully qualified domain name (FQDN) of your primary Finesse server.
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Step 6 Ensure that the Service Category is set to XML Service, and the Service Type is set to Standard IP Phone
Service.

Step 7 Check the Enable check box.
Step 8 Do one of the following:

• To automatically subscribe all phones in the cluster to the Finesse service, check the Enterprise
Subscription check box, and click Save. Agents and supervisors can now access Cisco Finesse by
selecting it from the Services menu on subscribed IP phones.

One Button Sign In is not supported with enterprise
subscriptions.

Note

Figure 3: Finesse Service Configuration with Enterprise Subscription
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• To subscribe only the desired phones to the Finesse service manually, leave theEnterprise Subscription
check box unchecked and click Save.

Figure 4: Finesse Service Configuration Without Enterprise Subscription

Step 9 With a two-node Finesse setup (primary and secondary Finesse servers), perform the preceding steps again
to create a secondary Finesse service that points to the secondary Finesse server.When you create the secondary
service, note the following procedural differences:

• At Step 4, in the Service Name field, enter a name that distinguishes the secondary service from the
primary service, such as Cisco Finesse Secondary.

• At Step 5, in the Service URL field, replace Finesse FQDN with the FQDN of the secondary server.

Add Service Parameters for One Button Sign In
With One Button Sign In, for any agent credentials that you want prepopulated, youmust set up corresponding
service parameters in Unified CM.

Only perform this procedure if you are setting up One Button Sign In. Otherwise, skip this procedure.
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Procedure

Step 1 FromCisco Unified CommunicationsManager Administration, select the Finesse phone service (underDevice
> Device Settings > Phone Services).

Step 2 Click New to the right of the Parameters box.
The Configure Cisco IP Phone Service Parameter page displays.

Step 3 Set up service parameters for the agent id, extension, and password credentials in accordance with the following
table. Enter only the parameters that you want prepopulated for the agents. For each parameter, enter the
required field values and click Save. To add additional parameters, click Add New and enter the required
values.

DescriptionField

Enter one of the following parameter names as follows:

• Id

• Extension

• Password

The values entered are the exact query string parameters used for the subscription
URL.

Parameter Name

Enter a descriptive parameter name; for example, id, extension, and password.Parameter Display
Name

Leave the default value blank for all parameters.Default Value

Enter a description of the parameter. The user can access this text when they
subscribe to the service.

Parameter Description

If the administrator will prepopulate the parameter in Unified CMAdministration,
check the Parameter is Required check box.

However, if the agent will prepopulate the parameter in the Self Care Portal, two
options are available:

• If the agents will prepopulate all defined parameters, check the Parameter
is Required check box for each parameter.

• If the agent and administrator will share the responsibility of prepopulating
the parameters, set only the administrator-defined parameters as required.
This configuration ensures that the administrator can save the subscription
without prepopulating all parameters. In this case, the administrator first
prepopulates the required parameters, and then the agents prepopulate the
nonrequired parameters.

Parameter is Required

Check this check box for the password only.

This check box masks the password entries in the Self Care Portal, to display
asterisks rather than the user entry.

Parameter is a
Password (mask
contents)
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When you save the last parameter, click Save and Close.

What to Do Next

You can prepopulate the agent credentials when you subscribe the agent phones, or the agents can prepopulate
their own credentials using the Unified CM Self Care Portal.

Subscribe Agent Phones to Manual Subscription Service
If you set up the Finesse service as a manual subscription, you can subscribe the agent phones to the Finesse
service in Unified CM and optionally define agent credentials for One Button Sign In.

If you prefer to allow the agents subscribe to the Finesse service using the Self Care Portal and prefer not to
specify One Button Sign In credentials for the agents, you can skip this procedure.
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Procedure

Step 1 From the menu bar, select Device > Phone.
Step 2 Select the phone that you want to subscribe to the Finesse service.
Step 3 From theRelated Links drop-down list on the upper right side of the window, select Subscribe/Unsubscribe

Services and click Go.
The Subscribed IP phone services window displays for this phone.

Step 4 From the Select a Service drop-down list, select Cisco Finesse.
Step 5 Click Next.
Step 6 (Applicable for One Button Sign In only) Enter values for any of the defined service parameters (id, password,

and extension) that you do not want the agents to enter using the Self Service Portal or at sign-in.
Step 7 Click the Subscribe button to subscribe this phone to the Cisco Finesse service.

The Cisco Finesse service displays in the Subscribed Services list.

Step 8 Click Save.
The subscribed agents or supervisors can now access Cisco Finesse by selecting it from the Services menu
on their IP phones.

Step 9 With a two-node Finesse setup (primary and secondary Finesse servers), perform this procedure again to also
subscribe the phones to the secondary Finesse service that points to the secondary Finesse server.

Set Up Agent Access to the Self Care Portal
You can optionally set up the agents with access to the Unified CM Self Care Portal to prepopulate their own
credentials and to subscribe to the Finesse service.

If you are not setting up One Button Sign In, or not enabling the agents with access to the Self Care Portal,
skip this procedure.

Procedure

Step 1 From the Unified CM Administration page, select System > Enterprise Parameters.
Step 2 Under the Self Care Portal Parameters, in the Self Care Portal Default Server field, select the IP address of

the Unified CM Publisher server from the drop-down list and click Save.
Step 3 Select User Management > End User.
Step 4 Select the user that you want to set up with access to the User Care Portal.
Step 5 Under Permissions Information, click Add to Access Control Group.
Step 6 From the list of Access Control groups displayed, check Standard CCMEnd Users and clickAdd Selected.
Step 7 Click Save.

With access enabled to the Self Care Portal, agents can sign in to the portal at http://<UCM address>/ucmuser
to subscribe to the Finesse service and enter their own credentials under Phones > Phone Settings > Services.
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In a two-node Finesse setup with two services configured, the agents must enter their credentials on both
the primary and secondary Finesse services.

Note

CTI Failover
Finesse follows the active/standby model of Unified CCX. Finesse on the active Unified CCX node is
"IN_SERVICE" and Finesse on the standby node is "OUT_OF_SERVICE".

A loss of connection to the CTI server can occur due to the following:

• Finesse misses three consecutive heartbeats from the connected CTI server.

• Finesse encounters a failure on the socket opened to the CTI server.

• The CTI server is not active on the node (Unified CCX is standby on the node).

When Finesse loses connection to the CTI server, Finesse attempts to reconnect until it makes a successful
connection to the CTI server.

Cisco Finesse connects successfully through CTI to the node where the Unified CCX Engine is currently
master. Agents should log in to Finesse on that node.

When the master Unified CCX Engine fails, Finesse establishes a connection with the Unified CCX Engine
on the other node, and agents must log in to other node.

Finesse IP Phone Agent Failover
With a two-node Finesse setup (primary and secondary Finesse servers), if the server that an agent is connected
to goes out of service, the Finesse IP Phone Agent (IPPA) displays a notification that the server is unavailable.
Finesse IPPA continues to check whether the current Finesse server recovers its state, and notifies the agent
if it reconnects.

Finesse IPPA attempts to reconnect to the server every 5 seconds and declares it out of service after three
failed attempts. The total time to go out of service is approximately 15 seconds.

Unlike the Finesse desktop, Finesse IPPA does not check whether the alternate Finesse server is available.
To connect to an alternate Finesse server, the agent must exit the current Finesse service, and manually sign
in to the alternate Finesse service.

The Finesse IPPA failover logic has two triggers to detect failure:

• Finesse IPPA receives a SystemInfo event that the current server is OUT_OF_SERVICE.

Finesse IPPA polls SystemInfo every 5 seconds to check whether the Finesse server is in service. After
three attempts, if the Finesse server is not in service, Finesse IPPA displays a server unavailable message
to the agent.

• Finesse IPPA receives an XMPP connection notification that the XMPP connection is disconnected.

Finesse IPPA tries every 5 seconds to reconnect with the XMPP server. After three attempts, if the
XMPP connection cannot be reestablished, Finesse IPPA displays a server unavailable message to the
agent.
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While the agent is still signed in to the current service, Finesse IPPA continues attempting to reestablish the
connections with the Finesse and XMPP servers. If they both resume service, Finesse IPPA displays the sign-in
screen and the agent can sign in again and continue as normal.

Otherwise, the agent must exit the current Finesse service and try to connect using an alternate Finesse service.

Finesse IPPA failover can occur for the following reasons:

• The Finesse Webapp Service goes down.

• The Cisco Finesse Notification Service goes down.

• The Finesse connection to the CTI server goes down.

Backup and Restore
The Unified CCX backup and restore component also backs up and restores Finesse configurations and data.

For more information about backup and restore, see Cisco Unified Contact Center Express Disaster Recovery
System Administration Guide at http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_
installation_and_configuration_guides_list.html

.

Additional Language Support
For the list of languages that are supported by Finesse, see the , located at:

http://docwiki-dev.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX.

If you want to use the Finesse desktop interface in a language other than English, download and install the
language COP file. For more information, see the “COP File” section of the Cisco Unified Contact Center
Express Install and Upgrade Guide, located at:

http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-express/
products-installation-guides-list.html.

Cisco Finesse Agent and Supervisor Desktop
Cisco Finesse Desktop provides easy access to the applications and information sources from a single
customizable cockpit. Providing this unique access to information helps the agents deliver fast and accurate
service.

For more information about Cisco Finesse Agent and Supervisor Desktop , see Cisco Finesse Agent and
Supervisor Desktop User Guide for Cisco Unified Contact Center Express at http://www.cisco.com/en/US/
products/sw/custcosw/ps1846/products_user_guide_list.html.

Call Manager-Based Call Recording Using Cisco MediaSense
Cisco Finesse in Unified CCX supports call recording using Cisco MediaSense.

MediaSense is the media-capture platform for Cisco Unified Communications.
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To use MediaSense, perform the following procedures:

1 Configure Cisco MediaSense with Unified CM, on page 385
2 Upload Cisco MediaSense Certificate to Unified CCX Server, on page 385
3 Upload MediaSense Recording License, on page 386
4 Configure MediaSense as a Recording Server, on page 386
5 Call Recording Through Workflow, on page 386
6 Configure MediaSense Search and Play Gadget, on page 387

After performing all of the procedures, restart the Unified CCX server. In high availability deployment,
restart both of the nodes.

Note

Configure Cisco MediaSense with Unified CM
For information about configuring Cisco MediaSense with Unified CM, see the "Unified CM provisioning
for Cisco MediaSense" section in the Installation and Administration Guide for Cisco MediaSense at http://
www.cisco.com/en/US/products/ps11389/prod_installation_guides_list.html.

Upload Cisco MediaSense Certificate to Unified CCX Server
To establish connection with Cisco MediaSense securely, you must upload the Cisco MediaSense certificate
to Unified CCX server.

Procedure

Step 1 Download the tomcat.pem certificate from the Cisco MediaSense server.
a) Sign in to Cisco Unified Operating System Administration on the Cisco MediaSense host (https://host or

IP address/cmplatform/showHome.do, where host or IP address is the hostname or IP address of the Cisco
MediaSense server).

b) Select Security > Certificate Management.
The Certificate List screen appears.

c) Click Find.
A list of certificates appears.

d) In the Common Name column, click the link of the certificate you want to download.
The Certificate Name must be tomcat-trust and the Certificate Type must be trusts-cert. The
Certificate Details pop-up window appears.

Note

e) Click Download .PEM File.
A pop-up window appears.

f) Select Save File radio button and Click OK.
The file gets saved on your system.

Step 2 Upload the certificate to the designated Unified CCX server.
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a) Sign in to Cisco Unified Operating System Administration on the primary Unified CCX node (http://host
or IP address/cmplatform, where host or IP address is the hostname or IP address of the Unified CCX
node).

b) Choose Security > Certificate Management.
c) Click Upload Certificate/Certificate Chain.
d) From the Certificate Name drop-down list, select tomcat-trust.
e) Click Browse and navigate to the tomcat.pem file that you downloaded in the previous step.
f) Click Upload File.

For more information about certificate management, see the Certificate Management Menu section of
the Cisco Unified Operating System Administration Guide, at http://www.cisco.com/en/US/products/sw/
custcosw/ps1846/products_installation_and_configuration_guides_list.html.

Upload MediaSense Recording License
To use the MediaSense recording feature, you must purchase the Unified CCX recording license and upload
it to the Unified CCX server.

For information about how to upload the license, see Upload Licenses.

Configure MediaSense as a Recording Server
For information about configuring MediaSense as a recording server, see Recording Configuration.

Call Recording Through Workflow
Use the HTTP Request action to invoke the Finesse Recording API after the call is answered.

Procedure

Step 1 Create an HTTP Request Recording action:
a) In the Manage Workflow Actions area, click New.
b) In the Name box, enter a name for the action.
c) From the Type drop-down list, select HTTP Request.
d) From the Handled By drop-down list, select Finesse Desktop.
e) From the Method drop-down list, select PUT.
f) From the Location drop-down list, select Finesse.
g) In the Content Type box, enter application/xml.
h) In the URL box, enter the following:

/finesse/api/Dialog/

i) Click the tag icon at the right of the box and select dialogId to add it to the URL.
j) In the Body box, enter the following:
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To add the extension, click the tag icon and select extension.

Example:

Step 2 Click Save to save workflow action.
Step 3 Add a Call Answered Workflow that executes the HTTP Request Recording action that you created in the

previous step.
The Call AnsweredWorkflow can be used to trigger an HTTP Request Recording action for inbound
calls, agent-initiated outbound calls, and Predictive, Progressive, and Direct Preview outbound calls.

Note

Step 4 Assign the workflow to the teams that you would like to record.

Configure MediaSense Search and Play Gadget

Before You Begin

In the MediaSense server, you must have already configured Unified CM, Cisco Finesse, and MediaSense
API.
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Procedure

Step 1 Sign in to the Cisco Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Find the MediaSense tab and gadget in the layout XML. Update the layout according to the comments in the

layout.
<!--

The following Tab and Gadget are for MediaSense. They are *ONLY* supported with
MediaSense.

If you are not using MediaSense,then remove them. If you are using MediaSense and wish
to show

Recording Management, then do the following:
1) Remove these comments leaving the tab and gadget
2) Replace all instances of "my-mediasense-server" with the Fully Qualified Domain

Name of your MediaSense Server.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented

prerequisite
steps.

<tab>
<id>manageRecordings</id>
<label>finesse.container.tabs.supervisor.manageRecordingsLabel</label>
<gadgets>

<gadget>https://my-mediasense-server:8440/ora/gadget/MediaSenseGadget.xml</gadget>
</gadgets>

</tab>
-->

Replace all instances of my-mediasense-server with https://<Fully Qualified Domain Name

of your MediaSense Server>/ora/gadget/MediaSenseGadget.xml.

Note

Example:
https://abcd-ef-gh102.abc.com:8440/ora/gadget/MediaSenseGadget.xml

Step 4 Click Save.
The supervisor must log out and log in again to Cisco Finesse Supervisor Desktop to access
MediaSense.

Note

Step 5 Sign in to Cisco Finesse desktop as a supervisor and confirm that MediaSense gadget is accessible.
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C H A P T E R  22
Extend and Connect

• Overview, page 389

Overview
With the Extend and Connect feature, Unified Contact Center Express agents and supervisors can work from
a remote location using any device.

This feature gives the user (agent or supervisor) the flexibility to answer or make calls using devices that are
connected to the PSTN or to mobile or other PBX networks. Extend and Connect functions by leveraging
CTI remote device and persistent connection features of Cisco Unified Communications Manager (CUCM).

You can enable the Extend and Connect feature through the Cisco Jabber client by selecting only the Extend
mode. This feature provide the following connections:

• CTI remote device—CTI remote devices are Unified CCX off-cluster devices for users that can be
connected to any of the third-party networks, such as PSTN, mobile, or PBX.

• Persistent connection—Unified CCX users use this feature to set up a persistent call connection to remote
destination. The advantage of this connection is that call establishment to the remote destination is much
faster.

For more information about the Extend and Connect feature, see http://www.cisco.com/c/en/us/td/docs/
voice_ip_comm/cucm/admin/9_1_1/ccmfeat/CUCM_BK_C3E0EFA0_00_cucm-features-services-guide-91/
CUCM_BK_C3E0EFA0_00_cucm-features-services-guide-91_chapter_0110010.html.

For more information about remote destination, see Cisco Unified Communications Manager Administration
Guide at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Server Configuration
To use the Extend and Connect, follow these server configuration steps:
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Procedure

Step 1 Perform the preinstallation tasks for IM and Presence nodes.
See "Perform pre-installation tasks for IM and Presence nodes" section in Installing Cisco Unified
Communications Manager at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-installation-guides-list.html

Step 2 Configure the Cisco IM and Presence node details on Call Manager before you install Cisco IM and Presence.
From Cisco Unified CM Administration on the publisher node, choose System > Server > Server Type and
then choose CUCM IM and Presence.
For information about server setup, see the Cisco Unified Communications Manager Administration Guide
at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Step 3 Install Cisco IM and Presence as a Call Manager subscriber.
For information about Cisco IM and Presence installation, see Installing Cisco Unified Communications
Manager at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-installation-guides-list.html

Step 4 Activate and start all the Cisco IM and Presence services in Cisco Unified Serviceability.
For information about activating services, see the "Activate services" section in Installing Cisco Unified
Communications Manager at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-installation-guides-list.html

Step 5 Create Presence Redundancy groups in Call Manager.
a) Choose System > Presence Redundancy Groups > Add New.
b) Select Cisco IM and Presence, which you installed from the Presence Server drop-down list.

For information about the Presence redundancy group setup, see the "Presence redundancy group setup"
section in Cisco Unified Communications Manager Administration Guide at http://www.cisco.com/c/en/
us/support/unified-communications/unified-communications-manager-callmanager/
products-maintenance-guides-list.html.

Step 6 Create UC services for CTI and IM Presence services in Call Manager.
You must select CTI and IM Presence
services.

Note

For information about creating UC services, see the "Add CTI service" section in Cisco Unified
Communications Manager Administration Guide at http://www.cisco.com/c/en/us/support/
unified-communications/unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Step 7 Set up the service profile in Call Manager.
You must specify CTI and IM Presence service that you created in step
6.

Note

For information about Service profile setup, see the "Service profile setup" section in Cisco Unified
Communications Manager Administration Guide at http://www.cisco.com/c/en/us/support/
unified-communications/unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Step 8 Set up the end user in Call Manager.
Perform the following steps:

a) Navigate to User Management > End User.
b) Click the User ID that you want to set up.
c) In the Service Settings section, select Enable User for Unified CM IM and Presence (Configure IM

and Presence in the associated UC Service Profile) and then in UC Service Profile, select the profile
that you created.
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d) In theMobile Information section, select Enable Mobility.
e) In Permission Information, add Standard CCM End user and Standard CTI enabled.
f) Navigate to User Management > Assign Presence End Users.
g) Click the User ID that you want to set up and then choose Assign Selected Users.

Step 9 Set up the trunk in Call Manager.
For information about the Trunk setup, see the "Trunk setup" section in Cisco Unified Communications
Manager Administration Guide at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Step 10 Add the route pattern in Call Manager to route the calls to the remote device.
For information about route pattern setup, see the "Route pattern setup" section in Cisco Unified
Communications Manager Administration Guide at http://www.cisco.com/c/en/us/support/
unified-communications/unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Step 11 Configure the Presence Gateway configuration on IM and Presence.
For information about configuring Presence Gateway on IM and Presence, see the "Configure Presence
Gateway configuration on IM and Presence" section in CiscoUnified CommunicationsManager Administration
Guide at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-maintenance-guides-list.html.

Persistent Connection
Unified CCX makes a persistent connection call to the agent's remote phone when an agent logs in to the
agent desktop.

The agent must first answer the persistent connection call and then change the status to Ready in the agent
desktop to answer the incoming call.

Note

After establishing the persistent connection, the call remains connected until the Maximum Call Duration
timer expires or until the agent logs out, provided that no other problems occur in the remote destination
network. You must specify to match the time on the Maximum Call Duration timer with your company shift
time or specify more than your company shift time. If the persistent connection gets disconnected, it retries
until the connection is established.

Add Customized Announcement for Persistent Connection Call

When an agent answers persistent connection call, make an announcement to the agent indicating that the
persistent connection must be retained so that further calls from or to customers are established over persistent
connection.

If the agent's remote device supports Caller ID display, it displays EC Mode as the caller name, which indicates
a persistent connection call.

By default, the Cisco Unified Communications Manager has announcements created. Unified CCX, through
JTAPI communication to Cisco Unified Communications Manager, calls the announcement ID UCCX
Persistent Connection Prompt. You must create the UCCX Persistent Connection Prompt customized
announcement ID.
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To add the customized announcement ID, see the"Upload customized announcement" procedure in the Cisco
Unified Communications Manager Administration Guide at http://www.cisco.com/c/en/us/support/
unified-communications/unified-communications-manager-callmanager/products-maintenance-guides-list.html.
Enter UCCX Persistent Connection Prompt in the Announcement Identifier field.

Note • Add a customized prompt to the created UCCX Persistent Connection Prompt, click Upload Files
and select the desired prompt (.wav file).

•When the announcement is played, the Caller ID information on agent's remote phone changes to
Voice Connect.

• If no announcement ID is created, Cisco Unified Communications Manager does not play any
announcement to the agent when the persistent call is answered.

Incoming Call Notification

An agent can configure a sound alert to notify an incoming call when the customer calls are routed through
Persistent Connection Calls of the agents.

To receive the sound alert, in Cisco Unified Communications Manager, configure the Announcement ID as
UCCX Customer Call Prompt. When the Announcement ID is configured, Unified CCX plays the
announcement before the call is routed to a desktop. If you do not configure an Announcement ID, Unified
CCX does not play an announcement, and then the agent relies on desktop signal for an incoming call.

Configure UCCX Customer Call Prompt in the English language in Cisco Unified Communications
Manager.

Note
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A P P E N D I X  A
Cisco Unified Contact Center Express License
Packages

This appendix describes the features that are available with each Unified CCX license package.

• Application Availability by License Package, page 393

• Trigger Availability by License Package, page 393

• Subsystem Availability by License Package, page 394

• Unified CCX Services Availability by License Package, page 394

• Unified CCX Component Availability by License Package, page 395

• Context Service Connection Timeouts and Retries, page 395

Application Availability by License Package
The following table lists the applications available with each license package:

Unified CCX
Premium

Unified CCX
Enhanced

Unified CCX
Standard

Unified IP
IVR

Application

XXXXCisco Script Application

XXXXBusy

XXXXRing No Answer

Trigger Availability by License Package
The following table lists the triggers available with each license package:
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Unified CCX
Premium

Unified CCX
Enhanced

Unified CCX
Standard

Unified IP IVRTrigger

XXXXUnified CM Telephony

XXHTTP

Subsystem Availability by License Package
The following table lists the subsystems available with each license package:

Unified CCX
Premium

Unified CCX
Enhanced

Unified CCX
Standard

Unified IP IVRSubsystem

XXXXCMT Subsystem

XXXXCore RTR Subsystem

XXDatabase Subsystem

XXeMail Subsystem

XXHTTP Subsystem

XXXXUnified CM Telephony Subsystem

XXMRCP ASR Subsystem

XXMRCP TTS Subsystem

XOutbound Subsystem4

XXXXRmCm Subsystem

XXVoice Browser Subsystem

XRouteAndQueue Subsystem

4 The Unified CCX Outbound Preview Dialer feature does not require an additional license and it comes as part of the Premium license package.

Unified CCX Services Availability by License Package
The following table lists the Unified CCX Services available with each license package:
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Unified CCX
Premium

Unified CCX
Enhanced

Unified CCX
Standard

Unified IP IVRNone5Unified CCX Services

XXXXXUnified CCX Cluster View
Daemon

XXXXXUnified CCX Administration

XXXXUnified CCX Engine

XXXXCisco Unified CCX Database

5 Available upon installation, before license package is activated.

Unified CCX Component Availability by License Package
The following table lists the Unified CCX Component available with each license package:

Unified CCX
Premium

Unified CCX
Enhanced

Unified CCX
Standard

Unified IP
IVR

None6Unified CCX Component

XXXXXUnified CCX Cluster View Daemon
(CVD)

XXXXUnified CCX Engine

XXXXUnified CCX Repository Datastore

XXXXUnified CCX Historical Datastore

XXXXUnified CCXConfigurationDatastore

XXUnified CCX Recording

XUnified CCX Monitoring

6 Available upon installation, before license package is activated.

Context Service Connection Timeouts and Retries
The Context Service client provides two connection properties that significantly affect the user experience
for your customers and agents.

• REQUEST_TIMEOUT defines how long the client waits for a response fromContext Service. Defaults
10,000 ms.
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• RETRIES defines how many times the client retries the request when a timeout is reached. Set values
based on factors specific to your deployment; the location relative to your Context Service instance,
Internet latency, and quality metrics for your organization. Defaults to 1. Note that a setting of 1 - 2 is
recommended. If it fails more than twice then it is unlikely to succeed in a reasonable amount of time.
The RETRIES value only applies to "search" queries. RETRIES is not used on create or update queries.
Create and update queries do not retry after a timeout.

Ideally, you set REQUEST_TIMEOUT to a value that is long enough that the client does not frequently hit
this limit before receiving a reply from Context Service, but not so long that callers hear long periods of silence
from the IVR. Context Service is a cloud service that runs over the Internet, and the latency of the Internet
can be highly variable. However, latency generally has a floor value based on your physical proximity to the
data center on which your Context Service instance is hosted. You can roughly determine your floor value
by pinging your Context Service instance at the times you experience the lowest call volume. Your
REQUEST_TIMEOUTmust never be lower than this floor value. Setting REQUEST_TIMEOUT lower than
this value typically triggers timeouts and initiates a retry.

The RETRIES property is used to retry the request after a timeout is reached. For instance, if you set RETRIES
to 1, then when a timeout is reached the request is resent and the timeout timer restarts. If Context Service
does not respond on that first retry, then the request fails. If there is an issue with your connection, then you
are potentially doubling the wait defined in REQUEST_TIMEOUT when RETRIES is set to 1. The effect
increases as you increase RETRIES. The default REQUEST_TIMEOUT is 10,000 ms (10 seconds) and the
default RETRIES is set to 1. This combination results in a 20 second wait (wait time = REQUSET_TIMEOUT

+ RETRIES * REQUEST_TIMEOUT). In a worst-case scenario, wait time can be significant if there are network
issues between your client and Context Service and your timeouts or retries are set too high. The RETRIES
property is intended to be used to handle network hiccups that infrequently occur. The default setting of 1
assumes that your REQUEST_TIMEOUT is sufficiently high enough that the request is normally serviced
on the first request. If the first 10 seconds is not enough, then the request is retried once and another 10 seconds
allotted to wait for a response.

Retries are not attempted for "create" or "update" operations. If these operations fail due to a timeout, then
your app/script could potentially request the "create" or "update" operation again, return a failure, or
perform some other operation.

Note

In general, typical requests within the same geographical area take from 100ms to 300ms. However, your
network environment, switching latency, and location in relation to Context Service instance can increase the
response time from Context Service.

Your service quality target ultimately defines how high REQUEST_TIMEOUT is set above the floor latency
value. Setting the value too high results in extended waits for the caller or agent when Internet latency is high.
Setting the value too low initiates retry requests that increase the wait in an attempt that can ultimately fail
during times of high latency.

You can improve the customer experience of waiting while the client is accessing Context Service by notifying
the customer that you are looking up information. For example, you can play prompts such as "Wait a moment
while I access your account details". If a timeout occurs and a retry is attempted you can play a prompt, such
as "I'm still accessing your account details." You could also opt to play MoH during the wait times to prevent
silence on the line.

Inevitably connections to Context Service can fail, possibly due to high Internet latency or connections issues
to the Internet itself. In those cases, your IVR scripting must account for a failed connection attempt to the
Context Service. Your scripts must be able to route to an agent (or continue with self-service) without the
benefit of Context Service data.

   Cisco Unified CCX Administration Guide, Release 11.0(1)
396

Cisco Unified Contact Center Express License Packages
Context Service Connection Timeouts and Retries



I N D E X

A

AAR 60, 125, 127, 254
files 125
group 60
management 254
uploading files 127

active server 5, 135, 136
administrator privileges 240
Administrator User Group 201
agent 33, 103, 217, 239, 241

capabilities 239
configuring 33
configuring teams 103
handling callbacks 217
user privileges 241

All Users Group 201
alternative pronunciation 242

Call by Name window 242
Call by Name window, how to add 242

application 3, 6, 11, 45, 171, 176, 251, 393
by package license 393
configuration overview 11
management 251
report 171, 176
server 3
subsystem 6
triggers 45

architecture, cluster 5
ASR 73, 74

overview 73
provisioning 74

Automated Alternate Routing, See AAR
automatic failover 5, 135, 136
Automatic Speech Recognition, See ASR

B

best practices 207
security 207

busy application 43
about 43
provisioning 43

C

cache size 219
contact records 219

call control channel 56
call waiting 213

disabling in Unified CM 213
calling search space 60, 66

ignore setting 66
restrict users 66
Unified CM Telephony trigger setting 66
usage 60, 66

campaigns 212, 218
Outbound subsystem 212
time changes 218

capabilities 239
users 239

channels 56
provisioning 56

Cisco IP Agent and Supervisor desktops 1
about 1

Cisco Media subsystem 6, 71
about 6
provisioning 71

Cisco Script Application 40, 41, 45
adding 40, 41
adding a trigger 45

Cisco Security Agent 210
usage 210

Cisco TelePresence application 36
Cisco Unified CCX Administration web interface 1, 15, 16, 19, 20

about 1, 15
configuration web pages 19
menu bar and menus 16
using navigation bars 20

Cisco Unified CCX applications 39
configuration overview 39

Cisco Unified CCX Administration Guide, Release 11.0(1)    
IN-1



Cisco Unified CCX cluster 135
profile 135

Cisco Unified CCX component availability 395
by package license 395

Cisco Unified CCX components 1
Cisco Unified CCX Editor, about 1
Cisco Unified CCX Engine 6

about 6
Cisco Unified CCX Engine subsystems 6

Applications 6
Cisco Media 6
Core Reporting 6
Database 6
eMail 6
HTTP 6
MRCP ASR 6
RmCm 6
TTS 6
Unified CM Telephony 6

Cisco Unified CCX platform, about 1
Cisco Unified CCX product family 3, 6

about 3
Unified CCX 3
Unified IP IVR 3, 6

Cisco Unified CCX Server, about 1
Cisco Unified CCX supervisor web interface 241
Cisco Unified CCX user options web interface 242
Cisco Unified Communications components 1

about 1
Cisco IP Agent and Supervisor desktops 1
Cisco Unified CCX Admnistration web interface 1
Cisco Unified CCX Editor 1
Cisco Unified CCX Server 1
Cisco Unified Gateway 1
historical reports database server 1
MRCP ASR server 1
MRCP TTS 1
Unified CM 1

Cisco Unified Communications Manager Administration 17
navigating 17

Cisco Unified IP IVR, about 6
cluster 5

active server 5
architecture 5
cluster manager 5
cluster view daemon 5

cluster, definition 135
CM Telephony 256, 257

Call Control group configuration 256
provider configuration 256
triggers 257

CMT dialog channels, about 71
CMT dialog group 71

about 71

CMT dialog interactions, about 71
competence level, about 90
component, definition 135
Computer Telephony Interface, See CTI
configuration 1

datastore server 1
configuration updates 218

Outbound subsystem 218
configuring, definition 7
Contact Service Queues 94, 97, 98, 99

about 94
configuration web page 97
creating 94, 97
deleting 99
modifying 98

contact summary report 210
Outbound 210

contacts report 172
Core Reporting subsystem, about 6
CPU utilization 50

and VRU scripts 50
CSQ 3, 94, 218, 261

about 3
creating 261
Outbound percentage 218
resource based 94
skill based 94
Subsystems menu 261

CSQ Cisco Unified CCX Stats report 181
CTI 6, 66

managing clusters 6
port device and route point 66

custom 248
classpaths for custom classes, steps, subsystems 248

custom file configuration 248
custom file configuration (System menu) 124

D

daily purge schedule 160
about 160
configuring 160

database 110
maximum connections 110
password 110
username 110

Database 210
in service 210

database connectivity 111
polling 111

Database subsystem 6, 107, 109, 110, 294
about 6, 107, 109

   Cisco Unified CCX Administration Guide, Release 11.0(1)
IN-2

Index



Database subsystem (continued)
adding JDBC datasource 110
configuration overview 109
configuration web page 110
configuring 109
defining ODBC datasource 294
supported Enterprise Databases 109

datasource usage report 177
datasource, adding 279
Daylight Savings Time, See DST
db_cra database 217

area code mapping 217
default time zone 232
devices 394

by package license 394
dialing functionality 209
dialing mode 210, 213

direct preview 210, 213
Directory Number 31

associations 31
Directory Number information 66
Do Not Call list 210

Outbound subsystem 210
do_not_call list 210

national 210
document file 121

unzipping after upload 121
documents 118

about 118
DST 231

Outbound subsystem 231

E

eMail subsystem 6, 107, 112
about 6, 107, 112
configuring 112

enabling campaigns 230
engine tasks report 172
execute permission 202

F

failover 5
automatic 5

feature, definition 135
files 115, 121

adding zip 121
managing for applications 115

G

general properties 214
Outbound subsystem 214

geographic region 210
Outbound support 210

grammars 117
about 117

Group 201

H

handling callbacks 217
Help menu 305, 306, 307

About 307
Contents and Index 305
For this Page 306

high availability 136
historical report user capabilities 239
historical report user privileges 240
historical reporting 1, 12

client 1
configuration overview 12

historical reporting database 158, 160, 162
configuring daily purge schedule 160
configuring database server 158
file restore 162
purge configuration 160

historical reports database 161
purging manually 161

historical reports database server 1
about 1

HTTP subsystem 6, 107, 108
about 6, 107, 108
configuration overview 108

HTTP triggers, adding 48

I

Integrated Service Router, See ISR
international area codes 210

mapping 210
invalid number 217

handling callbacks 217

J

JDBC datasource 110
adding 110

Cisco Unified CCX Administration Guide, Release 11.0(1)    
IN-3

Index



L

LDAP server information (System menu) 137
license 10, 66, 108, 109, 112, 393, 394, 395

adding components 10
application availability 393
Cisco Unified CCX component availability 395
database subsystem 109
eMail subsystem 112
HTTP subsystem 108
product 66
service availability 394
subsystem availability 394
trigger availability 393

logout 250
logout (System menu) 155

M

manage scripts 252
managing users 239
master service, definition 135
media channel 56
missed callback 217
MRCP ASR 74, 75, 77

groups configuration 77
provider configuration 74
provisioning 74
server configuration 75

MRCP ASR server, about 1
MRCP ASR subsystem 6, 74

about 6
configuration overview 74
provisioning 74

MRCP TTS 79, 80, 83
locals configuration 83
provider configuration 80
provisioning 79

MRCP TTS server, about 1
MRCP TTS subsystem 6, 79

about 6, 79
provisioning 79

multiple time zones 232

N

national do_not_call list 210
navigating 17

Cisco Unified Communications Manager Administration 17
nickname 242
node, definition 135

O

ODBC datasource 109, 294
about 109
defining 294

Outbound 213
licensed seat 213

Outbound subsystem 210
Do Not Call list 210

Outbound Subsystem 210
in service 210

Overall Unified CCX Stats report 177

P

pending records 231
Outbound subsustem 231

pending state 218
Permissions 202

and User Groups 202
plug-ins 291
point system for provisioning channels 56
product 66

licenses 66
product license 108, 109, 112

database subsystem 109
eMail subsystem 112
HTTP subsystem 108

profile, cluster 135
prompts 115, 122, 123, 124

about 115, 122
adding spoken name prompt 124
recording 123

provisioning call control groups 60
provisioning checklist 57

telephony and media resources 57
Provisioning checklist 22

Unified CCX subsystem 22
provisioning, definition 7
publisher 5

cluster manager 5
purge configuration 160

parameters 160
purging 160

automatic 160
manual 160

purging, manually 161

   Cisco Unified CCX Administration Guide, Release 11.0(1)
IN-4

Index



Q

queuing calls 70
with Unified CCX 70

R

read permission 202
real-time reports 162, 165, 166, 167, 169, 171, 172, 176, 177, 181, 182, 

190
about 162
application tasks 171
application tasks summary 171
available reports 162
contact summary 169
contacts 172
CSQ Cisco Unified CCX Stats 181
datasource usage 177
engine tasks 172
Overall Unified CCX Stats 177
printing reports 165
resetting statistics 166
Resource Unified CCX Stats 182, 190
running reports 165
sessions 176
setting appearance 167
setting options 166
viewing subreports 165

Refresh All button 20
Resource based CSQ 94
resource groups 87, 88, 260, 261

creating 87, 260, 261
deleting 88
modifying name 87

Resource Manager, about 3
Resource pool selection criteria 99, 100

between skills and groups 99
within a CSQ 100

Resource Unified CCX Stats report 182, 190
resources 91, 92, 93, 260

assigning to resource groups and skills in bulk 92
assigning to resource groups and skills individually 91
modifying 260
removing skills from individual agents 93

resynchronizing 58, 59, 71
Cisco JTAPI Client 58
Unified CM Telephony data 59
Unified CM Telephony information 71

Ring-No-Answer application 44
about 44
provisioning 44

RmCm provider 85
about 85

RmCm provider (continued)
provisioning 85

RmCm subsystem 210
in service 210

RmCm subsystem, about 6
RNA application 44

about 44
provisioning 44

Run As 205

S

scheduling callbacks 231
Outbound subsystem 231

script application 40, 41
about 40, 41
configuration overview 40, 41

script management 50, 252
script repository 40, 41
scripts 50, 51, 52, 53, 54

about 50
deleting 54
refreshing 52
renaming 53
viewing or downloading 51

scripts, uploading 50
security 207

best practices 207
servers 135, 136

active and standy 135, 136
service, definition 135
Session Initiation Protocol, See SIP
sessions report 176
SIP 6

router integration 6
Skill based CSQ 94
skills 88, 89, 93, 262

creating 88, 262
deleting 89
modifying name 89
removing 262
removing from individual agents 93

spoken name prompt 124
adding 124

standby server 135, 136
standby service, definition 135
subscriber 5

cluster manager 5
subsystems 394

by package license 394

Cisco Unified CCX Administration Guide, Release 11.0(1)    
IN-5

Index



Subsystems menu 72, 255, 256, 257, 259, 260, 261, 262, 279, 282, 283, 
284

Add a New Dialog Control Group 72
adding HTTP triggers 282
adding teams 262
agent-based routing 262
assigning skills 261
Cisco Media 283
CM Telephony 256
CM Telephony Call Control group configuration 256
CM Telephony provider configuration 256
CM Telephony triggers configuration 257
database configuration 279
eMail 283
HTTP 282
MRCP ASR 283
MRCP TTS 284
resource group 260
resources 260
RmCm provider 261
skills configuration 259
teams 262
Unified CCX 259

supervisor 103
configuring teams 103

supervisor capabilities 239
supervisor privileges 240
System menu 124, 137, 155, 245, 248, 250

about 245
custom file configuration 124, 248
LDAP Information 137
logout 155, 250
system parameters 137

systems parameters (System menu) 137

T

team 103, 104, 105
configuring 103
creating a team 104
deleting a team 105
making changtes to agents on a team 104

Text-to-speech, See TTS
time zone 217, 231

determining local time 231
handling callbacks 217

toolbar 20
using 20

Tools menu 168, 169, 171, 172, 176, 177, 181, 182, 190, 192, 193, 194, 
195, 291, 292, 296, 298, 299, 300, 301, 303, 306

application task summary 171
application tasks 171

Tools menu (continued)
Clear Contact 193
contact summary report 169
contacts 172
CSQ Unified CCX Stats 181
datasource usage 177
engine tasks 172
file restore 298
historical reporting 296
Open Printable Report 192
Options 195
overall Unified CCX Stats 177
overview 291
password management 303
plug-ins 291
purge now 298
purge schedule 298
real-time reporting 292
real-time snapshot config 292
Refresh Connections 193
report 168
Reset All Stats 192
Resource Unified CCX Stats 182, 190
sessions 176
Tools 192
troubleshooting tips 306
user configuration 298
user management 299, 300
user management, Name Grammar Generation 300
user management, Spoken Name Upload 301
Views 194

Tools meny 195
Settings 195

triggers 393
by package license 393

triggers and applications 45
TTS 73, 79, 81

default provider 81
overview 73
provisioning 79
VXML applications 81

U

UNICODE 79
Unified CCX 3

about 3
Unified CCX Administration 15

connecting 15
Unified CCX components 3

CSQ 3
Resource Manager 3

   Cisco Unified CCX Administration Guide, Release 11.0(1)
IN-6

Index



Unified CCX Enhanced with CTI Option, about 3
Unified CCX Enhanced, about 3
Unified CCX Standard, about 3
Unified CM 30, 243

connecting to web interface 30
users 243

Unified CM telephony 57
configuration 57

Unified CM Telephony 66
trigger information 66

Unified CM Telephony information, resynchronizing 71
Unified CM Telephony subsystem 6, 57, 59, 60, 66, 210

about 6
configuration overview 57
configuring Unified CM Telephony providers 59
in service 210
provisioning call control groups 60
provisioning Unified CM Telephony trigger 66

Unified CM Telephony trigger 46
adding 46

Unified CM Telephony triggers 70
using with Unified CCX 70

Unified CM User Options page 243
Unified Communications Manager 31

configure users 31
Unified ICME 6

about 6
Unified ICME subsystem 107

about 107
Unified IP IVR, about 3
uploading licenses 10
uploading scripts 50
User Groups 201, 202

Administrator User Group 201
and Permissions 202
Child Groups 201
Groups 201

User Permissions 202
write, read, and execute 202

user roles 239
users 31, 205

configuring in Unified Communications Manager 31
Run As 205

V

virtual agents 36
virtual infrastructure 36
voice gateways 1
VRU scripts 50

uploading time 50
VXML applications 81

default TTS provider 81

W

wizards 20
using 20

Wizards menu 287, 288
Application 287
RmCm 288

wrap-up data 102
usage 102

write permission 202

Z

zip files, uploading 121

Cisco Unified CCX Administration Guide, Release 11.0(1)    
IN-7

Index



   Cisco Unified CCX Administration Guide, Release 11.0(1)
IN-8

Index


	Cisco Unified CCX Administration Guide, Release 11.0(1)
	Contents
	Preface
	Change History
	About This Guide
	Audience
	Related Documents
	Documentation and Support
	Documentation Feedback

	Unified CCX Introduction
	Unified CCX Components
	Unified CCX Product Family
	Unified IP IVR
	Unified Contact Center Express

	Unified CCX Cluster Architecture
	Unified CCX Active Server

	Unified CCX Engine
	Set Up Unified CCX
	Provision Telephony and Media Subsystems
	Configure Unified CCX Subsystems
	Provision Unified CCX Subsystem
	Provision Additional Unified CCX Subsystems

	View License Information
	Upload Licenses

	Configure Unified CCX Applications
	Available Applications
	Manage Scripts Prompts, Grammars, and Documents

	Configure Unified CCX Historical Reporting

	Manage Unified CCX

	Unified CCX Administration Web Interface
	Access Unified CCX Administration Web Interface
	Cisco Unified CCX Administration Menu Bar and Menus
	Cisco Unified CCX Administration Navigation
	Unified CCX Configuration Web Pages
	Details for Advanced Configuration
	Toolbar and Buttons
	Application and RmCm Wizards


	Unified CCX Provision Checklist
	Unified CCX
	Provision Unified CCX
	Change Licensing Packages

	Provision Unified CM for Unified CCX
	Configure Unified Communications Manager Information
	Modify AXL Information
	Modify Unified Communications Manager Telephony Information
	Modify RmCm Provider Information
	Unified Communications Manager for Unified CCX Configuration
	Invoke Unified Communications Manager Administration
	Unified Communications Manager Users as Unified CCX Agents
	Guidelines for Agent Phone Configuration
	Modify Existing Unified Communications Manager Users
	Assign Unified Communications Manager Users as Cisco TelePresence Virtual Agents
	Configure Tool for Auto-Registered Phones Support (TAPS)


	Cisco Applications Configuration
	About Unified CCX Applications
	Configure Script Applications
	Add New Cisco Script Application
	Configure Busy Application
	Configure Ring-No-Answer Application

	Application Triggers
	Unified CM Telephony Trigger
	Add Unified CM Telephony Triggers from Application Web Page
	Add Unified CM Telephony Triggers from Unified CCX

	HTTP Trigger Provision
	Add HTTP Trigger from Application Web Page
	Add HTTP Trigger from HTTP Subsystem


	Script Management
	Upload New Scripts
	Download Script File
	Refresh Scripts
	Refresh Scripts Individually
	Refresh Bulk Scripts

	Rename Script or Folder
	Delete Script or Folder
	Sample Scripts


	Telephony and Media Provision
	Unified CCX Telephony and Media
	Media Termination Groups
	Channels Required to Process Calls
	Provision Telephony and Media Resources

	Provision Unified CM Telephony Subsystem
	Resynchronize Cisco JTAPI Client
	Resynchronize Unified CM Telephony Data
	Configure Unified CM Telephony Provider
	Add New Call Control Group
	Add Unified CM Telephony Trigger

	Additional Unified CM Telephony Information
	Unified CM Telephony Triggers for Unified CCX Queuing
	Unified CM Telephony Information Resynchronization

	Cisco Media Subsystem
	Add CMT Dialog Control Group

	ASR and TTS in Unified CCX
	Prepare to Provision ASR/TTS
	Provision of MRCP ASR Subsystem
	Provision MRCP ASR Providers
	Provision MRCP ASR Servers
	Provision MRCP ASR Dialog Groups

	MRCP TTS Subsystem
	Provision MRCP TTS Providers
	Configure Default TTS Provider for Unified CCX System

	Provision MRCP TTS Servers
	Provision MRCP TTS Default Genders



	Provision of Unified CCX
	RmCm Provider Configuration
	RmCm Provider Modification
	Associating Agent Extensions with the RmCm Provider

	Resource Groups
	Create Resource Group
	Modify Resource Group Name
	Delete Resource Group

	Skills Configuration
	Create a Skill
	Modify a Skill Name
	Delete a Skill

	Agent Configuration
	Implications of Deleting Agents in Unified CM
	Assign Resource Groups and Skills to One Agent
	Assign Resource Groups and Skills to Multiple Agents
	Remove Skills from Agents

	Contact Service Queue Configuration
	Create a Contact Service Queue
	Contact Service Queue Configuration Web Page

	Modify a Contact Service Queue
	Delete a Contact Service Queue
	Resource Pool Selection Criteria: Skills and Groups
	Resource Skill Selection Criteria within a Contact Service Queue

	Configure Agent-Based Routing
	Wrap-Up Data Usage

	Teams Configuration
	Assign Supervisor Privilege to a User
	Create Team Supervisor
	Create Teams
	Modify Agents on Teams
	Delete a Team


	Provision of Additional Subsystems
	About Additional Subsystems
	Provision of HTTP Subsystem
	Configure HTTP Triggers

	Provision of Database Subsystem
	Database Subsystem Configuration
	Add New Datasource
	Datasource Configuration Web Page

	Poll Database Connectivity

	Provision eMail Subsystem

	Management of Prompts, Grammars, Documents, and Custom Files
	Manage Prompt Files
	Manage Grammar Files
	Manage Document Files
	Language Management
	Create New Language
	Rename Language
	Delete Language
	Upload Zip Files to Language Folder

	Upload of Prompt Files
	Record a Prompt
	Add Spoken-Name Prompts

	Management of Custom Files
	Specify Custom Classpath Entries

	AAR File Management
	AAR File Creation
	Upload AAR Files
	META-INF Directory
	Directories for Prompts, Grammars, Documents, and Scripts
	Prompts Directory
	Grammars Directory
	Documents Directory
	Scripts Directory

	AAR Manifest
	Attribute Types
	Main Attributes
	Per-entry Attributes
	META-INF Directory Attributes
	Application Subdirectory Attributes




	Unified CCX System Management
	Basic Terminology
	High Availability and Automatic Failover
	Network Partitions

	Unified CCX CDS Information Management
	Manage System Parameters
	System Parameters Configuration Web Page

	Unified CCX IP Address/hostname Management
	Prepare System for IP Address/host name Change
	IP Address Modification
	Change IP Address for Server in Single-Node Deployment
	IP Address Modification in High-Availability (HA) Deployment
	Change IP Address for Publisher Server in HA Deployment
	Change IP Address for Subscriber Server in HA Deployment


	Host Name Modification
	Change Host Name for Server in a Single-Node Deployment
	Host Name Modification in High-Availability (HA) Deployment
	Change Host Name for Publisher Server in HA Deployment
	Change Host Name for Subscriber Server in HA Deployment


	Verify Proper Function of System after IP Address/host name Change

	Exit Unified CCX Administration

	Unified CCX Reporting
	Reporting Administration on Unified CCX
	Import of Stock Reports
	Unified CCX Historical Reports
	Unified CCX Historical Datastore
	Historical Reporting Configuration
	Configure Database Server Limits
	View Historical Reports

	Purge of Historical Data
	Configure Automatic Purging
	Configure Purge Schedule Configuration Parameters

	Purge Manually

	File Restore

	Unified CCX Real-Time Reports
	Available Unified CCX Real-Time Reports
	Open Real-Time Reports
	Run Reports
	View Detailed Subreports
	Print Reports
	Reset Report Statistics
	Clear Contact Option for Stuck Calls
	Set Report Options
	Set Report Appearance
	Application Reporting User Interface
	Report Menu
	High Availability (HA) Setup
	Contacts Summary Real-Time Report
	Application Tasks Summary
	Application Tasks Real-Time Report
	Engine Tasks Real-Time Report
	Contacts Report
	Call Contacts Detailed Info Report
	Email Detailed Info Report
	HTTP Detailed Info Report

	Applications Report
	Sessions Report
	Data Source Usage Report
	Overall Cisco Unified Contact Center Express Stats Report
	CSQ Cisco Unified Contact Center Express Stats Report
	Preview Outbound Campaign Cisco Unified Contact Center Express Stats Report
	Chat CSQ Cisco Unified Contact Center Express Stats Report
	Chat Resource Cisco Unified Contact Center Express Stats Report
	Overall Chat Cisco Unified Contact Center Express Stats Report
	Outbound Campaign Stats Report
	Overall Outbound Stats Report
	Resource Cisco Unified Contact Center Express Stats Report
	Failover Behavior for Unified CCX Stats

	Tools Menu
	Reset All Statistics
	Open Printable Report
	Refresh Connections
	Clear Contact Menu
	Clear Stuck Calls from Sontacts Real-Time Report
	Clear Stuck Calls from Overall Cisco Unified CCX Stats
	Clear Stuck Calls from CSQ Cisco Unified CCX Stats


	Views Menu
	Application Tasks
	Contacts by Application Task ID
	Engine Tasks by Application Task ID

	Contacts
	Applications
	Sessions
	Contacts by Session ID
	Detailed Info


	Settings Menu
	Options Menu




	Reporting Administration on Unified Intelligence Center
	Overview
	Start Unified Intelligence Center
	Administrator Overview
	Security Overview
	User List
	Create a User
	User Groups
	About User Groups
	Create a User Group

	Manage User Permissions
	About Permissions
	User Roles and Permissions
	Assigned Group Permissions
	Assigned User Permissions

	Run As
	Audit Trail Logging in Cisco Unified Intelligence Center
	View Audit Trail Logging in Unified Intelligence Center

	Audit Trail Report
	Security Considerations


	Unified CCX Outbound Dialer Configuration
	Outbound Feature for Unified CCX
	Outbound Characteristics
	Unified CCX Requirements
	Outbound Components

	Supported Dialers and Dialing Modes for Outbound
	Unified CCX Outbound Dialing Modes
	Direct Preview Dialing Mode
	Progressive Dialing Mode
	Predictive Dialing Mode

	Configure Outbound Subsystem in Unified CCX
	Configure General Outbound Properties
	Callbacks
	Outbound Area Code Functionality
	Configuration Updates
	CSQ Agent Pool Allocation

	Configure Application and Trigger for Outbound Campaign
	Add New Campaign
	Import Contacts for Campaign
	Enable Campaigns
	Outbound Subsystem and Time Detection
	Add Area Codes
	Call Status Values
	Contact States Reset at Midnight

	Call Result Values
	Reclassification Status Behavior
	Call Retrieval Priority
	Failover and System Restarts

	Cisco Unified Contact Center Express Supervisor and User Options Plug-Ins
	About User Management
	About Unified CCX User Capabilities
	Administrator Privileges
	Supervisor Privileges
	Historical Report User Privileges
	Agent Privileges

	Unified CCX Supervisor Web Interface
	Access Unified CCX Supervisor Web Page

	Unified CCX User Options Web Interface
	Access Unified CCX User Options Web Page
	Add Alternative Pronunciations
	Access Unified CM User Options Page


	System Menu
	Access Server Menu
	Configure Server
	Configure IPv6 Address


	Unified CM Configuration
	Recording Configuration
	Custom File Configuration
	Standalone Cisco Unified Intelligence Center Configuration
	License Information
	Add Licenses
	Display Licenses

	Language Information
	Logout Menu

	Applications Menu
	Access Application Management Menu
	Manage Scripts
	Prompt Management
	Grammar Management
	Document Management
	AAR Management

	Subsystems Menu
	Unified CM Telephony Menu
	Unified CM Telephony Provider Configuration
	Unified CM Telephony Call Control Group Configuration
	Unified CM Telephony Triggers Configuration
	Synchronize Unified CM Telephony Data
	Unified CM Telephony Cisco JTAPI Resync
	Unified CM Telephony Advanced Settings

	RmCm Menu
	Skill Configuration
	Add New Skill
	Modify Skills

	Resources Configuration
	Modify Resource

	Resource Group Configuration
	Add New Resource Group
	Modify Existing Resource Groups

	Contact Service Queues Configuration
	Add a CSQ

	RmCm Provider Configuration
	Skills Configuration Assignment
	Add Skills
	Remove Skills

	Agent Based Routing Settings Configuration
	Teams Configuration
	Add New Team


	Chat and Email Menu Options
	SocialMiner Configuration
	Reinject Email Contacts
	Chat Transcripts

	Mail Server Configuration
	Contact Service Queues Configuration
	Predefined Responses
	Predefined Response Configuration

	Channel Parameters
	List Chat Web Forms
	Chat Web Form Configuration

	Teams

	Outbound Menu
	General Configuration
	Campaign Configuration
	Add New Campaigns
	Import Contacts
	Delete Contacts

	Area Code Management
	Add New Area Code

	Configure SIP Gateway
	SIP Gateway Configuration Web Page
	Dial Peer Configuration for Outbound


	Database Menu
	DataSource
	New DataSource

	Add New Database Driver
	Driver
	Add New Database Driver

	HTTP Menu
	HTTP Configuration
	Add New HTTP Trigger

	eMail Menu
	Cisco Media Menu
	MRCP ASR Menu
	MRCP ASR Provider
	MRCP ASR Servers
	MRCP ASR Dialog Groups

	MRCP TTS Menu
	MRCP TTS Providers
	MRCP TTS Servers
	MRCP TTS Default Genders


	Wizards Menu
	Application Wizard
	RmCm Wizard

	Tools Menu
	Plug-Ins Menu
	Real-Time Reporting Menu
	Real-Time Snapshot Config Menu
	Create System DSN for Wallboard
	Wallboard Software in High Availability (HA) Deployment
	Use Upgraded Wallboard Software with New Service in HA Deployment
	Use Wallboard Software (without New Service) in HA Deployment



	Historical Reporting Menu
	Database Server Configuration
	SMTP Configuration
	Purge Schedule Configuration Option
	Purge Now Option
	File Restore Option

	User Management Menu
	User View Submenu
	Name Grammar Generator Configuration
	Spoken Name Upload Submenu
	Administrator Capability View Menu
	Supervisor Capability View Menu
	Reporting Capability View Menu
	Agent Capability View Menu

	Password Management

	Help Menu
	Contents and Index
	For This Page Menu
	Troubleshooting Tips Menu
	Unified CCX Documentation Link
	About Menu

	Cisco Mobile Skill Manager
	Access Mobile Skill Manager
	Adding Skills Using Cisco Mobile Skill Manager
	Searching Skills Using Cisco Mobile Skill Manager
	View Details of Resources Assigned to Supervisor
	View Resources Assigned to Supervisor
	Search Resources Using Cisco Mobile Skill Manager
	Modify Resource Team
	Assign Skill Competency to Resource
	Unassign Skill Competency of Resource

	Cisco Finesse
	Introduction
	Cisco Finesse Administration Console
	Getting Started
	Administration Tools
	Cisco Finesse Administration Console
	Sign In to Cisco Finesse Administration Console
	Account Locked After Five Failed Sign In Attempts



	Manage System Settings
	Context Service Settings
	Context Service Network Connectivity Requirements
	Configure Context Service Settings


	Manage Call Variables Layouts
	Call Variables Layouts
	Call Variables
	Configure Call Variables Layouts
	Add ECC Variables to Call Variables Layout
	Assign Call Variables Layouts
	Manipulate Call Variables Layouts with a Workflow

	Manage Desktop Layout
	Finesse Desktop Layout XML
	Default Layout XML
	Update Default Desktop Layout
	XML Schema Definition
	Add Web Chat and Email to Finesse
	Add Web Chat and Email to the Default Desktop Layout
	Add Web Chat and Email to a Custom Desktop Layout
	Add Web Chat and Email to a Team Layout

	Live Data Gadgets
	Add Live Data Gadgets to Desktop Layout
	Add Customized Live Data Gadgets to Desktop Layout

	Live Data Reports
	Configure Live Data Reports with Multiple Views


	Manage Phone Books
	Phone Books and Contacts
	Add Phone Book
	Edit Phone Book
	Delete Phone Book
	Import Contacts
	Export Contacts
	Add Contact
	Edit Contact
	Delete Contact

	Manage Reasons
	Not Ready Reason Codes
	Add Not Ready Reason Code
	Edit Not Ready Reason Code
	Delete Not Ready Reason Code

	Sign Out Reason Codes
	Add Sign Out Reason Code
	Edit Sign Out Reason Code
	Delete Sign Out Reason Code

	Wrap-Up Reasons
	Add Wrap-Up Reason
	Edit Wrap-Up Reason
	Delete Wrap-Up Reason


	Manage Team Resources
	Team Resources
	Assign Phone Books and Reasons to Team
	Unassign Phone Books and Reasons from Team
	Assign Custom Desktop Layout to Team
	Assign Workflows to Team
	Unassign Workflows from Team

	Manage Workflows
	Workflows and Workflow Actions
	Workflow Triggers and Outbound Calls

	Add Browser Pop Workflow Action
	Add HTTP Request Workflow Action
	Edit Workflow Action
	Delete Workflow Action
	Add Workflow
	Edit Workflow
	Delete Workflow

	Manage Security
	HSTS
	Trust Self-Signed Certificate
	Obtain and Upload CA Certificate
	Add Certificate for HTTPS Gadget
	Add Certificate for Multi-session Chat and Email

	Manage Finesse IP Phone Agent
	Finesse IP Phone Agent
	One Button Sign In
	Finesse IP Phone Service Subscription Options
	Set Up Application User, Web Access, and HTTPS Server Parameters
	Configure Finesse IP Phone Service in Unified CM
	Add Service Parameters for One Button Sign In
	Subscribe Agent Phones to Manual Subscription Service
	Set Up Agent Access to the Self Care Portal

	CTI Failover
	Finesse IP Phone Agent Failover

	Backup and Restore
	Additional Language Support

	Cisco Finesse Agent and Supervisor Desktop
	Call Manager-Based Call Recording Using Cisco MediaSense
	Configure Cisco MediaSense with Unified CM
	Upload Cisco MediaSense Certificate to Unified CCX Server
	Upload MediaSense Recording License
	Configure MediaSense as a Recording Server
	Call Recording Through Workflow
	Configure MediaSense Search and Play Gadget


	Extend and Connect
	Overview
	Server Configuration
	Persistent Connection


	Cisco Unified Contact Center Express License Packages
	Application Availability by License Package
	Trigger Availability by License Package
	Subsystem Availability by License Package
	Unified CCX Services Availability by License Package
	Unified CCX Component Availability by License Package
	Context Service Connection Timeouts and Retries

	INDEX

